Jump to content
Froxlor Forum
  • 0

Andauernder Erneuter Login


Question

Hallo Liebe Froxlor Community,

 

derzeitig beschäftige ich mich mit einem sehr koriosen Problem was mich, je länger ich damit zu kämpfen habe, zur Weisglut bringt.
Aktuell benutze ich die letzte Froxlor Github Version und muss mich permanent neu einloggen.
Dabei spielt es keine Rolle ob ich mich als Admin oder Kunde anmelde.
Der automatische Logout kommt nach einer unbestimmten Zeit und egal welcher Aktion

Beispiel Ablauf:
- Logge mich als Admin ein
- Bearbeite die Domains
- Werde gewzungen mich neu anzumelden und  vorherige eingegebene Daten sind verschwunden bzw nicht gesichert worden

- Logge mich erneut ein
- Wähle Kundenverwaltung
- Klicke auf Kunde
- Werde gewzungen mich neu anzumelden...

Ja ich habe schon die Sessiontime für die Logins erhöht und weitere einstllungen probiert, jedoch ist dies nicht mein Fehler bzw ändern nichts an dem permanenten wiederanmelden.
Ich habe auch schon in den Webserver logs nach Fehlern geschaut aber da wird sowohl in den access als auch im Error Log keinerlei Fehlemeldung angezeigt.

Bei mir spielt es ausserdem auch keine Rolle welche Browser ich benutze da bei allen (sowohl aktuellster FireFox als auch Chrome / Opera Browser) das selbe Phenonem auftritt.

Daten:

Root: OVH Dedicated Root (4kerne, 64gb Ram 2TB HHD)
OS: Ubuntu 16.04 LTS
Webserver: apache2 (version 2.4)

 

Ich hoffe das ihr mir weiterhelfen könnt.

Sollte ich etwas an Informationen vergessen haben, bitte bescheid geben.


lg H4nSolo

Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

Hallo D00p,

ich stehe gerade etwas auf dem Schlauch.
Wie meinst du das mit PHP eingebunden.

Ich habe nach der Webserver Installation über SSh die Packete PHP und die dazugehörigen packete (php-common, php-mysql,etc) über apt-get nachinstalliert.
Diese sind auch in /etc/apache2/mods-available drin und in /etc/apache2/mods-enabled liegt auch eine saubere verknüpfung auf die php5.6.load sowie php5.6.conf

In den Apache logs sehe ich derzeit keine ungewöhnlichen aktivitäten was auf den Fehler hindeutet.
 

Im /var/customers/tmp oder /tmp ist nichts drin was vom webserver kommt und irgendwelche sessions abspeichert.
Der /var/customers hat alle lese und Schreibrechte (testweise mal auf 0777 gestellt) ohne ergebnisse

 

lg H4nSolo

Link to post
Share on other sites
  • 0

Also mod_php. Und nicht gucken ob in den Ordnern was drin ist sondern Berechtigungen anschauen (sollten beide 0777 sein). Und dann Schauste Mal in die PHP.ini was da so bzgl Session steht. Nach einer Default Installation aber sollte das alles problemlos funktionieren, sicher daß das alles Default ist?

Link to post
Share on other sites
  • 0

Ok ich habe es jetzt auf meine Internet verbindung begrenzt.

Derzeit gehe ich über einen T-Online Hotspot mit vpn zugang ins Internet.
Da meine Verbindungsqualität hierbei nicht die beste ist, gehe ich mal davon aus das ich zuviele unterschiedliche anfragen an den Webserver schicke, der meine meine identität bzw session andauernt verliert und meint das ich nciht angemeldet wäre.

Gott sei hab ich ab Mittwoch besseres Internet.

Habe jetzt mal für mein Problem einen umweg genommen und richte grade alles über eine Windows VM  vom Root direkt aus ein. [Keinerlei Probleme]
Nun hänge ich aber vor dem nächsten Problem.
Ich kann es hier ja mal anschneiden in der Hoffnung das ich das hier auch gelöst bekomme, am sonsten eröffne ich dafür einen neuen Thread.


Neues Problem:

Ich habe  nun erfolgreich die benötigte Domain eingerichtet und würde gerne auch einige subdomains der Haubtdomain über https haben. (phpmyadmin, webmail, gameserverpanel, etc)
Die Subdomains sind auch erfolgreich angelegt und entsprechende einstellungen für https wurden erstellt.
Wenn ich jetzt zbsp auf meine subdomain http://panel.mgc4you.de gehe, werde ich auch sofort auf https umgeleitet.
Hier endet jedoch das schauspiel den die jeweiligen https Seiten sind nicht erreichbar.
Lets encrypt hat erfolgreich für die betroffenenden Domains bzw subdomains die Zertifikate erstellt und werden beim Webserver neustart auch nicht bemängelt oder sonstige.

Ich erhalte nur meldungen das er die Zertifikate eungebunden hat.
Ein Check der Ports war auch Positiv. Also Offen.

 

Ich hoffe das man mir da weiter helfen kann.

 

lg H4nSolo

Link to post
Share on other sites
  • 0

job ich bin derzeit dabei die sachen wieder einigermassen nutzbar zu machen.

Wenn ich es jedoch wieder umstelle, wird auf die https seite weiter geleitet aber dann passiert nicht mehr.
Im FF wird mir angezeigt das die Seite nicht erreichbar ist, Im Chrome sagt er mir das die verbindung abgelehnt wurde.

Ich hatte jetzt mal testweise auf dem Root die Seite per ssh aufgerufen (openssl s_client -connect adresse:https)
und erhielt am anfang den ssl code gefolgt von Zertifikats Informationen und am ende den Quelltext der Seite.
Im Quelltext sagte er mir dann das er die Seite auch nicht aufrufen konnte (Fehlermeldung 400 Bad Request)
 

Ich habe das gleich  jetzt mal mit der subdomain http://owncloud.mgc4you.de/ gemacht.
Hier passiert wieder das gleiche.

Seite wird aufgerufen -> weitergeleitet zu https -> Seite nicht aufrufbar...

 

root@mgc4you:~# openssl s_client -connect owncloud.mgc4you.de:https                                                                                                              CONNECTED(00000003)
depth=0 C = FR, ST = Roubaix, O = Internet Widgits Pty Ltd, emailAddress = mc@mg                                                                                                 c4you.de
verify error:num=18:self signed certificate
verify return:1
depth=0 C = FR, ST = Roubaix, O = Internet Widgits Pty Ltd, emailAddress = mc@mg                                                                                                 c4you.de
verify return:1
---
Certificate chain
 0 s:/C=FR/ST=Roubaix/O=Internet Widgits Pty Ltd/emailAddress=mc@mgc4you.de
   i:/C=FR/ST=Roubaix/O=Internet Widgits Pty Ltd/emailAddress=mc@mgc4you.de
---
Server certificate
-----BEGIN CERTIFICATE-----
MIIFPDCCAyQCCQCdjP7n7yUH3jANBgkqhkiG9w0BAQsFADBgMQswCQYDVQQGEwJG
UjEQMA4GA1UECAwHUm91YmFpeDEhMB8GA1UECgwYSW50ZXJuZXQgV2lkZ2l0cyBQ
dHkgTHRkMRwwGgYJKoZIhvcNAQkBFg1tY0BtZ2M0eW91LmRlMB4XDTE3MTIxMTIw
NDY1NVoXDTE4MTIxMTIwNDY1NVowYDELMAkGA1UEBhMCRlIxEDAOBgNVBAgMB1Jv
dWJhaXgxITAfBgNVBAoMGEludGVybmV0IFdpZGdpdHMgUHR5IEx0ZDEcMBoGCSqG
SIb3DQEJARYNbWNAbWdjNHlvdS5kZTCCAiIwDQYJKoZIhvcNAQEBBQADggIPADCC
AgoCggIBAMUJtgggANLaBXytbmVAANMD0tqadgUge+Xn3SQm33Dwx5FBkkn0ErOR
2C/CaakP35JkZK/kTbCGbDGTnkjCuzgdglG5dFTsZWz4pI3WDDmZdVjowgeDU8zd
o1VL3y3XL5y7KgAK9vmuNqNJBSG2z4SdUe3unKm7Tf7yDq4/yXAe2YOdv+msH/vM
0FmqHUu4A1BkzOLgWn4lQ7q3yCmSXVterrKb5PfIIqZlVz45kBPgYWLN9bjRHyaq
fr98gzcWdWgqKBkGpTmEocR483mGDWc9Vo6nYRVwhDXgXmP9kG5VMB0hxcMfsSDA
YAwbP5795ZfMERckFjv+Gp6PWZIW9kzTUS7c+9J9pce4SpBwVTmiLFoj7Ek5GsEz
+hxcYODYjW54wGfbefltnS1vj0GpAmxx2gKDVNgTPms6hcxrxPQJJPmNhNuTFah7
lll+LfEl2wy1swyIDFfTdR5P9i57doqHvS2YdDE+AMLfzLU6E7XrtTzDJDLcrT/o
bwyeQC4Jh9iFrz5Ryn8nj15//W1eZwnDRLVYsCS7TYFe+wbOphmtu2lTXmtJ51gt
PDYIPfPMx8SZBaIyuFCn0oX4DzUJgT+Y4eCShdGmdoiqEAoiXRkvDmPnEWdc/GQe
GAO/1XdOJOpFAC6krlNufjYZkbbQQNj1d/xUG4uGUyQrDZbVQHWDAgMBAAEwDQYJ
KoZIhvcNAQELBQADggIBAChxMliaSZDNGImrTywDi14nLaC2lg29vGjPKnAwPnPB
Y50KHhUZRMYNRbgmGi8eKiCXIQ4TlL030cQD9Wo1Lnb/V4Q49ttox1hTw8NOblLO
2jNCqs3g6TJwV5MyIDiGtIuk0FIFqQGq+b03MSKxr6jUd6GH8CvO1550olgMIk+5
VKVvMR9cewf7Mb5fVO3DwfSGxMdXkn3Ytjajv6MhcsbF3q3QCJKG+ecw80McFFa2
dy4zaB9i8XeXc87lB5j5BJT9a6NRVK9EKsqG1QqItznNuxmj2UxS/jWbbxUjpA19
foQywMvKAyWO145ZHm+i0g3WqS2le/V7RcgSgBbJu6Ldb4q2pmKY+8tc0lBZBpE6
whtBe+8c20hHkXptRYVFWDWU01zRu6GGPUdopVs0dAGeG8vrKPgg1ONzxMMwKWfr
5AKVyoK/8MBUFI+sgHttpaz11Uwl2vOtRlKjz6w/+8qLUbV65o5X8NBMrFww3VSL
2n6Li6DTWLDPZRmeykrZ0xND6h0ieLeLkfriduAPbTaRfTT43cpKY4VysxzcsD0w
3ajSX4FzLlE+V1AWCAd4G3hk5VUBT0LgOG4x9lrn/VGi61axWsnXqStI4LSvbWZW
gzMK304Ah/q12Vq3/ddEZpDvskORy68u2aeJ2nMSW8j2ji5rUYCygxdu3B6iyuai
-----END CERTIFICATE-----
subject=/C=FR/ST=Roubaix/O=Internet Widgits Pty Ltd/emailAddress=mc@mgc4you.de
issuer=/C=FR/ST=Roubaix/O=Internet Widgits Pty Ltd/emailAddress=mc@mgc4you.de
---
No client certificate CA names sent
Peer signing digest: SHA512
Server Temp Key: ECDH, P-256, 256 bits
---
SSL handshake has read 2286 bytes and written 302 bytes
Verification error: self signed certificate
---
New, TLSv1.2, Cipher is ECDHE-RSA-AES256-GCM-SHA384
Server public key is 4096 bit
Secure Renegotiation IS supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
SSL-Session:
    Protocol  : TLSv1.2
    Cipher    : ECDHE-RSA-AES256-GCM-SHA384
    Session-ID: 931AC99FAF65EE89432117DD3586ABBAC4B507F3A8B1D2F785E8DA1251D0FD70
    Session-ID-ctx:
    Master-Key: 0386798F0D9563834DE3073A7B9EE7656EDAE640F6A1592D6A5396C44123ACB8                                                                                                 BDAD2CDA755D4C9D7146052CD0821B48
    PSK identity: None
    PSK identity hint: None
    SRP username: None
    TLS session ticket lifetime hint: 300 (seconds)
    TLS session ticket:
    0000 - 09 e9 4d 4e e7 99 46 7c-f3 0b 50 cb a0 fe 2f 30   ..MN..F|..P.../0
    0010 - d5 06 00 87 23 39 59 39-bf 67 9d fc 69 85 65 4c   ....#9Y9.g..i.eL
    0020 - 73 d1 31 0a 07 54 93 ae-01 5e 7e d1 a8 f8 e7 72   s.1..T...^~....r
    0030 - 35 f7 4c 46 08 73 bf 79-23 d0 d8 00 d3 39 be ff   5.LF.s.y#....9..
    0040 - 0f 9a 53 fe a8 25 d4 5f-9d 73 36 28 b5 38 2f 4e   ..S..%._.s6(.8/N
    0050 - 37 fc 83 60 bf 49 4b 45-88 cc 03 31 01 d0 ad 23   7..`.IKE...1...#
    0060 - 3f 0d 1b 3e b0 e2 7b f9-f0 b1 89 82 21 8e 35 d2   ?..>..{.....!.5.
    0070 - f8 5c 1b 71 07 52 26 78-eb 58 15 ab f3 e0 c6 3c   .\.q.R&x.X.....<
    0080 - 8d 14 17 f2 ba 58 6e 07-9d 2f 46 41 ae f8 2d 43   .....Xn../FA..-C
    0090 - a2 46 34 00 6e e3 f2 f2-d0 63 83 84 cb c8 ab 1d   .F4.n....c......
    00a0 - 94 1f 02 21 e3 f8 b6 e4-70 e8 f4 98 cb 04 a7 a8   ...!....p.......
    00b0 - 39 17 c5 ae 25 bc e6 74-a6 3b 76 c4 42 f2 37 c6   9...%..t.;v.B.7.

    Start Time: 1513073867
    Timeout   : 7200 (sec)
    Verify return code: 18 (self signed certificate)
    Extended master secret: no
---

HTTP/1.1 400 Bad Request
Date: Tue, 12 Dec 2017 10:17:48 GMT
Server: Apache/2.4.18 (Ubuntu)
Content-Length: 303
Connection: close
Content-Type: text/html; charset=iso-8859-1

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>400 Bad Request</title>
</head><body>
<h1>Bad Request</h1>
<p>Your browser sent a request that this server could not understand.<br />
</p>
<hr>
<address>Apache/2.4.18 (Ubuntu) Server at mgc4you.de Port 443</address>
</body></html>
closed

 

Edited by H4nSolo
Fehler beseitig und openssl output hinzugefügt
Link to post
Share on other sites
  • 0

10_froxlor_ipandport_94.23.6.180.80.conf:

# 10_froxlor_ipandport_94.23.6.180.80.conf
# Created 12.12.2017 11:49
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

<VirtualHost 94.23.6.180:80>
DocumentRoot /var/customers/webs/mgc4you/mainsite
 ServerName mgc4you.de
</VirtualHost>

10_froxlor_ipandport_94.23.6.180.443.conf:

# 10_froxlor_ipandport_94.23.6.180.443.conf
# Created 12.12.2017 11:49
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

<VirtualHost 94.23.6.180:443>
DocumentRoot /var/customers/webs/mgc4you/mainsite
 ServerName mgc4you.de
 SSLEngine On
 SSLProtocol -ALL +TLSv1 +TLSv1.2
 Protocols h2 http/1.1
 SSLCompression Off
 SSLHonorCipherOrder On
 SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128
 SSLVerifyDepth 10
 SSLCertificateFile /etc/apache2/apache2.pem
 SSLCertificateKeyFile /etc/apache2/apache2.key
</VirtualHost>

 

 

Sachen sollten eigentlich soweit stimmen.

Oder muss als Zertifikat das von /etc/ssl/froxlor-custom/mgc4you.* rein?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By Pro-Webs
      Hallo,
      ich bin gerade dabei einen Shopware Shop v.5 unter nginx mit froxlor einzurichten.
      Das ist jedoch relativ problematisch.
      Aktuell habe ich im Froxlor folgende vHost Einstellung zur Domain:
      location @php { fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location / { index index.html index.php shopware.php; rewrite shopware.dll /shopware.php; rewrite files/documents/.* /engine last; #rewrite images/ayww/(.*) /images/banner/$1 last; rewrite backend/media/(.*) /media/$1 last; if (!-e $request_filename){ rewrite . /shopware.php last; } location ~ \.(jpe?g|png|gif|css|js)$ { rewrite backend/media/(.*) /media/$1 last; expires 1M; } } location ~ \.(tpl|yml|ini)$ { deny all; } location /install/ { location /install/assets { } if (!-e $request_filename){ rewrite . /install/index.php last; } } location /update/ { location /update/assets { } location /update/templates { } if (!-e $request_filename){ rewrite . /update/index.php last; } } location /recovery/install/ { location /recovery/install/assets { } if (!-e $request_filename){ rewrite . /recovery/install/index.php last; } } location /recovery/update/ { location /recovery/update/assets { } if (!-e $request_filename){ rewrite . /recovery/update/index.php last; } } location ~ ^/(logs|media/temp|bin|cache)/ { deny all; } location ~ \.php$ { try_files $uri =404; include /etc/nginx/fastcgi_params; fastcgi_pass 127.0.0.1:9000; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param HTTPS $fastcgi_https; fastcgi_param HTTP_AUTHORIZATION $http_authorization; } Diese Einstellung führt zu einem 500 error.
      Meine 35_froxlor_ssl_vhost_studio-ausruestung.de.conf sieht damit leider wie folgt aus:
      # 35_froxlor_ssl_vhost_studio-ausruestung.de.conf # Created 02.01.2020 14:30 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen 91.250.82.51:443 ssl; server_name studio-ausruestung.de www.studio-ausruestung.de xn--studio-ausrstung-tzb.de *.xn--studio-ausrstung-tzb.de studioausruestung.de *.studioausruestung.de priolite-shop.com www.priolite-shop.com sirui-shop.de www.sirui-shop.de shooting-gutschein.de *.shooting-gutschein.de shooting-gutscheine.de *.shooting-gutscheine.de; ssl_protocols TLSv1 TLSv1.2; ssl_ciphers ECDHE-RSA-AES128-SHA256:AES128-GCM-SHA256:RC4:HIGH:!MD5:!aNULL:!EDH; ssl_ecdh_curve secp384r1; ssl_prefer_server_ciphers on; ssl_certificate /etc/ssl/froxlor-custom/studio-ausruestung.de.crt; ssl_certificate_key /etc/ssl/froxlor-custom/studio-ausruestung.de.key; add_header Strict-Transport-Security "max-age=0"; ssl_stapling on; ssl_stapling_verify on; ssl_trusted_certificate /etc/ssl/froxlor-custom/studio-ausruestung.de.crt; include /etc/apache2/conf-enabled/acme.conf; access_log /var/customers/logs/klimek-studio-ausruestung.de-access.log combined; error_log /var/customers/logs/klimek-studio-ausruestung.de-error.log error; root /var/customers/webs/klimek/studio-ausruestung.de/shopware/; location / { index index.php index.html index.htm; try_files $uri $uri/ @rewrites; index index.html index.php shopware.php; rewrite shopware.dll /shopware.php; rewrite files/documents/.* /engine last; #rewrite images/ayww/(.*) /images/banner/$1 last; rewrite backend/media/(.*) /media/$1 last; if (!-e $request_filename){ rewrite . /shopware.php last; } location ~ \.(jpe?g|png|gif|css|js)$ { rewrite backend/media/(.*) /media/$1 last; expires 1M; } } location @rewrites { rewrite ^ /index.php last; } location /webalizer { alias /var/customers/webs/klimek/webalizer/studio-ausruestung.de/; auth_basic "Restricted Area"; auth_basic_user_file /etc/nginx/htpasswd/1-c3d3ffdab2b8342809d19524c21b98c1.htpasswd; } location ~ \.php { try_files /333c3697df6a41bcc37bccd05271f644.htm @php; } location @php { fastcgi_split_path_info ^(.+\.php)(/.+)$; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param PATH_INFO $fastcgi_path_info; try_files $fastcgi_script_name =404; fastcgi_index index.php; fastcgi_param HTTPS on; fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location ~ \.(tpl|yml|ini)$ { deny all; } location /install/ { location /install/assets { } if (!-e $request_filename){ rewrite . /install/index.php last; } } location /update/ { location /update/assets { } location /update/templates { } if (!-e $request_filename){ rewrite . /update/index.php last; } } location /recovery/install/ { location /recovery/install/assets { } if (!-e $request_filename){ rewrite . /recovery/install/index.php last; } } location /recovery/update/ { location /recovery/update/assets { } if (!-e $request_filename){ rewrite . /recovery/update/index.php last; } } location ~ ^/(logs|media/temp|bin|cache)/ { deny all; } } Man bemerkt u.a. das einige Konfigurationen doppelt vorhanden sind, da floxlor diese auch selbst generiert. Das könnte natürlich schon die Ursache des Fehler sein. Ich weiß nur leider nicht, wie ich es "besser" lösen kann.
      Die original .htaccess für den appache sieht folgende Konfiguration vor:
      php_value memory_limit 1024M php_value max_execution_time 600 php_value upload_max_filesize 20M php_value post_max_size 20M <IfModule mod_rewrite.c> RewriteEngine on #RewriteBase /shopware/ # Https config for the backend #RewriteCond %{HTTPS} !=on #RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] RewriteRule shopware.dll shopware.php RewriteRule files/documents/.* engine [NC,L] RewriteRule backend/media/(.*) media/$1 [NC,L] RewriteRule custom/.*(config|menu|services|plugin)\.xml$ ./shopware.php?controller=Error&action=pageNotFoundError [NC,L] RewriteCond %{REQUEST_URI} !(\/(engine|files|templates|themes|web)\/) RewriteCond %{REQUEST_URI} !(\/media\/(archive|banner|image|music|pdf|unknown|video)\/) RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ shopware.php [PT,L,QSA] # Fix missing authorization-header on fast_cgi installations RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L] </IfModule> <IfModule mod_alias.c> # Restrict access to VCS directories RedirectMatch 404 /\\.(svn|git|hg|bzr|cvs)(/|$) # Restrict access to root folder files RedirectMatch 404 /(autoload\.php|composer\.(json|lock|phar)|README\.md|UPGRADE-(.*)\.md|CONTRIBUTING\.md|eula.*\.txt|\.gitignore|.*\.dist|\.env.*)$ # Restrict access to shop configs files RedirectMatch 404 /(web\/cache\/(config_\d+\.json|all.less))$ # Restrict access to theme configurations RedirectMatch 404 /themes/(.*)(.*\.lock|package\.json|\.gitignore|Gruntfile\.js|all\.less|node_modules\/.*)$ </IfModule> # Staging environment #SetEnvIf Host "staging.test.shopware.in" SHOPWARE_ENV=staging # Development environment #SetEnvIf Host "dev.shopware.in" SHOPWARE_ENV=dev #SetEnv SHOPWARE_ENV dev DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php # Disables download of configuration <Files ~ "\.(tpl|yml|ini)$"> # Deny all requests from Apache 2.4+. <IfModule mod_authz_core.c> Require all denied </IfModule> # Deny all requests from Apache 2.0-2.2. <IfModule !mod_authz_core.c> Deny from all </IfModule> </Files> # Enable gzip compression <IfModule mod_deflate.c> AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/javascript application/json application/font-woff application/font-woff2 image/svg+xml </IfModule> <Files ~ "\.(jpe?g|png|gif|css|js|woff|woff2|ttf|svg|webp|eot|ico)$"> <IfModule mod_expires.c> ExpiresActive on ExpiresDefault "access plus 1 month" </IfModule> <IfModule mod_headers.c> Header append Cache-Control "public" Header unset ETag </IfModule> FileETag None </Files> # Match generated files like: # 1429684458_t22_s1.css # 1429684458_t22_s1.js <FilesMatch "([0-9]{10})_(.+)\.(js|css)$"> <ifModule mod_headers.c> Header set Cache-Control "max-age=31536000, public" </ifModule> <IfModule mod_expires.c> ExpiresActive on ExpiresDefault "access plus 1 year" </IfModule> </FilesMatch> # Disables auto directory index <IfModule mod_autoindex.c> Options -Indexes </IfModule> <IfModule mod_negotiation.c> Options -MultiViews </IfModule> <IfModule mod_php5.c> # php_value memory_limit 256M # php_value max_execution_time 120 # php_value upload_max_filesize 20M php_flag phar.readonly off php_flag magic_quotes_gpc off php_flag session.auto_start off php_flag suhosin.session.cryptua off php_flag zend.ze1_compatibility_mode off php_value always_populate_raw_post_data -1 </IfModule> # AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php <IfModule mod_headers.c> Header append X-Frame-Options SAMEORIGIN </IfModule>  
      Für Ideen und Vorschläge wäre ich wie immer sehr dankbar
    • By nisamudeen97
      Hi,
      Our froxlor server is behiend NAT and it uses the local IP  192.168.73.40.  We have enabled letsencrypt module in froxlor and tried validating SSL for a domain in the server.  SSL generation is getting failed with 403 error.  See the debug log information.      Replaced domain name and main IP.    Can any one help me regarding the issue.
       
      [information] Updating Let's Encrypt certificates [information] Updating domain-name.com [information] Adding SAN entry: domain-name.com [information] Adding SAN entry: www.domain-name.com [information] letsencrypt-v2 Using 'https://acme-v02.api.letsencrypt.org' to generate certificate [information] letsencrypt-v2 Using existing account key [information] letsencrypt-v2 Starting certificate generation process for domains [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/new-order [information] letsencrypt-v2 Requesting challenge for domain-name.com [information] letsencrypt-v2 Got challenge token for domain-name.com [information] letsencrypt-v2 Token for domain-name.com saved at /var/www/froxlor/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k and should be available at http://domain-name.com/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [information] letsencrypt-v2 Sending request to challenge [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/chall-v3/803008408/k46kFQ [information] letsencrypt-v2 Verification pending, sleeping 1s [information] letsencrypt-v2 Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for domain-name.com: Verification ended with error: {"type":"http-01","status":"invalid","error":{"type":"urn:ietf:params:acme:error:unauthorized","detail":"Invalid response from http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [212.224.xxx.xxx]: \"<!DOCTYPE html>\\n<html lang=\\\"en-CA\\\" class=\\\"html_stretched responsive av-preloader-active av-preloader-enabled av-default-lightbox\"","status":403},"url":"https:\/\/acme-v02.api.letsencrypt.org\/acme\/chall-v3\/803008408\/k46kFQ","token":"vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","validationRecord":[{"url":"http:\/\/www.domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"www.domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"},{"url":"http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"}]} [information] Let's Encrypt certificates have been updated  
    • By Jason Szymanski
      Hallo,
       
      ich habe leider ein Problem mit Froxlor.
      Zu meiner Situation: Froxlor läuft auf der Subdomain web01.meinedomain.net
      Jetzt möchte ich die Domain aber auch noch weiter Nutzen und habe mich daher als Kunde angelegt und die Domain meineDomain.net als Domain hinzugefügt.
      Dort kann ich auch weitere Subdomains hinzufügen. Das scheint soweit auch zu klappen ich sehe das er VHosts anlegt und auch die Verzeichnisse im FTP anlegt.
      Wenn ich jetzt allerdings versuche auf meinedomain.net oder eine andere Subdomain unter dieser Domain zuzugreifen leitet er mich auf web01.meinedomain.net
      Ich habe mich schon in den Einstellungen umgeschaut konnte aber keine entsprechende Einstellung finden an der das liegen könnte.
      Wie verhindere ich also das er mich auf Froxlor umleitet?
       
      Mit Freundlichen Grüßen
      Jason Szymanski
    • By nisamudeen97
      Hi,
      Wile doing migration of email accounts from one froxlor server to another I have noting some thing.   Expecting some clarification on this.  As we all know emails are normally stored in the location "/var/customers/mail/user/domain.com/user/Maildir/" .   I create email accounts via froxlor panel and copy the email files directly via scp or rsync from old server to new.  The strange thing I have noticed is it is not coping custom folders and its emails like we have in source.  
      The solution I have found for this is to use imapsync between old and new.  imapsync is preserving custom folders like as it is in source.    Does it mean custom folder settings are stored somewhere else?  How we can preserve it and copy emails manually?
    • By irisdina
      Warning, this is not an official guide!!!
      1.
      sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list
      sudo nano /etc/apt/source.list 1b.  insert (for Debian Stretch)
      1.2B (for Ubuntu Cosmic)
       
      1c. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. 
      sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server
      2. MariaDB install
      Warning use sudo command für this install!
      sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional)
      3. nginx install
      sudo apt install nginx 3a. 
      mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf
      4. PHP install
      sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. 
      sudo service nginx restart sudo service php7.3-fpm restart Froxlor install
      There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master)
      Stable Version
      1. 
      cd /var/www/html/ 1a. 
      sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or
      Git Version (Beta Version)
      sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer  su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory
      composer install --no-dev 1b. 
      sudo chown -R www-data:www-data Froxlor/ Set up Froxlor
      2. Open Your Browser
      2a.
      http://your IP or Hostname/Froxlor
       

      Install Froxlor finish
       3d. Move userdata (Optional) 
      sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. 
      sudo rm /etc/nginx/site-enable/default don't restart nginx!
      Froxlor Settings
      1. Cronjob
      sudo nano /etc/cron.d/froxlor insert 
      # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend
      Settings > Webserver settings > Nginx PHP backend
      from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock
      3. 
      sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port

      2a(1), SSL Port



      Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually
      sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional
      PHP-FPM activate
      1. User/Group add
      sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install 
      sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

      3. Settings > PHP-FPM > Activated:
      Change from NO to YES
      3a. PHP-FPM versions
      Change > php-fpm restart command:
      service php7.3-fpm restart and
      Configuration directory of php-fpm: > to 
      /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

      3c. 
      sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate
      1.
      sudo apt install certbot 1a. 
      sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File
      sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. 
      sudo nano /etc/nginx/acme.conf insert
      location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } }  
      2. Open your  Froxlor Panel
      Settings> SSL > Activated:
      Change from NO to YES
      2a. Settings > SSL > Settings
      Change your path from your certificate / Keyfile
      Path to the SSL certificate
      insert
      /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile
      insert
      /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings
      Activate > Enable Let's Encrypt

      Change Path to the acme.conf snippet to > 
      /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings
      - Enable Let's Encrypt for the froxlor vhost
      - Enable SSL-redirect for the froxlor vhost
      - HTTP Strict Transport Security (HSTS)
      - Include HSTS for any subdomain






      2d. Activated HTTP2 Support on > Settings > Nginx
       
×
×
  • Create New...