Jump to content
Froxlor Forum
  • 0
MGmeiner

SSL - Let's Encrypt - Debian Jessie (8.x) - Apache 2.4

Question

Hallo.

Ich habe gerade gesehen, dass es hier das Forum auch in Deutsch gibt :)
Habe die Frage zwar im englischen schon gestellt, aber in Deutsch wär mi das ganze doch lieber :) (Admin du kannst gerne meine Post im EN Forum löschen).

Ich habe seit dem Update auf Debian 8 das Problem, dass ich einen 404 Error erhalte.
Ich habe (wie in Froxlor beschrieben) die acme.conf erstellt und den Dienst "apache2" neugestartet.

Weiters habe ich auch noch 

Could not get Let's Encrypt certificate for cloudservice.DOMAIN.com: Verification ended with error: {"identifier":{"type":"dns","value":"cloudservice.DOMAIN.com"},"status":"invalid","expires":"2017-06-07T20:05:14Z","challenges":[{"type":"tls-sni-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/0auSVGvqbDFt-nH6HwptOkKZPYZNgDEguWYqE-vXTmQ\/1258196287","token":"IRK9FHJuWGV9l3qnCnoHuh7XGudY4bWd5Sx1JerSkSU"},{"type":"dns-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/0auSVGvqbDFt-nH6HwptOkKZPYZNgDEguWYqE-vXTmQ\/1258196288","token":"ufnSkvFtYYIXOWhqBGuv1QZF_iaOkrZ5USKYE0U52QM"},{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:unauthorized","detail":"Invalid response from http:\/\/cloudservice.DOMAIN.com\/.well-known\/acme-challenge\/KbrYzEkrkGJLiCBf9F-tuAq_RSft3oa1Ub8bwhsVVb8: \"<html>\r\n<head><title>404 Not Found<\/title><\/head>\r\n<body bgcolor=\"white\">\r\n<center><h1>404 Not Found<\/h1><\/center>\r\n<hr><center>\"","status":403},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/0auSVGvqbDFt-nH6HwptOkKZPYZNgDEguWYqE-vXTmQ\/1258196289","token":"KbrYzEkrkGJLiCBf9F-tuAq_RSft3oa1Ub8bwhsVVb8","keyAuthorization":"KbrYzEkrkGJLiCBf9F-tuAq_RSft3oa1Ub8bwhsVVb8.smiCkvGETnwE6QlOocMBuKikIIKHHcPhTBjXZgHYBt4","validationRecord":[{"url":"http:\/\/cloudservice.DOMAIN.com\/.well-known\/acme-challenge\/KbrYzEkrkGJLiCBf9F-tuAq_RSft3oa1Ub8bwhsVVb8","hostname":"cloudservice.DOMAIN.com","port":"80","addressesResolved":["188.68.55.173","2001:1a50:11:0:5f:8f:acfa:7c"],"addressUsed":"2001:1a50:11:0:5f:8f:acfa:7c","addressesTried":[]}]}],"combinations":[[2],[0],[1]]}
nano /etc/apache2/conf-enabled/acme.conf
Alias "/.well-known/acme-challenge" "/var/www/froxlor/.well-known/acme-challenge"
<Directory "/var/www/froxlor/.well-known/acme-challenge">
        Require all granted
</Directory>

Weiters habe ich mir dann noch gedacht ich checke die apache Einstellungen die Floxlor angeben hat.

mkdir -p /etc/apache2/sites-enabled/
chown root:0 /etc/apache2/sites-enabled/
chmod 0600 /etc/apache2/sites-enabled/
mkdir -p /etc/apache2/sites-enabled/
chown root:0 /etc/apache2/sites-enabled/
chmod 0600 /etc/apache2/sites-enabled/
mkdir -p /var/customers/webs/
mkdir -p /var/customers/logs/
mkdir -p /var/customers/tmp
chmod 1777 /var/customers/tmp
a2dismod userdir
a2enmod headers
apt-get install libapache2-mod-fastcgi

Ich habe alles außer mkdir nochmals durchgeführt. Da die Folder sind ja schon vorhanden.
Kann ich sonst noch irgendwo was einstellen oder kontrollieren?

 

592f26f85b34b_Bildschirmfoto2017-05-31um22_23_32.thumb.png.c9336b59ca03b95ff4961a8609022c15.png

592f26f26da2f_Bildschirmfoto2017-05-31um22_23_25.thumb.png.b1a8fe8e8f2597db1c547e1229ce46b4.png

592f26ec6b549_Bildschirmfoto2017-05-31um22_22_38.thumb.png.f1e4df682c6983ac4c3ade7cdcf63028.png

Liebe Grüße
Matthias

 

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

1) erstelle /var/www/froxlor/.well-known/acme-challenge/test und schreib "hallo" rein

2) öffne http://cloudservice.DOMAIN.com/.well-known/acme-challenge/test im browser und guck ob "hallo" angezeigt wird

Share this post


Link to post
Share on other sites
  • 0

Ich konnte das Problem früher lösen indem ich die Anführungszeichen aus der acme.conf entfernt habe:

 

Alias /.well-known/acme-challenge /var/www/froxlor/.well-known/acme-challenge
<Directory /var/www/froxlor/.well-known/acme-challenge>
        Require all granted
</Directory>

Share this post


Link to post
Share on other sites
  • 0

Habe die Datei angepasst und Apache neugestartet.

Bekomme leider immer noch den gleichen Fehler. :/ 
 

Alias /.well-known/acme-challenge /var/www/froxlor/.well-known/acme-challenge
<Directory /var/www/froxlor/.well-known/acme-challenge>
        Require all granted
</Directory>
/etc/init.d/apache2 restart
     
Could not get Let's Encrypt certificate for cloudservice.DOMAIN.com: Verification ended with error: {"identifier":{"type":"dns","value":"cloudservice.DOMAIN.com"},"status":"invalid","expires":"2017-06-08T13:05:16Z","challenges":[{"type":"dns-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/1R7AYyh-akU_ozfgm9l4wOnb2jL2hI_sxQXUhnR4cMk\/1262591480","token":"8G2PVi-I6CI5CW4Cc4FeWi8QPYiPhGEtNYIVHROYNY0"},{"type":"tls-sni-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/1R7AYyh-akU_ozfgm9l4wOnb2jL2hI_sxQXUhnR4cMk\/1262591481","token":"9RBImxAtl6z6RuUDQgr-YCE1rf2raIbsHizUM5iodHM"},{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:unauthorized","detail":"Invalid response from http:\/\/cloudservice.DOMAIN.com\/.well-known\/acme-challenge\/nvjPaJZ90ZgsTisXBUqtyHR8nxzxQ-2ra2wv-ypmMYk: \"<html>\r\n<head><title>404 Not Found<\/title><\/head>\r\n<body bgcolor=\"white\">\r\n<center><h1>404 Not Found<\/h1><\/center>\r\n<hr><center>\"","status":403},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/1R7AYyh-akU_ozfgm9l4wOnb2jL2hI_sxQXUhnR4cMk\/1262591482","token":"nvjPaJZ90ZgsTisXBUqtyHR8nxzxQ-2ra2wv-ypmMYk","keyAuthorization":"nvjPaJZ90ZgsTisXBUqtyHR8nxzxQ-2ra2wv-ypmMYk.f7N1DND5PhqeqtGzbxEu4gPZzA7v_A7aTqBFpNAczC8","validationRecord":[{"url":"http:\/\/cloudservice.DOMAIN.com\/.well-known\/acme-challenge\/nvjPaJZ90ZgsTisXBUqtyHR8nxzxQ-2ra2wv-ypmMYk","hostname":"cloudservice.DOMAIN.com","port":"80","addressesResolved":["188.68.55.173","2001:1a50:11:0:5f:8f:acfa:7c"],"addressUsed":"2001:1a50:11:0:5f:8f:acfa:7c","addressesTried":[]}]}],"combinations":[[0],[1],[2]]}

Liebe Grüße

Matthias

Share this post


Link to post
Share on other sites
  • 0

ich hab von vielen schon gehört das komische konstellationen in der /etc/hosts datei auch dazu führen, dass der "self-check" von froxlor nicht funktioniert. Ansonsten natürlich prüfen: zeigt die Domain auch auf die korrekten IPs? Mehr kann man mit DOMAIN.com leider nicht anfangen, dann müsst ich schon die echte kennen, auch in bezug auf einträge in der /etc/hosts...aber schau einfach mal nach, vllt fällt dir ja schon was auf

Share this post


Link to post
Share on other sites
  • 0

Hallo.

Die Domain habe ich via AAA und A weitergeleitet. Ansurfen kann ich die Seite ja auch, komme dann auch auf die richtigen Daten die im FTP Verzeichnis liegen.

/etc/host steht
 


127.0.0.1       localhost
127.0.1.1       kvmimageinstall.yourvserver.net kvmimageinstall

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
1XX.XX.XX.XXX   XXXXX.happysrv.de  XXXXX

Ich schick dir mal die IP und die Domain in einer PN.
Lg Matthias

Share this post


Link to post
Share on other sites
  • 0

Wie sollten die Rechte der Ordner vergeben sein?
Eventuell stimmt hier etwas nicht, dass er (Froxlor - ConJob) keine Datei erstellen kann.

Liebe Grüße
Matthias

Share this post


Link to post
Share on other sites
  • 0

ne das passt alles, zeig uns mal bitte den vhost (nonssl und ssl) von der domain, hilfreich wäre halt wenn ips nicht unbedingt verschleiert würden (das letzte segment kannste ja weglassen, aber das helfen ist immer schwer wenn jemand x.x.x.x schreibt und am ende steht da z.B. ne interne IP [192.168...] oder sonstwas und man sucht sich nen wolf)

Share this post


Link to post
Share on other sites
  • 0

Ich habe dir Gestern ein PN mit der IP gesendet :)

Die vhost der Domain

# 35_froxlor_normal_vhost_cloudservice.DOMAIN.com.conf
# Created 01.06.2017 14:10
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

# Domain ID: 22 - CustomerID: 4 - CustomerLogin: owncloud
<VirtualHost 188.68.55.XXX:80>
  ServerName cloudservice.DOMAIN.com
  ServerAdmin mail@DOMAIN.com
  DocumentRoot "/var/customers/webs/owncloud/"
  FastCgiExternalServer /var/www/php-fpm/owncloud/cloudservice.DOMAIN.com/fpm.external -socket /var/lib/apache2/fastcgi/owncloud-cloudservice.DOMAIN.com-php-fpm.socket -idle-timeout 30
  <Directory "/var/customers/webs/owncloud/">
    <FilesMatch "\.php$">
      SetHandler php5-fastcgi
      Action php5-fastcgi /fastcgiphp
      Options +ExecCGI
    </FilesMatch>
    Require all granted
    AllowOverride All
  </Directory>
  Alias /fastcgiphp /var/www/php-fpm/owncloud/cloudservice.DOMAIN.com/fpm.external
  ErrorLog "/var/customers/logs/owncloud-error.log"
  CustomLog "/var/customers/logs/owncloud-access.log" combined
</VirtualHost>

Die  SSL vhost der Domain

# 35_froxlor_ssl_vhost_cloudservice.DOMAIN.com.conf
# Created 01.06.2017 14:10
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

# Domain ID: 22 (SSL) - CustomerID: 4 - CustomerLogin: owncloud
# no ssl-certificate was specified for this domain, therefore no explicit vhost is being generated

Und hier nochmals /etc/host (nur die letzen 3 Zeichen ersetzt)

 


127.0.0.1       localhost
127.0.1.1       kvmimageinstall.yourvserver.net kvmimageinstall

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
188.68.55.XXX   SERVERNAME.happysrv.de  SERVERNAME

 

Share this post


Link to post
Share on other sites
  • 0

@d00p Ich komme hier leider vorab nicht weiter. Ich habe mit 

watch -n .1 "ls -al"

kontrollierte, das im "/.well-known/acme-challenge" Ordern so passiert wenn ich den Cron starte.
Es wird die Datei erstellt mit root als Besitzer und danach wird sie gelöscht, leider erhalte ich trotzdem ein 404 Fehler.
Dann habe ich im Script das Löschen auskommentiert, danach bleibt die Datei und ich kann sie auch direkt ansurfen.
Trotzdem erhalte ich einen 404 Fehler über den Cron-Job. 

Bietest du deine Dienst auch gegen eine Spende für euere Projekt an?
Bin leider am Ende meiner Ideen :)

Liebe Grüße
Matthias

Share this post


Link to post
Share on other sites
  • 0

Morgen kann ich gern mal schauen. Bräuchte dann natürlich entsprechenden Zugang (root), einfach per PM. Oder schau morgen einfach im IRC vorbei.

Share this post


Link to post
Share on other sites
  • 0

Nun klappt alles. :)
Ich hatte ein Fehler im AAAA Eintrag. Hier hatte ich versehentlich die falsche Adresse bei der Domain hinterlegt.

Danke für eute Hilfe.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By j4mb4l4j4
      Hallo, ich hätte eine Frage da ich aktuell in folgendes Problem laufe.
      Froxlor version: 0.9.39.5 (DB: 201805290)
      Meine Domains bekommen aktuell keine neuen Zertifikate mehr, da der Cronjob der die Letsencrypt Zertifikate erzeugt einen Fehler wirft.
      Gemäß Syspanel bekomme ich die Meldung (customer = mein Kunde, my.domain.com = meine Domain):
      25.03.19 18:51:38 error customer Could not get Let's Encrypt certificate for my.domain.com: Curl: Unknown SSL protocol error in connection to acme-v02.api.letsencrypt.org:443 25.03.19 17:48:28 error froxlor.panel Could not get Let's Encrypt certificate for my.domain.com: Curl: Unknown SSL protocol error in connection to acme-v02.api.letsencrypt.org:443 25.03.19 17:35:04 error customer Could not get Let's Encrypt certificate for my.domain.com: Curl: Empty reply from server 25.03.19 16:47:52 error froxlor.panel Could not get Let's Encrypt certificate for my.domain.com: Curl: Unknown SSL protocol error in connection to acme-v02.api.letsencrypt.org:443 25.03.19 16:43:53 error froxlor.panel Could not get Let's Encrypt certificate for my.domain.com: Curl: Empty reply from server 25.03.19 16:43:53 error customer Could not get Let's Encrypt certificate for my.domain.com: Curl: Unknown SSL protocol error in connection to acme-v02.api.letsencrypt.org:443 25.03.19 16:30:27 error froxlor.panel Could not get Let's Encrypt certificate for my.domain.com: Curl: Empty reply from server 20.03.19 16:55:42 error froxlor.panel Could not get Let's Encrypt certificate for my.domain.com: Curl: Could not resolve host: acme-v02.api.letsencrypt.org 20.03.19 16:50:50 error customer Could not get Let's Encrypt certificate for my.domain.com: Curl: Could not resolve host: acme-v02.api.letsencrypt.org 20.03.19 16:50:20 error froxlor.panel Could not get Let's Encrypt certificate for my.domain.com: Curl: Operation timed out after 0 milliseconds with 0 out of 0 bytes received 09.03.19 16:12:36 error customer Could not get Let's Encrypt certificate for my.domain.com: Curl: Empty reply from server 09.03.19 14:52:02 error customer Could not get Let's Encrypt certificate for my.domain.com: Curl: Empty reply from server 01.03.19 14:54:10 error customer Could not get Let's Encrypt certificate for my.domain.com: Curl: Unknown SSL protocol error in connection to acme-v02.api.letsencrypt.org:443 01.03.19 05:30:01 error customer Could not get Let's Encrypt certificate for my.domain.com: Curl: error:14077438:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert internal error Leider bekomme ich wenn ich folgenden Befehl ausführe auch keine Meldung, es hängt einfach und passiert nix:
      root@server:/var/run# php -q /var/www/my.domain.com/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Updating Let's Encrypt certificates [information] Updating my.domain.com [information] letsencrypt-v2 Using 'https://acme-v02.api.letsencrypt.org' to generate certificate [information] letsencrypt-v2 Using existing account key [information] letsencrypt-v2 Starting certificate generation process for domains [information] letsencrypt-v2 Requesting challenge for my.domain.com Leider sehe ich keine weitere Möglichkeit zum Debugging.
      Wo müsste ich ansetzen um mehr Logs zu bekommen, bzw. kennt jemand den Fehler und kann mir sagen was ich falsch mache ?
      Irgendwie verstehe ich nicht was das Problem ist.
      Auf einem anderen Server mit anderer IP und Froxlor habe ich genau das gleiche Problem.
      Ich kann erfolgreich pingen und telnetten:
      root@server:/var/run# telnet acme-v02.api.letsencrypt.org 443 Trying 2a02:26f0:eb:186::3a8e... Connected to e14990.dscx.akamaiedge.net. Escape character is '^]'. ^CConnection closed by foreign host.  

    • By princeofnaxos
      After migrating from syscp, all SSL hosts have empty host files. A comment is there, saying "# no ssl-certificate was specified for this domain, therefore no explicit vhost is being generated".
      Looking in lib/Froxlor/Cron/Http/Apache.php, I see that $domain['ssl_cert_file'] must be empty in order to get that message. But where in the domain form should I enter the certificate's filename? There is nothing under "Webserver SSL settings" that looks like that.
       
    • By FearTheDude
      Folgende Situation:
      Ich betreibe einen vServer mit Froxlor als Hostingpanel
      Der docroot von meinedomain.tld liegt unter /var/customers/webs/meinAccount
      Eine SSL Weiterleitung wurde auf meinedomain.tld eingerichtet
      Kunden verwenden ein paar vorinstallierte tools (Webmailer, DB Frontend, Froxlor Panel) über toolname.meinedomain.tld
      Die Tools liegen nicht im docroot von meinedomain.tld sondern unter /var/www/toolname
      Folgendes Problem:
      Die SSL Weiterleitung von http auf https bei der Hauptdomain meinedomain.tld funktioniert nicht, es sei denn, man verwendet eine der Subdomains für die Tools
      Für meinedomain.tld wird anstatt /var/customers/webs/meinAccount der docroot /var/www verwendet
      Vorübergehende Lösung:
      Die Prüfung, ob mod_rewrite in der NN_froxlor_normal_vhost_meinedomain.tld.conf aktiv ist, entfernen
      <IfModule !mod_rewrite.c> Redirect 301 / https://meinedomain.tld/ </IfModule> Dann findet IMMER ein Redirect auf HTTPS statt, wobei hier auch der richtige docroot geladen wird.
      Nachteil:
      Sobald die Configs neu geschrieben werden, ist die Änderung weg.
      Fragen:
      Kann man die mod_rewrite prüfung für die SSL Weiterleitung irgendwo dauerhaft deaktivieren?
      Warum verwendet der vHost Container für http keinen bzw. den falschen docroot?
      Wie kann ich persistente Änderungen an den .conf Dateien für einen vHost vornehmen?
    • By megoo
      Hallo, ich habe in Problem mit dem Einrichten von SSL via  Let's Encrypt. Ich nutze
      froxlor 0.9.39.5-1
      Apache/2.2.22 (Debian)
      Ich möchte für alle Domains SSL mittels Let's Encrypt aktivieren. 
      domain1 dafür entsprechend konfigiert. Funktioniert alles.
      domain2 genauso wie Domain1 konfiguriert (gleiche IP:443, Benutze Let's Encrypt an, ServerAlias-Angabe für Domain: www), der Zugriff via https gibt allerdings den Fehler aus: SSL_ERROR_BAD_CERT_DOMAIN
      Der Browser sagt, das Zertifikat gilt nur für folgende Namen: domain1
      domain2 nutzt also das falsche Zertifikate. 
      Die Debug Ausgabe des froxlor master cronjob sagt:
      [Thu Jul 12 13:28:05 2018] [warn] VirtualHost meineip:443 overlaps with VirtualHost meineip:443, the first has precedence, perhaps you need a NameVirtualHost directive
      Ich hab mir die erzeugten conf Dateien in /etc/apache2/sites-enabled angesehen, dort ist keine NameVirtualHost Anweisung erhalten. Diese eingefügt, Apache neu gestartet, funktioniert alles. Nun überschreibt froxlor diese Einstellung wieder, folglich, wieder das oben beschriebene Problem.
      Wie/wo kann ich das in Froxlor einstellen, global? Oder muss ich für jede Domain eine "Eigene vHost-Einstellungen" festlegen?
      Auf einem anderen Server mit Apache 2.4 und der gleichen Vorgehensweise hat alles problemlos mit einer IP und über 10 Domains funktioniert. Und dort steht keine NameVirtualHost directive in den conf Dateien.
    • By Keon
      Hallo alle miteinander,
       
      ich bin derweil dabei mir Froxlor auf einem CentOS7 System zum laufen zu bringen. Hier mal kurz ein kleiner Überblick wie ich aktuell stehe:
      SSH Port ändern, sudo User, NTP, EPEL Release, FirewallD für http, https, ssh mit neuem Port frei, fail2ban für SSH Apache, MariaDB, PHPMyAdmin, mod_ssl inkl. config und self signed cert, Froxlor Grundinstallation, Webserver und SSL Einstellungen Admin Menü, (Pfade, reload Script etc.) IP/Port 443 hinzugefügt, Konfiguration -> CentOS -> sonstiges -> cronjob for froxlor Ebenso habe ich - auch wenn unter "Konfiguration" für "CentOS" nicht vorhanden, die acme.conf angelegt  
      Kommen wir zur Frage:
      Wie bekomme ich hin, dass ich folgende Einstellung setzen kann:
       
      Habe ich noch etwas vergessen? Etwas grundlegendes? Bin normalerweise seit Debian Etch bis Jessie gewöhnt - sammle grad die ersten Erfahrungen mit Froxlor & CentOS nach 2 Jahren Pause aus der Informatik.
       
      Beste Grüße




×
×
  • Create New...