Jump to content
Froxlor Forum
  • 0

Need a little help (Apache, Ubuntu, PHP7)


Question

Hello. I have been looking around the forums for about two days now, and can't find an answer, so I am begging for help!

I have everything installed on a clean run of Ubi14.04 with all updates to everything. Plugged nano, curl, and wget into my normal setup process. 

When I installed Froxlor, I ran into some issues because of the documentation pointing to /var/www/froxlor rather than /var/www/html/froxlor as it should have been. Fixed that, did my chow chow (chown) to the www-data user and everything was fine for a few minutes, but now I get a constant error every 5 mins or so saying this:

Whoops!
The configuration file lib/userdata.inc.php cannot be read from the webserver.
 
This mostly happens due to wrong ownership.
Try the following command to correct the ownership:
 
chown -R www-data:www-data /var/www/html/froxlor

Is this a bug, or do I need to change something because it wasn't typed correctly, like the instructions? 

 

And no, d00p, I have checked and for whatever reason PHP7 will not allow, or already has installed the "mod_php". As for the constant other recommendation of installing "mod_fcgid", I did so with no change in the results. Seriously, please help me.

Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
16 hours ago, jstacklin said:

The configuration file lib/userdata.inc.php cannot be read from the webserver.

Check your settings then?! Either your webserver user is not www-data or your are using fcgid/php-fpm and have it incorrectly setup

16 hours ago, jstacklin said:

And no, d00p, I have checked and for whatever reason PHP7 will not allow, or already has installed the "mod_php". As for the constant other recommendation of installing "mod_fcgid", I did so with no change in the results. Seriously, please help me.

i don't know what you want to tell me with this...

Link to post
Share on other sites
  • 0
16 hours ago, jstacklin said:

Further, I would like to ask why I as the end user needs to set everything up (ie: where cron goes, etc, etc)

you are not the end-user...your customers are the enduser - you sir are the ADMIN of the server...YOU are in control of your server, not froxlor

Link to post
Share on other sites
  • 0
2 hours ago, d00p said:

Check your settings then?! Either your webserver user is not www-data or your are using fcgid/php-fpm and have it incorrectly setup

Then why does it say to use "www-data"?!? And why does when I type that, it works, but my other username, it doesn't? Well to be honest, I followed your instructions to the letter, so if you mis-translated something or didn't take the time to even look and make sure that your program worked then you need to check your privilege and come down to earth with the rest of us because your attitude isn't helping anyone. 

2 hours ago, d00p said:

i don't know what you want to tell me with this...

That I did the troubleshooting steps that you so rudely pushed on other users. Other END USERS.

2 hours ago, d00p said:

you are not the end-user...your customers are the enduser - you sir are the ADMIN of the server...YOU are in control of your server, not froxlor

No. There is two levels of end-users: Me, who is the end-user of your software which IS responsible for installing dependencies and putting things into place like they are supposed to. All your competitors do it, so why can't you? Sentora, Virtualmin, Kloxor-MR, ISPconfig, and VestaCP all install crons, settings, and everything else. You and your software is no better than them. You are a developer, just like they are, and your software is open-sourced just like theirs is. The next level of end-user is the customer, who is the end-user of my websites and services. I didn't install your control panel to have to do everything myself. If I wanted that, I would have just coded the scripts and everything, since your software can't even do that properly.

Link to post
Share on other sites
  • 0

You dont like it - dont use it. There are thousands of users who are satisfied and have no issues at all. Froxlor is not for beginners. And so is operating a server.

Link to post
Share on other sites
  • 0
2 minutes ago, d00p said:

You dont like it - dont use it. There are thousands of users who are satisfied and have no issues at all. Froxlor is not for beginners. And so is operating a server.

No, operating a server is easy: When you write documentation in whatever little world you live in, and it doesn't make sense to the rest of us, then you give us shit for asking for help; that's my issue. You need to shut up, step up and get real. Your own services went down for a while. Again, shut up, step up, and man up. I don't know if all you Germans are like this, but you aren't the best. I am sincerely worried about your mental health, buddy. You push off all advice and questions as if I am nothing compared to you. The fact is that you don't know me, and let's be frank: You don't care. All you want is me to buy your services, so I will give you access to my server so you can do whatever you would like.

 

Man up. We make mistakes all the time, look at the original zPanel, or Kloxor for examples of that! Maybe it's time to let the project die, fork it, and start anew. 

 

Else, I don't know what world you live in. But I truly think you need some help, buddy.

Link to post
Share on other sites
  • 0

You really should think before you post anything like that just because you are frustrated with your server. There are lots of users who can handle their stuff. And no, i don't want you to buy my services, because i don't want to help you anymore, not even for money. Good bye

 

Link to post
Share on other sites
  • 0
23 hours ago, jstacklin said:

I don't know if all you Germans are like this, but you aren't the best. I am sincerely worried about your mental health, buddy. You push off all advice and questions as if I am nothing compared to you. The fact is that you don't know me, and let's be frank: You don't care. All you want is me to buy your services, so I will give you access to my server so you can do whatever you would like.

Poor, retarded and isolated kid...

I wish you all the best for your mental health dude...

  • Like 1
Link to post
Share on other sites
  • 0
On 4/26/2017 at 4:18 AM, jstacklin said:

No, operating a server is easy: When you write documentation in whatever little world you live in, and it doesn't make sense to the rest of us, then you give us shit for asking for help; that's my issue. You need to shut up, step up and get real. Your own services went down for a while. Again, shut up, step up, and man up. I don't know if all you Germans are like this, but you aren't the best. 

Man this was pure impulse.  Might want to get checked for ADHD in all seriousness.  But honestly I understand the frustration.

That was a bad start so let me try again. Hello everyone!  I'm new here.  I've been co-administering dozens of dedicated windows web servers and 2 clustered environments that I helped architect for about 3 years with no formal education. Each server environment usually had sql server and mysql.  Maybe I'm just a fast, self taught learner...idk.  My point is that as of last week I had no experience at all with Linux or apache.  One week later I have a working Froxlor setup with php-fpm on ubuntu 16 with php7.1 (small annoyance here but it works and I'll figure it out eventually).  I can relate to what this user experienced following the setup guides, but then again I'm using ubuntu 16 which was my choice.  I first tried with centos and had no luck.  The SOLUTION was I relied on a few outside forums that i would compare to a froxlor guide or forum post, slightly modify the paths/variables for my environment and eventually find a way.  The final breakthrough came when I discovered a video d00p had posted describing setup steps I had somehow not encountered in the configuration.

 

@Jstacklin The update thing doesn't currently work for me... but I just discovered the issue 2 hours ago and this was my first stop.  I already know the problem was that I moved the froxlor root from www/html/froxlor to www/froxlor during setup.  So when I have time I'll dive into how to fix it.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By Nicholas Wood
      Hey,
      I'm installing Froxlor on CentOS 8 and everything seems to have gone well for the most part. However the config file was supposedly saved in /tmp/xxx but I can't find that file anywhere.
      cd tmp/fxVnlJGY ... doesn't exist. Anyone know where that is?


       
       
      Running the below command from www/html folder and then reinstalling produces the same result.
      sudo chown -R apache:apache froxlor  
    • By Matteo
      I am installing Froxlor 10 on Debian 10 with MySQL and Apache2 on a home web server.
      I get to the installation screen by going to localhost/froxlor and I get
      "Welcome to Froxlor"
      "It seems that Froxlor has not been installed yet."
      "Click on the link below to start the installation."
      I click "Start Install" and get to this page:
      Checking system requirements...
      All requirements are satisfied [green] and this is at the bottom:
      All requirements are satisfied
        Clicking the link to continue takes me to:
      Database connection
      MySQL-Hostname:
      Database name:
      Username for the unprivileged MySQL-account:
      Password for the unprivileged MySQL-account:
      Username for the MySQL-root-account:
      Password for the MySQL-root-account:
       
      Administrator Account
      Administrator Username:
      Administrator Password:
      Administrator-Password (confirm):
      Enable the official newsfeed
      (https://inside.froxlor.org/news/):
       
      Server settings
      Server name (FQDN, no ip-address):
      Server IP:
      Webserver Apache 2.4:
      HTTP username:
      HTTP groupname:
       
      [With all the correct fields and passwords filled in...]
      Clicking the [continue] button takes me to the success screen...:
      Froxlor install - setup
      Checking MySQL-root access... OK Creating backup of old database... OK  Preparing database... OK Creating database and username... OK Testing if database and user have been created correctly... OK Importing data... OK Adjusting settings... OK Inserting new values... OK Creating admin-account... OK Creating configfile... File was saved in /... Froxlor was installed successfully.
        Clicking the login button takes me to this:
      "Welcome to Froxlor"
      "It seems that Froxlor has not been installed yet."
      "Click on the link below to start the installation."
      And the process starts all over again...
      It doesn't matter which browser I use - Chrome, Firefox - the result is the same.
      I am a new Linux user, so some help would be appreciated.
      Thank you.
       
    • By Marcel -//- AdSoleWare
      Hello.
      I manually installed Froxlor on Debian 8 and tried setting up. i installed php 7.3 in as it was the only missing point. i restarted apache2 and now it wont start. I need help
       
      Error Log:
       
    • By Pro-Webs
      Hallo,
      ich bin gerade dabei einen Shopware Shop v.5 unter nginx mit froxlor einzurichten.
      Das ist jedoch relativ problematisch.
      Aktuell habe ich im Froxlor folgende vHost Einstellung zur Domain:
      location @php { fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location / { index index.html index.php shopware.php; rewrite shopware.dll /shopware.php; rewrite files/documents/.* /engine last; #rewrite images/ayww/(.*) /images/banner/$1 last; rewrite backend/media/(.*) /media/$1 last; if (!-e $request_filename){ rewrite . /shopware.php last; } location ~ \.(jpe?g|png|gif|css|js)$ { rewrite backend/media/(.*) /media/$1 last; expires 1M; } } location ~ \.(tpl|yml|ini)$ { deny all; } location /install/ { location /install/assets { } if (!-e $request_filename){ rewrite . /install/index.php last; } } location /update/ { location /update/assets { } location /update/templates { } if (!-e $request_filename){ rewrite . /update/index.php last; } } location /recovery/install/ { location /recovery/install/assets { } if (!-e $request_filename){ rewrite . /recovery/install/index.php last; } } location /recovery/update/ { location /recovery/update/assets { } if (!-e $request_filename){ rewrite . /recovery/update/index.php last; } } location ~ ^/(logs|media/temp|bin|cache)/ { deny all; } location ~ \.php$ { try_files $uri =404; include /etc/nginx/fastcgi_params; fastcgi_pass 127.0.0.1:9000; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param HTTPS $fastcgi_https; fastcgi_param HTTP_AUTHORIZATION $http_authorization; } Diese Einstellung führt zu einem 500 error.
      Meine 35_froxlor_ssl_vhost_studio-ausruestung.de.conf sieht damit leider wie folgt aus:
      # 35_froxlor_ssl_vhost_studio-ausruestung.de.conf # Created 02.01.2020 14:30 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen 91.250.82.51:443 ssl; server_name studio-ausruestung.de www.studio-ausruestung.de xn--studio-ausrstung-tzb.de *.xn--studio-ausrstung-tzb.de studioausruestung.de *.studioausruestung.de priolite-shop.com www.priolite-shop.com sirui-shop.de www.sirui-shop.de shooting-gutschein.de *.shooting-gutschein.de shooting-gutscheine.de *.shooting-gutscheine.de; ssl_protocols TLSv1 TLSv1.2; ssl_ciphers ECDHE-RSA-AES128-SHA256:AES128-GCM-SHA256:RC4:HIGH:!MD5:!aNULL:!EDH; ssl_ecdh_curve secp384r1; ssl_prefer_server_ciphers on; ssl_certificate /etc/ssl/froxlor-custom/studio-ausruestung.de.crt; ssl_certificate_key /etc/ssl/froxlor-custom/studio-ausruestung.de.key; add_header Strict-Transport-Security "max-age=0"; ssl_stapling on; ssl_stapling_verify on; ssl_trusted_certificate /etc/ssl/froxlor-custom/studio-ausruestung.de.crt; include /etc/apache2/conf-enabled/acme.conf; access_log /var/customers/logs/klimek-studio-ausruestung.de-access.log combined; error_log /var/customers/logs/klimek-studio-ausruestung.de-error.log error; root /var/customers/webs/klimek/studio-ausruestung.de/shopware/; location / { index index.php index.html index.htm; try_files $uri $uri/ @rewrites; index index.html index.php shopware.php; rewrite shopware.dll /shopware.php; rewrite files/documents/.* /engine last; #rewrite images/ayww/(.*) /images/banner/$1 last; rewrite backend/media/(.*) /media/$1 last; if (!-e $request_filename){ rewrite . /shopware.php last; } location ~ \.(jpe?g|png|gif|css|js)$ { rewrite backend/media/(.*) /media/$1 last; expires 1M; } } location @rewrites { rewrite ^ /index.php last; } location /webalizer { alias /var/customers/webs/klimek/webalizer/studio-ausruestung.de/; auth_basic "Restricted Area"; auth_basic_user_file /etc/nginx/htpasswd/1-c3d3ffdab2b8342809d19524c21b98c1.htpasswd; } location ~ \.php { try_files /333c3697df6a41bcc37bccd05271f644.htm @php; } location @php { fastcgi_split_path_info ^(.+\.php)(/.+)$; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param PATH_INFO $fastcgi_path_info; try_files $fastcgi_script_name =404; fastcgi_index index.php; fastcgi_param HTTPS on; fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location ~ \.(tpl|yml|ini)$ { deny all; } location /install/ { location /install/assets { } if (!-e $request_filename){ rewrite . /install/index.php last; } } location /update/ { location /update/assets { } location /update/templates { } if (!-e $request_filename){ rewrite . /update/index.php last; } } location /recovery/install/ { location /recovery/install/assets { } if (!-e $request_filename){ rewrite . /recovery/install/index.php last; } } location /recovery/update/ { location /recovery/update/assets { } if (!-e $request_filename){ rewrite . /recovery/update/index.php last; } } location ~ ^/(logs|media/temp|bin|cache)/ { deny all; } } Man bemerkt u.a. das einige Konfigurationen doppelt vorhanden sind, da floxlor diese auch selbst generiert. Das könnte natürlich schon die Ursache des Fehler sein. Ich weiß nur leider nicht, wie ich es "besser" lösen kann.
      Die original .htaccess für den appache sieht folgende Konfiguration vor:
      php_value memory_limit 1024M php_value max_execution_time 600 php_value upload_max_filesize 20M php_value post_max_size 20M <IfModule mod_rewrite.c> RewriteEngine on #RewriteBase /shopware/ # Https config for the backend #RewriteCond %{HTTPS} !=on #RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] RewriteRule shopware.dll shopware.php RewriteRule files/documents/.* engine [NC,L] RewriteRule backend/media/(.*) media/$1 [NC,L] RewriteRule custom/.*(config|menu|services|plugin)\.xml$ ./shopware.php?controller=Error&action=pageNotFoundError [NC,L] RewriteCond %{REQUEST_URI} !(\/(engine|files|templates|themes|web)\/) RewriteCond %{REQUEST_URI} !(\/media\/(archive|banner|image|music|pdf|unknown|video)\/) RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ shopware.php [PT,L,QSA] # Fix missing authorization-header on fast_cgi installations RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L] </IfModule> <IfModule mod_alias.c> # Restrict access to VCS directories RedirectMatch 404 /\\.(svn|git|hg|bzr|cvs)(/|$) # Restrict access to root folder files RedirectMatch 404 /(autoload\.php|composer\.(json|lock|phar)|README\.md|UPGRADE-(.*)\.md|CONTRIBUTING\.md|eula.*\.txt|\.gitignore|.*\.dist|\.env.*)$ # Restrict access to shop configs files RedirectMatch 404 /(web\/cache\/(config_\d+\.json|all.less))$ # Restrict access to theme configurations RedirectMatch 404 /themes/(.*)(.*\.lock|package\.json|\.gitignore|Gruntfile\.js|all\.less|node_modules\/.*)$ </IfModule> # Staging environment #SetEnvIf Host "staging.test.shopware.in" SHOPWARE_ENV=staging # Development environment #SetEnvIf Host "dev.shopware.in" SHOPWARE_ENV=dev #SetEnv SHOPWARE_ENV dev DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php # Disables download of configuration <Files ~ "\.(tpl|yml|ini)$"> # Deny all requests from Apache 2.4+. <IfModule mod_authz_core.c> Require all denied </IfModule> # Deny all requests from Apache 2.0-2.2. <IfModule !mod_authz_core.c> Deny from all </IfModule> </Files> # Enable gzip compression <IfModule mod_deflate.c> AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/javascript application/json application/font-woff application/font-woff2 image/svg+xml </IfModule> <Files ~ "\.(jpe?g|png|gif|css|js|woff|woff2|ttf|svg|webp|eot|ico)$"> <IfModule mod_expires.c> ExpiresActive on ExpiresDefault "access plus 1 month" </IfModule> <IfModule mod_headers.c> Header append Cache-Control "public" Header unset ETag </IfModule> FileETag None </Files> # Match generated files like: # 1429684458_t22_s1.css # 1429684458_t22_s1.js <FilesMatch "([0-9]{10})_(.+)\.(js|css)$"> <ifModule mod_headers.c> Header set Cache-Control "max-age=31536000, public" </ifModule> <IfModule mod_expires.c> ExpiresActive on ExpiresDefault "access plus 1 year" </IfModule> </FilesMatch> # Disables auto directory index <IfModule mod_autoindex.c> Options -Indexes </IfModule> <IfModule mod_negotiation.c> Options -MultiViews </IfModule> <IfModule mod_php5.c> # php_value memory_limit 256M # php_value max_execution_time 120 # php_value upload_max_filesize 20M php_flag phar.readonly off php_flag magic_quotes_gpc off php_flag session.auto_start off php_flag suhosin.session.cryptua off php_flag zend.ze1_compatibility_mode off php_value always_populate_raw_post_data -1 </IfModule> # AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php <IfModule mod_headers.c> Header append X-Frame-Options SAMEORIGIN </IfModule>  
      Für Ideen und Vorschläge wäre ich wie immer sehr dankbar
    • By nisamudeen97
      Hi,
      Our froxlor server is behiend NAT and it uses the local IP  192.168.73.40.  We have enabled letsencrypt module in froxlor and tried validating SSL for a domain in the server.  SSL generation is getting failed with 403 error.  See the debug log information.      Replaced domain name and main IP.    Can any one help me regarding the issue.
       
      [information] Updating Let's Encrypt certificates [information] Updating domain-name.com [information] Adding SAN entry: domain-name.com [information] Adding SAN entry: www.domain-name.com [information] letsencrypt-v2 Using 'https://acme-v02.api.letsencrypt.org' to generate certificate [information] letsencrypt-v2 Using existing account key [information] letsencrypt-v2 Starting certificate generation process for domains [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/new-order [information] letsencrypt-v2 Requesting challenge for domain-name.com [information] letsencrypt-v2 Got challenge token for domain-name.com [information] letsencrypt-v2 Token for domain-name.com saved at /var/www/froxlor/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k and should be available at http://domain-name.com/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [information] letsencrypt-v2 Sending request to challenge [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/chall-v3/803008408/k46kFQ [information] letsencrypt-v2 Verification pending, sleeping 1s [information] letsencrypt-v2 Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for domain-name.com: Verification ended with error: {"type":"http-01","status":"invalid","error":{"type":"urn:ietf:params:acme:error:unauthorized","detail":"Invalid response from http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [212.224.xxx.xxx]: \"<!DOCTYPE html>\\n<html lang=\\\"en-CA\\\" class=\\\"html_stretched responsive av-preloader-active av-preloader-enabled av-default-lightbox\"","status":403},"url":"https:\/\/acme-v02.api.letsencrypt.org\/acme\/chall-v3\/803008408\/k46kFQ","token":"vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","validationRecord":[{"url":"http:\/\/www.domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"www.domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"},{"url":"http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"}]} [information] Let's Encrypt certificates have been updated  
×
×
  • Create New...