Jump to content
Froxlor Forum
  • 0
Sign in to follow this  
yoursql719

Mailboxen werden nicht mehr richtig angelegt

Question

Hallo,

immer wenn ich neue Mailboxen bei Kunden anlegen möchte, kommt folgender Fehler in der Syslog:

Apr  7 09:53:46 postfix/smtp[30715]: A1FC23A2408: to=<tester@xy.de>, relay=:25, delay=0.06, delays=0.02/0/0.03/0.02, dsn=5.1.1, sta          tus=bounced (host said: 550 5.1.1 <tester@xy.de>: Recipient address rejected: User unknown in virtual mailbox table (in reply to RCPT TO comma          nd))
 

Ich habe die Verbindung zu MySQL und das Passwort bei den Virtual Maps Dateien getestet, aber komme nicht weiter... Wie kann ich weiter debuggen - wo könnte der Hund begraben sein?

Danke und liebe Grüße

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
 echo "SELECT destination FROM mail_virtual WHERE email = 'tester@xy.de' AND trim(destination) <> ''" | mysql -u froxlor -p froxlor

Was kommt raus wenn du das auf der Console eingibst?

 

 

 

Share this post


Link to post
Share on other sites
  • 0

dann solltest du deine mysql-virtual* Dateien in /etc/postfix/ nochmals überprüfen. Wie die aussehen müssen kannst du unter System -> Konfiguration nachschauen. Möglicherweise hast du da das Passwort für MySQL nicht angepasst oder ein Umbruchproblem

Share this post


Link to post
Share on other sites
  • 0

Du könntest das ganze auch mal manuell Testen:

 

postmap -q tester@xy.de mysql:/etc/postfix/mysql-virtual_alias_maps.cf

Hier sollte einfach die E-Mail als Antwort kommen

Und dann noch:

postmap -q tester@xy.de mysql:/etc/postfix/mysql-virtual_mailbox_maps.cf

Hier bekommst du dann das HomeDir zurück.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By thunfischbaum
      Hi everyone,
      I'm running a Debian 10 Buster Server with PHP7.3 installed. The PHP7.3 update is the new component in the system. since then, I can't find any Mailboxes. There are no folders in the var/customers/mail/[customer] directory.
      If you take look at the Screenshot, you see, that the E-Mail adress is existent in Froxlor. 

      Mail Bounce
      Mail Log
       
      If I missed a log, please let me know, so I can attach it
      Best regards,
      thunfischbaum

    • By alex84
      Hallo,
      ich würde gerne Quotas für die Mailboxen nutzen. Dazu habe ich u.g. Funktion aktiviert und kann jetzt pro Mailbox Kontingente festlegen. 
      Allerdings werden die weder in Thunderbird noch Roundcube angezeigt. Die Option oben besagt ja auch, das eine "spezielle Konfiguration" vorausgesetzt wird. Also nun meine Frage(n) Was muss ich noch anpassen oder installieren? Haben sich mit der Aktivierung dieser Option auch die Konfigurationstemplates geändert? (Auf dem ersten Blick würde ich sagen: Nein)
      Ich nutze das aktuelle Froxlor 0.9.40.1 (allerdings auf Debian 10 - Ich habe mich dabei an diese Anleitung gehalten, so weit es rein um Froxlor geht. Also ohne die "Partitionieren"-etc Abschnitte: https://lichtmetzger.de/2019/05/31/debian-10-buster-und-froxlor-0-9-auf-einem-hetzner-ex52-server-installieren/) Die Config-Templates (Postfix/Dovecot) habe ich soweit 1:1 übernommen, lediglich die SSL-Zertifikate und das message_size_limit angepasst.
      Danke schonmal,
      Alex
    • Guest
      By Guest
      in der config-Datei steht
       
      was für eine valid e-mail Adresse muss das sein ?  diese root@frx.beispiel.de ist ja bisher nicht eingerichtet und packt systemmeldungen in ein verzeichnis

      sollte dort also eine mailadresse rein, die auf einem anderen Server liegt und Mails empfängt, oder sollte/könnte diese root@beispiel.de im froxlor eingerichtet sein ?
    • By jonny87
      Guten Morgen liebe Community,
      ich hab schon gesucht hier, aber nicht wirklich was passendes gefunden, darum mach ich jetzt hier nochmal nen Thread auf. Ich nutz Froxlor nun erfolgreich seit über einem Jahr auf zwei Servern, es funktioniert soweit auch alles mit LetsEncrypt und den Zertifikaten.
      Jetzt hab ich nur folgendes Problem, bzw. ist dies möglich, da ich mehrere Kunden über Froxlor auf zwei Servern verwalte, muss ich natürlich auch E-Mails verwalten, und zwar verschlüsselt. Kann man das über Froxlor machen? Sprich, dass die Kunden ihre Emails über
      imap.kunde1.de & smtp.kunde1.de sowie imap.kunde2.de & smtp.kunde2.de usw. abrufen können. 
      Momentan muss man ja bzw. so hat es mein Admin gemacht, ein Zertifikat für alle hinterlegen, welches auch nicht automatisch per Script geupdatet wird?! -> Ist das so richtig?
      Oder müssen alle Kunden ihre E-Mails per imap.hauptdomain.de abrufen? 
       
       
       
       
       
    • By Pierre
      Ich nutze eine kleine PHP-Datei als kontakt.php - sprich als kontaktformular.
      Dieses lief bis vor ca. 3 Wochen tadellos. Jedoch seit ca. 3 Wochen gibt es folgende Fehlermeldung aus, dass es die E-Mailadresse (Admin des Portals) an den die Nachrichten des Kontaktformulars gehen nicht findet, bzw. das diese nicht existieren würde, obwohl sie existiert und erreichbar ist und auf dem selben Server für die gleiche Domain liegt:
      SMTP Error: The following recipients failed: meine-emailadresse@meinedomain.de
      Innerhalb des Portals werden z.B. alle Newsletter, Paidmails etc. ohne Probleme über SMTP versendet.
      Wurde mit dem letzten Froxlor Update irgend etwas geändert was dies auslöst (from oder reply-to)?




×
×
  • Create New...