Jump to content
Froxlor Forum

Ithariel

Members
  • Content Count

    99
  • Joined

  • Last visited

  • Days Won

    11

Everything posted by Ithariel

  1. Nein, natürlich nicht. Aber wenn du nicht mehr geblockt bist und das ganze mit --debug ausführst, siehst du was schief läuft. Wenn du den Cron weiter laufen lässt, dann wird der LE Block mit pech immer wieder von vorn angefangen.
  2. Okay, du bist erstmal bei LE geblockt. LE Cron deaktivieren und bissel abwarten, für ne Stunde oder so. Genaue Zeiten findest du in der LE Doku. Danach nochmal Debug ausführen und guggen was passiert.
  3. Zeigt die SubDomain denn auf deinen Server? Ist die denn ohne SSL auch richtig erreichbar? Du kannst den Cronjob auch mal manuell aufrufen: /usr/bin/php /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug durch den Debug Parameter kriegt man da ne menge mit.
  4. Joa, mit nscd kannst du dir die Änderungen halt sparen. Da gehts dann auch wenn die libnss-mysql.cfg nur von root gelesen werden kann.
  5. Installier dir mal nscd, dann funktioniert das ganze auch.
  6. Als Admin unter Einstellungen -> Systemeinstellungen -> Standard-IP/Port
  7. Ist dein Froxlor aktuell? Let's Encrypt hatte da mal die User Agreements geändert, aber die waren dann nicht in Froxlor hinterlegt. Dadurch konnte man keine gültigen Zertifikate mehr ausstellen. Am besten mal: Froxlor auf den neusten Stand bringen In der Datenbank ggf. die LE Daten der Betroffenen Kunden auf NULL setzten Betroffene LE Certs in Froxlor als Admin unter "SSL Zertfikate" löschen LE cronjob aufrufen, am besten mit --debug damit du was sehen kannst Nen MySQL Dump von der Froxlor DB zu machen bevor du was drin änderst wäre natürlich auch nicht verkehr
  8. Du könntest das ganze auch mal manuell Testen: postmap -q tester@xy.de mysql:/etc/postfix/mysql-virtual_alias_maps.cf Hier sollte einfach die E-Mail als Antwort kommen Und dann noch: postmap -q tester@xy.de mysql:/etc/postfix/mysql-virtual_mailbox_maps.cf Hier bekommst du dann das HomeDir zurück.
  9. Zertifikat ist Zertifikat, ist eigentlich egal von wem. Wenns vom Format nicht passen würde, würde der Mail-Server gar nicht erst Starten. Testen kannst du das natürlich auch, für SMTP mit STARTTLS z.B.: openssl s_client -connect SERVERIP:smtp -starttls smtp
  10. Ich hab das gefühl dass das eigentlich nichts mit deinem Server zutun hatte. Es war ja der Nitrado Server der deine Mail abgelehnt hat und zwar mit "not logged in". Das ist eigentlich ein Zeichen dafür, besonders wenn die Froxlor und Postfix verwenden, das die Empfänger Domain aus deren Sicht Extern liegt. Man muss sich ja erst Authentifizieren bevor man über den Server rausschicken darf, sonst hätte man ja ein Open Relay... Warum es jetzt geht und was tatsächlich Kaputt war kann ich nicht sagen.
  11. Okay, die abc123.de ist aber auch Korrekt mit E-Mail und Postfach bei Nitrado eingerichtet oder? Weil wenn das der Fall ist, weis ich echt nicht mehr weiter
  12. Also, du verschickst von abc.de an abc123.de richtig? Liegt die abc.de den wirklich bei dir, oder nimmst du nur als Absender? Liegt die vielleicht auch beim Empfänger? Soweit mir bekannt bietet Nitrado nur Webhosting an, der vweb10.nitrado.net als Empfänger liegt also Extern und hat an sich nichts mit deinem Server zutun richtig?
  13. Der Let's Encrypt Client kann auch Web-Server Konfigurieren, dafür ist der Parameter vermutlich da. Um das ganze in Froxlor zu aktivieren kannst du z.B. bei den Eigenen vHost Einstellungen folgendes Eintragen: Header always set Strict-Transport-Security "max-age=31536000" Natürlich kann der HSTS Header variieren, da musst du selber gucken wie du den gern hättest.
  14. Durch das verschleiern der Domains wird es leider oftmals etwas schwierig bei so etwas zu helfen. Tausch am besten mal die Domains durch dummys aus (also z.b. abc.de oder 123.de) und gib an welche Domain nun bei dir liegt und welche Extern. Ich kann dir aber jetzt schon sagen: Der Externe Server lehnt die Mail ab, weil denen deine (Ab- ) Sender Domain nicht passt. Da kannst du bei dir so viele Permits rein machen wie du willst, das wird sich nicht ändern.
  15. Etwas spät, aber was solls. Das Problem äussert sich darin, dass nach anlegen des Kunden (also des virtuellen Users), der Webserver keine Lese-Berechtigung auf das Kundenverzeichnis hat. Dadurch gibt der Webserver einfach 403 Forbidden aus.
  16. Du hast "protocol" unter bzw. in den "protocol" Block geschrieben. Hast du vielleicht die Configs aus Froxlor einfach in die 20-pop3.conf kopiert und diese nicht komplett überschrieben? Poste ggf. mal nen Pastebin oder GitGist von der Datei.
  17. DNS, main.cnf und hosts passen. An deiner resolv.conf solltest du nicht rumfummeln, wenn du dir nicht sicher bist. Da kommen die Resolver rein, die du verwenden willst. Entweder die von deinem Provider, oder z.B. die von Google (8.8.8.8, 8.8.4.4). Ohne die Resolver kann dein Server keine DNS mehr aufl?sen.
  18. Soweit ich das sehe passiert das wohl in folgender Datei: froxlor/scripts/jobs/cron_tasks.php
  19. @Lexl Das passiert aber nur wenn du in Froxlor den vHost f?r diese IP angibst und dann kein g?ltiges Zertifikat angibst. Wenn du diesen Wegl?sst, kann auch nichts geladen werden.
  20. Ob das wirklich das selbe Problem ist, ist fraglich. Prinzipiell w?rde ich behaupten mann sollte solch alte Threads nicht noch mal aufgreifen, wenn man sich nicht sicher ist. Das sorgt nur f?r Verwirrung. Mach am besten einen neuen auf und wichtig, schreib deine Meldungen dazu. Was kriegst du beim Upgrade, welche befehle nutzt du etc..
  21. Das kann mehrere Probleme haben, wie z.B: 1) Ein vHost ?berschreibt deinen Froxlor-Domain-vHost 2) Dein A-Record stimmt nicht mit der IP von deinem vHost ?berein 3) Die Apache Konfiguration hat einen Fehler und wird gar nicht neu geladen. F?hre am besten mal einen "apache2ctl configtest" aus
  22. Wie heisst den deine eigene vHost Datei? Apache l?dt seine Configs alphanumerisch. Wenn dein vHost also vor dem IP vHost geladen wird, wundert mich das ganze nicht. Nenn deinen vHost am besten mal 15_ oder sowas.
  23. @CosmicDebri At first, you should not hijack old threads. Better open your own so nobody gets confused with the problem from OP. Secondly, i just installed nginx in debian jessie. The configuration file is found in /etc/nginx/sites-enabled/default and the default docroot is /var/www/html. Just change that to /var/www
  24. Ithariel

    Danke!

    /thread Es gibt schon gr?nde warum Froxlor mein Lieblings Panel ist.
  25. Ithariel

    PHP Cache

    Seit PHP 5.5 (?) nutzt PHP von hause aus OpCache was wohl auch zusammen mit APC nicht funktioniert. Deshalb gibt es inzwischen zus?tzlich noch APCu was dann auch zusammen mit OpCache funktioniert.
×
×
  • Create New...