Jump to content
Froxlor Forum
  • 0
ZeroGodForce

Customer domain pointing to froxlor login

Question

Hello there,

 

I've set up a new domain inside froxlor and uploaded site source into the document root, yet when I attempt to access the domain, I'm routed to the froxlor login page.

 

I don't know where froxlor keeps it's customer vhost config files. I've checked in the default apache location and it isn't there. Only the main froxlor vhost resides.

 

I'm sure it's something really simple that I've missed, but I'm new to froxlor and have used a bunch of other (terrible) panels, so maybe I'm just looking in the wrong places. Any advice would be greatly appreciated.

 

Thanks

Share this post


Link to post
Share on other sites

21 answers to this question

Recommended Posts

  • 0

Check whether the vhosts are being generated in /etc/apache2/sites-enabled/

Share this post


Link to post
Share on other sites
  • 0

symlink? we do not create symlinks...are you sure the cronjob has been setup correctly? Check /etc/cron.d/froxlor and paste it here please

Share this post


Link to post
Share on other sites
  • 0

run the following command as root (and adjust path if different):

php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force

Share this post


Link to post
Share on other sites
  • 0

The command generated some errors:

PHP Warning:  touch(): Unable to create file /var/customers/logs/username-domain.com-error.log because No such file or directory in /var/www/froxlor/scripts/jobs/cron_tasks.inc.http.10.apache.php on line 604
PHP Warning:  chown(): No such file or directory in /var/www/froxlor/scripts/jobs/cron_tasks.inc.http.10.apache.php on line 605
PHP Warning:  chgrp(): No such file or directory in /var/www/froxlor/scripts/jobs/cron_tasks.inc.http.10.apache.php on line 606
PHP Warning:  touch(): Unable to create file /var/customers/logs/username-domain.com-access.log because No such file or directory in /var/www/froxlor/scripts/jobs/cron_tasks.inc.http.10.apache.php on line 610
PHP Warning:  chown(): No such file or directory in /var/www/froxlor/scripts/jobs/cron_tasks.inc.http.10.apache.php on line 611
PHP Warning:  chgrp(): No such file or directory in /var/www/froxlor/scripts/jobs/cron_tasks.inc.http.10.apache.php on line 612
Output of config test was:
(2)No such file or directory: AH02291: Cannot access directory '/var/customers/logs/' for error log of vhost defined at /etc/apache2/sites-enabled/35_froxlor_normal_vhost_domain.com.conf:6
AH00014: Configuration check failed
Action 'configtest' failed.
The Apache error log may have more information.

Share this post


Link to post
Share on other sites
  • 0

Hmmm, yes I did have quite a few problems getting to the "complete the install" UI, so that does not come as a huge shock to me.  I followed a digitalocean tutorial that did it via apt. Okay I will roll back the server to fresh and start again. Thanks for your help, I'll report back how it goes.

Share this post


Link to post
Share on other sites
  • 0

You will need to run a few "configuration" commands as root on the shell to configure all the daemons and create various folders etc. Just follow the wiki :)

Share this post


Link to post
Share on other sites
  • 0

The default docroot for my webserver is /var/www/html. Given that there's no vhost to tell it otherwise, and there aren't any related commands on the wiki to be run at that stage, should I move the froxlor folder inside html? Because I'm not sure how else the webserver is going to know it's there. Thanks

Share this post


Link to post
Share on other sites
  • 0

That's just the Debian Jessie default, the apache default is /var/www/ - just change 000-default accordingly and you're good to go

Share this post


Link to post
Share on other sites
  • 0

Okay I changed that, got everything configured, and went through the settings. But do I actually need to run the configuration for apache webserver (as it's already installed, and one of the commands was to install it) and the others? Because in truth, I'm not really sure what I want to do setupwise about FTP and mail. I just want the domain up and running, I don't really care about the rest right now. What do you think?

Share this post


Link to post
Share on other sites
  • 0

If you installed via debian package you do not need to re-install them again of course.

 

If you want your customers to be able to edit their data, you should setup ftp. If you want your customer to be able to add and use e-mail addresses, you should setup mail...pretty easy eh? :)

Share this post


Link to post
Share on other sites
  • 0

That's fair enough. I'm not so worried about client access at the moment as all of the sites it'll be hosting require access beyond myself.

 

The reason I asked originally though (and I'm not really sure why I didn't mention that before) was that I created the first customer and domain, but when I saved the domain, the folder was not created (I changed the default to /home/customers/). Was that a poor decision?

Share this post


Link to post
Share on other sites
  • 0

Depends on your needs. By default all customer data is within /var/customers/ - but when there is no folder created, check the cronjob or manually run it (like before) with the --force parameter

Share this post


Link to post
Share on other sites
  • 0

Cool. So I ran that, it generated a bunch of errors but did create the customers/username/directory. However it does create a webilizer directory (which I don't need) and doesn't create an htdocs/public_html/etc directory. do I take it that the customers/username/ directory "is" the webroot and just delete the webilizer directory?

Share this post


Link to post
Share on other sites
  • 0

/var/customers/webs/[username] is the webroot for the customer. The webalizer-Folder is being created by the traffic-calculation cronjob, if you don't need it, you can delete it, but it will be re-created every night :)

Share this post


Link to post
Share on other sites
  • 0

Okay then, I'll leave that where it is. I've set the (domain name as default value for DocumentRoot path) so that removes the problem entirely :)

 

I'm nearly there but for a couple of things. When I add a new domain, it doesn't seem to add the folders unless I run the force cronjob - I assume there's a misconfiguration somewhere.

 

And I'm not sure you can help with this, but is there anything in froxlor that might be causing php to be in strict mode. One of my sites is a concrete5 install, and once I'd uploaded the source and set up the database, the homepage was full of PHP strict warnings. When I tried to turn these off in the php.ini it didn't work. I was on php 5.5.9 but I've upgraded to 5.6.17 to see if it would make a difference when I tried changing it again. It didn't.

Share this post


Link to post
Share on other sites
  • 0

I'm nearly there but for a couple of things. When I add a new domain, it doesn't seem to add the folders unless I run the force cronjob - I assume there's a misconfiguration somewhere.

Did you set up the cronjob as shown in the configuration templates? What does your /etc/cron.d/froxlor file look like? Is the cron-daemon running?

 

And I'm not sure you can help with this, but is there anything in froxlor that might be causing php to be in strict mode. One of my sites is a concrete5 install, and once I'd uploaded the source and set up the database, the homepage was full of PHP strict warnings. When I tried to turn these off in the php.ini it didn't work. I was on php 5.5.9 but I've upgraded to 5.6.17 to see if it would make a difference when I tried changing it again. It didn't.

Depends on how you use php. If you are using php-fpm: Log in as Admin -> Menu "PHP-Configuration" -> Adjust php's error_reporting there

If not: create a script in the customer-docroot which outputs a "phpinfo()" call and there you can see the used php.ini which is to be adjusted

Share this post


Link to post
Share on other sites
  • 0

I'm not using php-fpm and the loaded file was the one I changed.

 

To be honest, I've been at this for days, and I don't have any more time to bash my head against these walls. I don't have a unique setup - it's a simple ubuntu 14.04 install on digitalocean. There's nothing special about it, yet I've rebuilt it twice and I still can't get this working.

 

I hate setting these things up by hand - which is why I like control panels. But to be honest I can't help but thinking if I had, it'd have been working the same day. I think I'm going to drop this. Thanks anyway.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By alex84
      Hi,
      wie der Titel schon sagt: Ich würde gerne bei einer Subdomain eigene vhost-Einstellungen vornehmen. Leider taucht (bei mir) das entsprechende Feld beim Kunden in "(Sub-)Domain bearbeiten" nicht auf. Liegt das vielleicht daran, das bei der Hauptdomain im vhost-Bereich die Checkbox "Übernehme Einstellungen für alle Subdomains" angehakt ist? Falls dem so ist, wie bekomme ich den Haken weg? Dieser weigert sich, zu verschwinden, nach jedem Speichern ist er wieder da. (Was könnte hier das Problem sein?) Hier der Screenshot, welchen ich meine:

      Oder geht das generell nicht über Froxlor und ich müsste das "außenrum" lösen? Oder bei der Hauptdomain über ein generelles 
      IncludeOptional /var/customers/additionalVhostConfigs/{CUSTOMER}/{DOMAIN}/*.conf ? Deutlich schöner fände ich es allerdings, wenn es bei der Subdomain ginge. Trac (zum Beispiel) verlangt ein paar Einstellungen, die via .htaccess nicht zulässig sind...
      Danke, Alex
    • By chw
      Hallo zusammen,
       
      ich stehe gerade vor der Aufgabe ca. 100 Domains eines Kunden löschen zu müssen.
      (aber nicht alle Domains des Kunden und auch nicht den Kunden selbst!)
       
      Gibt es eine Möglichkeit, diese anhand einer txt/csv Datei löschen zu lassen? Ähnlich dem Bulk-Import?
       
      Ich wäre auch mit einer SQL Lösung zufrieden, nur kenne ich mich mit froxlor noch zu wenig aus, um die ganzen Abhängigkeiten in den DB-Tabellen aufzudröseln.
       
      Ansonsten würde mir ja wirklich nur die Möglichkeit bleiben, jede Domain über das UI einzeln zu löschen - also Domain raussuchen, auf´s Kreuz klicken, Bestätigung klicken (
       
      Danke schonmal für eure Hilfe/Vorschläge/Lösungsansätze
       
      Olli
       
       
       
       
    • By behrang
      Hi
      when a customer has many domains he will see awstats for all domains.
      we would like to seperate stats for each domains. The question is: is this maybe possible by preferences already.
      or do we have to change confs manually and is it on the vhost side or within awstats itself.
      thx
    • By iSweety
      Guten Tag,
      ich habe ein kleines Problem mit den vHosts. Meine Konfiguration siehe Signatur.
      Die vHost-Dateien in "/etc/nginx/sites-enabled" werden auch erstellt, Inhalt korrekt.
      Allerdings werden die nicht geladen.
      In der nginx Konfiguration steht der Pfad auch auf include /etc/nginx/sites-enabled/*;.
      Was ist zu tun?
       
      Mit freundlichen Gr??en,
      iSweety
       
       
      #edit:
      Hier ist einmal die Konfiguration von bk001.vweb01.bukkcom.de. Wenn ich bk001.vweb01.bukkcom.de aufrufe, kommt der Fehler, dass der Server nicht erreichbar w?hre:
      # 20_froxlor_normal_vhost_bk001.vweb01.bukkcom.de.conf # Created 22.08.2014 23:02 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen 185.28.77.73:80; server_name bk001.vweb01.bukkcom.de *.bk001.vweb01.bukkcom.de; access_log /var/customers/logs/bk001-access.log combined; error_log /var/customers/logs/bk001-error.log error; root /var/customers/webs/bk001/; location / { index index.php index.html index.htm; try_files $uri $uri/ @rewrites; } location @rewrites { rewrite ^ /index.php last; } location /webalizer { alias /var/customers/webs/bk001/webalizer/bk001.vweb01.bukkcom.de/; auth_basic "Restricted Area"; auth_basic_user_file /etc/nginx/froxlor-htpasswd/1-fd7da6a3e35bd3aa80d08e3adb18b281.htpasswd; } location ~ \.php$ { try_files $uri =404; fastcgi_split_path_info ^(.+\.php)(/.+)$; fastcgi_pass unix:/var/run/nginx/bk001-bk001.vweb01.bukkcom.de-php-fpm.socket; fastcgi_index index.php; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; include /etc/nginx/fastcgi_params; } } Die Log-Dateien beispielsweise werden erstellt, drin steht aber nichts.
    • By gab
      Hi all,
       
      I searched in the forum, but the answers weren't to clear to me(since one says Yes, and other No), and SysCP worked with different versions from php(yes, using fcgid).

      My question is quite simple: Can I use PHP 5.4 for customer A, and PHP 5.5 for customer B? I have to upload the php.ini, but how? 
       
      And if just keeps compatibility with fcgi, where can I find a Howto with that?
       
      Environment:
       
      Nginx 1.6
      PHP 5.4.14 with FPM(which runs Froxlor)
      PHP 5.4.30 with FPM
      PHP 5.5.14 with FPM
       
       
       
      Yes:
      http://forum.froxlor.org/index.php/topic/11662-merged-add-custom-phpini-files-for-php-fpm/
       
      No:
      http://forum.froxlor.org/index.php/topic/12610-erledigt-php-fpm-verschiedene-php-versionen/
       
       
      And if I should do another question in the same topic, is there a way to set ssh login to all users without mysql every time with new user added?  I mean, setting different shells(just /bin/false, or /bin/bash)? Or should I patch it?
       
      TIA
       
      Best Regards,
       
      Gabriel
×
×
  • Create New...