Jump to content
Froxlor Forum
  • 0
alex84

Eigene vhost-direktiven per einzelner Subdomain (oder Inlcude)

Question

Hi,

wie der Titel schon sagt: Ich würde gerne bei einer Subdomain eigene vhost-Einstellungen vornehmen. Leider taucht (bei mir) das entsprechende Feld beim Kunden in "(Sub-)Domain bearbeiten" nicht auf. Liegt das vielleicht daran, das bei der Hauptdomain im vhost-Bereich die Checkbox "Übernehme Einstellungen für alle Subdomains" angehakt ist? Falls dem so ist, wie bekomme ich den Haken weg? Dieser weigert sich, zu verschwinden, nach jedem Speichern ist er wieder da. (Was könnte hier das Problem sein?) Hier der Screenshot, welchen ich meine:

image.thumb.png.92cac43199f29d06d6f6809cfffb201f.png

Oder geht das generell nicht über Froxlor und ich müsste das "außenrum" lösen? Oder bei der Hauptdomain über ein generelles 

IncludeOptional /var/customers/additionalVhostConfigs/{CUSTOMER}/{DOMAIN}/*.conf

? Deutlich schöner fände ich es allerdings, wenn es bei der Subdomain ginge. Trac (zum Beispiel) verlangt ein paar Einstellungen, die via .htaccess nicht zulässig sind...

Danke, Alex

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
13 hours ago, alex84 said:

Leider taucht (bei mir) das entsprechende Feld beim Kunden in "(Sub-)Domain bearbeiten" nicht auf.

Weil der Kunde sowas nicht darf...er könnte damit den ganzen Webserver lahmlegen wenn er da was falsches einträgt

13 hours ago, alex84 said:

Dieser weigert sich, zu verschwinden, nach jedem Speichern ist er wieder da. (Was könnte hier das Problem sein?)

dieser switch ist ein ONE-TIME switch, d.h. entweder willst du die änderungen die du gerade an der Domain gemacht hast für alle subdomains mit übernehmen oder nicht. Er setzt sich halt standardmäßig auf "ja" beim nächsten editieren

13 hours ago, alex84 said:

Oder geht das generell nicht über Froxlor und ich müsste das "außenrum" lösen?

Lege doch die Subdomain einfach als Admin an (quasi als "hauptdomain"). Musst nur beim Anlegen darauf achten das du die Hauptdomain bei "Ist Subdomain einer Hauptdomain" auswählst.

Dann kannst du für die Subdomain auch alles separat setzen ohne andere zu beeinflussen

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By ZeroGodForce
      Hello there,
       
      I've set up a new domain inside froxlor and uploaded site source into the document root, yet when I attempt to access the domain, I'm routed to the froxlor login page.
       
      I don't know where froxlor keeps it's customer vhost config files. I've checked in the default apache location and it isn't there. Only the main froxlor vhost resides.
       
      I'm sure it's something really simple that I've missed, but I'm new to froxlor and have used a bunch of other (terrible) panels, so maybe I'm just looking in the wrong places. Any advice would be greatly appreciated.
       
      Thanks
    • By iSweety
      Guten Tag,
      ich habe ein kleines Problem mit den vHosts. Meine Konfiguration siehe Signatur.
      Die vHost-Dateien in "/etc/nginx/sites-enabled" werden auch erstellt, Inhalt korrekt.
      Allerdings werden die nicht geladen.
      In der nginx Konfiguration steht der Pfad auch auf include /etc/nginx/sites-enabled/*;.
      Was ist zu tun?
       
      Mit freundlichen Gr??en,
      iSweety
       
       
      #edit:
      Hier ist einmal die Konfiguration von bk001.vweb01.bukkcom.de. Wenn ich bk001.vweb01.bukkcom.de aufrufe, kommt der Fehler, dass der Server nicht erreichbar w?hre:
      # 20_froxlor_normal_vhost_bk001.vweb01.bukkcom.de.conf # Created 22.08.2014 23:02 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen 185.28.77.73:80; server_name bk001.vweb01.bukkcom.de *.bk001.vweb01.bukkcom.de; access_log /var/customers/logs/bk001-access.log combined; error_log /var/customers/logs/bk001-error.log error; root /var/customers/webs/bk001/; location / { index index.php index.html index.htm; try_files $uri $uri/ @rewrites; } location @rewrites { rewrite ^ /index.php last; } location /webalizer { alias /var/customers/webs/bk001/webalizer/bk001.vweb01.bukkcom.de/; auth_basic "Restricted Area"; auth_basic_user_file /etc/nginx/froxlor-htpasswd/1-fd7da6a3e35bd3aa80d08e3adb18b281.htpasswd; } location ~ \.php$ { try_files $uri =404; fastcgi_split_path_info ^(.+\.php)(/.+)$; fastcgi_pass unix:/var/run/nginx/bk001-bk001.vweb01.bukkcom.de-php-fpm.socket; fastcgi_index index.php; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; include /etc/nginx/fastcgi_params; } } Die Log-Dateien beispielsweise werden erstellt, drin steht aber nichts.
    • By gab
      Hi all,
       
      I searched in the forum, but the answers weren't to clear to me(since one says Yes, and other No), and SysCP worked with different versions from php(yes, using fcgid).

      My question is quite simple: Can I use PHP 5.4 for customer A, and PHP 5.5 for customer B? I have to upload the php.ini, but how? 
       
      And if just keeps compatibility with fcgi, where can I find a Howto with that?
       
      Environment:
       
      Nginx 1.6
      PHP 5.4.14 with FPM(which runs Froxlor)
      PHP 5.4.30 with FPM
      PHP 5.5.14 with FPM
       
       
       
      Yes:
      http://forum.froxlor.org/index.php/topic/11662-merged-add-custom-phpini-files-for-php-fpm/
       
      No:
      http://forum.froxlor.org/index.php/topic/12610-erledigt-php-fpm-verschiedene-php-versionen/
       
       
      And if I should do another question in the same topic, is there a way to set ssh login to all users without mysql every time with new user added?  I mean, setting different shells(just /bin/false, or /bin/bash)? Or should I patch it?
       
      TIA
       
      Best Regards,
       
      Gabriel
    • By 3bsd
      Hello
       
      This patch adds the ability to use custom php.ini files together with php-fpm.
      At first you have to apply the Apache 2.4 patch even if you use Nginx or Lighttpd.

      patch -p0 < froxlor-apache24.patch
      Apply the PHP-FPM patch:

      patch -p0 < froxlor-php-fpm.patch
      Configure php-fpm and PHP Configurations as usual.
      Be careful defined settings in PHP Configurations can't be overwritten in ".user.ini" files.
      http://php.net/manua...le.per-user.php
       
      Furthermore this method to configure PHP works for the CGI, FastCGI and FPM SAPI.
      So once support for PHP 5.2 in Froxlor is dropped this could be the default method to configure custom php.ini files.
       
      Patch for Froxlor 0.9.28-svn5:
      https://gist.github....smomill/4753944
       
      Bye
      Rene
×
×
  • Create New...