Jump to content
Froxlor Forum

Question

Hallo, 

 

Das geh?rt hier eigentlich nicht unbedingt in das Forum, ich hoffe aber, dass das dennoch Tolleriert wird. Wenn nicht, bitte einfach l?schen. 

 

Ich betreibe auf mehreren Servern Webhosting mit Froxlor. Darunter sind kleine Server mit 2GB RAM, 2 vCores und gr??ere mit 6 Dedizierten Kernen und 16GB RAM. 

Gerade auf den kleinen Servern zwingen Seiten wie Wordpress den Server in die Kniehe. Da entstehen pro Aufruf den Blogs gut und gerne 50% CPU Last. 

Um das einzugrenzen bin ich auf der Suche nach einem PHP Cache, der Cache sollte m?glichst einfach zu installieren und administrieren zu sein, und mit meiner verwendeten Software kompatibel sein. 

Eventuell konnte jemand hier schon selbst Erfahrungen sammeln und ist bereit diese an mich weiterzugeben. 

 

Ich bin ?ber jede Hilfe dankbar. 

 

Danke

 

 

Apache 2.2

PHP 5.4

MySQL 5.5

Debian 7

 

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Guten Tag,

 

f?r solche f?lle nutze ich memcache.

Es besitzt ein Server Interface, welches es erm?glicht die Daten von externen Server, den zugang zum Speicher zu erm?glichen.

 

Ich habe es bis jetzt immer so gemacht, dass ich den Server mit dem meisten Arbeitsspeicher einen zugriff an memcache gegebene habe und die anderen Server mit weniger Arbeitsspeicher haben sich immer mit dem Server verbunden.

Einziger nachteil ist, dass die Anwendungen memcache unterst?tzen m?ssen.

Soweit ich wei? unterst?tzt Wordpress memcached per Plugin, lediglich froxlor nicht.

http://www.memcached.org/
http://php.net/manual/de/book.memcache.php

Weitere bekannte beschleuniger sinde Accelerator, XCache, Alternative PHP Cache (kurz APC)

Share this post


Link to post
Share on other sites
  • 0

Hallo, 
Danke f?r die Antwort, ich denke Memcache kommt dann wohl nicht in Frage, wenn die Anwendung das unterst?tzem muss. 

 

Bez?glich PHP APC, ich habe oft gelesen, dass das schon "veraltet" sei und nicht mehr unterst?tzt wird. Stimmt das? 

Share this post


Link to post
Share on other sites
  • 0

 

Bez?glich PHP APC, ich habe oft gelesen, dass das schon "veraltet" sei und nicht mehr unterst?tzt wird. Stimmt das? 

 

Seit PHP 5.5 (?) nutzt PHP von hause aus OpCache was wohl auch zusammen mit APC nicht funktioniert. Deshalb gibt es inzwischen zus?tzlich noch APCu was dann auch zusammen mit OpCache funktioniert.

Share this post


Link to post
Share on other sites
  • 0

Musstes du nach dem update auf php 5.5 irgendetwas konfigurieren un Opcache zu verwenden?

 

Bemerkst du performance unterschiede mit Opcache?

Share this post


Link to post
Share on other sites
  • 0

Nein, du solltest aber via phpinfo schauen, ob Opcache aktiv ist.

 

Ich habe die PHP Konfigurarion etwas angepasst, wenn Interesse besteht, kann ich sie dir schicken.

Der Performance Unterschied ist insbesondere bei Anwendungen wie WordPress sehr hoch. In meinem Fall ist WordPress nun Ca. 50% schneller laut Benchmarks.

Share this post


Link to post
Share on other sites
  • 0

Nein, du solltest aber via phpinfo schauen, ob Opcache aktiv ist.

 

Ich habe die PHP Konfigurarion etwas angepasst, wenn Interesse besteht, kann ich sie dir schicken.

Der Performance Unterschied ist insbesondere bei Anwendungen wie WordPress sehr hoch. In meinem Fall ist WordPress nun Ca. 50% schneller laut Benchmarks.

 

Da es mir selber haupts?chlich um wordpress geht w?re ich sehr an der PHP Konfiguration interessiert :)

 

Danke !

Share this post


Link to post
Share on other sites
  • 0


allow_call_time_pass_reference = Off

allow_url_fopen = On

asp_tags = Off

disable_classes =

disable_functions =

display_errors = On

display_startup_errors = Off

enable_dl = Off

error_reporting = E_ALL & ~E_NOTICE

expose_php = Off

file_uploads = On

cgi.force_redirect = 1

gpc_order = "GPC"

html_errors = Off

ignore_repeated_errors = Off

ignore_repeated_source = Off

include_path = ".:{PEAR_DIR}"

log_errors = On

log_errors_max_len = 1024

magic_quotes_gpc = Off

magic_quotes_runtime = Off

magic_quotes_sybase = Off

max_execution_time = 30

max_input_time = 60

memory_limit = 265M

{OPEN_BASEDIR_C}open_basedir = "{OPEN_BASEDIR}"

output_buffering = 4096

post_max_size = 20G

precision = 14

register_argc_argv = Off

register_globals = Off

report_memleaks = On

sendmail_path = "/usr/sbin/sendmail -t -i -f {CUSTOMER_EMAIL}"

session.auto_start = 0

session.bug_compat_42 = 0

session.bug_compat_warn = 1

session.cache_expire = 180

session.cache_limiter = nocache

session.cookie_domain =

session.cookie_lifetime = 0

session.cookie_path = /

session.entropy_file = /dev/urandom

session.entropy_length = 16

session.gc_divisor = 1000

session.gc_maxlifetime = 1440

session.gc_probability = 1

session.name = PHPSESSID

session.referer_check =

session.save_handler = files

session.save_path = "{TMP_DIR}"

session.serialize_handler = php

session.use_cookies = 1

session.use_trans_sid = 0

short_open_tag = On

suhosin.mail.protect = 1

suhosin.simulation = Off

track_errors = Off

upload_max_filesize = 20G

upload_tmp_dir = "{TMP_DIR}"

variables_order = "GPCS"

;mail.add_x_header = On

;mail.log = "/var/log/phpmail.log"

 

safe_mode = off

 

opcache.enable = "1"

opcache.enable_cli = "0"

opcache.enable_file_override = "1"

opcache.error_log = "/var/log/php_opcache.log"

opcache.fast_shutdown = "1"

opcache.interned_strings_buffer = "8"

opcache.log_verbosity_level = "2"

opcache.max_accelerated_files = "4000"

opcache.memory_consumption = "128"

opcache.revalidate_freq = "20"

opcache.revalidate_path = "1"

Share this post


Link to post
Share on other sites
  • 0

Hallo Thunderbird,

 

Wenn man administrativen Zugriff auf die Backends der Wordpress-Installationen hat, kann man ja Plugins wie Cachify installieren.  Der Performancegewinn bei der Auslieferung der Seiten ist betr?chtlich.

Share this post


Link to post
Share on other sites
  • 0

Hallo,

Das stimmt, da ich aber mehr als 20 WordPress Instanzen auf dem Server laufen hatte, war es einfacher einen Globalen Opcache zu aktivieren.

 

Gr??e

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By nisamudeen97
      Hi,
      Our froxlor server is behiend NAT and it uses the local IP  192.168.73.40.  We have enabled letsencrypt module in froxlor and tried validating SSL for a domain in the server.  SSL generation is getting failed with 403 error.  See the debug log information.      Replaced domain name and main IP.    Can any one help me regarding the issue.
       
      [information] Updating Let's Encrypt certificates [information] Updating domain-name.com [information] Adding SAN entry: domain-name.com [information] Adding SAN entry: www.domain-name.com [information] letsencrypt-v2 Using 'https://acme-v02.api.letsencrypt.org' to generate certificate [information] letsencrypt-v2 Using existing account key [information] letsencrypt-v2 Starting certificate generation process for domains [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/new-order [information] letsencrypt-v2 Requesting challenge for domain-name.com [information] letsencrypt-v2 Got challenge token for domain-name.com [information] letsencrypt-v2 Token for domain-name.com saved at /var/www/froxlor/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k and should be available at http://domain-name.com/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [information] letsencrypt-v2 Sending request to challenge [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/chall-v3/803008408/k46kFQ [information] letsencrypt-v2 Verification pending, sleeping 1s [information] letsencrypt-v2 Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for domain-name.com: Verification ended with error: {"type":"http-01","status":"invalid","error":{"type":"urn:ietf:params:acme:error:unauthorized","detail":"Invalid response from http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [212.224.xxx.xxx]: \"<!DOCTYPE html>\\n<html lang=\\\"en-CA\\\" class=\\\"html_stretched responsive av-preloader-active av-preloader-enabled av-default-lightbox\"","status":403},"url":"https:\/\/acme-v02.api.letsencrypt.org\/acme\/chall-v3\/803008408\/k46kFQ","token":"vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","validationRecord":[{"url":"http:\/\/www.domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"www.domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"},{"url":"http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"}]} [information] Let's Encrypt certificates have been updated  
    • By Jason Szymanski
      Hallo,
       
      ich habe leider ein Problem mit Froxlor.
      Zu meiner Situation: Froxlor läuft auf der Subdomain web01.meinedomain.net
      Jetzt möchte ich die Domain aber auch noch weiter Nutzen und habe mich daher als Kunde angelegt und die Domain meineDomain.net als Domain hinzugefügt.
      Dort kann ich auch weitere Subdomains hinzufügen. Das scheint soweit auch zu klappen ich sehe das er VHosts anlegt und auch die Verzeichnisse im FTP anlegt.
      Wenn ich jetzt allerdings versuche auf meinedomain.net oder eine andere Subdomain unter dieser Domain zuzugreifen leitet er mich auf web01.meinedomain.net
      Ich habe mich schon in den Einstellungen umgeschaut konnte aber keine entsprechende Einstellung finden an der das liegen könnte.
      Wie verhindere ich also das er mich auf Froxlor umleitet?
       
      Mit Freundlichen Grüßen
      Jason Szymanski
    • By nisamudeen97
      Hi,
      Wile doing migration of email accounts from one froxlor server to another I have noting some thing.   Expecting some clarification on this.  As we all know emails are normally stored in the location "/var/customers/mail/user/domain.com/user/Maildir/" .   I create email accounts via froxlor panel and copy the email files directly via scp or rsync from old server to new.  The strange thing I have noticed is it is not coping custom folders and its emails like we have in source.  
      The solution I have found for this is to use imapsync between old and new.  imapsync is preserving custom folders like as it is in source.    Does it mean custom folder settings are stored somewhere else?  How we can preserve it and copy emails manually?
    • By Schutzgeist
      Hallo, 
      vielleicht kann mir jemand hier ja einen kleinen Tipp geben.
      Es ist mehr eine nginx-Konfiguration. 
      PHP-404-Rückmeldungen sollen "sauber" an Joomla übergeben werden.
       
      Mein 'Froxlor-Standardvhost sieht wie folgt aus

      Allerdings kann ich über das Joomla eigene REDIRECT Modul keine .php - Erweiterungen intern umleiten. 
      Anstatt  die joomla-eigene 404 Seite zu erhalten, bekomme ich die von nginx, da  die Abfrage hier als erstes ausgeführt wird. 
      Also habe ich meine vhost stümperhaft umgeschrieben, s.d. ein Teil seinen Soll erfüllt. 

      Teilweise kann ich nun die Redirects über Joomla verwalten lassen, aber oft erhalte ich LOOPs, da ich ja immer auf die index.php verweise. 
      So, warum nutze ich nicht die nginx-Weiterleitungen ? 

      Ich nutze ein Multi-Sitemodul  sowie ein Modul, um eine php-Endung  zu simulieren. 
      Beide haben mit meiner und der Standardvhost-Konfiguration leichte Schwierigkeiten. 

       
      Welche Vhost-Anpassungen nutzt ihr bei Eurer Joomla-Webseite ? 
      Der Fehler sitzt vermutlich 30 cm vor meinem Bildschirm. 
      Innerhalb meiner letzten 30 Versuche habe ich wohl  oft alte Cache-Webseiten geladen und ggf. die richtige Konfig übersehen.
       

       
       
       
       
       
    • By irisdina
      Warning, this is not an official guide!!!
      1.
      sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list
      sudo nano /etc/apt/source.list 1b.  insert (for Debian Stretch)
      1.2B (for Ubuntu Cosmic)
       
      1c. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. 
      sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server
      2. MariaDB install
      Warning use sudo command für this install!
      sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional)
      3. nginx install
      sudo apt install nginx 3a. 
      mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf
      4. PHP install
      sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. 
      sudo service nginx restart sudo service php7.3-fpm restart Froxlor install
      There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master)
      Stable Version
      1. 
      cd /var/www/html/ 1a. 
      sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or
      Git Version (Beta Version)
      sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer  su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory
      composer install --no-dev 1b. 
      sudo chown -R www-data:www-data Froxlor/ Set up Froxlor
      2. Open Your Browser
      2a.
      http://your IP or Hostname/Froxlor
       

      Install Froxlor finish
       3d. Move userdata (Optional) 
      sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. 
      sudo rm /etc/nginx/site-enable/default don't restart nginx!
      Froxlor Settings
      1. Cronjob
      sudo nano /etc/cron.d/froxlor insert 
      # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend
      Settings > Webserver settings > Nginx PHP backend
      from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock
      3. 
      sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port

      2a(1), SSL Port



      Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually
      sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional
      PHP-FPM activate
      1. User/Group add
      sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install 
      sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

      3. Settings > PHP-FPM > Activated:
      Change from NO to YES
      3a. PHP-FPM versions
      Change > php-fpm restart command:
      service php7.3-fpm restart and
      Configuration directory of php-fpm: > to 
      /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

      3c. 
      sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate
      1.
      sudo apt install certbot 1a. 
      sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File
      sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. 
      sudo nano /etc/nginx/acme.conf insert
      location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } }  
      2. Open your  Froxlor Panel
      Settings> SSL > Activated:
      Change from NO to YES
      2a. Settings > SSL > Settings
      Change your path from your certificate / Keyfile
      Path to the SSL certificate
      insert
      /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile
      insert
      /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings
      Activate > Enable Let's Encrypt

      Change Path to the acme.conf snippet to > 
      /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings
      - Enable Let's Encrypt for the froxlor vhost
      - Enable SSL-redirect for the froxlor vhost
      - HTTP Strict Transport Security (HSTS)
      - Include HSTS for any subdomain






      2d. Activated HTTP2 Support on > Settings > Nginx
       
×
×
  • Create New...