Jump to content
Froxlor Forum
  • 0
v3ng

Probleme mit Froxlor/Apache nach update auf Apache 2.4

Question

Hallo,

 

Ich habe Apache auf meinem Server von der Version 2.2 auf die Version 2.4 upgegradet. Danach wollte ich Apache restarten, doch dabei habe ich folgende Ausgabe bekommen.

F?r eure Hilfe w?re ich wirklich dankbar.

 

Vielen Dank und einen sch?nen Abend!

 

Ps: Wie weit ist Froxlor eigentlich mit Debian 8 kompatibel?

root@vps:/var/www# service apache2 restart
[FAIL] Restarting web server: apache2 failed!
[warn] The apache2 configtest failed. ... (warning).
Output of config test was:
AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/10_froxlor_ipandport_xx.xxx.xx.xx.conf:5
AH00526: Syntax error on line 11 of /etc/apache2/sites-enabled/20_froxlor_normal_vhost_test.srv.meinedomain.de.conf:
Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
root@vps:/var/www#

Share this post


Link to post
Share on other sites

22 answers to this question

Recommended Posts

  • 0
Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration

 

Du hast entweder mod_php gekickt oder in Apache 2.4 hei?t das seit neuem anders. Vermutlich aber eher ersteres.

 

Zum Thema Jessie: Sollte laufen. Du musst aber f?r FCGID/FPM libnss-mysql-bg installieren, was aus den Paket-Quellen geflogen ist. Das Wheezy Paket l?sst sich aber wohl Problemlos installieren.

Share this post


Link to post
Share on other sites
  • 0

Hallo, 

Ich glaube du hattest recht, mod_php fehlt. Wenn ich es installieren will, bekomme ich allerdings folgende Meldung: 

root@vps:~# apt-get install php5 libapache2-mod-php5
Reading package lists... Done
Building dependency tree
Reading state information... Done
php5 is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 dpkg : Breaks: libapache2-mod-php5 (< 5.6.4+dfsg-3~) but 5.5.25-1~dotdeb+7.1 is to be installed
 libapache2-mod-php5 : Depends: apache2-mpm-prefork but it is not going to be installed or
                                apache2-mpm-itk but it is not going to be installed
                       Depends: php5-common (= 5.5.25-1~dotdeb+7.1) but 5.6.7+dfsg-1 is to be installed
 sendmail-bin : Depends: sendmail-base but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
root@vps:~#

Share this post


Link to post
Share on other sites
  • 0

schmeiss erstmal das dotdeb zeug raus

 

Ps: Wie weit ist Froxlor eigentlich mit Debian 8 kompatibel?

 

100% - Froxlor selbst ist nur PHP, das l?uft so gut wie ?berall. Nur Konfigurations-Templates f?r Debian 8.0 kommen erst in der n?chsten Version. Und nein, ich kann dir nicht sagen wann die kommen wird - sie kommt wenn sie fertig ist.

Share this post


Link to post
Share on other sites
  • 0

Danke, nachdem ich das "dotdeb zeug" runtergeschmissen habe l?uft es nun. Leider bekomme ich, wenn ich als Kunde den Webspace aufrufen m?chte 

Forbidden

Share this post


Link to post
Share on other sites
  • 0

Das kann viele Gr?nde haben. Bitte benutze doch die Foren-Suche.

Share this post


Link to post
Share on other sites
  • 0

Sorry, ich sehe allein wenn ich die Thread-Liste durchgehen mind. 4 threads die das behandeln, ein bisschen Initiative zeigen w?re sch?n....sonst gerne via https://froxlor.support/

Share this post


Link to post
Share on other sites
  • 0

Wie gesagt, ich bin alle durchgegangen, hat aber leider nicht geholfen. In den Theads war ja meistens der Fehler, dass irgendein Paket gefehlt hat, das habe ich aber auch schon ?berpr?ft.

Share this post


Link to post
Share on other sites
  • 0

Und wer sagt das bei dir kein Paket fehlt? Wie w?rs du schaust mal in die error-logs und findest raus, wieso er dir "forbidden" zeigt...sonst wie gesagt, gerne offiziell ?ber froxlor.support, dann schau ich gern f?r dich

Share this post


Link to post
Share on other sites
  • 0

In den Log von Apache? Habe ich schon geschaut, steht nichts. 

Ich bin der Reihe nach alle Pakete durchgegangen, die installiert werden sollen, also denke ich nichts, dass ich etwas vergessen habe.

Share this post


Link to post
Share on other sites
  • 0

Ich habe nun in der "/etc/apache2/sites-enabled/05_froxlor_dirfix_nofcgid.conf" 

 
Folgendes ge?ndert: 
 
<Directory "/var/customers/webs/">
    Order allow,deny
    Allow from all
</Directory>

zu: 

<Directory "/var/customers/webs/">
    Require all granted
    Allow from all
</Directory>

Danach hat es funktioniert. Das wird ja aber leider wieder durch das Panel gel?scht. Woran liegt das, dass dort die "Falschen?" Einstellungen eingetragen sind?

Share this post


Link to post
Share on other sites
  • 0

In einem anderen Post habe ich gelesen, dass es helfen soll "adduser www-data froxlorlocal" auszuf?hren. Da bekomme ich aber folgende Meldung

adduser: The group `froxlorlocal' does not exist.

Die Gruppe m?sste doch eigentlich Existieren, oder liege ich da falsch?

Share this post


Link to post
Share on other sites
  • 0

Hast du denn in den froxlor Einstellungen auch apache-2.4 Modifikation aktiviert?

Share this post


Link to post
Share on other sites
  • 0

Zu deinem Post im anderen Thread. 

 

 

Hast du fpm oder fcgid lies bitte die entsprechenden handbooks im wiki 

Ich habe beides Installiert.

Share this post


Link to post
Share on other sites
  • 0

Nein, wo mache ich denn das?

Edit: habe es gefunden

Hat aber leide rnichts gebracht

 

...cronjob abgewartet? Neue configs schreiben und so...bisschen ungeduldig was?

Share this post


Link to post
Share on other sites
  • 0

Zu deinem Post im anderen Thread. 

Ich habe beides Installiert.

 

Beides...Du weisst aber was du da tust ja?

Share this post


Link to post
Share on other sites
  • 0

Hat funktioniert, nur bei dem ersten Kunden, bei dem ich es auch zuerst getestet habe nicht. Das ist aber egal, da es scheinbar bei den anderen und neuen funktioniert. 
 

Ps: Also muss man, wenn man Apache 2.4 nutzt immer in den Einstellungen den Haken setzten?

Share this post


Link to post
Share on other sites
  • 0

In der Konfig sind beide zu installieren, also habe ich beide installiert. Ist das falsch?

Share this post


Link to post
Share on other sites
  • 0

Ps: Also muss man, wenn man Apache 2.4 nutzt immer in den Einstellungen den Haken setzten?

 

nat?rlich, daf?r gibt es die Option ja, sonst kann Froxlor nicht wissen ob er 2.2er oder 2.4er configs erstellen sollen. Apache 2.4 ist erst in aktuelleren Distributionen standard, viele haben noch 2.2.

 

 

In der Konfig sind beide zu installieren, also habe ich beide installiert. Ist das falsch?

 

"Falsch" kann man das nicht gerade nennen, du solltest aber doch bitte nicht blind einfach alles copy-pasten was wir vorgeben.

Share this post


Link to post
Share on other sites
  • 0

Okay.

Soll ich nun beide drauf lasen oder eins entfernen? Stellt das eine Sicherheitsl?cke dar oder beeintr?chtigt es den Betrieb?

Share this post


Link to post
Share on other sites
  • 0

Schlimm ist es nicht, du solltest dich aber f?r eine der Beiden entscheiden

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Pro-Webs
      Hallo,
      ich bin gerade dabei einen Shopware Shop v.5 unter nginx mit froxlor einzurichten.
      Das ist jedoch relativ problematisch.
      Aktuell habe ich im Froxlor folgende vHost Einstellung zur Domain:
      location @php { fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location / { index index.html index.php shopware.php; rewrite shopware.dll /shopware.php; rewrite files/documents/.* /engine last; #rewrite images/ayww/(.*) /images/banner/$1 last; rewrite backend/media/(.*) /media/$1 last; if (!-e $request_filename){ rewrite . /shopware.php last; } location ~ \.(jpe?g|png|gif|css|js)$ { rewrite backend/media/(.*) /media/$1 last; expires 1M; } } location ~ \.(tpl|yml|ini)$ { deny all; } location /install/ { location /install/assets { } if (!-e $request_filename){ rewrite . /install/index.php last; } } location /update/ { location /update/assets { } location /update/templates { } if (!-e $request_filename){ rewrite . /update/index.php last; } } location /recovery/install/ { location /recovery/install/assets { } if (!-e $request_filename){ rewrite . /recovery/install/index.php last; } } location /recovery/update/ { location /recovery/update/assets { } if (!-e $request_filename){ rewrite . /recovery/update/index.php last; } } location ~ ^/(logs|media/temp|bin|cache)/ { deny all; } location ~ \.php$ { try_files $uri =404; include /etc/nginx/fastcgi_params; fastcgi_pass 127.0.0.1:9000; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param HTTPS $fastcgi_https; fastcgi_param HTTP_AUTHORIZATION $http_authorization; } Diese Einstellung führt zu einem 500 error.
      Meine 35_froxlor_ssl_vhost_studio-ausruestung.de.conf sieht damit leider wie folgt aus:
      # 35_froxlor_ssl_vhost_studio-ausruestung.de.conf # Created 02.01.2020 14:30 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen 91.250.82.51:443 ssl; server_name studio-ausruestung.de www.studio-ausruestung.de xn--studio-ausrstung-tzb.de *.xn--studio-ausrstung-tzb.de studioausruestung.de *.studioausruestung.de priolite-shop.com www.priolite-shop.com sirui-shop.de www.sirui-shop.de shooting-gutschein.de *.shooting-gutschein.de shooting-gutscheine.de *.shooting-gutscheine.de; ssl_protocols TLSv1 TLSv1.2; ssl_ciphers ECDHE-RSA-AES128-SHA256:AES128-GCM-SHA256:RC4:HIGH:!MD5:!aNULL:!EDH; ssl_ecdh_curve secp384r1; ssl_prefer_server_ciphers on; ssl_certificate /etc/ssl/froxlor-custom/studio-ausruestung.de.crt; ssl_certificate_key /etc/ssl/froxlor-custom/studio-ausruestung.de.key; add_header Strict-Transport-Security "max-age=0"; ssl_stapling on; ssl_stapling_verify on; ssl_trusted_certificate /etc/ssl/froxlor-custom/studio-ausruestung.de.crt; include /etc/apache2/conf-enabled/acme.conf; access_log /var/customers/logs/klimek-studio-ausruestung.de-access.log combined; error_log /var/customers/logs/klimek-studio-ausruestung.de-error.log error; root /var/customers/webs/klimek/studio-ausruestung.de/shopware/; location / { index index.php index.html index.htm; try_files $uri $uri/ @rewrites; index index.html index.php shopware.php; rewrite shopware.dll /shopware.php; rewrite files/documents/.* /engine last; #rewrite images/ayww/(.*) /images/banner/$1 last; rewrite backend/media/(.*) /media/$1 last; if (!-e $request_filename){ rewrite . /shopware.php last; } location ~ \.(jpe?g|png|gif|css|js)$ { rewrite backend/media/(.*) /media/$1 last; expires 1M; } } location @rewrites { rewrite ^ /index.php last; } location /webalizer { alias /var/customers/webs/klimek/webalizer/studio-ausruestung.de/; auth_basic "Restricted Area"; auth_basic_user_file /etc/nginx/htpasswd/1-c3d3ffdab2b8342809d19524c21b98c1.htpasswd; } location ~ \.php { try_files /333c3697df6a41bcc37bccd05271f644.htm @php; } location @php { fastcgi_split_path_info ^(.+\.php)(/.+)$; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param PATH_INFO $fastcgi_path_info; try_files $fastcgi_script_name =404; fastcgi_index index.php; fastcgi_param HTTPS on; fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location ~ \.(tpl|yml|ini)$ { deny all; } location /install/ { location /install/assets { } if (!-e $request_filename){ rewrite . /install/index.php last; } } location /update/ { location /update/assets { } location /update/templates { } if (!-e $request_filename){ rewrite . /update/index.php last; } } location /recovery/install/ { location /recovery/install/assets { } if (!-e $request_filename){ rewrite . /recovery/install/index.php last; } } location /recovery/update/ { location /recovery/update/assets { } if (!-e $request_filename){ rewrite . /recovery/update/index.php last; } } location ~ ^/(logs|media/temp|bin|cache)/ { deny all; } } Man bemerkt u.a. das einige Konfigurationen doppelt vorhanden sind, da floxlor diese auch selbst generiert. Das könnte natürlich schon die Ursache des Fehler sein. Ich weiß nur leider nicht, wie ich es "besser" lösen kann.
      Die original .htaccess für den appache sieht folgende Konfiguration vor:
      php_value memory_limit 1024M php_value max_execution_time 600 php_value upload_max_filesize 20M php_value post_max_size 20M <IfModule mod_rewrite.c> RewriteEngine on #RewriteBase /shopware/ # Https config for the backend #RewriteCond %{HTTPS} !=on #RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] RewriteRule shopware.dll shopware.php RewriteRule files/documents/.* engine [NC,L] RewriteRule backend/media/(.*) media/$1 [NC,L] RewriteRule custom/.*(config|menu|services|plugin)\.xml$ ./shopware.php?controller=Error&action=pageNotFoundError [NC,L] RewriteCond %{REQUEST_URI} !(\/(engine|files|templates|themes|web)\/) RewriteCond %{REQUEST_URI} !(\/media\/(archive|banner|image|music|pdf|unknown|video)\/) RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ shopware.php [PT,L,QSA] # Fix missing authorization-header on fast_cgi installations RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L] </IfModule> <IfModule mod_alias.c> # Restrict access to VCS directories RedirectMatch 404 /\\.(svn|git|hg|bzr|cvs)(/|$) # Restrict access to root folder files RedirectMatch 404 /(autoload\.php|composer\.(json|lock|phar)|README\.md|UPGRADE-(.*)\.md|CONTRIBUTING\.md|eula.*\.txt|\.gitignore|.*\.dist|\.env.*)$ # Restrict access to shop configs files RedirectMatch 404 /(web\/cache\/(config_\d+\.json|all.less))$ # Restrict access to theme configurations RedirectMatch 404 /themes/(.*)(.*\.lock|package\.json|\.gitignore|Gruntfile\.js|all\.less|node_modules\/.*)$ </IfModule> # Staging environment #SetEnvIf Host "staging.test.shopware.in" SHOPWARE_ENV=staging # Development environment #SetEnvIf Host "dev.shopware.in" SHOPWARE_ENV=dev #SetEnv SHOPWARE_ENV dev DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php # Disables download of configuration <Files ~ "\.(tpl|yml|ini)$"> # Deny all requests from Apache 2.4+. <IfModule mod_authz_core.c> Require all denied </IfModule> # Deny all requests from Apache 2.0-2.2. <IfModule !mod_authz_core.c> Deny from all </IfModule> </Files> # Enable gzip compression <IfModule mod_deflate.c> AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/javascript application/json application/font-woff application/font-woff2 image/svg+xml </IfModule> <Files ~ "\.(jpe?g|png|gif|css|js|woff|woff2|ttf|svg|webp|eot|ico)$"> <IfModule mod_expires.c> ExpiresActive on ExpiresDefault "access plus 1 month" </IfModule> <IfModule mod_headers.c> Header append Cache-Control "public" Header unset ETag </IfModule> FileETag None </Files> # Match generated files like: # 1429684458_t22_s1.css # 1429684458_t22_s1.js <FilesMatch "([0-9]{10})_(.+)\.(js|css)$"> <ifModule mod_headers.c> Header set Cache-Control "max-age=31536000, public" </ifModule> <IfModule mod_expires.c> ExpiresActive on ExpiresDefault "access plus 1 year" </IfModule> </FilesMatch> # Disables auto directory index <IfModule mod_autoindex.c> Options -Indexes </IfModule> <IfModule mod_negotiation.c> Options -MultiViews </IfModule> <IfModule mod_php5.c> # php_value memory_limit 256M # php_value max_execution_time 120 # php_value upload_max_filesize 20M php_flag phar.readonly off php_flag magic_quotes_gpc off php_flag session.auto_start off php_flag suhosin.session.cryptua off php_flag zend.ze1_compatibility_mode off php_value always_populate_raw_post_data -1 </IfModule> # AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php <IfModule mod_headers.c> Header append X-Frame-Options SAMEORIGIN </IfModule>  
      Für Ideen und Vorschläge wäre ich wie immer sehr dankbar
    • By nisamudeen97
      Hi,
      Our froxlor server is behiend NAT and it uses the local IP  192.168.73.40.  We have enabled letsencrypt module in froxlor and tried validating SSL for a domain in the server.  SSL generation is getting failed with 403 error.  See the debug log information.      Replaced domain name and main IP.    Can any one help me regarding the issue.
       
      [information] Updating Let's Encrypt certificates [information] Updating domain-name.com [information] Adding SAN entry: domain-name.com [information] Adding SAN entry: www.domain-name.com [information] letsencrypt-v2 Using 'https://acme-v02.api.letsencrypt.org' to generate certificate [information] letsencrypt-v2 Using existing account key [information] letsencrypt-v2 Starting certificate generation process for domains [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/new-order [information] letsencrypt-v2 Requesting challenge for domain-name.com [information] letsencrypt-v2 Got challenge token for domain-name.com [information] letsencrypt-v2 Token for domain-name.com saved at /var/www/froxlor/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k and should be available at http://domain-name.com/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [information] letsencrypt-v2 Sending request to challenge [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/chall-v3/803008408/k46kFQ [information] letsencrypt-v2 Verification pending, sleeping 1s [information] letsencrypt-v2 Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for domain-name.com: Verification ended with error: {"type":"http-01","status":"invalid","error":{"type":"urn:ietf:params:acme:error:unauthorized","detail":"Invalid response from http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [212.224.xxx.xxx]: \"<!DOCTYPE html>\\n<html lang=\\\"en-CA\\\" class=\\\"html_stretched responsive av-preloader-active av-preloader-enabled av-default-lightbox\"","status":403},"url":"https:\/\/acme-v02.api.letsencrypt.org\/acme\/chall-v3\/803008408\/k46kFQ","token":"vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","validationRecord":[{"url":"http:\/\/www.domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"www.domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"},{"url":"http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"}]} [information] Let's Encrypt certificates have been updated  
    • By Jason Szymanski
      Hallo,
       
      ich habe leider ein Problem mit Froxlor.
      Zu meiner Situation: Froxlor läuft auf der Subdomain web01.meinedomain.net
      Jetzt möchte ich die Domain aber auch noch weiter Nutzen und habe mich daher als Kunde angelegt und die Domain meineDomain.net als Domain hinzugefügt.
      Dort kann ich auch weitere Subdomains hinzufügen. Das scheint soweit auch zu klappen ich sehe das er VHosts anlegt und auch die Verzeichnisse im FTP anlegt.
      Wenn ich jetzt allerdings versuche auf meinedomain.net oder eine andere Subdomain unter dieser Domain zuzugreifen leitet er mich auf web01.meinedomain.net
      Ich habe mich schon in den Einstellungen umgeschaut konnte aber keine entsprechende Einstellung finden an der das liegen könnte.
      Wie verhindere ich also das er mich auf Froxlor umleitet?
       
      Mit Freundlichen Grüßen
      Jason Szymanski
    • By JavaLink
      Hi
      I try install Froxlor several times bu every time i get error
       SQLSTATE[HY000] [1045] Access denied for user 'myuser'@'localhost' (using password: YES)
      I do these things for create use:
      CREATE USER 'myuser'@'localhost' IDENTIFIED BY 'pP123!@#Hello'; then
      create database froxlor;  
      and then
      GRANT ALL PRIVILEGES ON `froxlor` TO 'myuser'@'localhost';
       
      FLUSH PRIVILEGES;  
      I check connection with a file called con.php contain this ---> and it's OK.
      <?php $servername = "localhost"; $username = "myuser"; $password = "pP123!@#Hello"; // Create connection $conn = new mysqli($servername, $username, $password); // Check connection if ($conn->connect_error) { die("Connection failed: " . $conn->connect_error); } echo "Connected successfully";  
      but after run froxlor to install it and fill all information, i get that error.
      Also i check again with server and find out that the `myuser` user is deleted...What happened? What Froxlor do?
    • By nisamudeen97
      Hi,
      Wile doing migration of email accounts from one froxlor server to another I have noting some thing.   Expecting some clarification on this.  As we all know emails are normally stored in the location "/var/customers/mail/user/domain.com/user/Maildir/" .   I create email accounts via froxlor panel and copy the email files directly via scp or rsync from old server to new.  The strange thing I have noticed is it is not coping custom folders and its emails like we have in source.  
      The solution I have found for this is to use imapsync between old and new.  imapsync is preserving custom folders like as it is in source.    Does it mean custom folder settings are stored somewhere else?  How we can preserve it and copy emails manually?
×
×
  • Create New...