Jump to content
Froxlor Forum

irisdina

Members
  • Content Count

    95
  • Joined

  • Days Won

    12

Everything posted by irisdina

  1. Logs? Apache oder nginx logs Prüfe auch deine Vhost conf (apache oder nginx) auf welches verz. diese Domain geht.
  2. Schau mal nach, was in /etc/apache2/sites-enabled/ drin ist ... gott ich habe schon seit Jahrzehnten nicht mehr mit Apache2 gearbeitet. Hast du probiert den Eigentümer zu ändern oder kommt die Obere Meldung von Froxlor?
  3. Ups war mein Fehler mit dem Log Ordner. Muss mich hier an den Standard Pfad gewöhnen Was sagt den der Cronjob, wenn du diesen Manuell ausführst mit php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug (ggf. Pfad zu deiner Froxlor installation anpassen!) Ist Froxlor überhaupt auch Richtig eingerichtet oder einfach nur Installiert und drauf los gelegt?
  4. Deine Vhost Dateien findest du unter /etc/apache2/sites-available/ Deine Error Logs zu der Domain findest du unter /etc/customers/logs
  5. Was sagt der Apache Error log, wie sieht die vhost Datei von dieser Sub-Domain aus usw? Ohne Logs, kann man nur raten...
  6. erstmal --force --debug benutzen und nicht --letsencrypt -- debug Desweiteren kannst auch erstmal für einige Stunden den Cronjob von LE Certs in Froxlor auf Off stellen und dann nochmal nach einiger Zeit probieren, per SSH den befehl zu benutzen.
  7. Certs sind wieder da, auch im froxlor-custom ordner.
  8. LE sagt ja bei Limit Rate Also nehme ich jetzt an, das es am IP Bereich liegt, aber dagegen kann ich ja selbst nicht tun, sondern, da müsste jetzt hetzner was machen. daher bleibt mir nichts anderes übrig, als einige tage zu warten. Und 300 Anfragen kann ich ja selbst gar nicht, erstellen. ich benutze ja nicht mal den cron für frox, das er alle 5min die anfragen an LE sendet.
  9. ok, ich schreibe noch mal alles auf. Limit Rate Fehler [Sat 06 Jun 2020 03:33:08 PM CEST] Create new order error. Le_OrderFinalize not found. { "type": "urn:ietf:params:acme:error:rateLimited", "detail": "Error creating new order :: too many certificates already issued for exact set of domains: imap.tokushu.xxxxxx.eu,imaps.tokushu.xxxxxx.eu,mail.tokushu.xxxxxx.eu,pop3.tokushu.xxxxxx.eu,pop3s.tokushu.xxxxxx.eu,smtp.tokushu.xxxxxx.eu,smtps.tokushu.xxxxxx.eu,ssl.smtp.tokushu.xxxxxx.eu,ssl.tokushu.xxxxxx.eu,tokushu.xxxxxx.eu: see https://letsencrypt.org/docs/rate-limits/", [Sat 0
  10. Aktuell bleibt mir auch nichts anderes übrig, als dieses Manuelle gefrickel zu machen, solange ich im Limit bei Let's bin. Daher warte ich mal einige Tage, dann setze ich mich nochmal dran.
  11. ja, habe per certbot einfach die zerts erstellt. probiere in einigen tagen dann nochmal mit der acme.sh und frox
  12. hab die einstellungen gefunden. nur erstellt mir die acme.sh jetzt überhaupt kein cert mehr, egal für welche domain. wenn ich bei frox --force --debug mache.
  13. dann muss ich halt einige tage jetzt mal warten. wie verhindere ich jetzt, wenn ich meine domains wieder dazu packe, das er mir für die froxlor url, das cert holt?
  14. nope, an der DB hab ich direkt nichts gemacht. Und ja, den Fehler habe ich auch gesehen, aber warum kann ich dann ohne probleme manuell mehrmals am tag das cert erstellen? ^^
  15. [Fri 05 Jun 2020 12:10:38 PM CEST] tokushu.xxxxxx.eu is removed, the key and cert files are in /root/.acme.sh/tokushu.xxxxxx.eu_ecc [Fri 05 Jun 2020 12:10:38 PM CEST] You can remove them by yourself. root@tokushu ~ # rm -r .acme.sh/ root@tokushu ~ # php /var/www/html/froxlor/scripts/froxlor_master_cronjob.php --force --debug [information] TasksCron: Searching for tasks to do [information] Running Let's Encrypt cronjob prior to regenerating webserver config files [information] Could not find acme.sh - installing it to /root/.acme.sh/ --2020-06-05 12:16:00-- https://get.acme.sh/ Resolving get
  16. das sind die einzigen dateien die im ordner vorhanden sind.
  17. na ja, aber /etc/ssl/froxlor-custom ist immer noch leer, so lange er da die certs nicht erstellt. geht dies leider halt nicht.
  18. Leider noch nicht. [error] Could not find file 'tokushu.xxxxxx.eu.cer' in '/root/.acme.sh/tokushu.xxxxxx.eu_ecc/' [error] Could not find file 'ca.cer' in '/root/.acme.sh/tokushu.xxxxxx.eu_ecc/' [error] Could not find file 'fullchain.cer' in '/root/.acme.sh/tokushu.xxxxxx.eu_ecc/' [error] Could not get Let's Encrypt certificate for tokushu.xxxxxx.eu: nginx: [emerg] no "ssl_certificate" is defined for the "listen ... ssl" directive in /etc/nginx/sites-enabled/10_froxlor_ipandport_xxxxxxxx.443.conf:5 ich probiere gleich mal, wenn ich frox eine andere sub domain zuweise, ob dies geht.
  19. Ja, aber auch das Costum Ordner keine dateien vorhanden sind, verstehe ich irgendwie nicht., für domains erstellt er die. nur für die froxlor domain nicht, aber manuel ein cert erstellen geht ohne probleme. Die Domain für Froxlor, ist zwar nur eine Sub-Domain, aber die hat bisher noch nie probleme gemacht.
  20. irgendwie suckt die acme.sh immer noch bei mir ... bekomme wieder den fehler "[error] Could not find file 'xxxxxxxxx.cer' in '/root/.acme.sh/xxxxxxxxx_ecc/_ecc/'" nginx meckert auch wegen, "nginx: [emerg] no "ssl_certificate" is defined for the "listen ... ssl" directive in "/etc/nginx/sites-enabled/10_froxlor_ipandport_xxxxxxxxxx.conf:5" da keine Dateien unter "/etc/ssl/froxlor-custom" vorhanden sind. vorhande dateien im acme ordner: ~/.acme.sh/xxxxxxxxx_ecc # ls xxxxxxxxx.conf xxxxxxxxx.csr xxxxxxxxx.csr.conf xxxxxxxxx.key aktuelle git vers.
  21. merke ich mir das nächste mal und erwähne dann git-stand eine Warnung spuckt er aber noch aus, habe ich gerade gesehen. [warning] ECC certificates activated but found only non-ecc file [warning] ECC certificates activated but found only non-ecc file [warning] ECC certificates activated but found only non-ecc file [warning] ECC certificates activated but found only non-ecc file [warning] ECC certificates activated but found only non-ecc file Aber let's läuft sonst jetzt wieder.
  22. habe mir die logs noch mal genauer angesehen und acme.sh meckert, das er den ordner "_ecc" nicht findet, aber die acme.sh erstellt die verz. eig. so: /.amce.sh/domain_ecc/ also macht keinen unterordner "_ecc" php froxlor_master_cronjob.php --letsencrypt --force [error] Could not find certificate-folder '/root/.acme.sh/xxxxxxx.eu/_ecc/' [error] Could not get Let's Encrypt certificate for xxxxxxx.eu: [Sun 31 May 2020 04:24:32 AM CEST] Domains not changed. [Sun 31 May 2020 04:24:32 AM CEST] Skip, Next renewal time is: Thu 30 Jul 2020 02:19:46 AM UTC [Sun 31 May 2020 04:24:32 AM CEST] Add '--f
  23. Hi, habe froxlor heute auf dem neusten stand gebracht und wollte eine domain hinzufügen inkl. ssl settings. Da ist mit dieser Fehler aufgefallen, durch den Fehler wird auch mein nginx process gekillt jedesmal. php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug [information] TasksCron: Searching for tasks to do [information] Running Let's Encrypt cronjob prior to regenerating webserver config files [information] Requesting 1 new Let's Encrypt certificates [warning] Skipping Let's Encrypt generation for xxxxxxxxxxxxxx.eu due to an enabled ssl_redirect
  24. Du musst dazu noch "fastcgi_parm ... Upload size" dazu packen und am besten dann noch "fastcgi_read_timeout" dazu bsp: location / { .... client_max_body_size 1000M; .... } location @php { try_files $1 =404; ... fastcgi_param PHP_VALUE "upload_max_filesize=1000M \n post_max_size=1000M"; fastcgi_read_timeout 600; ... } Dann sollte es ohne probleme gehen.
  25. geändert, funzt wieder. kA warum ich dass auf "Staging" stehen hatte. ich kann jetzt wieder ein kaffee trinken ^^
×
×
  • Create New...