Jump to content
Froxlor Forum

saxandl

Members
  • Posts

    24
  • Joined

  • Last visited

saxandl's Achievements

Explorer

Explorer (4/14)

  • Collaborator Rare
  • Dedicated Rare
  • First Post
  • Conversation Starter
  • One Month Later

Recent Badges

0

Reputation

  1. automatisiertes update halt, ich hätte es aber auch zugelassen, wenn es zu bestätigen gewesen wäre. Wir erwähnt proxy_fcgi-error erstmal um 10:40 aufgetreten, davon um 10:33 update von php 8.0.11 => 8.0.12 sowohl apache2 als auch system-neustart - beides ohne erfolg. Kann es mit suexec in zusammenhang stehen? denn auch hier kommt eine Fehlermeldung "suexec policy violation" und im suexec.log bei aufruf von cgi-script: [2021-10-26 12:44:20]: target uid/gid (1001/1001) mismatch with directory (10000/10000) or program (10000/10000)
  2. das Phänomen ist spontan und ohne mein zutun aufgetreten srw-rw---- 1 customer2 customer2 0 Okt 26 11:48 1-customer2-<domain>.<tdl>-php-fpm.socket srw-rw---- 1 customer1 customer1 0 Okt 26 11:48 1-customer1-<domain>.<tdl>-php-fpm.socket es wundert mich auch: zumal das spontan aufgetreten ist und ungefähr zeitgleich im apt.log das update ausgeführt wurde!
  3. da sind dann alle domains und subdomains aufgelistet. Auszug: customer1 3504 0.0 0.0 234592 11772 ? S 11:48 0:00 \_ php-fpm: pool <domain>.<tdl> customer1 3505 0.0 0.0 234592 11772 ? S 11:48 0:00 \_ php-fpm: pool <domain>.<tdl> customer2 3514 0.0 0.0 234592 11776 ? S 11:48 0:00 \_ php-fpm: pool <domain>.<tdl> customer2 3515 0.0 0.0 234592 11776 ? S 11:48 0:00 \_ php-fpm: pool <domain>.<tdl> die domain von customer1 bildet index.php ab; die domain von customer2 nicht mehr => Error 502 (sehr wahrscheinlich seit dem Update von PHP)
  4. *ggg* ich kann leider nicht alles wissen 😞 aber ich versuchs mir zu merken: root 3484 0.5 0.1 234816 33976 ? Ss 11:48 0:00 php-fpm: master process (/etc/php/8.0/fpm/php-fpm.conf)
  5. wie überprüft man das? // update: ja, läuft: php8.0-fpm & php8.0-fpm.service jetzt beide reseller ident
  6. Hi Nach einem automatisierten update von PHP 8.0.11 auf 8.0.12 erschein folgende Fehlermeldung im log: [Tue Oct 26 11:17:44.413045 2021] [proxy:error] [pid 890] (13)Permission denied: AH02454: FCGI: attempt to connect to Unix domain socket /var/lib/apache2/fastcgi/1-<customer>-<domain>.<tdl>-php-fpm.socket (*) failed [Tue Oct 26 11:17:44.413120 2021] [proxy_fcgi:error] [pid 890] [client nn.nn.nn.nn:44115] AH01079: failed to make connection to backend: httpd-UDS Die website meldet Fehler 503 Service Unavailable. Zur Ergänzung: es handelt sich um websites mit index.php Obiges tritt interessanter Weise nur bei einem customer auf, bei einem zweiten nicht. Der einzig erkennbare Unterschied: bei Customer mit error fehlt in der Option Domains=>(Sub-) Domain bearbeiten => die Option "OpenBasedir-Pfad"
  7. das script selbst tut nichts anderes, als das Environment auszulesen und an den Browser weiter geben - vergleichbar mit phpinfo(). Am script liegt es definitiv nicht! Wenn ich das script über den Browser aufrufe, bekomme ich einen 404-error und im logfile den beschriebenen error. Es sieht so aus, als würde apache nicht auf das Verzeichnis des customers zugreifen, sondern das script im Verzeichnis /usr/lib/cgi-bin/ ausführen versuchen. Nur zur Sicherheit: FCGID ist deaktiviert
  8. das weiss ich nicht! das cgi-script wird nicht im Verzeichnis ausgeführt - daher hab ich ins logfile geschaut.
  9. bin exakt wie beschrieben vorgegangen. softlink's werden korrekt eingerichtet, apache scheint nicht richtig darauf zu reagieren: AH02811: script not found or unable to stat: /usr/lib/cgi-bin/env.cgi
  10. update: leider ein Folgeproblem aufgetreten: apache error.log: AH01215: suexec policy violation: see suexec log for more details: suexec.log uid: (10000/<customer>) gid: (10000/<customer>) cmd: env.cgi command not in docroot (/mnt/datastore2/webs/<customer>/<domain>.<tdl>/shop/cgi-bin/env.cgi) sieht so aus, was würde das env.cgi aufgrund Rechteproblem nicht ausgeführt werden können. Es gibt da bei den Einstellungen Perl/CGI den Punkt - Aktiviere SuExec-Workaround der vermutlich angepasst werden muss. Ich habe die Pfade grundsätzlich so angelegt, dass sich das Verzeichnis /cgi-bin/ unterhalb des docroots befindet: /var/customers/webs/<customer>/<domain>.<tdl>/cgi-bin/ und dies in der vHost-Einstellung über ScriptAlias definiert. Wie sollte die Konfiguration angepasst werden?
  11. a2enmod proxy_fcgi => alles gut thanks!
  12. als root von der console: # sudo service Usage: service < option > | --status-all | .... Debian 10 Apache 2.4.38 php 8.0 MariaDB 10.3.31 wo finde ich froxlor/php-fpm-daemon settings?
  13. wie vorgeschlagen vorgegangen libnss-extrausers eingerichtet - scheint zu funktionieren: ftp user:group wird auf customer:customer umgeschrieben. neues Problem entstanden: php wird nicht ausgeführt, sondern der code im browser angezeigt. Zum Test deaktiviere ich den <FilesMatch \.(php)$> im vhost => wird php ausgeführt. vl auch von Bedeutung: Froxlor\Cron\Http\ApacheFcgi::reload: running service php8.0-fpm restart sh: 1: service: not found
  14. heisst das im Umkehrschluss, wenn ich FCGID & PHP-FPM in den Einstellungen aktiviere benötige ich libnss-extrausers nicht?
  15. wo finde ich diese Einstellung bzw. wie lässt es ermitteln?
×
×
  • Create New...