Jump to content
Froxlor Forum

irisdina

Members
  • Content Count

    69
  • Joined

  • Days Won

    12

Everything posted by irisdina

  1. mysql -h localhost -u root -p ###Set the new type of validation SET GLOBAL validate_password_policy=0; //For Low ###Restart mysql sudo service mysql restart or you can use a password, which has fewer special characters, some programs have problems with it. Best example is there dovecot.
  2. gut, erwähne ich in der doku ?
  3. Benutze Bitte libnss-extrausers und nicht libnss-mysql Um welche Froxlor Version handelt es sich den? Du kannst nähmlich auch php /var/www/html/Froxlor/install/scripts/config-services.php --froxlor-dir=/var/www/html/Froxlor/ --create benutzen, da macht er dir die confs automatisch, du musst nur angeben für welches OS und was du Installieren willst Das die Doku in der Wiki angeht, die wird komplett erneuert, daran wird schon gearbeitet
  4. Einen neuen Kunden extra für phpmyadmin zu erstellen brauchst du schon mal nicht, aber was du erstellen musst, wenn du andere confs für php-fpm benutzen willst, ist halt ne eigene conf, das dauert keine 5min und ist im Panel ruck zuck gemacht. Und zwar unter PHP-Konfigurationen > Neue Konfiguration erstellen so mache ich dies auch bei vers. CMS die ich am laufen habe. Du musst dann nur nach dem erstellen der conf im Panel, einem oder dem einen Kunden die rechte für die php-conf geben. Kunden > Kunden bearbeiten > PHP-Konfiguration und fast ganz unten, dann die conf mit einem hacken aktivieren und schwups kannst du bei jeder domain wo der kunde besitzt die conf aktivieren.
  5. Du hast gerade dir die Antwort selbst gegeben, ja die Pfade.
  6. also deine Fehler Meldung sagt doch schon alles /etc/apache2/apache2.pem' does not exist or is empty entferne mal die Certs unter den SSL Settings im Panel und starte den Froxlor Cron neu oder erstelle die fehlende Cert von hand.
  7. Also noch mal, du hast erwähnt Also noch mal, deine Apache Cert, die du selbst erstellt hast, brauchst du nicht mehr, nach dem du LE aktiviert und benutzt hast. Wenn du Froxlor über eine IP aufrufst, bekommst du natürlich kein LE Cert, sondern brauchst halt eine Domain o. Sub-Domain für Froxlor. Froxlor macht, alles von alleine was LE angeht, du musst nur wenn du eine Domain oder Sub-Domain in Froxlor anlegst, musst du nur dann SSL für diese Domain oder Sub-Domain einstellen, den Rest macht das Panel.
  8. Meldung genau Bitte bzw. error.log mal vom apache posten. und deine selbst erstellten apache cert. haben nichts mit LE oder dem Vhost zu tun. Weil deine LE Cert sind korrekt in deinem Vhost drin, daher weiß ich nicht ohne Logs, wo er deine eigenen Certs haben will ...
  9. und jetzt starte mal den web cronjob neu mit php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug dann sollten die ssl settings in deinen vhost dateien drin stehen.
  10. Sind bei den Domains auch LE aktiviert? wenn ja, per ssh mal "php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug" und zeige mal die meldungen
  11. also wenn das die ssl conf sein soll, ist da nichts mit LE. check mal bitte deine froxlor settings
  12. nein, die von Froxlor zb. oder einer anderen domain. kA jetzt ob die für apache auch 35_froxlor_ssl_vhost_domain.tld.conf heißen.
  13. die wo Froxlor erstellt hat, also sites-enable
  14. Zeige mal Bitte die komplette vhost datei. Da ich bezweifel, das LE aktiviert ist bzw. der Cronjob dafür durch gelaufen ist.
  15. wurde der webserver nach dem erstellen der LE Certs neu gestatert bzw. noch mal den cronjob manuel starten, dann sollte es passen.
  16. Du kannst dein Selbst erstellstes Cert in => SSL-Einstellungen > Pfad zum SSL-Zertifikat und deine Key Datei in > Pfad zum SSL Private-Key eintragen inkl. Pfad
  17. hier steht schon der fehler: Mai 10 17:52:32 root.DOMAIN.TLD proftpd[25520]: Starting ftp server: proftpd2019-05-10 17:52:32,954 root.DOMAIN.TLD proftpd[25528]: warning: unable to determine IP address of 'root.DOMAIN.TLD' Mai 10 17:52:32 root.DOMAIN.TLD proftpd[25520]: 2019-05-10 17:52:32,955 root.DOMAIN.TLD proftpd[25528]: error: no valid servers configured Mai 10 17:52:32 root.DOMAIN.TLD proftpd[25520]: 2019-05-10 17:52:32,955 root.DOMAIN.TLD proftpd[25528]: fatal: error processing configuration file '/etc/proftpd/proftpd.conf' Mai 10 17:52:32 root.DOMAIN.TLD proftpd[25520]: failed!
  18. Ja, einfach SSL in den Optionen aktivieren und LE aktivieren und den rest macht dann Froxlor selbst, nach dem der Cron gelaufen ist. SSL-Einstellungen Für Optimale SSL TLS settings für Apache2 oder Nginx Webserver => https://mozilla.github.io/server-side-tls/ssl-config-generator/ Pfad zu acme.conf => Bei Apache "/etc/apache2/acme.conf | Bei Nginx "/etc/nginx/acme.conf" acme.conf Alias "/.well-known/acme-challenge" "/var/www/html/Froxlor/.well-known/acme-challenge" <Directory "/var/www/html/Froxlor/.well-known/acme-challenge"> Require all granted </Directory> Optional: Schlüsselgröße für neue Let's Encrypt Zertifikate => 4096 oder 8192 ECC / ECDSA Zertifikate ausstellen => ec-384 Froxlor VirtualHost Einstellungen Let's Encrypt für den froxlor Vhost verwenden => Ja SSL-Weiterleitung für den froxlor Vhost aktivieren => Ja HTTP Strict Transport Security (HSTS) => 31536000
  19. Du kannst das auch in der SQL direkt ändern, per phpmyadmin oder per ssh. Alternativ kannst du auch den vhost für Froxlor per ssh manuel ändern.
  20. Habe mit deinem Anbieter Telefoniert, auf den Cloud-Servern ist ein stink normales Debian Jessie installiert mit den Standard Settings, auch der Nano Befehl oh. Probleme, auch eine Source.list ist vorhanden usw. Du hast auch vollen Root Zugriff auf die Kiste, also kA genau was du da gemacht hast. Wenn du noch nichts wichtiges auf dem Server drauf hast, mache einen Re-Install von Debian Jesse und fange ganz von vorne Bitte an. Du kannst dir dann Froxlor wieder installieren, wie dies dann geht findest du hier > https://github.com/Froxlor/Froxlor/wiki/Install-froxlor-on-debian Die Paketabhängikteien, wie Apache2 usw. werden dann automatisch mit Installiert, wenn du dies nach nach der Oben genannten Anletiung machst. Wenn du Probleme hast, wende dich auch an deinen Hoster, er Hilft dir auch
  21. Ok, von so einem Debian hab ich noch nie was gehört im Leben. Ich frag mal morgen deinen Anbieter mal per Tele, was die da genau benutzen, das interessiert mich selbst sehr.
  22. Rufe pls mal die Source.list mit nano oder einen anderen ssh Editor auf und Poste diese hier mal. also mit nano /etc/apt/source.list
  23. Nein, das macht mehr kaputt dann, als es was bringt. Welche Service hast du in Anspruch genommen bei dogado, bzw. ist das überhaupt ein Dedicated Server oder eher ein V-Server etc?
  24. Ich tippe auf eine Debian Minimal Installation. @Iprod Du hast jetzt mehere möglichkeiten, entweder installiert du Manuel, alle Standard Sachen nach, wie Nano und co. Dafür gibt es viele, How To's im Web, oder du installiert Debian neu, bsp direkt Stretch und Webserver (manche Anbieter), haben dafür vorgefertigte Templates. Aber auf jedenfall solltest du die Basic's noch lernen für Linux.
  25. Dann hast du wohl Dovecot nicht richtig installiert. apt remove --purge dovecot-imapd dovecot-pop3d dovecot-mysql dovecot-managesieved dovecot-sieve apt install dovecot dovecot-imapd dovecot-pop3d dovecot-mysql dovecot-managesieved dovecot-sieve Welches OS ist eig. auf dem Server installiert?
×
×
  • Create New...