Jump to content
Froxlor Forum

みゆき

Members
  • Posts

    122
  • Joined

  • Days Won

    15

Everything posted by みゆき

  1. Sorry, das ich dich da etwas berechtigen muss. Das mit einer Stunde von d00p war eher als Metapher gewesen und ein System was keinerlei Support mehr hat, nicht die Zeit wert ist. Und man handelt als Server Betreiber grob fahrlässig, wenn man solch ein System benutzt und besonders, wenn man da eine kommerzielle Website betreibt und noch mal besonders wenn man Kundendaten Speichert, dies kann eine schöne Jahres Geldsumme kosten, wenn man damit Probleme bekommt. Ps. Es heißt, seid 9. Januar 2018 Matomo und nicht mehr Piwik
  2. Man könnte sich jetzt darüber streiten aber fakt ist halt, Froxlor hat kein Plugin System und es wird wohl so schnell auch nicht kommen. Wenn man halt unbedingt ein Plugin System haben will, muss man halt Plesk und Co. benutzen und dafür blechen
  3. Das mit den Daten gibt es in der Theo schon, sprichwort "WebFTP" url kann man in Froxlor eintragen" dann sieht das jeder Kunde auch im Panel. Was die DB angeht, ist das PW so ein Prob? einmal im Browser gespeichert und man muss nix mehr eingeben An den jeweiligen DBs im laufende Betrieb einer Webseite zu ändern, ist halt immer so ne sache ... Plugins schön und gut, man darf aber nicht vergessen, das Froxlor Open Source ist und damit Verdient d00p keine Knete, sondern mit dem Support etc. das sollte man auch mal beachten und ein Plugin System bringt mehr Probleme. Weil was macht man, wenn ein Plugin von einer Externen Quelle Probleme macht und dir eine Froxlor install zerstört?
  4. Was vermisst du denn bzw, was brauchst du denn?
  5. Nein, Plugins, Module etc. gibt es nicht. Du kannst höchstens neue Funktionen Programmieren und diese an d00p weitereichen, das er diese ggf. ein Froxlor einbauen kann.
  6. Falls du FPM installiert hast, musst du natürlich dieses auch neu Starten mit "service php7.4-fpm restart" und nicht einfach nur apache neu Starten ... Ansonsten, den ganzen shice sauber Installieren apt remove --purge php* rm -r /etc/php/ apt update && apt dist-upgrade -y apt install php7.4 php7.4-cli php7.4-fpm php7.4-json php7.4-common php7.4-mysql php7.4-zip php7.4-gd php7.4-mbstring php7.4-curl php7.4-xml php7.4-pear php7.4-bcmath php7.4-apcu php7.4-curl apache2 libapache2-mod-php7.4 php7.4-xml Du solltest dich aber direkt Fragen, wenn man schon keine Logs posten kann, ob man einen Webserver betreiben sollte, wenn man null Ahnung von der Materie hat... 1. Gefährdest dich und andere mit einem Ungesicherten Webserver 2. Haben wir auch keine Lust uns mit Leuten zu beschäftigen die Null Ahnung haben, was Sie tun und nicht mal bereit sind, zu lernen sondern nur nach irgend einer Anleitung im Web gehen und sich dann fragen warum dies nicht läuft...
  7. Ok wait ... you've been trying to install Froxlor on CentOS 8 for 8 months, really? What mistakes do you have? And if it's really 8 months, then you should ask yourself whether it makes sense what you're doing there.
  8. Your SSL certificates are not found. Please check whether the files are available in "/root/acme.sh/Your Domain" and in "/etc/ssl/froxlor-custom". Otherwise check your SSL settings. You can also check whether LE created the certificate correctly with. "php /var/www/Froxlor/scripts/froxlor_master_cronjob.php --force --debug" or "php /var/www/Froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug" And also check your Froxlor settings for SSL! addendum: According to "Let's Debug Toolkit" no certificate was created for the domain "radicalcomputingconcepts.com" in the last 91 days, so your settings in Froxlor seem to be wrong. Please check all settings in Froxlor
  9. You know Google right? The first link already helps you > https://www.google.com/search?q=centos8+froxlor&rlz=1C1CHBD_deDE848DE848&oq=centos8+froxlor&aqs=chrome..69i57j0i22i30j0i8i13i30.4680j0j7&sourceid=chrome&ie=UTF-8 And I recommend that you really learn the beginner stuff before you even think about a website.
  10. You can change the following things in the Froxlor database "with phpmyadmin or with the terminal", "panel_admins"> "type_2fa"> Change> 0 Empty "data_2fa"
  11. You can easily answer your questions yourself. Does it pay off as a website operator not to let a website run 24/7? Before you put anything on the Internet, you should ask yourself. - Do I know what I'm doing? - What do I want to do with a website? - Do I have any idea about the hosting system, Linux? Froxlor is only an aid and not an all-purpose weapon, it makes your work easier, but if you have no idea about the basic matter, then you have a problem and endanger yourself and others on the Internet with it.
  12. Welche an "menge" Probleme hattest du denn, würde ich mich mal interessieren... Vorweg, Froxlor ist "nur" ein Hilfsmittel mehr und weniger nicht. Es nimmt dir nicht zu 100% die Arbeit ab, wenn man man von der Materie wie ein Linux Server keine Ahnung hat, sollte man sich erst mal einlesen... Wie d00p bereits angemerkt hat, kann man dir ohne Logs usw. nicht Helfen, woran dein Problem genau liegt. In der "/etc/dovecot/dovecot.conf" kannst du folgendes setzen für "debug" auth_verbose = yes auth_verbose_passwords = no auth_debug = yes auth_debug_passwords = yes mail_debug = yes verbose_ssl = yes danach dovecot neu starten und in den logs schauen. Alternativ kannst du auch per SSH folgendes benutzen: Verwenden Sie zum einfachen Testen der Authentifizierung: doveadm auth test user@domain password Verwenden Sie zum Nachschlagen von Userdb-Informationen für einen Benutzer: doveadm user user@domain Um eine vollständige Anmeldung mit passdb- und userdb-Suche zu simulieren, verwenden Sie: doveadm auth login user@domain password
  13. Froxlor läuft eig. schon oh. probleme auf den neusten Deb/Ubu Varianten.
  14. Setze den hacken bei "Keine generierte try_files Anweisung" Und schreibe bei Eigene vHost-Einstellungen oder Eigene SSL vHost-Einstellungen (je nach dem was du benutzt) location / { try_files $uri $uri/ /index.php?$args; } Damit wird der block im nginx vhost gesetzt, was du machen willst.
  15. Die Api Doku findest du hier https://api.froxlor.org/doc/0.10.25/ zur aktiviert der Api im Froxlor Panel "Einstellungen > Einstellungen > Aktiviere externe API Nutzung > hacken setzen"
  16. Wenn man eine Domain in Froxlor löscht, wird auch (wenn benutzt) das dazugehörige LE Cert Automatisch gelöscht. Laut deiner Fehlerbeschreibung, versucht dein System immer noch ein LE Cert für die Domain zu erstellen, auch wenn die Domain eig. gar nicht mehr auf deine Server IP läuft. Das kann folgende gründe haben - Du hast die Domain noch immer bei dir in Froxlor eingetragen (Domain übersicht) - Deine DNS Settings für die Domain sind fehlerhaft. Welcher Server ist der neue/alte (tango.xxxx.de/ew.xxxxx.de) Du kannst auch mal probieren acme.sh --remove domain, falls da noch reste drin sind
  17. sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal
  18. welche Fehlermeldung bekommst du denn? Darüber hinaus, löscht Froxlor auch keine Ordner im .acme.sh verz. sondern macht nur --remove. die ordner muss man selbst schon löschen. das wird einem auch mit einer root mail gesagt. Cron <root@xxxxx> /usr/bin/nice -n 5 /usr/bin/php -q /var/www/Froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null [Wed Feb 24 12:30:01 PM CET 2021] xxxxxxxxx.tokyo is already removed, You can remove the folder by yourself: /root/.acme.sh/xxxxxxxxx.tokyo_ecc [Wed Feb 24 12:30:01 PM CET 2021] xxxxxxxxx.eu is already removed, You can remove the folder by yourself: /root/.acme.sh/xxxxxxxxx.eu_ecc
  19. Ansicht läuft Froxlor oh. probleme mit PHP8, klar gibt es kleinere kinderkrankheiten, was normal ist. persönlich habe ich oh. probleme froxlor mit php8 im aktiven einsatz. nur viele CMS Systeme (wenn man sowas benutzen will), haben noch viele probleme damit.
  20. und poste mal deine apache conf für die domain.
  21. Schau in deine DB > ps_configuration und suche folgende Zeilen raus Und ändere diese werte mal auf eine Domain
  22. Ich bin jetzt ganz offen, hast du überhaupt ne Ahnung, was du da treibst? Wie erwähnt, habe das Sys ohne Probleme mit LE SSL installiert (siehe oberen link). Poste doch mal den error log, von deiner Domain oder nenne doch mal deine Domain, das wir dir weiterhelfen können. Laut deiner .htaccess läuft dein Shop Sys auf einer IP, anstatt einer richtigen Domain, die Datei bekommt ihre Infos aus der DB, also hast du einfach falsch installiert oder dein ganzes Sys läuft falsch.
  23. Du musst in den Optionen folgendes aktivieren: Welcher Webserver wird benutzt? habe dieses Shop System oh. Probleme mit LE SSL getestet und ging ohne Probleme. Und wie d00p, schon angemerkt hat, wurde deine Shop Seite per IP anstatt mit einer Domain installiert. Daher kannst du probieren in der DB, Manuel die Einträge zu ändern oder installiert den Shop noch mal richtig mit einer Domain. *Nachtrag* Du kannst die die Domain auch per DB ändern. In folgenden Tabellen findet du die Einträge: - ps_configuration - ps_connections_source Test Installation inkl. Demo Content > https://testing.anime-mitsuketa.tokyo/
  24. Du kannst auch ganz einfach php7.4 unter Stretch installieren. Dann hast du keine Probleme aktuell mehr.
×
×
  • Create New...