Jump to content
Froxlor Forum
  • 0

A database error occurred When Adding Customers?


Question

Hi so i'm pretty new to this, I have a LAMP stack running on Ubuntu 16.04 Amazon's Lightsail EC2 style platform similar to DigitalOcean's droplet setups

So far i got everything setup, php-7 is installed, mysql is installed and it's all working i installed Froxlor with no errors, i've even setup the Mail Server and FTP though i haven't been able to test those yet

I'm currently taking classes for sysadminstration and web development but my experience is still at a beginer level. If anyone can tell me what i set up wrong or need to change, i'd really appreciate it. It took me a long time to get this running because all the documentation was very out of date, i ended up doloading the latest version and extracting it in my var/www/html/ directory, i can access the pannel and even login to the admin account i set up during the setup phase.

When trying to add a new user to test thing i get the following message once i've filling everything out

A database error occurred

SQLSTATE[01000]: Warning: 1265 Data truncated for column 'add_date' at row 1

 

EDIT: Also redtext sorry not familiar with this forum setup. SO it DID add the User, but i'm still getting Mysql errors on things like email.I followed the instructions to the letter through ssh everything should be good. I've gone through them twice step by step to make sure.

Rebuilt the whole LAMP stack from the ground up, configured everything exactly how it said to in the config guides

Here's the Rerror it gives.

Dear froxlor-team,

the following error has been reported by a user:

-------------------------------------------------------------
01000 SQLSTATE[01000]: Warning: 1265 Data truncated for column 'add_date' at row 1

File: /lib/classes/database/class.Database.php:72

Trace:
#0 /lib/classes/database/class.Database.php(72): PDOStatement->execute(Array)
#1 /admin_customers.php(935): Database::pexecute(Object(PDOStatement), Array)
#2 {main}

-------------------------------------------------------------

Froxlor-version: 0.9.38.7
DB-version: 201612110

End of report

 

Link to post
Share on other sites

3 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By Nicholas Wood
      Hey,
      I'm installing Froxlor on CentOS 8 and everything seems to have gone well for the most part. However the config file was supposedly saved in /tmp/xxx but I can't find that file anywhere.
      cd tmp/fxVnlJGY ... doesn't exist. Anyone know where that is?


       
       
      Running the below command from www/html folder and then reinstalling produces the same result.
      sudo chown -R apache:apache froxlor  
    • By Matteo
      I am installing Froxlor 10 on Debian 10 with MySQL and Apache2 on a home web server.
      I get to the installation screen by going to localhost/froxlor and I get
      "Welcome to Froxlor"
      "It seems that Froxlor has not been installed yet."
      "Click on the link below to start the installation."
      I click "Start Install" and get to this page:
      Checking system requirements...
      All requirements are satisfied [green] and this is at the bottom:
      All requirements are satisfied
        Clicking the link to continue takes me to:
      Database connection
      MySQL-Hostname:
      Database name:
      Username for the unprivileged MySQL-account:
      Password for the unprivileged MySQL-account:
      Username for the MySQL-root-account:
      Password for the MySQL-root-account:
       
      Administrator Account
      Administrator Username:
      Administrator Password:
      Administrator-Password (confirm):
      Enable the official newsfeed
      (https://inside.froxlor.org/news/):
       
      Server settings
      Server name (FQDN, no ip-address):
      Server IP:
      Webserver Apache 2.4:
      HTTP username:
      HTTP groupname:
       
      [With all the correct fields and passwords filled in...]
      Clicking the [continue] button takes me to the success screen...:
      Froxlor install - setup
      Checking MySQL-root access... OK Creating backup of old database... OK  Preparing database... OK Creating database and username... OK Testing if database and user have been created correctly... OK Importing data... OK Adjusting settings... OK Inserting new values... OK Creating admin-account... OK Creating configfile... File was saved in /... Froxlor was installed successfully.
        Clicking the login button takes me to this:
      "Welcome to Froxlor"
      "It seems that Froxlor has not been installed yet."
      "Click on the link below to start the installation."
      And the process starts all over again...
      It doesn't matter which browser I use - Chrome, Firefox - the result is the same.
      I am a new Linux user, so some help would be appreciated.
      Thank you.
       
    • By Marcel -//- AdSoleWare
      Hello.
      I manually installed Froxlor on Debian 8 and tried setting up. i installed php 7.3 in as it was the only missing point. i restarted apache2 and now it wont start. I need help
       
      Error Log:
       
    • By Tom Spielvogel
      Hello community, i have updated my froxlor version from 0.8 or 0.9 i don't exactly remember to 0.10.12 to use the ACMEv2 challenges for Let's Encrypt.
      I have sql-dumped the old database.
      Any pointers on how I can restore the data into my new database? I don't want to manually type in all the customers with all their settings again 😮
      Please help!
    • By tmuecksch
      Hallo liebe Community.
      Ich habe einen neuen Debian 9.4 Server aufgesetzt und Froxlor installiert (gemäß Wiki). Nach Durchführung aller notwendigen Konfigurationsschritte hat Froxlor wie gewohnt funktioniert. Anschließend habe ich ein SSL Zertifikat hochgeladen und in Froxlor, unter Einstellungen > SSL-Einstellungen  habe ich SSL aktiviert und die Pfade Zertifikatfiles angegeben. Anschließend habe ich eine einen neuen Eintrag unter IPs und Ports konfiguriert mit Port 443.
      Nach Generierung der neuen Config Files durch Froxlor ist folgender Fehler aufgetreten, der Apache nicht mehr starten lässt.
      May 17 09:50:14 X.de apachectl[1516]: (99)Cannot assign requested address: AH00072: make_sock: could not bind to address X:443 May 17 09:50:14 X.de apachectl[1516]: no listening sockets available, shutting down  
      Also würde ja nahe liegen, dass der Socket in Verwendung ist (was bei einem frischen Debian doch unwahrscheinlich ist)
      ➜ ~ netstat -tlpn | grep 443 ➜ ~ Der Port ist, wie wir sehen nicht in Verwendung. 
       
      ➜ ~ grep -r "Listen" /etc/apache2/ /etc/apache2/sites-enabled/10_froxlor_ipandport_X.443.conf:Listen X:443 /etc/apache2/ports.conf:Listen 80 /etc/apache2/ports.conf: Listen 443 /etc/apache2/ports.conf:# Listen 443 Man könnte nun vermuten, dass die beiden Listen 443 Einträge in der ports.conf den Fehler verursachen. Doch weit gefehlt. Wenn ich die beiden Einträge entferne ändert das nichts.
       
      Der Fehler lässt sich nur beheben wenn ich in der folgenden Datei die Zeile "Listen X:443" manuell lösche:
      # 10_froxlor_ipandport_X.443.conf # Created 17.05.2018 09:49 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. Listen X:443 <VirtualHost X:443> DocumentRoot "/var/www/" ServerName Z.de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder On SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/letsencrypt/live/Z.de/cert.pem SSLCertificateKeyFile /etc/letsencrypt/live/Z.de/privkey.pem SSLCertificateChainFile /etc/letsencrypt/live/Z.de/chain.pem </VirtualHost>  
      Wie kann das sein? Wieso generiert Froxlor eine nicht funktionierende VHost Config? Habe ich vielleicht was falsch gemacht? Ist der Fehler schon bekannt?
       
      P.S: Meine IP Adresse und Domain habe ich durch Großbuchstaben ersetzt.
       
×
×
  • Create New...