Jump to content
Froxlor Forum
  • 0

[Fehler/Bug]: Cronjob sendet alle 5 Minuten eine Mail an mich


Question

Hi,

seit gestern um 18:40h erhalte ich alle 5 Minuten folgende Mail. Da ich seit Längerem nichts am Server geändert habe (außer gelegentliche Update) würde ich mal ganz lapidar einen Fehler meinerseits ausschließen. Bisher hat ja alles problemlos geklappt.

Nach etwas Recherche scheint der Fehler mit acme.sh zusammenzuhängen.

Betreff: 
 

Quote

Cron <root@XXXXXXX> /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/

Inhalt:
 

Quote

Please specify at least one validation method: '--webroot', '--standalone', '--apache', '--nginx' or '--dns' etc. 

 

Was kann ich tun um den Fehler zu Debugger und/oder zu beheben?

 

 

Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Ja, und ich eigentlich geben wir da den webroot Parameter an... ruf den cron bitte mit --force --debug auf damit wir mehr Info haben

Link to post
Share on other sites
  • 0

Dabei kommt leider auch nicht viel Info rum...

 

Folgenden Befehl habe ich ausgeführt:

 

Quote

 sudo php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug --force

 

Ausgabe:

[Entfernt da ohnehin nicht hilfreich]

 

 

Link to post
Share on other sites
  • 0

Hm.... --webroot für nen renew...das war bisher nicht so. Muss ich mal durch die acme.sh changelog gucken.

Bis dahin kannst du ja gerne versuchen folgenden Patch zu benutzen ob es dann funktioniert:

diff --git a/lib/Froxlor/Cron/Http/LetsEncrypt/AcmeSh.php b/lib/Froxlor/Cron/Http/LetsEncrypt/AcmeSh.php
index 2515783a..9d967080 100644
--- a/lib/Froxlor/Cron/Http/LetsEncrypt/AcmeSh.php
+++ b/lib/Froxlor/Cron/Http/LetsEncrypt/AcmeSh.php
@@ -322,9 +322,9 @@ class AcmeSh extends \Froxlor\Cron\FroxlorCron
 
                        $acmesh_cmd = self::$acmesh . " --auto-upgrade 0 --server " . self::$apiserver . " --" . $cert_mode . " -d " . implode(" -d ", $domains);
 
-                       if ($cert_mode == 'issue') {
+                       //if ($cert_mode == 'issue') {
                                $acmesh_cmd .= " -w " . Settings::Get('system.letsencryptchallengepath');
-                       }
+                       //}
                        if (Settings::Get('system.leecc') > 0) {
                                $acmesh_cmd .= " --keylength ec-" . Settings::Get('system.leecc');
                        } else {

 

Link to post
Share on other sites
  • 0
On 1/22/2020 at 9:18 AM, d00p said:

acme.sh sagt immer noch für ein renew einfach nur "acme.sh --renew -d example.com" ausführen, siehe https://github.com/Neilpang/acme.sh#12-how-to-renew-the-certs

 

@d00p Ja das habe ich auch schon gesehen. Die Fehlermeldung macht in diesem Kontext echt überhaupt keinen Sinn. Ich kann Dir nur sagen, dass ich eine Domain gekündigt habe und diese erst kürzlich aus Froxlor entfernt habe. Allerdings erst nachdem diese merkwürdige Fehlermeldung aufgetaucht ist.

Ich probiere mal den vorgeschlagenen Patch aus und melde mich dann zurück.

Link to post
Share on other sites
  • 0

Der Patch hat nichts gebracht. Also habe ich mal ein

var_dump($acmesh_cmd); exit;

eingefügt. Den Command setzt er wie folgt zusammen:

Quote

string(175) "/root/.acme.sh/acme.sh --auto-upgrade 0 --server https://acme-v02.api.letsencrypt.org/directory --renew -d bp.admin.bico-app.de -d www.bp.admin.bico-app.de -w /var/www/froxlor"

 

Ohne exit sieht die Ausgabe so aus:

Quote

[information] Running Let's Encrypt cronjob prior to regenerating webserver config files
[information] Requesting/renewing Let's Encrypt certificates
[information] Updating certificate for bp.admin.bico-app.de
[information] Adding SAN entry: bp.admin.bico-app.de
[information] Adding SAN entry: www.bp.admin.bico-app.de
string(175) "/root/.acme.sh/acme.sh --auto-upgrade 0 --server https://acme-v02.api.letsencrypt.org/directory --renew -d bp.admin.bico-app.de -d www.bp.admin.bico-app.de -w /var/www/froxlor"
[Thu Jan 23 11:45:26 CET 2020] Lets find script dir.
[Thu Jan 23 11:45:26 CET 2020] _SCRIPT_='/root/.acme.sh/acme.sh'
[Thu Jan 23 11:45:26 CET 2020] _script='/root/.acme.sh/acme.sh'
[Thu Jan 23 11:45:26 CET 2020] _script_home='/root/.acme.sh'
[Thu Jan 23 11:45:26 CET 2020] Using default home:/root/.acme.sh
[Thu Jan 23 11:45:26 CET 2020] Using config home:/root/.acme.sh
[Thu Jan 23 11:45:26 CET 2020] Using server: https://acme-v02.api.letsencrypt.org/directory
[Thu Jan 23 11:45:26 CET 2020] Running cmd: renew
[Thu Jan 23 11:45:26 CET 2020] Using config home:/root/.acme.sh
[Thu Jan 23 11:45:26 CET 2020] ACME_DIRECTORY='https://acme-v02.api.letsencrypt.org/directory'
[Thu Jan 23 11:45:26 CET 2020] DOMAIN_PATH='/root/.acme.sh/bp.admin.bico-app.de'
[Thu Jan 23 11:45:26 CET 2020] Le_API
Please specify at least one validation method: '--webroot', '--standalone', '--apache', '--nginx' or '--dns' etc.
[debug] https://github.com/Neilpang/acme.sh
v2.8.5
[Thu Jan 23 11:45:26 CET 2020] Renew: 'bp.admin.bico-app.de'
[information] Updated Let's Encrypt certificate for bp.admin.bico-app.de
[information] Let's Encrypt certificates have been updated
[information] apache::createIpPort: creating ip/port settings for  195.201.27.7:80
[debug] 195.201.27.7:80 :: inserted vhostcontainer
[information] apache::createIpPort: creating ip/port settings for  195.201.27.7:443
[debug] 195.201.27.7:443 :: inserted vhostcontainer
[information] apache::createIpPort: creating ip/port settings for  [2a01:4f8:1c1c:351c::1]:80
[debug] [2a01:4f8:1c1c:351c::1]:80 :: inserted vhostcontainer
[information] apache::createIpPort: creating ip/port settings for  [2a01:4f8:1c1c:351c::1]:443
[debug] [2a01:4f8:1c1c:351c::1]:443 :: inserted vhostcontainer

Sehr merkwürdig, dass er meckert obwohl -w gesetzt wird. Ich versteh' das nicht...

Acme.sh Version:

Quote

$ sudo /root/.acme.sh/acme.sh --version
https://github.com/Neilpang/acme.sh
v2.8.5

Also ist acme.sh up-to-date....

Link to post
Share on other sites
  • 0

Ha, interessant - die config erstellt acme.sh aber selbst· damit hat froxlor nichts zu tun. Füge die Zeile doch einfach in die config ein, ich denke dann sollte das wieder funktionieren :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By mrairstone
      Guten Morgen,
      mir ist in Froxlor ein kleiner Fehler in Bezug auf CatchAll Email aufgefallen.
      Zum System:
      Debian 10, 64-Bit Froxlor 0.10.11 Postfix, Dovecot, Spamc Zum Problem:
      Beim Anlegen einer neuen E-Mailadresse kann man je Domain nur eine CatchAll-Adresse definieren. Wenn man jedoch eine bestehende E-Mailadresse bearbeitet, kann man dort ganz einfach auf CatchAll umschalten.
      Dadurch kann es passieren, dass mehrere Emailadressen unterhalb einer Domain als CatchAll definiert sind. Das ist mir erst aufgefallen, als ich E-Mails in meinem Postfach hatte, welche nicht für meine E-Mailadresse bestimmt waren.
      Da auf dem Account in Froxlor mehrer Nutzer zugreifen (Feuerwehr) und E-Mailadressen hinzufügen, ändern und auch löschen - habe ich erst sehr spät gesehen das mehrere CatchAll vorhanden waren.
      Wenn man eine Mail an eine E-Mailadresse sendet, welche als CatchAll definiert wurde, wird die Mail auch an alle anderen E-Mailadressen weitergeleitet, die unterhalb der Domain als CatchAll definiert sind.(Jedenfalls bei postfix)
      Temporäre Lösung:
      Damit eingehende Mails an eine vorhandene E-Mailadresse, welche als CatchAll definiert ist, auch nur im Postfach dieser E-Mailadresse landen, habe ich die SQL-Anweisung in der "mysql-virtual_alias_maps.cf" wie folgt abgeändert:
      query = SELECT destination FROM mail_virtual AS v, panel_customers AS c WHERE c.customerid = v.customerid AND c.deactivated = 0 AND (v.email = '%s' OR v.email_full = '%s') AND trim(v.destination) <> '' Ich habe das eben auch noch einmal in der Demoversion ausprobiert, Screenshot im Anhang.
       
      Gruß

    • By tmuecksch
      Hallo liebe Community.
      Ich habe einen neuen Debian 9.4 Server aufgesetzt und Froxlor installiert (gemäß Wiki). Nach Durchführung aller notwendigen Konfigurationsschritte hat Froxlor wie gewohnt funktioniert. Anschließend habe ich ein SSL Zertifikat hochgeladen und in Froxlor, unter Einstellungen > SSL-Einstellungen  habe ich SSL aktiviert und die Pfade Zertifikatfiles angegeben. Anschließend habe ich eine einen neuen Eintrag unter IPs und Ports konfiguriert mit Port 443.
      Nach Generierung der neuen Config Files durch Froxlor ist folgender Fehler aufgetreten, der Apache nicht mehr starten lässt.
      May 17 09:50:14 X.de apachectl[1516]: (99)Cannot assign requested address: AH00072: make_sock: could not bind to address X:443 May 17 09:50:14 X.de apachectl[1516]: no listening sockets available, shutting down  
      Also würde ja nahe liegen, dass der Socket in Verwendung ist (was bei einem frischen Debian doch unwahrscheinlich ist)
      ➜ ~ netstat -tlpn | grep 443 ➜ ~ Der Port ist, wie wir sehen nicht in Verwendung. 
       
      ➜ ~ grep -r "Listen" /etc/apache2/ /etc/apache2/sites-enabled/10_froxlor_ipandport_X.443.conf:Listen X:443 /etc/apache2/ports.conf:Listen 80 /etc/apache2/ports.conf: Listen 443 /etc/apache2/ports.conf:# Listen 443 Man könnte nun vermuten, dass die beiden Listen 443 Einträge in der ports.conf den Fehler verursachen. Doch weit gefehlt. Wenn ich die beiden Einträge entferne ändert das nichts.
       
      Der Fehler lässt sich nur beheben wenn ich in der folgenden Datei die Zeile "Listen X:443" manuell lösche:
      # 10_froxlor_ipandport_X.443.conf # Created 17.05.2018 09:49 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. Listen X:443 <VirtualHost X:443> DocumentRoot "/var/www/" ServerName Z.de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder On SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/letsencrypt/live/Z.de/cert.pem SSLCertificateKeyFile /etc/letsencrypt/live/Z.de/privkey.pem SSLCertificateChainFile /etc/letsencrypt/live/Z.de/chain.pem </VirtualHost>  
      Wie kann das sein? Wieso generiert Froxlor eine nicht funktionierende VHost Config? Habe ich vielleicht was falsch gemacht? Ist der Fehler schon bekannt?
       
      P.S: Meine IP Adresse und Domain habe ich durch Großbuchstaben ersetzt.
       
    • By v3ng
      Hallo, 
       
      Ich habe leider ein Problem. Wenn ich in einem erstellten Webspace die "setup-owncloud.php" in das "Hauptverzeichnis" hochlade und ausf?hre bekomme ich folgenden Fehler: 
      Dependency check Dependencies not found. Can't write to the current directory. Please fix this by giving the webserver user write access to the directory. Wenn allerdings ein Verzeichnis erstelle und die setup-owncloud.php in dieses Verzeichnis ziehe und erneut aufrufe habe ich keine Probleme und die Installation funktioniert.
      Wie kann ich das l?sen? 
    • By Gamerboy59
      Hi,
      I'm getting the following error when opening:

      Ubuntu 12.04 (Precise) ? Mailserver (SMTP) ? Exim4This is the error message:
      PHP warning/error #2 file_get_contents(./templates/misc/configfiles/ubuntu_precise/exim4/etc_exim4_conf.d_acl_30_exim4-config_check_rcpt.rul): failed to open stream: No such file or directory /var/www/html/admin_configfiles.php:130 PHP warning/error #2 file_get_contents(./templates/misc/configfiles/ubuntu_precise/exim4/etc_exim4_conf.d_auth_30_froxlor-config): failed to open stream: No such file or directory /var/www/html/admin_configfiles.php:130 PHP warning/error #2 file_get_contents(./templates/misc/configfiles/ubuntu_precise/exim4/etc_exim4_conf.d_main_10_froxlor-config_options): failed to open stream: No such file or directory /var/www/html/admin_configfiles.php:130 PHP warning/error #2 file_get_contents(./templates/misc/configfiles/ubuntu_precise/exim4/etc_exim4_conf.d_router_180_froxlor-config): failed to open stream: No such file or directory /var/www/html/admin_configfiles.php:130 PHP warning/error #2 file_get_contents(./templates/misc/configfiles/ubuntu_precise/exim4/etc_exim4_conf.d_transport_30_froxlor-config): failed to open stream: No such file or directory /var/www/html/admin_configfiles.php:130 Btw: Where to post bugs?
    • By JulesNet
      Erstmal vielen Dank f?r das Update.
      W?hrend der Aktualisierung von froxlor via apt trat kein Fehler auf (Debian), ich wurde aufgefordert mich als Administrator anzumelden.
      Allerdings ist eine Anmeldung unm?glich und ich bekomme folgende Benachrichtigungen von dem master cronjob "Version of file doesnt match version of database. Exiting...".
      Darauf hin habe ich manuel in der Datenbank die Version von 0.9.27 auf 0.9.28 aktualisiert und konnte mich ohne Probleme anmelden.
      Ist dieses Verfahren unumstritten m?glich oder wird bei der ersten Anmeldung als Administrator die Datenbank mit den Updates versehen, sodass die Software zwar nun aktualisiert ist, die Datenbank jedoch nicht?
       
      Ich danke f?r eure Hilfe
       
      [EDIT] bei der Anmeldung erhalte ich folgende Meldung: "HTTP-Fehler 500 (Internal Server Error): Beim Versuch des Servers, die Anforderung zu verarbeiten, ist eine unerwartete Bedingung aufgetreten."
×
×
  • Create New...