Jump to content
Froxlor Forum

tmuecksch

Members
  • Posts

    27
  • Joined

  • Last visited

Everything posted by tmuecksch

  1. Selbes Problem auch auf meinem Server seit dem letzten `apt upgrade`. Gibt es schon einen Workaround? Ich blicke nicht so ganz durch.
  2. Guter Hinweis! Ich habe mal die Konfiguration mit den anderen vorliegenden Konfigurationen verglichen und folgende Zeile fehlt: Le_Webroot='/var/www/froxlor'
  3. Der Patch hat nichts gebracht. Also habe ich mal ein var_dump($acmesh_cmd); exit; eingefügt. Den Command setzt er wie folgt zusammen: Ohne exit sieht die Ausgabe so aus: Sehr merkwürdig, dass er meckert obwohl -w gesetzt wird. Ich versteh' das nicht... Acme.sh Version: Also ist acme.sh up-to-date....
  4. @d00p Ja das habe ich auch schon gesehen. Die Fehlermeldung macht in diesem Kontext echt überhaupt keinen Sinn. Ich kann Dir nur sagen, dass ich eine Domain gekündigt habe und diese erst kürzlich aus Froxlor entfernt habe. Allerdings erst nachdem diese merkwürdige Fehlermeldung aufgetaucht ist. Ich probiere mal den vorgeschlagenen Patch aus und melde mich dann zurück.
  5. Dabei kommt leider auch nicht viel Info rum... Folgenden Befehl habe ich ausgeführt: Ausgabe: [Entfernt da ohnehin nicht hilfreich]
  6. Hinweis: Ich habe soeben im Froxlor cronjob die Zeile für Letsencrypt auskommentiert. Seitdem kommen die Mails nicht mehr. Also hat es ziemlich sicher mit letsencrypt zu tun.
  7. Hi, seit gestern um 18:40h erhalte ich alle 5 Minuten folgende Mail. Da ich seit Längerem nichts am Server geändert habe (außer gelegentliche Update) würde ich mal ganz lapidar einen Fehler meinerseits ausschließen. Bisher hat ja alles problemlos geklappt. Nach etwas Recherche scheint der Fehler mit acme.sh zusammenzuhängen. Betreff: Inhalt: Was kann ich tun um den Fehler zu Debugger und/oder zu beheben?
  8. Falls noch einmal jemand ein solches Problem mit Wordpress haben sollte hier meine Lösung: Unter https://gist.github.com/Adirael/3383404 gibt es ein script welches die Permissions für Wordpress Installationen fixt. Anschließend werden die Dateien wieder korrekt angelegt. Bitte unbedingt die Kommentare lesen, da sind wichtige Infos dabei.
  9. @Neutrino Danke für den Tipp. Auch das zeigt leider keine Wirkung. Mittlerweile bin ich auch noch mal einen Schritt weiter. Ich habe mit folgendem Script mal getestet wie von PHP Dateien angelegt werden: <?php if ($fp = fopen(time() . '.txt', 'w')) { fwrite($fp, 'This is a simple test.'); fclose($fp); echo "done"; } else { echo "error - cannot create file"; } Quelle: https://serverfault.com/questions/383734/how-do-i-set-default-umask-in-apache-on-debian Und mit diesem Script werden die Dateien korrekt angelegt. Das heißt, es muss ein Wordpress-Problem und kein Konfigurationsld00problem sein. @d00p Vielen dank für's in die Richtige Richtung schubsen.
  10. Danke für den Hinweis, das Stichwort umask hat mir gefehlt. sudo -u www-data touch foo erstellt Daten mit korrekten Rechten (-rw-r--r--). Laut diversen Google-Ergebnissen soll es helfen in "/etc/apache2/envvars" eine umask option "umask 002" einzufügen (+ apache2 Neustart versteht sich). Auch das hilft leider nicht. Ich google mal weiter...
  11. Trotz installation und Aktivierung in den Einstellungen bleibt das Permissions problem. Ich habe mal einen Screenshot einer hochgeladenen Datei beigefügt. Sie wird mit "--w--w--w- 1 www-data www-data" erstellt...
  12. Danke für Deine Antwort! Hier zunächst mal zu Einfachheit meine via apt-get installierten Pakete, sofern das für Dich interessant ist: https://pastebin.com/ExwSc9HY Hier noch meine aktivierten Apache mods: https://pastebin.com/fQagdrxG Weder bei libnss-mysql noch bei extrausers klingelt es bei mir. Der Server ist erst vor kurzem installiert worden, dazu habe ich ein reines Debian Image genutzt und dann Froxlor gemäß der Anleitung im Wiki und gemäß der Anweisungen in der Admin-UI unter Konfigurationen installiert. Das Einzige was ich darüber hinaus noch gemacht habe ist php-memcache zu installieren, da unser Wordpress ohne nicht funktioniert hat.
  13. Guten Tag, ich habe einen Debian 9 Server mit Froxlor und Apache2 am laufen. Wenn ich mit dem Kunden FTP Zugang Dateien hochlade haben diese Ordnungsgemäß das ownership 10000:10000. Wenn jedoch in der PHP-Weboberfläche eine Datei hochgeladen wird, wird diese mit dem ownership www-data:www-data hochgeladen. Liegt hier ein Konfigurationsfehler vor oder ist das Verhalten sogar so gewünscht? Ich kann den Fehler leider nicht entdecken. Das Problem ist nur, dass das PHP-Script dann eine Permission Denied Fehlermeldung wirft, wenn versucht wird die Datei zu lesen. Liebe Grüße tmuecksch
  14. Hallo. Ich habe leider genau das selbe Problem und google schon seit stunden. Hast Du eine Lösung gefunden?
  15. Hallo liebe Community. Ich habe einen neuen Debian 9.4 Server aufgesetzt und Froxlor installiert (gemäß Wiki). Nach Durchführung aller notwendigen Konfigurationsschritte hat Froxlor wie gewohnt funktioniert. Anschließend habe ich ein SSL Zertifikat hochgeladen und in Froxlor, unter Einstellungen > SSL-Einstellungen habe ich SSL aktiviert und die Pfade Zertifikatfiles angegeben. Anschließend habe ich eine einen neuen Eintrag unter IPs und Ports konfiguriert mit Port 443. Nach Generierung der neuen Config Files durch Froxlor ist folgender Fehler aufgetreten, der Apache nicht mehr starten lässt. May 17 09:50:14 X.de apachectl[1516]: (99)Cannot assign requested address: AH00072: make_sock: could not bind to address X:443 May 17 09:50:14 X.de apachectl[1516]: no listening sockets available, shutting down Also würde ja nahe liegen, dass der Socket in Verwendung ist (was bei einem frischen Debian doch unwahrscheinlich ist) ➜ ~ netstat -tlpn | grep 443 ➜ ~ Der Port ist, wie wir sehen nicht in Verwendung. ➜ ~ grep -r "Listen" /etc/apache2/ /etc/apache2/sites-enabled/10_froxlor_ipandport_X.443.conf:Listen X:443 /etc/apache2/ports.conf:Listen 80 /etc/apache2/ports.conf: Listen 443 /etc/apache2/ports.conf:# Listen 443 Man könnte nun vermuten, dass die beiden Listen 443 Einträge in der ports.conf den Fehler verursachen. Doch weit gefehlt. Wenn ich die beiden Einträge entferne ändert das nichts. Der Fehler lässt sich nur beheben wenn ich in der folgenden Datei die Zeile "Listen X:443" manuell lösche: # 10_froxlor_ipandport_X.443.conf # Created 17.05.2018 09:49 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. Listen X:443 <VirtualHost X:443> DocumentRoot "/var/www/" ServerName Z.de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder On SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/letsencrypt/live/Z.de/cert.pem SSLCertificateKeyFile /etc/letsencrypt/live/Z.de/privkey.pem SSLCertificateChainFile /etc/letsencrypt/live/Z.de/chain.pem </VirtualHost> Wie kann das sein? Wieso generiert Froxlor eine nicht funktionierende VHost Config? Habe ich vielleicht was falsch gemacht? Ist der Fehler schon bekannt? P.S: Meine IP Adresse und Domain habe ich durch Großbuchstaben ersetzt.
  16. Vielen Dank. Dann werde ich das mal ausprobieren!
  17. Hey, kurze Frage. Laut Debian-Wiki wird Debian 9 "Stretch" am 16.06.2017 offizielle released und damit stable (Link: https://wiki.debian.org/DebianStretch#Before_the_release). Ich möchte einen neuen Debian-Server mit Froxlor aufsetzen. Unterstützt Froxlor bereits Debian Stretch? Oder soll ich lieber Jessie nehmen? PS.: Über die Foren-Suche konnte ich leider keine Antwort darauf finden. Liebe Grüße tmuecksch
×
×
  • Create New...