Jump to content
Froxlor Forum
d00p

Release candidate 0.10.0 - It's Froxlor, but with API :)

Recommended Posts

i had it installed before as a package can there be a problem when the package was uninstalled and i uploaded the data via ftp?

Share this post


Link to post
Share on other sites

No, as said, the initial services config is not automatically called

Share this post


Link to post
Share on other sites

I believe you already.

But where does it come from if I didn't execute anything? that wasn't even possible because the problem occurred in the middle of the update process.

Share this post


Link to post
Share on other sites

In the package "froxlor-0.10.0-rc2.tar.gz" the "froxlor_master_cronjob.php" is not executable. Couldn't this be stored in tar.gz?

I only came across it because I had to update it manually and the crons didn't run through.

Share this post


Link to post
Share on other sites
10 minutes ago, Tealk said:

In the package "froxlor-0.10.0-rc2.tar.gz" the "froxlor_master_cronjob.php" is not executable. Couldn't this be stored in tar.gz?

I only came across it because I had to update it manually and the crons didn't run through.

it's run with "php", not directly...cron works fine here on my servers

Share this post


Link to post
Share on other sites

How is your cron run? can you please specify what exactly it is you do? It's hard to help with so few information

Share this post


Link to post
Share on other sites

I raised froxlor to 0.10 before the Debian update. Renamed the old folder and restored the config file.
Since then I haven't changed anything in the settings.
After the Debian Update I have removed old cipher and noticed that the cron doesn't work anymore.
When I make the file "froxlor_master_cronjob.php" executable it runs as usual again.

I had installed Froxlor before as a package, that was uninstalled during the update of Debian.

Share this post


Link to post
Share on other sites

That does not answer the question how you run the cronjob...

Share this post


Link to post
Share on other sites

With the following file:

/etc/cron.d/froxlor

# automatically generated cron-configuration by froxlor
# do not manually edit this file as it will be re-generated periodically.
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
#
*/5 * * * * root /usr/bin/nice -n 5 /usr/bin/php7.2 -q /var/www/froxlor//scripts/froxlor_master_cronjob.php --tasks 1> /dev/null
0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php7.2 -q /var/www/froxlor//scripts/froxlor_master_cronjob.php --traffic 1> /dev/null
5 0 * * * root /usr/bin/nice -n 5 /usr/bin/php7.2 -q /var/www/froxlor//scripts/froxlor_master_cronjob.php --usage_report 1> /dev/null
0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php7.2 -q /var/www/froxlor//scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null
*/5 * * * * root /usr/bin/nice -n 5 /usr/bin/php7.2 -q /var/www/froxlor//scripts/froxlor_master_cronjob.php --letsencrypt 1> /dev/null
10 0 * * * root /usr/bin/nice -n 5 /usr/bin/php7.2 -q /var/www/froxlor//scripts/froxlor_master_cronjob.php --backup 1> /dev/null

 

Share this post


Link to post
Share on other sites

My cronjob has the following permissions and works just fine:

-rw-r--r--  1 froxlor froxlor  641 Jan  2  2019 froxlor_master_cronjob.php

 

Share this post


Link to post
Share on other sites

Like I said I have to give the user executive permissions. Why don't I know and currently don't know where to start investigating.

Share this post


Link to post
Share on other sites

And like I said, works for me flawlessly, no idea what you've done to your system...seems like you a few issues here

Share this post


Link to post
Share on other sites

As recommended I copied my database to a fresh Debian 10 and started the internal update. Changed the IP and got stuck. Apache doesn't start due:

AH00526: Syntax error on line 11 of /etc/apache2/sites-enabled/28_froxlor_normal_vhost_web1.s01.XXXX.info.conf:
Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration

These are the lines for open basedir and email. Any recommendations how to fix this?

If I remove all php_admin_value Entries from all fines it is running fine.

Share this post


Link to post
Share on other sites

I enabled mod_php, looked into it ten times and still missed that it was disabled again...

Thx a lot.

 

Another strange thing I found is that I disabled a customer and tried to reenable it. Ending here:

A database error occurred
SQLSTATE[42000]: Syntax error or access violation: 1044 Access denied for user 'froxlor_root'@'127.0.0.1' to database 'web8sql1'
Dear froxlor-team,

the following error has been reported by a user:

-------------------------------------------------------------
42000 SQLSTATE[42000]: Syntax error or access violation: 1044 Access denied for user 'froxlor_root'@'127.0.0.1' to database 'web8sql1'

File: lib/Froxlor/Database/Database.php:203

Trace:
#0 [internal function]: PDO->query('GRANT ALL PRIVI...')
#1 lib/Froxlor/Database/Database.php(203): call_user_func_array(Array, Array)
#2 lib/Froxlor/Database/Manager/DbManagerMySQL.php(203): Froxlor\Database\Database::__callStatic('query', Array)
#3 lib/Froxlor/Api/Commands/Customers.php(1081): Froxlor\Database\Manager\DbManagerMySQL->enableUser('web8sql1', '127.0.0.1')
#4 admin_customers.php(376): Froxlor\Api\Commands\Customers->update()
#5 {main}

-------------------------------------------------------------

Froxlor-version: 0.10.0-rc2
DB-version: 201904250

End of report

User froxlor_root got full global rights. So this shouldn't be a problem. Any guesses?

Share this post


Link to post
Share on other sites

Could you please try to reproduce this using the real root user to be sure it's not a permission issue?

Share this post


Link to post
Share on other sites

That doesn't change anything.

SQLSTATE[42000]: Syntax error or access violation: 1044 Access denied for user 'root'@'127.0.0.1' to database 'web8sql1'

But I think that isn't intended to work. Newer releases only accept root from shell if you are currently a root user.

Share this post


Link to post
Share on other sites
8 hours ago, mike87 said:

But I think that isn't intended to work.

But it needs to work for froxlor. In order to manage mysql databases and users we need a privileged user.

Share this post


Link to post
Share on other sites
vor 5 Stunden schrieb d00p:

But it needs to work for froxlor. In order to manage mysql databases and users we need a privileged user.

I know. I just wanted you to know about this problem. Debian 10/MariaDB 10.3 uses unix_socket as plugin for the root user. So this isn't working anymore and you have to create another root-like user.

That's why I use froxlor_root with full global rights, identified by password from 127.0.0.1/localhost/server-ip.

Connecting via shell is working: mysql -u froxlor_root -p

May you know the SQL-statement so I could test it via shell?

Share this post


Link to post
Share on other sites

This was an issue even before Debian buster. There are many many topics here how to fix that. Also, a fresh install should do the required steps. 

3 minutes ago, mike87 said:

May you know the SQL-statement so I could test it via shell

As said, search the Forum, it's on here a few times, try searching for "update mysql.user" maybe

Share this post


Link to post
Share on other sites

Before I imported the old database I did a fresh install and my froxlor_root user was accepted.

It took me some time but I found the issue. MariaDB got a bug in 10.3. Granting ALL PRIVILEGES lacks DELETE HISTORY. So another grant ALL PRIVILEGES fails. You need to grant all priviliges manually and it is working. (See Bug Report)

Share this post


Link to post
Share on other sites

Hey d00p,

I updated/upgraded from 0.9.40.1 to this RC and now getting this after the login page:

Zitat

Fatal error: Uncaught Error: Class 'Settings' not found in /var/www/froxlor/lib/navigation/10.tickets.php:25 Stack trace: #0 /var/www/froxlor/lib/Froxlor/PhpHelper.php(165): include() #1 /var/www/froxlor/lib/init.php(423): Froxlor\PhpHelper::loadConfigArrayDir('lib/navigation/') #2 /var/www/froxlor/admin_index.php(20): require('/var/www/froxlo...') #3 {main} thrown in /var/www/froxlor/lib/navigation/10.tickets.php on line 25

I downloaded the package and unzipped it to my desktop and then uploaded all the files into my froxlor folder on my server with overwriting existing files. Any help here would be nice.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By peterpan
      Hi,
      I have a domain equipped with a certificate from LE. The cert is valid another 2 months. Now I added a domain as an alias of the existing domain, but the certificate isn't updated to have the new domain as its SAN.
      How do I trigger getting a new and updated certificate? Should I delete the existing one?
      Thanks for helping out.
       
      Peter
    • By tt33tt
      Hallo alle zusammen,
      ich würde gerne auf eine API von Limesurvey zurückgreifen. Dafür muss ich installieren: https://github.com/weberhofer/jsonrpcphp
      Kann ich in die composer.json einfach so hinzufügen? Ist das mit Froxlor kompatibel?
      Das readme zeigt mir diese beiden Möglichkeiten:
      To install
      composer require weberhofer/jsonrpcphp or add this to your composer.json, and composer update
      { "require": { "weberhofer/jsonrpcphp": "~2" } }
    • By princeofnaxos
      Wenn running "froxlor_master_cronjob.php -- tasks", it produces this error at the end:
      sh: 1: /etc/init.d/php-fpm: not found
      On Debian Stretch with PHP 7.2, this should be "/etc/init.d/php7.2-fpm". Is this a configuration setting? I can't find it.
    • By LukasH
      [Dieses Problem hat sich gelöst, ich hab mich doch tatsächlich verlesen, im Einsatz ist nur die .de, die .com ist nur eine Weiterleitung, klar funktioniert die nicht]
       
      ______________________________________________________________________________
       
      Dann habe ich noch ein weiteres Problem und zwar habe ich eine neue Subdomain angelegt, beim versuch ein SSL Zertifikat zu ziehen kommen nun nur die folgenden Fehlermeldungen:
      [Lets Encrypt self-check] Please check http://www.mail.hoerth.eu/.well-known/acme-challenge/_s_fIpGAblEU_T6A9Iej0RV1Wp-gte-xrTeVRu9naPI - token seems to be not available. This is just a simple self-check, it might be wrong but consider using this information when Let's Encrypt fails to issue a certificate Could not get Let's Encrypt certificate for mail.hoerth.eu: Verification ended with error: {"identifier":{"type":"dns","value":"www.mail.hoerth.eu"},"status":"invalid","expires":"2018-06-15T12:01:38Z","challenges":[{"type":"dns-01","status":"invalid","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/SXa_3IeDJd19Xg3oVtLd0iaj3H2lKBN_fzM1cZPtguc\/5014287643","token":"mOYe0nDwOyTxrfZc83fmpBVeL1vZesbZrV-t_nkRdZ0"},{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:dns","detail":"DNS problem: NXDOMAIN looking up A for www.mail.hoerth.eu","status":400},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/SXa_3IeDJd19Xg3oVtLd0iaj3H2lKBN_fzM1cZPtguc\/5014287644","token":"_s_fIpGAblEU_T6A9Iej0RV1Wp-gte-xrTeVRu9naPI","keyAuthorization":"_s_fIpGAblEU_T6A9Iej0RV1Wp-gte-xrTeVRu9naPI.JriXbK73HFGeqTSIPL3Qg0VCDy2Qt0n4wrUZon9dCEM","validationRecord":[{"url":"http:\/\/www.mail.hoerth.eu\/.well-known\/acme-challenge\/_s_fIpGAblEU_T6A9Iej0RV1Wp-gte-xrTeVRu9naPI","hostname":"www.mail.hoerth.eu","port":"80"}]}],"combinations":[[0],[1]]} Ich habe dann mal nachgesehen und der Token existiert defintiv nicht - klar findet ihn Lets Encrypt also nicht, was ist denn gerade bei mir Los?
    • By jonny87
      Guten Morgen liebe Community,
      ich hab schon gesucht hier, aber nicht wirklich was passendes gefunden, darum mach ich jetzt hier nochmal nen Thread auf. Ich nutz Froxlor nun erfolgreich seit über einem Jahr auf zwei Servern, es funktioniert soweit auch alles mit LetsEncrypt und den Zertifikaten.
      Jetzt hab ich nur folgendes Problem, bzw. ist dies möglich, da ich mehrere Kunden über Froxlor auf zwei Servern verwalte, muss ich natürlich auch E-Mails verwalten, und zwar verschlüsselt. Kann man das über Froxlor machen? Sprich, dass die Kunden ihre Emails über
      imap.kunde1.de & smtp.kunde1.de sowie imap.kunde2.de & smtp.kunde2.de usw. abrufen können. 
      Momentan muss man ja bzw. so hat es mein Admin gemacht, ein Zertifikat für alle hinterlegen, welches auch nicht automatisch per Script geupdatet wird?! -> Ist das so richtig?
      Oder müssen alle Kunden ihre E-Mails per imap.hauptdomain.de abrufen? 
       
       
       
       
       




×
×
  • Create New...