Jump to content
Froxlor Forum
  • 0
Andrew Stafford

Froxlor and Godaddy DNS Setup

Question

Good day, 

First time posting here, I just got Froxlor setup on a hyperV, Debian 9 VM.

It is up and running, got my customers/ domains added. I can't seem to get the domain to cooperate though. 

I use Godaddy to buy and host my domains. What do I need to do on Godaddy and through Froxlor to get my website visible to the public?

I currently tried setting an a record on godaddy with my servers ip.

I changed the name servers in froxlor to those listed by godaddy for my domain.

Am i on the right track or missing it entirely?

Any help would be appreciated!

Thanks, - Andrew 

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 1

Well your domains need to point to your server IP. If you use godaddy and their nameserver you do not need to activate Nameserver related stuff in froxlor

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, d00p said:

Well your domains need to point to your server IP. If you use godaddy and their nameserver you do not need to activate Nameserver related stuff in froxlor

Ok cool, so what do i need to do record wise with godaddy? If i disable the name server stuff in froxlor, what else would need to be done?

Share this post


Link to post
Share on other sites
  • 1

Please test your settings at GoDaddy then, as we cannot know what you've booked with them.

Also please use a shell instead of webtools, if you run and maintain a server these are the basics...

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, d00p said:

Well your domains need to point to your server IP. If you use godaddy and their nameserver you do not need to activate Nameserver related stuff in froxlor

Sorry I'm not near a computer to ping it properly. I'm out snd about on my phone.

Here's the godaddy records.

Share this post


Link to post
Share on other sites
  • 0
26 minutes ago, d00p said:

Please test your settings at GoDaddy then, as we cannot know what you've booked with them.

Also please use a shell instead of webtools, if you run and maintain a server these are the basics...

Records

Last updated 9/21/2018 1:42 AM
A
Name  @
Value  47.201.255.139
Edit
A
Name  *
Value  47.201.255.139
Edit
A
Name  mail
Value  47.201.255.139
Edit
A
Name  ns01.domaincontrol.com
Value  47.201.255.139
Edit
A
Name  ns02.domaincontrol.com
Value  47.201.255.139
Edit
A
Name  www
Value  47.201.255.139
Edit
CNAME
Name  ftp
Value  @
Edit
CNAME
Name  panel
Value  @
Edit
CNAME
Name  _domainconnect
Value _domainconnect.gd.domaincontrol.com
Edit
NS
Name  @
Value  ns01.domaincontrol.com
 
NS
Name  @
Value  ns02.domaincontrol.com
 
SOA
Name  @
Value  Primary nameserver: ns01.domaincontrol.com.

Share this post


Link to post
Share on other sites
  • 1

Well, looks okay. Login to your server and check

#> dig yourdomain.tld A @ns01.domaincontrol.com

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, d00p said:

Well, looks okay. Login to your server and check

#> dig yourdomain.tld A @ns01.domaincontrol.com

Not sure what I am looking at here.
But here is the results of the command.

Thank you so much for your help so far! 

-A

dig results.png

Share this post


Link to post
Share on other sites
  • 0

So I forwarded port 80, which I totally forgot about.

Now when I search "thestafford.company" it shows the "Apache2 Debian Default Page".
Why is my domain not being routed to the site I have created in froxlor?
Doesn't it do this automatically?

Share this post


Link to post
Share on other sites
  • 0

So I got the issues resolved, apparently there is a section in the Panel that required you to go through configuration of the services. I didn't read this anywhere and I had no idea about it. I can now view my pages, however... Now since running the commands in the config section I can no longer connect to the panel to log in anymore.

I made sure it is moved to /var/www/ and not /var/www/html/
I updated it accordingly In the /etc/apache2/sites-enabled/000-default.conf, there I have it pointing to /var/www/

So why does: domain/froxlor/ no longer work?

-A

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, Andrew Stafford said:

So I got the issues resolved, apparently there is a section in the Panel that required you to go through configuration of the services. I didn't read this anywhere and I had no idea about it

Really? Our installation guide says that....

6 hours ago, Andrew Stafford said:

So why does: domain/froxlor/ no longer work

Depends on your settings. Check the generated vhost configs. If you did not let froxlor create its own vhost then you probably can access froxlor only by using http://{your-server-ip-address}/froxlor

 

Share this post


Link to post
Share on other sites
  • -1

Am very much aware lot's of First Timers (include me)  to using FROXLOR end up using one of the Numerous (Uncompleted) Guides out there hence the reason for the numerous issues we they end up having.

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, kingsley ezenwa said:

Am very much aware lot's of First Timers (include me)  to using FROXLOR end up using one of the Numerous (Uncompleted) Guides out there hence the reason for the numerous issues we they end up having.

He clearly said he just did not read out guide...so...

Share this post


Link to post
Share on other sites
  • 0
On 9/22/2018 at 9:17 AM, d00p said:

He clearly said he just did not read out guide...so...

My understanding is that He didn't read the Guide on FROXLOR's page.

Most people i know got to know about FROXLOR via the numerous comparisons done on blogs (most of which are Copy & Paste with little to no modifications).
So they just follow the instruction until the end.

It's when they are unable to make use of things that they keep searching till they find the forum where questions and answers are found.

 

 

My Suggestion : 
A well detailed tutorial/guide can be made and a link placed on the download page in such a well it's easily visible to anyone on that page.
Can't  remember the number of days and all the stress it took me till a member on the chats section sent me a link to a page i had to translate to understand.

And that was the deal breaker .

 

FROXLOR is nice, Neat and uncluttered - major reason i abandoned ISPConfig 3 (UI looks like it was designed before the birth of Abacus) which was working perfectly for me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Sisir Adhikari
      I am slowly & successfully setup my hosting service thanks to Froxlor support. Thanks for that.
      Now after finishing the dns setup from configuration.
      $ /etc/init.d/bind9 start $ [ ok ] Starting bind9 (via systemctl): bind9.service But when I run
      $ systemctl status bind9 Loaded: loaded (/lib/systemd/system/bind9.service; enabled; vendor preset: enabled) Active: failed (Result: exit-code) since Mon 2020-04-27 11:16:33 UTC; 14s ago Docs: man:named(8) Process: 31381 ExecStart=/usr/sbin/named -f $OPTIONS (code=exited, status=1/FAILURE) Main PID: 31381 (code=exited, status=1/FAILURE) Apr 27 11:16:33 server named[31381]: /etc/bind/froxlor_bind.conf:20: zone 'xxxx.net': already exists previous definition: /etc/bind/froxlor_bind.conf:20 Apr 27 11:16:33 server named[31381]: /etc/bind/froxlor_bind.conf:27: zone 'xxxx.me': already exists previous definition: /etc/bind/froxlor_bind.conf:27 Apr 27 11:16:33 server named[31381]: /etc/bind/froxlor_bind.conf:34: zone 'xxxx.ml': already exists previous definition: /etc/bind/froxlor_bind.conf:34 Apr 27 11:16:33 server named[31381]: /etc/bind/froxlor_bind.conf:41: zone 'xxxx.com': already exists previous definition: /etc/bind/froxlor_bind.conf:41 Apr 27 11:16:33 server named[31381]: /etc/bind/froxlor_bind.conf:48: zone 'xxxx.com': already exists previous definition: /etc/bind/froxlor_bind.conf:48 Apr 27 11:16:33 server named[31381]: /etc/bind/froxlor_bind.conf:55: zone 'xxxx.com': already exists previous definition: /etc/bind/froxlor_bind.conf:55 Apr 27 11:16:33 server named[31381]: loading configuration: failure Apr 27 11:16:33 server named[31381]: exiting (due to fatal error) Apr 27 11:16:33 server systemd[1]: bind9.service: Main process exited, code=exited, status=1/FAILURE Apr 27 11:16:33 server systemd[1]: bind9.service: Failed with result 'exit-code'. .All of the domains are active they are not deleted. One of them are not DNS forwarded to my server (if that is important).
       
    • By Pro-Webs
      Hallo,
      ich bin gerade dabei einen Shopware Shop v.5 unter nginx mit froxlor einzurichten.
      Das ist jedoch relativ problematisch.
      Aktuell habe ich im Froxlor folgende vHost Einstellung zur Domain:
      location @php { fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location / { index index.html index.php shopware.php; rewrite shopware.dll /shopware.php; rewrite files/documents/.* /engine last; #rewrite images/ayww/(.*) /images/banner/$1 last; rewrite backend/media/(.*) /media/$1 last; if (!-e $request_filename){ rewrite . /shopware.php last; } location ~ \.(jpe?g|png|gif|css|js)$ { rewrite backend/media/(.*) /media/$1 last; expires 1M; } } location ~ \.(tpl|yml|ini)$ { deny all; } location /install/ { location /install/assets { } if (!-e $request_filename){ rewrite . /install/index.php last; } } location /update/ { location /update/assets { } location /update/templates { } if (!-e $request_filename){ rewrite . /update/index.php last; } } location /recovery/install/ { location /recovery/install/assets { } if (!-e $request_filename){ rewrite . /recovery/install/index.php last; } } location /recovery/update/ { location /recovery/update/assets { } if (!-e $request_filename){ rewrite . /recovery/update/index.php last; } } location ~ ^/(logs|media/temp|bin|cache)/ { deny all; } location ~ \.php$ { try_files $uri =404; include /etc/nginx/fastcgi_params; fastcgi_pass 127.0.0.1:9000; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param HTTPS $fastcgi_https; fastcgi_param HTTP_AUTHORIZATION $http_authorization; } Diese Einstellung führt zu einem 500 error.
      Meine 35_froxlor_ssl_vhost_studio-ausruestung.de.conf sieht damit leider wie folgt aus:
      # 35_froxlor_ssl_vhost_studio-ausruestung.de.conf # Created 02.01.2020 14:30 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen 91.250.82.51:443 ssl; server_name studio-ausruestung.de www.studio-ausruestung.de xn--studio-ausrstung-tzb.de *.xn--studio-ausrstung-tzb.de studioausruestung.de *.studioausruestung.de priolite-shop.com www.priolite-shop.com sirui-shop.de www.sirui-shop.de shooting-gutschein.de *.shooting-gutschein.de shooting-gutscheine.de *.shooting-gutscheine.de; ssl_protocols TLSv1 TLSv1.2; ssl_ciphers ECDHE-RSA-AES128-SHA256:AES128-GCM-SHA256:RC4:HIGH:!MD5:!aNULL:!EDH; ssl_ecdh_curve secp384r1; ssl_prefer_server_ciphers on; ssl_certificate /etc/ssl/froxlor-custom/studio-ausruestung.de.crt; ssl_certificate_key /etc/ssl/froxlor-custom/studio-ausruestung.de.key; add_header Strict-Transport-Security "max-age=0"; ssl_stapling on; ssl_stapling_verify on; ssl_trusted_certificate /etc/ssl/froxlor-custom/studio-ausruestung.de.crt; include /etc/apache2/conf-enabled/acme.conf; access_log /var/customers/logs/klimek-studio-ausruestung.de-access.log combined; error_log /var/customers/logs/klimek-studio-ausruestung.de-error.log error; root /var/customers/webs/klimek/studio-ausruestung.de/shopware/; location / { index index.php index.html index.htm; try_files $uri $uri/ @rewrites; index index.html index.php shopware.php; rewrite shopware.dll /shopware.php; rewrite files/documents/.* /engine last; #rewrite images/ayww/(.*) /images/banner/$1 last; rewrite backend/media/(.*) /media/$1 last; if (!-e $request_filename){ rewrite . /shopware.php last; } location ~ \.(jpe?g|png|gif|css|js)$ { rewrite backend/media/(.*) /media/$1 last; expires 1M; } } location @rewrites { rewrite ^ /index.php last; } location /webalizer { alias /var/customers/webs/klimek/webalizer/studio-ausruestung.de/; auth_basic "Restricted Area"; auth_basic_user_file /etc/nginx/htpasswd/1-c3d3ffdab2b8342809d19524c21b98c1.htpasswd; } location ~ \.php { try_files /333c3697df6a41bcc37bccd05271f644.htm @php; } location @php { fastcgi_split_path_info ^(.+\.php)(/.+)$; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param PATH_INFO $fastcgi_path_info; try_files $fastcgi_script_name =404; fastcgi_index index.php; fastcgi_param HTTPS on; fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location ~ \.(tpl|yml|ini)$ { deny all; } location /install/ { location /install/assets { } if (!-e $request_filename){ rewrite . /install/index.php last; } } location /update/ { location /update/assets { } location /update/templates { } if (!-e $request_filename){ rewrite . /update/index.php last; } } location /recovery/install/ { location /recovery/install/assets { } if (!-e $request_filename){ rewrite . /recovery/install/index.php last; } } location /recovery/update/ { location /recovery/update/assets { } if (!-e $request_filename){ rewrite . /recovery/update/index.php last; } } location ~ ^/(logs|media/temp|bin|cache)/ { deny all; } } Man bemerkt u.a. das einige Konfigurationen doppelt vorhanden sind, da floxlor diese auch selbst generiert. Das könnte natürlich schon die Ursache des Fehler sein. Ich weiß nur leider nicht, wie ich es "besser" lösen kann.
      Die original .htaccess für den appache sieht folgende Konfiguration vor:
      php_value memory_limit 1024M php_value max_execution_time 600 php_value upload_max_filesize 20M php_value post_max_size 20M <IfModule mod_rewrite.c> RewriteEngine on #RewriteBase /shopware/ # Https config for the backend #RewriteCond %{HTTPS} !=on #RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] RewriteRule shopware.dll shopware.php RewriteRule files/documents/.* engine [NC,L] RewriteRule backend/media/(.*) media/$1 [NC,L] RewriteRule custom/.*(config|menu|services|plugin)\.xml$ ./shopware.php?controller=Error&action=pageNotFoundError [NC,L] RewriteCond %{REQUEST_URI} !(\/(engine|files|templates|themes|web)\/) RewriteCond %{REQUEST_URI} !(\/media\/(archive|banner|image|music|pdf|unknown|video)\/) RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ shopware.php [PT,L,QSA] # Fix missing authorization-header on fast_cgi installations RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L] </IfModule> <IfModule mod_alias.c> # Restrict access to VCS directories RedirectMatch 404 /\\.(svn|git|hg|bzr|cvs)(/|$) # Restrict access to root folder files RedirectMatch 404 /(autoload\.php|composer\.(json|lock|phar)|README\.md|UPGRADE-(.*)\.md|CONTRIBUTING\.md|eula.*\.txt|\.gitignore|.*\.dist|\.env.*)$ # Restrict access to shop configs files RedirectMatch 404 /(web\/cache\/(config_\d+\.json|all.less))$ # Restrict access to theme configurations RedirectMatch 404 /themes/(.*)(.*\.lock|package\.json|\.gitignore|Gruntfile\.js|all\.less|node_modules\/.*)$ </IfModule> # Staging environment #SetEnvIf Host "staging.test.shopware.in" SHOPWARE_ENV=staging # Development environment #SetEnvIf Host "dev.shopware.in" SHOPWARE_ENV=dev #SetEnv SHOPWARE_ENV dev DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php # Disables download of configuration <Files ~ "\.(tpl|yml|ini)$"> # Deny all requests from Apache 2.4+. <IfModule mod_authz_core.c> Require all denied </IfModule> # Deny all requests from Apache 2.0-2.2. <IfModule !mod_authz_core.c> Deny from all </IfModule> </Files> # Enable gzip compression <IfModule mod_deflate.c> AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/javascript application/json application/font-woff application/font-woff2 image/svg+xml </IfModule> <Files ~ "\.(jpe?g|png|gif|css|js|woff|woff2|ttf|svg|webp|eot|ico)$"> <IfModule mod_expires.c> ExpiresActive on ExpiresDefault "access plus 1 month" </IfModule> <IfModule mod_headers.c> Header append Cache-Control "public" Header unset ETag </IfModule> FileETag None </Files> # Match generated files like: # 1429684458_t22_s1.css # 1429684458_t22_s1.js <FilesMatch "([0-9]{10})_(.+)\.(js|css)$"> <ifModule mod_headers.c> Header set Cache-Control "max-age=31536000, public" </ifModule> <IfModule mod_expires.c> ExpiresActive on ExpiresDefault "access plus 1 year" </IfModule> </FilesMatch> # Disables auto directory index <IfModule mod_autoindex.c> Options -Indexes </IfModule> <IfModule mod_negotiation.c> Options -MultiViews </IfModule> <IfModule mod_php5.c> # php_value memory_limit 256M # php_value max_execution_time 120 # php_value upload_max_filesize 20M php_flag phar.readonly off php_flag magic_quotes_gpc off php_flag session.auto_start off php_flag suhosin.session.cryptua off php_flag zend.ze1_compatibility_mode off php_value always_populate_raw_post_data -1 </IfModule> # AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php <IfModule mod_headers.c> Header append X-Frame-Options SAMEORIGIN </IfModule>  
      Für Ideen und Vorschläge wäre ich wie immer sehr dankbar
    • By nisamudeen97
      Hi,
      Our froxlor server is behiend NAT and it uses the local IP  192.168.73.40.  We have enabled letsencrypt module in froxlor and tried validating SSL for a domain in the server.  SSL generation is getting failed with 403 error.  See the debug log information.      Replaced domain name and main IP.    Can any one help me regarding the issue.
       
      [information] Updating Let's Encrypt certificates [information] Updating domain-name.com [information] Adding SAN entry: domain-name.com [information] Adding SAN entry: www.domain-name.com [information] letsencrypt-v2 Using 'https://acme-v02.api.letsencrypt.org' to generate certificate [information] letsencrypt-v2 Using existing account key [information] letsencrypt-v2 Starting certificate generation process for domains [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/new-order [information] letsencrypt-v2 Requesting challenge for domain-name.com [information] letsencrypt-v2 Got challenge token for domain-name.com [information] letsencrypt-v2 Token for domain-name.com saved at /var/www/froxlor/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k and should be available at http://domain-name.com/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [information] letsencrypt-v2 Sending request to challenge [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/chall-v3/803008408/k46kFQ [information] letsencrypt-v2 Verification pending, sleeping 1s [information] letsencrypt-v2 Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for domain-name.com: Verification ended with error: {"type":"http-01","status":"invalid","error":{"type":"urn:ietf:params:acme:error:unauthorized","detail":"Invalid response from http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [212.224.xxx.xxx]: \"<!DOCTYPE html>\\n<html lang=\\\"en-CA\\\" class=\\\"html_stretched responsive av-preloader-active av-preloader-enabled av-default-lightbox\"","status":403},"url":"https:\/\/acme-v02.api.letsencrypt.org\/acme\/chall-v3\/803008408\/k46kFQ","token":"vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","validationRecord":[{"url":"http:\/\/www.domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"www.domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"},{"url":"http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"}]} [information] Let's Encrypt certificates have been updated  
    • By Jason Szymanski
      Hallo,
       
      ich habe leider ein Problem mit Froxlor.
      Zu meiner Situation: Froxlor läuft auf der Subdomain web01.meinedomain.net
      Jetzt möchte ich die Domain aber auch noch weiter Nutzen und habe mich daher als Kunde angelegt und die Domain meineDomain.net als Domain hinzugefügt.
      Dort kann ich auch weitere Subdomains hinzufügen. Das scheint soweit auch zu klappen ich sehe das er VHosts anlegt und auch die Verzeichnisse im FTP anlegt.
      Wenn ich jetzt allerdings versuche auf meinedomain.net oder eine andere Subdomain unter dieser Domain zuzugreifen leitet er mich auf web01.meinedomain.net
      Ich habe mich schon in den Einstellungen umgeschaut konnte aber keine entsprechende Einstellung finden an der das liegen könnte.
      Wie verhindere ich also das er mich auf Froxlor umleitet?
       
      Mit Freundlichen Grüßen
      Jason Szymanski
    • By nisamudeen97
      Hi,
      Wile doing migration of email accounts from one froxlor server to another I have noting some thing.   Expecting some clarification on this.  As we all know emails are normally stored in the location "/var/customers/mail/user/domain.com/user/Maildir/" .   I create email accounts via froxlor panel and copy the email files directly via scp or rsync from old server to new.  The strange thing I have noticed is it is not coping custom folders and its emails like we have in source.  
      The solution I have found for this is to use imapsync between old and new.  imapsync is preserving custom folders like as it is in source.    Does it mean custom folder settings are stored somewhere else?  How we can preserve it and copy emails manually?
×
×
  • Create New...