Jump to content
Froxlor Forum

Question

Ich hab mal wieder ein Problem bzw. einen Fehler mit unguten Auswirkungen begangen und bekomme es nicht mehr gerade gebügelt.

Und zwar habe ich nach anfänglichem Testen mittlerweile auch mein privates Mailkonto auf einen neuen Server mit Froxlor gezogen.

Ich hatte wie erwähnt bereits vorher einen Umzug mit Website, daher auch Datenbanken so wie Mailadressen erfolgreich durchgeführt. Der Umzug lief auch relativ glatt und auch meine privaten Mails liegen auf dem neuen Server, senden funktioniert, alle Websites sind via https erreichbar (Letsencrypt Zertifikate erfolgreich gezogen) und alles könnte eigentlich besser nicht sein. 

Nun kann ich mich allerdings von Extern nicht mehr am smtp Server anmelden mit meiner privaten Mail-Adresse. Und zwar wollte ich in meiner noch Unwissenheit (das ist mein erstes "eigenes" Serverprojekt, meine ersten Server wurden durch andere eingerichtet und ich habe nur zugekuckt/mitgeschrieben) SSL Zertifikate für den Mailserver bekommen, Outlook hat nämlich die überaus nervige Angewohnheit bei jedem Start Zertifikatsfehlermeldungen auszugeben (bei Selbstsignierten) und auch das Speichern in den vertrauenswürdigen Zertifikatsspeicher von Windows bringt hier scheinbar keine Lösung.

Nun dachte ich, ist ja einfach, einfach in Froxlor für jede Domain welche auch Mailadressen hat noch die Subdomain "mail.*" und "smtp.*" anlegen, LetsEncrypt anschmeißen und fertig, den Verweis stelle ich einfach auf den Ordner in welchem der Webmailer liegt. Soweit so gut, nun hat er hier allerdings keine Zertifikate gezogen sondern nur am laufenden meter PHP Errors ausgegeben. Diese hatte ich vorher immer wenn der PHP Flag für eine Domain nicht richtig gesetzt war, also mit dem admin in Froxlor eingelogt, Domain aufgerufen und gespeichert und... nichts. Gleicher Fehler. PHP Funktioniert (Webmailer wird korrekt aufgerufen) nur werden keine Zertifikate gezogen. 

Also wollte ich erst einmal alles rückgängig machen und habe alle Subdomains (mail.* & smtp.*) wieder gelöscht. So und nun habe ich den Salat, seltsamerweise kann noch sämtliche Mailkonten von extern ansteuern, auch den jeweiligen smtp nur bei meiner privaten Mailadresse mit eigener Domain geht es nicht, auch nicht mehr bei der meiner Frau mit gleicher Domain. Outlook fragt nach den SMTP Zugangsdaten und nimmt Mailadresse + Passwort nicht, Thunderbird sagt er findet das Passwort nicht, iPhone & Android bringen ebenfalls diese Fehler. 

ALLE anderen Domains bzw. verbundenen Mailkonten funktionieren (bis auf den Punkt mit dem Zertifikatsfehler) problemlos. Nur die meiner Hauptdomain nicht. 

Das ganz komische ist aber, dass mein Webmailer noch ganz normal Empfangen und vor allem auch Senden kann, dieser erreicht den SMTP Server ohne Probleme und hat auch keine Login Probleme. 

Ports sind Frei in der Windows eigenen Firewall, Ping an smtp.* geht problemlos durch, ich habe auch keinen Speedport mit vertrauenswürdiger E-Mail Liste sondern eine Fritz!Box. Bis vor 2 Stunden lief auch noch alles. Und ganz kurios ist auch, dass Outlook den smtp Server bei einer anderen Domain auf "smtpauth.*" geändert hat, Thunderbird geht allerdings via "smtp.*" ran. 

Nun noch Screenshots von meinem Webmailer (Rainloop) und der dort voll funktionalen Konfiguration welche aber von Extern (egal ob mein Heimnetz (Unitymedia) oder Handynetz (Telekom & O2)) nicht laufen will:

5a54e4b3305de_2018-01-0916_11_03-Hoerth.euWebmail.png.bd663ed200b63f54657d9c13ce4a2184.png

5a54e4b5daa11_2018-01-0916_12_37-Hoerth.euWebmail.png.a12f4f27e80af84af7aa1b12aa4fb891.png

5a54e4b4f0b48_2018-01-0916_12_04-Kontondern.png.6b3b7180983cf61579319e8234827818.png

5a54e4b6d8f08_2018-01-0916_13_08-Internet-E-Mail-Einstellungen.png.93d96bdcea477ea99c09839fd60d05ec.png

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Zum Einen: smtp.* oder mail.* mit Zertifikat austatten bringt nix, du verbindest dich mit einem Hostname zu einem Server (postfix, dovecot), dieser hat in seiner Konfiguration, wenn korrekt, ein Zertifikat hinterlegt, welches für EINEN (system)hostnamen gültig ist (siehe z.B. postfix/main.cf -> mydomain) - DIESE Domain musst du natürlich im Mail-Client als Servername eintragen, sonst ist das Zertifikat nicht valide. In Standard-Froxlor Config ist hier auch der SMTP nicht unterschiedlich zum IMAP/POP3 Server  (wie in deinem Screenshot zu sehen)

Ansonsten: logs logs logs logs, viel text ist fein, aber hilft nur bedingt

Share this post


Link to post
Share on other sites
  • 0

okidoki, folgendes aus /var/log/mail.log 

Versuch das Konto in Outlook einzubinden: 

Jan  9 17:13:27 hoerth dovecot: imap-login: Login: user=<lukas@hoerth.eu>, method=PLAIN, rip=46.5.2.163, lip=185.16.61.72, mpid=2038, TLS, session=<96HkMVpikgAuBQKj>
Jan  9 17:13:27 hoerth dovecot: imap-login: Login: user=<lukas@hoerth.eu>, method=PLAIN, rip=46.5.2.163, lip=185.16.61.72, mpid=2039, TLS, session=<Mu/kMVpikQAuBQKj>
Jan  9 17:13:27 hoerth dovecot: imap(lukas@hoerth.eu): Disconnected: Disconnected in IDLE in=11 out=372
Jan  9 17:13:32 hoerth dovecot: imap-login: Login: user=<lukas@hoerth.eu>, method=PLAIN, rip=46.5.2.163, lip=185.16.61.72, mpid=2041, TLS, session=<21syMlpi9gAuBQKj>
Jan  9 17:13:33 hoerth dovecot: imap(lukas@hoerth.eu): Disconnected: Disconnected in IDLE in=771 out=2811
Jan  9 17:14:09 hoerth dovecot: imap(lukas@hoerth.eu): Disconnected: Logged out in=2266 out=20605

(Abbruch durch Fehlermeldung in Outlook)

Versuch über Thunderbird, wo das Konto immerhin via IMAP abrufbar ist aber eben beim senden auch der SMTP Fehler kommt, eine Mail zu senden:

Jan  9 17:17:23 hoerth dovecot: imap-login: Login: user=<lukas@hoerth.eu>, method=PLAIN, rip=46.5.2.163, lip=185.16.61.72, mpid=2105, TLS, session=<SDP8P1pivgAuBQKj>

Senden einer Mail von einer der problemlos funktionierenden Adressen:

Jan  9 17:23:55 hoerth postfix/smtpd[2179]: connect from HSI-KBW-046-005-002-163.hsi8.kabel-badenwuerttemberg.de[46.5.2.163]
Jan  9 17:23:55 hoerth postfix/smtpd[2179]: Anonymous TLS connection established from hsi-kbw-046-005-002-163.hsi8.kabel-badenwuerttemberg.de[46.5.2.163]: TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)
Jan  9 17:23:55 hoerth postfix/smtpd[2179]: 43B6A4021A: client=HSI-KBW-046-005-002-163.hsi8.kabel-badenwuerttemberg.de[46.5.2.163], sasl_method=LOGIN, sasl_username=trash@eqcp.de
Jan  9 17:23:55 hoerth postfix/cleanup[2188]: 43B6A4021A: message-id=<008401d38966$3f65c4e0$be314ea0$@eqcp.de>
Jan  9 17:23:55 hoerth postfix/qmgr[1112]: 43B6A4021A: from=<trash@eqcp.de>, size=2874, nrcpt=1 (queue active)
Jan  9 17:23:55 hoerth postfix/smtp[2190]: 43B6A4021A: to=<surishy@gmail.com>, relay=gmail-smtp-in.l.google.com[74.125.133.26]:25, delay=0.66, delays=0.09/0.01/0.13/0.44, dsn=2.0.0, status=sent (250 2.0.0 OK 1515515035 l127si9774962wmb.$
Jan  9 17:23:55 hoerth postfix/qmgr[1112]: 43B6A4021A: removed
Jan  9 17:23:56 hoerth dovecot: imap-login: Login: user=<trash@eqcp.de>, method=PLAIN, rip=46.5.2.163, lip=185.16.61.72, mpid=2193, TLS, session=<p+NoV1piAAAuBQKj>
Jan  9 17:23:57 hoerth postfix/smtpd[2179]: disconnect from HSI-KBW-046-005-002-163.hsi8.kabel-badenwuerttemberg.de[46.5.2.163]

Share this post


Link to post
Share on other sites
  • 0

Und der Fehler hat sich auch schon wieder erledigt. 

Ein neustart des Postfix und es funktioniert wieder alles, entschuldigt daher den Thread! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Michael Groß
      Hallo zusammen,
      ich kämpfe momentan mit der SSL Konfiguration von meinem Froxlor-Server.
      Bedauerlicherweise befindet sich der Webserver hinter einer Firewall und hat eine private IP Adresse zugewiesen bekommen. 
      Die Firewall leitet entsprechend den Traffic von außerhalb auf den Server weiter (HTTP ist das alles kein Problem).
      Nun habe ich vorhin SSL aktivieren wollen und hierzu kann ich leider keine private IP Adresse eintragen (lässt Froxlor nicht zu).
      Entsprechend habe ich die public IP eingetragen, was aber auch nicht funktioniert, da durch das NAT der Firewall die private IP angesprochen wird - somit funktioniert dies nicht.
      Habt ihr eine Idee, wie man das umbauen kann?
      An sich brauche ich nur die private IP Adresse als SSL Adresse eintragen - vermute aber, dass dadurch Let's Encrypt auch nicht mehr richtig laufen wird.
      Viele Grüße
      Michael
      PS: Ein 1:1 NAT wäre noch eine Möglichkeit, da ich die Public IP aber für diverse Server verwende, fällt das auch raus. Müsste dann eine neue Public IP kaufen, welche ich dann mit einem 1:1 NAT auf den Webserver laufen lasse (wäre noch eine Möglichkeit)
    • By mrairstone
      Guten Morgen,
      mir ist in Froxlor ein kleiner Fehler in Bezug auf CatchAll Email aufgefallen.
      Zum System:
      Debian 10, 64-Bit Froxlor 0.10.11 Postfix, Dovecot, Spamc Zum Problem:
      Beim Anlegen einer neuen E-Mailadresse kann man je Domain nur eine CatchAll-Adresse definieren. Wenn man jedoch eine bestehende E-Mailadresse bearbeitet, kann man dort ganz einfach auf CatchAll umschalten.
      Dadurch kann es passieren, dass mehrere Emailadressen unterhalb einer Domain als CatchAll definiert sind. Das ist mir erst aufgefallen, als ich E-Mails in meinem Postfach hatte, welche nicht für meine E-Mailadresse bestimmt waren.
      Da auf dem Account in Froxlor mehrer Nutzer zugreifen (Feuerwehr) und E-Mailadressen hinzufügen, ändern und auch löschen - habe ich erst sehr spät gesehen das mehrere CatchAll vorhanden waren.
      Wenn man eine Mail an eine E-Mailadresse sendet, welche als CatchAll definiert wurde, wird die Mail auch an alle anderen E-Mailadressen weitergeleitet, die unterhalb der Domain als CatchAll definiert sind.(Jedenfalls bei postfix)
      Temporäre Lösung:
      Damit eingehende Mails an eine vorhandene E-Mailadresse, welche als CatchAll definiert ist, auch nur im Postfach dieser E-Mailadresse landen, habe ich die SQL-Anweisung in der "mysql-virtual_alias_maps.cf" wie folgt abgeändert:
      query = SELECT destination FROM mail_virtual AS v, panel_customers AS c WHERE c.customerid = v.customerid AND c.deactivated = 0 AND (v.email = '%s' OR v.email_full = '%s') AND trim(v.destination) <> '' Ich habe das eben auch noch einmal in der Demoversion ausprobiert, Screenshot im Anhang.
       
      Gruß

    • By Pro-Webs
      Hallo,
      ich bin gerade dabei einen Shopware Shop v.5 unter nginx mit froxlor einzurichten.
      Das ist jedoch relativ problematisch.
      Aktuell habe ich im Froxlor folgende vHost Einstellung zur Domain:
      location @php { fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location / { index index.html index.php shopware.php; rewrite shopware.dll /shopware.php; rewrite files/documents/.* /engine last; #rewrite images/ayww/(.*) /images/banner/$1 last; rewrite backend/media/(.*) /media/$1 last; if (!-e $request_filename){ rewrite . /shopware.php last; } location ~ \.(jpe?g|png|gif|css|js)$ { rewrite backend/media/(.*) /media/$1 last; expires 1M; } } location ~ \.(tpl|yml|ini)$ { deny all; } location /install/ { location /install/assets { } if (!-e $request_filename){ rewrite . /install/index.php last; } } location /update/ { location /update/assets { } location /update/templates { } if (!-e $request_filename){ rewrite . /update/index.php last; } } location /recovery/install/ { location /recovery/install/assets { } if (!-e $request_filename){ rewrite . /recovery/install/index.php last; } } location /recovery/update/ { location /recovery/update/assets { } if (!-e $request_filename){ rewrite . /recovery/update/index.php last; } } location ~ ^/(logs|media/temp|bin|cache)/ { deny all; } location ~ \.php$ { try_files $uri =404; include /etc/nginx/fastcgi_params; fastcgi_pass 127.0.0.1:9000; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param HTTPS $fastcgi_https; fastcgi_param HTTP_AUTHORIZATION $http_authorization; } Diese Einstellung führt zu einem 500 error.
      Meine 35_froxlor_ssl_vhost_studio-ausruestung.de.conf sieht damit leider wie folgt aus:
      # 35_froxlor_ssl_vhost_studio-ausruestung.de.conf # Created 02.01.2020 14:30 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen 91.250.82.51:443 ssl; server_name studio-ausruestung.de www.studio-ausruestung.de xn--studio-ausrstung-tzb.de *.xn--studio-ausrstung-tzb.de studioausruestung.de *.studioausruestung.de priolite-shop.com www.priolite-shop.com sirui-shop.de www.sirui-shop.de shooting-gutschein.de *.shooting-gutschein.de shooting-gutscheine.de *.shooting-gutscheine.de; ssl_protocols TLSv1 TLSv1.2; ssl_ciphers ECDHE-RSA-AES128-SHA256:AES128-GCM-SHA256:RC4:HIGH:!MD5:!aNULL:!EDH; ssl_ecdh_curve secp384r1; ssl_prefer_server_ciphers on; ssl_certificate /etc/ssl/froxlor-custom/studio-ausruestung.de.crt; ssl_certificate_key /etc/ssl/froxlor-custom/studio-ausruestung.de.key; add_header Strict-Transport-Security "max-age=0"; ssl_stapling on; ssl_stapling_verify on; ssl_trusted_certificate /etc/ssl/froxlor-custom/studio-ausruestung.de.crt; include /etc/apache2/conf-enabled/acme.conf; access_log /var/customers/logs/klimek-studio-ausruestung.de-access.log combined; error_log /var/customers/logs/klimek-studio-ausruestung.de-error.log error; root /var/customers/webs/klimek/studio-ausruestung.de/shopware/; location / { index index.php index.html index.htm; try_files $uri $uri/ @rewrites; index index.html index.php shopware.php; rewrite shopware.dll /shopware.php; rewrite files/documents/.* /engine last; #rewrite images/ayww/(.*) /images/banner/$1 last; rewrite backend/media/(.*) /media/$1 last; if (!-e $request_filename){ rewrite . /shopware.php last; } location ~ \.(jpe?g|png|gif|css|js)$ { rewrite backend/media/(.*) /media/$1 last; expires 1M; } } location @rewrites { rewrite ^ /index.php last; } location /webalizer { alias /var/customers/webs/klimek/webalizer/studio-ausruestung.de/; auth_basic "Restricted Area"; auth_basic_user_file /etc/nginx/htpasswd/1-c3d3ffdab2b8342809d19524c21b98c1.htpasswd; } location ~ \.php { try_files /333c3697df6a41bcc37bccd05271f644.htm @php; } location @php { fastcgi_split_path_info ^(.+\.php)(/.+)$; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param PATH_INFO $fastcgi_path_info; try_files $fastcgi_script_name =404; fastcgi_index index.php; fastcgi_param HTTPS on; fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location ~ \.(tpl|yml|ini)$ { deny all; } location /install/ { location /install/assets { } if (!-e $request_filename){ rewrite . /install/index.php last; } } location /update/ { location /update/assets { } location /update/templates { } if (!-e $request_filename){ rewrite . /update/index.php last; } } location /recovery/install/ { location /recovery/install/assets { } if (!-e $request_filename){ rewrite . /recovery/install/index.php last; } } location /recovery/update/ { location /recovery/update/assets { } if (!-e $request_filename){ rewrite . /recovery/update/index.php last; } } location ~ ^/(logs|media/temp|bin|cache)/ { deny all; } } Man bemerkt u.a. das einige Konfigurationen doppelt vorhanden sind, da floxlor diese auch selbst generiert. Das könnte natürlich schon die Ursache des Fehler sein. Ich weiß nur leider nicht, wie ich es "besser" lösen kann.
      Die original .htaccess für den appache sieht folgende Konfiguration vor:
      php_value memory_limit 1024M php_value max_execution_time 600 php_value upload_max_filesize 20M php_value post_max_size 20M <IfModule mod_rewrite.c> RewriteEngine on #RewriteBase /shopware/ # Https config for the backend #RewriteCond %{HTTPS} !=on #RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] RewriteRule shopware.dll shopware.php RewriteRule files/documents/.* engine [NC,L] RewriteRule backend/media/(.*) media/$1 [NC,L] RewriteRule custom/.*(config|menu|services|plugin)\.xml$ ./shopware.php?controller=Error&action=pageNotFoundError [NC,L] RewriteCond %{REQUEST_URI} !(\/(engine|files|templates|themes|web)\/) RewriteCond %{REQUEST_URI} !(\/media\/(archive|banner|image|music|pdf|unknown|video)\/) RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ shopware.php [PT,L,QSA] # Fix missing authorization-header on fast_cgi installations RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L] </IfModule> <IfModule mod_alias.c> # Restrict access to VCS directories RedirectMatch 404 /\\.(svn|git|hg|bzr|cvs)(/|$) # Restrict access to root folder files RedirectMatch 404 /(autoload\.php|composer\.(json|lock|phar)|README\.md|UPGRADE-(.*)\.md|CONTRIBUTING\.md|eula.*\.txt|\.gitignore|.*\.dist|\.env.*)$ # Restrict access to shop configs files RedirectMatch 404 /(web\/cache\/(config_\d+\.json|all.less))$ # Restrict access to theme configurations RedirectMatch 404 /themes/(.*)(.*\.lock|package\.json|\.gitignore|Gruntfile\.js|all\.less|node_modules\/.*)$ </IfModule> # Staging environment #SetEnvIf Host "staging.test.shopware.in" SHOPWARE_ENV=staging # Development environment #SetEnvIf Host "dev.shopware.in" SHOPWARE_ENV=dev #SetEnv SHOPWARE_ENV dev DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php # Disables download of configuration <Files ~ "\.(tpl|yml|ini)$"> # Deny all requests from Apache 2.4+. <IfModule mod_authz_core.c> Require all denied </IfModule> # Deny all requests from Apache 2.0-2.2. <IfModule !mod_authz_core.c> Deny from all </IfModule> </Files> # Enable gzip compression <IfModule mod_deflate.c> AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/javascript application/json application/font-woff application/font-woff2 image/svg+xml </IfModule> <Files ~ "\.(jpe?g|png|gif|css|js|woff|woff2|ttf|svg|webp|eot|ico)$"> <IfModule mod_expires.c> ExpiresActive on ExpiresDefault "access plus 1 month" </IfModule> <IfModule mod_headers.c> Header append Cache-Control "public" Header unset ETag </IfModule> FileETag None </Files> # Match generated files like: # 1429684458_t22_s1.css # 1429684458_t22_s1.js <FilesMatch "([0-9]{10})_(.+)\.(js|css)$"> <ifModule mod_headers.c> Header set Cache-Control "max-age=31536000, public" </ifModule> <IfModule mod_expires.c> ExpiresActive on ExpiresDefault "access plus 1 year" </IfModule> </FilesMatch> # Disables auto directory index <IfModule mod_autoindex.c> Options -Indexes </IfModule> <IfModule mod_negotiation.c> Options -MultiViews </IfModule> <IfModule mod_php5.c> # php_value memory_limit 256M # php_value max_execution_time 120 # php_value upload_max_filesize 20M php_flag phar.readonly off php_flag magic_quotes_gpc off php_flag session.auto_start off php_flag suhosin.session.cryptua off php_flag zend.ze1_compatibility_mode off php_value always_populate_raw_post_data -1 </IfModule> # AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php <IfModule mod_headers.c> Header append X-Frame-Options SAMEORIGIN </IfModule>  
      Für Ideen und Vorschläge wäre ich wie immer sehr dankbar
    • By thunfischbaum
      Hi everyone,
      just a little problem here. I have severa domains registered on my froxlor installation and a different hostname of course. So let's say domain1.de is my hostname. The second domain, which is used by a customer is called domain2.de . When I view the mail.log I am not able to find my connection request. I do only see the bruteforce bots with example@domain1.de connecting. But any example@domain2.de request is not getting forwareded. I did configure the installation accordingdly with the provided templates.
      Best regards,
      thunfischbaum
    • By nisamudeen97
      Hi,
      Our froxlor server is behiend NAT and it uses the local IP  192.168.73.40.  We have enabled letsencrypt module in froxlor and tried validating SSL for a domain in the server.  SSL generation is getting failed with 403 error.  See the debug log information.      Replaced domain name and main IP.    Can any one help me regarding the issue.
       
      [information] Updating Let's Encrypt certificates [information] Updating domain-name.com [information] Adding SAN entry: domain-name.com [information] Adding SAN entry: www.domain-name.com [information] letsencrypt-v2 Using 'https://acme-v02.api.letsencrypt.org' to generate certificate [information] letsencrypt-v2 Using existing account key [information] letsencrypt-v2 Starting certificate generation process for domains [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/new-order [information] letsencrypt-v2 Requesting challenge for domain-name.com [information] letsencrypt-v2 Got challenge token for domain-name.com [information] letsencrypt-v2 Token for domain-name.com saved at /var/www/froxlor/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k and should be available at http://domain-name.com/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [information] letsencrypt-v2 Sending request to challenge [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/chall-v3/803008408/k46kFQ [information] letsencrypt-v2 Verification pending, sleeping 1s [information] letsencrypt-v2 Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for domain-name.com: Verification ended with error: {"type":"http-01","status":"invalid","error":{"type":"urn:ietf:params:acme:error:unauthorized","detail":"Invalid response from http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [212.224.xxx.xxx]: \"<!DOCTYPE html>\\n<html lang=\\\"en-CA\\\" class=\\\"html_stretched responsive av-preloader-active av-preloader-enabled av-default-lightbox\"","status":403},"url":"https:\/\/acme-v02.api.letsencrypt.org\/acme\/chall-v3\/803008408\/k46kFQ","token":"vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","validationRecord":[{"url":"http:\/\/www.domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"www.domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"},{"url":"http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"}]} [information] Let's Encrypt certificates have been updated  
×
×
  • Create New...