Jump to content
Froxlor Forum
  • 0
Leguz

Probleme mit PHP FCGID

Question

Hallo Zusammen

Habe folgendes problem.
Da ich 3 verschiedene webverzeichnise habe und 2 nur mit php7 laufen und das andere nur mit php 5.6 habe ich versucht dieses problem mit FCGID zu lösen.

erstmal zu meinem einstellungen des Servers.

Debain 64 bit Jessie

Froxlor installation unter /var/www/froxlor/

Installierte Version:

0.9.38.7 (DB: 201612110)

PHP 5.6 sowie php7.0 installiert mit allen notwenidgen zusätze.
Der Server würde dann mit :

a2dismod php5
a2enmod php7.0
service apache2 restart

Auf PHP7 umgestellt.

Nun habe ich nach der Anleitung für FCGID gehalten und durchgeführt.


Unbenannt1.thumb.PNG.38d2b2dfe307e1d392d411af9381c5ae.PNG

Unbenannt2.thumb.PNG.2c08571836c2bc6b96a0d6a7129bac9a.PNG

 

 

Unbenannt3.thumb.PNG.27661bd163b6b6d50d49708b7c398768.PNG

 

Alles läuft auf ssl ebene.
Damit ich auch Mailadresse habe bin in Froxlor hingegangen und habe ein Web erstellt mir system.
Diese habe ich dann die Domain zugewisssen und bei DocumentRoot habe ich dann /var/www/froxlor eingeben.
Openbasedir off
Das funktioniert auch alles soweit zu gut.

Schalte ich nun FCGID ein unter einstellung und führe dann

php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force
service apache2 restart

Scheint alles zu gehen Seite 1 und 2 laufen mit php7 und seite 3 mit php5.6

Dann nach einer zeit X ( 1 bis 2 Stunden ) sind die seiten offline

Error aus Log datei :

froxlor.weblog

[Wed May 17 16:20:31.484784 2017] [fcgid:warn] [pid 2048] (104)Connection reset by peer: [client 95.88.89.239:54941] mod_fcgid: error reading data from FastCGI server, referer: https://XXX/index.php?s=165cbc6730c6e268e8abf34b0f5c5738&script=admin_autoupdate.php&qrystr=s%3D165cbc6730c6e268e8abf34b0f5c5738%26page%3Derror%26errno%3D5
[Wed May 17 16:20:31.484905 2017] [core:error] [pid 2048] [client 95.88.89.239:54941] End of script output before headers: index.php, referer: https://XXX/index.php?s=165cbc6730c6e268e8abf34b0f5c5738&script=admin_autoupdate.php&qrystr=s%3D165cbc6730c6e268e8abf34b0f5c5738%26page%3Derror%26errno%3D5
[Wed May 17 16:20:47.851492 2017] [fcgid:warn] [pid 2046] (104)Connection reset by peer: [client 95.88.89.239:54946] mod_fcgid: error reading data from FastCGI server, referer: https://XXX/index.php?s=165cbc6730c6e268e8abf34b0f5c5738&script=admin_autoupdate.php&qrystr=s%3D165cbc6730c6e268e8abf34b0f5c5738%26page%3Derror%26errno%3D5
[Wed May 17 16:20:47.851703 2017] [core:error] [pid 2046] [client 95.88.89.239:54946] End of script output before headers: index.php, referer: https://XXX/index.php?s=165cbc6730c6e268e8abf34b0f5c5738&script=admin_autoupdate.php&qrystr=s%3D165cbc6730c6e268e8abf34b0f5c5738%26page%3Derror%26errno%3D5
[Wed May 17 16:32:26.619756 2017] [fcgid:warn] [pid 2144] (104)Connection reset by peer: [client 95.88.89.239:55206] mod_fcgid: error reading data from FastCGI server, referer: https://XXX/index.php?s=165cbc6730c6e268e8abf34b0f5c5738&script=admin_autoupdate.php&qrystr=s%3D165cbc6730c6e268e8abf34b0f5c5738%26page%3Derror%26errno%3D5
[Wed May 17 16:32:26.619914 2017] [core:error] [pid 2144] [client 95.88.89.239:55206] End of script output before headers: index.php, referer: https://XXX/index.php?s=165cbc6730c6e268e8abf34b0f5c5738&script=admin_autoupdate.php&qrystr=s%3D165cbc6730c6e268e8abf34b0f5c5738%26page%3Derror%26errno%3D5
[Wed May 17 16:32:46.989698 2017] [fcgid:warn] [pid 2651] [client 95.88.89.239:55237] mod_fcgid: stderr: PHP Warning:  curl_exec() has been disabled for security reasons in /var/www/froxlor/lib/ajax.php on line 55, referer: https://XXX/admin_index.php?s=d4a1f3b250a3490ae20fd9585371fc02
web1.log

[Wed May 17 16:42:41.775238 2017] [fcgid:warn] [pid 3057] (104)Connection reset by peer: [client 66.249.76.132:52958] mod_fcgid: error reading data from FastCGI server
[Wed May 17 16:42:41.775692 2017] [core:error] [pid 3057] [client 66.249.76.132:52958] End of script output before headers: include.php
[Wed May 17 16:43:15.916843 2017] [fcgid:warn] [pid 3080] (104)Connection reset by peer: [client 178.154.200.38:38734] mod_fcgid: error reading data from FastCGI server
[Wed May 17 16:43:15.917114 2017] [core:error] [pid 3080] [client 178.154.200.38:38734] End of script output before headers: index.php
[Wed May 17 16:43:22.559605 2017] [fcgid:warn] [pid 3081] (104)Connection reset by peer: [client 66.249.64.83:48591] mod_fcgid: error reading data from FastCGI server
[Wed May 17 16:43:22.559755 2017] [core:error] [pid 3081] [client 66.249.64.83:48591] End of script output before headers: index.php
web2.log

[Wed May 17 16:53:38.575320 2017] [fcgid:warn] [pid 4053] (104)Connection reset by peer: [client 95.88.89.239:55635] mod_fcgid: error reading data from FastCGI server
[Wed May 17 16:53:38.575554 2017] [core:error] [pid 4053] [client 95.88.89.239:55635] End of script output before headers: index.php

 

 

Vielen dank jetzt schon für hilfestellungen

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Vielen Dank für die Hilfe habe alle Logs durchgesehen von /var/customers/logs für web1 bis web2 und der Apache log das aber der Fehler in der suexec.log steht hätte ich nicht gedacht.

Problem ist gewesen mit den schreibrechte.

Da die Temp Datei von froxlor unter /var/www/php-fcgi-scripts

Angelegt hat wurden diese irgendwie von dem Benutzer www-data überschrieben. Nach dem ich diese gelöscht habe und von froxlor neu angelegt würden geht es.

Die Seite bleibt auch nach x Std aktiv

Share this post


Link to post
Share on other sites
  • 0

Denselbigen Fehler hatte ich unter FCGI auch...
Der Dienst stoß nach einer 1/2 Std. - 1 Std. an sein Limit an Dateien, die er öffnen darf...

Entweder du erhöst diese Limits in den Systemd konfigurationen oder du machst es wie ich und wechselt auf PHP-FPM. Läuft mMn sowieso viel schneller und stabieler.

Außerdem haben die PHP Apache Module, welche du aktiviert, bzw. deaktiviert hast nichts mit FCGI zu tun. Du müsstest nur die Module FCGID & Suexec aktivieren.
Siehe z.B. auch -> HIER <-

Share this post


Link to post
Share on other sites
  • 0

Kundendomain und DocumentRoot /var/www/froxlor ??? Ist doch garnicht innerhalb des Kunden-Homedirs, das kann ja nix werden permission-technisch. Und was meinst du mit "damit ich auch Mailadresse habe"? Benutzt du z.B. meine-domain.de als Froxlor Hostname und willst aber da auch email-Konten nutzen? Das wird nicht gehen. Dann hättest du als Froxlor-Hostname z.B. 'froxlor.meine-domain.de' nehmen müssen oder Ähnliches. Dann einen eigenen Kunden anlegen und 'meine-domain.de' als normale Domain für diesen Kunden hinzufügen

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, d00p said:

Kundendomain und DocumentRoot /var/www/froxlor ??? Ist doch garnicht innerhalb des Kunden-Homedirs, das kann ja nix werden permission-technisch. Und was meinst du mit "damit ich auch Mailadresse habe"? Benutzt du z.B. meine-domain.de als Froxlor Hostname und willst aber da auch email-Konten nutzen? Das wird nicht gehen. Dann hättest du als Froxlor-Hostname z.B. 'froxlor.meine-domain.de' nehmen müssen oder Ähnliches. Dann einen eigenen Kunden anlegen und 'meine-domain.de' als normale Domain für diesen Kunden hinzufügen

meine Domain zum Server 000X00X.de
desweiteren habe ich wie jeder auch hostname vmdXXX.XXXX.xxxx

Für die Domain habe ich beim Anlegen von Kunden froxlor als Benutzername:  angebeben.
damit ich ganz normal die Web1 bis fortlaufend für Kunden habe.
Dem Kunde Froxlor habe ich meine Domain zugefügt.
als DocumentRoot: / var/www/froxlor

Beim Speichert warn Froxlor mich das der angebene Pfad nicht im Kundenvereichnis liegt.
Aber mit Ja nimmt er diese einstellung an.

Nun kann ich ganz normal die Domain aufrufen und bekomme Froxlor angezeigt.
Das funktioniert auch alles.
So kann ich auch Subdomain verwalten für Mail FTP und PhpMyadmin.

Auch Email Adressen gehen.
Auch habe ich keine Probleme mit dem Zugriff läuft ja alles ohne probleme.

Meine Fehler liegen ja wie beschrieben wenn ich FCGID  aktiviere.
Gehen alle Seiten offline auch diese die von Froxlor normal angelegt sind Web1 Web2 Web3 Web4 usw

 

 

Share this post


Link to post
Share on other sites
  • 0

mod_php = Prozess User -> Webserver

Fcgid = Prozess User -> Kunde

Problem damit klar, warum es bei Umstellung knallt?

Mir ist noch nicht so ganz klar wieso du einen froxlor Kunden anlegst, dessen Domain auf froxlor zeigt...aber gut.

Desweiteren, eine bessere Fehlerbeschreibung als "alle Seiten sind dann offline" wäre angebracht. Schau mal in die entsprechenden logs. Zu 99% ein konfigurations-/Einstellungsproblem.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, d00p said:
1 hour ago, d00p said:

mod_php = Prozess User -> Webserver

Fcgid = Prozess User -> Kunde

Problem damit klar, warum es bei Umstellung knallt?

Mir ist noch nicht so ganz klar wieso du einen froxlor Kunden anlegst, dessen Domain auf froxlor zeigt...aber gut.

Desweiteren, eine bessere Fehlerbeschreibung als "alle Seiten sind dann offline" wäre angebracht. Schau mal in die entsprechenden logs. Zu 99% ein konfigurations-/Einstellungsproblem.

 

Weil ich Froxlor dann auch mail adressen hinzufügen kann.

Naja Das Fcgid = Prozess User -> Kunde ist war mir auch klar.
Logs habe ich doch oben gepostet.

Aktivere ich wie gesagt Fcgid und lass cronjob ausführen und starte den Apacheserver neu
Geht auch alles wie gewünscht.
Dann nach einer Zeit X gegen alle Seiten Sprich Webvereichnisse offline.

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at  to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.


Apache/2.4.10 (Debian) Server at  Port 443

Share this post


Link to post
Share on other sites
  • 0

sind halt die falschen logs, da steht nix verwertbares drin. Guck mal in die apache error.log und ggfls suexec.log...irgendwo muss ja der 500er den du da postest geloggt sein. Zudem ist mir immernoch nicht ganz klar was du da genau machst, du sagst was von FCGID nutzen aber fummelst irgendwas mit mod_php rum, also was genau isses denn nu? Hast du FCGID ordentlich eingerichtet, die Einstellungen gesetzt und die Configs entsprechend angepasst, oder wie ist da nun der Stand? Einfach immer nur "ja geht halt nicht" ohne zu wissen was genau du alles gemacht hast und was nicht und mit anständigen aussagekräftigen logs kann man nunmal einfach nicht helfen...ich hab leider immernoch keine Glaskugel dir mir alles verrät

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • By ffx2kx
      Hi Leute, hi d00p,
      also so ganz bekomme ich das hier nicht ans Laufen. das libnss-mysql paket für froxlor referenziert noch libmysqlclient18, welches wohl in stretch nicht angeboten wird.
      Entpacken von libnss-mysql-bg (1.5-3+frx1) ... dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libnss-mysql-bg:  libnss-mysql-bg hängt ab von libmysqlclient18 (>= 5.5.24+dfsg-1); aber:   Paket libmysqlclient18 ist nicht installiert. dpkg: Fehler beim Bearbeiten des Paketes libnss-mysql-bg (--install):  Abhängigkeitsprobleme - verbleibt unkonfiguriert Fehler traten auf beim Bearbeiten von:  libnss-mysql-bg xxx@xxx.xxxxxx:/home/xxxxx# apt-cache search libmysqlclient libglpk40 - linear programming kit with integer (MIP) support libcrypt-mysql-perl - Perl module to emulate the MySQL PASSWORD() function libmariadbclient-dev-compat - MariaDB database development files (libmysqlclient compatibility) default-libmysqlclient-dev - MySQL database development files (metapackage) https://packages.debian.org/search?suite=default&section=all&arch=any&searchon=names&keywords=libmysqlclient
      Was jedenfalls verfügbar und installiert ist ist das Paket libmariadbclient18.
      Ideen? Alternativen? Handarbeit?
      Gruß,
      ffx2kx
    • By tt33tt
      Hi all,
      how can I change the option FcgidIOTimeout?
      I have a new apache with FCGID on Ubuntu 16.04.
      Thanks
    • By tt33tt
      Seit ich mit http://redmine.froxlor.org/projects/froxlor/wiki/FCGID_-_Handbuch fcgid und suexex eingerichtet habe, funktioniert phpmyadmin nicht mehr. Das äußert sich darin, dass ich beim Öffnen von der phpmyadmin-Seite die php-Datei angezeigt bekomme und im Quellcode sogar die php-Befehle stehen. Das bedeutet, dass keine Interpretation stattfindet.
      Muss ich dafür nun auch einen vhost, einen User etc. anlegen?
      Wenn ich +ExecCGI unter Options hineinschreibe, dann kommt die Fehlermeldung: Either all Options must start with + or -, or no Option may.
       
      Meine /etc/apache2/conf.d/phpmyadmin.conf sieht so aus:
      # phpMyAdmin default Apache configuration Alias /phpmyadmin /usr/share/phpmyadmin <Directory /usr/share/phpmyadmin>     Options FollowSymLinks     DirectoryIndex index.php     <IfModule mod_php5.c>         AddType application/x-httpd-php .php         php_flag magic_quotes_gpc Off         php_flag track_vars On         php_flag register_globals Off         php_admin_flag allow_url_fopen Off         php_value include_path .         php_admin_value upload_tmp_dir /var/lib/phpmyadmin/tmp         php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/phpmyadmin/:/usr/share/php/php-gettext/:/usr/share/javascript/     </IfModule> </Directory> # Authorize for setup <Directory /usr/share/phpmyadmin/setup> <IfModule mod_authn_file.c> AuthType Basic AuthName "phpMyAdmin Setup" AuthUserFile /etc/phpmyadmin/htpasswd.setup </IfModule> Require valid-user </Directory> # Disallow web access to directories that don't need it <Directory /usr/share/phpmyadmin/libraries> Order Deny,Allow Deny from All </Directory> <Directory /usr/share/phpmyadmin/setup/lib> Order Deny,Allow Deny from All </Directory>
    • By tt33tt
      Hallo alle zusammen,
       
      ich habe Wordpress und erhalte dort den Fehler, dass curl deaktiviert ist. In der phpInfo steht dies auch unter disabled functions: disable_functions -> curl_exec,curl_multi_exec
      Auf meinem Webserver habe ich Frolxor mit fcgid und suExec.
      Vermutlich muss ich die "Default Config" ändern, die unter dem Punkt "Voreingestellte PHP-Konfiguration für neue Domains" auf der Seite Einstellungen->fcgid ändern oder?
      Ist das richtig und wo finde ich sie? Ich konnte sie bisher nicht finden.
      Muss ich beide Funktionen curl_exec und curl_multi_exec aktivieren?
    • By tt33tt
      Hallo alle zusammen,
       
      ich versuche gerade herauszufinden, ob ich suPHP, mod_php oder CGI/FastCGI habe.
      Meinen Webserver habe ich entsprechend diese Anleitung angepasst: http://redmine.froxlor.org/projects/froxlor/wiki/FCGID_-_Handbuch
      In Froxlor steht -> Webserver: Apache/2.4.7 (Ubuntu) mod_fcgid/2.3.9
       
      Dann habe ich CGI/FastCGI oder?
      Trotz suExec habe ich kein suPHP aktiviert oder? Sollte ich letzteres noch tun?


×