Jump to content
Froxlor Forum
  • 0
ffx2kx

Debian 9 Stretch - libnss-mysql

Question

Hi Leute, hi d00p,

also so ganz bekomme ich das hier nicht ans Laufen. das libnss-mysql paket für froxlor referenziert noch libmysqlclient18, welches wohl in stretch nicht angeboten wird.

Entpacken von libnss-mysql-bg (1.5-3+frx1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libnss-mysql-bg:
 libnss-mysql-bg hängt ab von libmysqlclient18 (>= 5.5.24+dfsg-1); aber:
  Paket libmysqlclient18 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes libnss-mysql-bg (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 libnss-mysql-bg
xxx@xxx.xxxxxx:/home/xxxxx# apt-cache search libmysqlclient
libglpk40 - linear programming kit with integer (MIP) support
libcrypt-mysql-perl - Perl module to emulate the MySQL PASSWORD() function
libmariadbclient-dev-compat - MariaDB database development files (libmysqlclient compatibility)
default-libmysqlclient-dev - MySQL database development files (metapackage)

https://packages.debian.org/search?suite=default&section=all&arch=any&searchon=names&keywords=libmysqlclient

Was jedenfalls verfügbar und installiert ist ist das Paket libmariadbclient18.

Ideen? Alternativen? Handarbeit?

Gruß,

ffx2kx

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Alternativen...für stretch nimmste wohl am besten libnss-extrausers, musste in froxlor auch aktivieren

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • By tt33tt
      Hi all,
      how can I change the option FcgidIOTimeout?
      I have a new apache with FCGID on Ubuntu 16.04.
      Thanks
    • By Leguz
      Hallo Zusammen
      Habe folgendes problem.
      Da ich 3 verschiedene webverzeichnise habe und 2 nur mit php7 laufen und das andere nur mit php 5.6 habe ich versucht dieses problem mit FCGID zu lösen.
      erstmal zu meinem einstellungen des Servers.

      Debain 64 bit Jessie
      Froxlor installation unter /var/www/froxlor/
      Installierte Version: 0.9.38.7 (DB: 201612110)
      PHP 5.6 sowie php7.0 installiert mit allen notwenidgen zusätze.
      Der Server würde dann mit :
      a2dismod php5
      a2enmod php7.0
      service apache2 restart

      Auf PHP7 umgestellt.
      Nun habe ich nach der Anleitung für FCGID gehalten und durchgeführt.




       
       

       
      Alles läuft auf ssl ebene.
      Damit ich auch Mailadresse habe bin in Froxlor hingegangen und habe ein Web erstellt mir system.
      Diese habe ich dann die Domain zugewisssen und bei DocumentRoot habe ich dann /var/www/froxlor eingeben.
      Openbasedir off
      Das funktioniert auch alles soweit zu gut.
      Schalte ich nun FCGID ein unter einstellung und führe dann
      php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force
      service apache2 restart
      Scheint alles zu gehen Seite 1 und 2 laufen mit php7 und seite 3 mit php5.6
      Dann nach einer zeit X ( 1 bis 2 Stunden ) sind die seiten offline

      Error aus Log datei :
      froxlor.weblog [Wed May 17 16:20:31.484784 2017] [fcgid:warn] [pid 2048] (104)Connection reset by peer: [client 95.88.89.239:54941] mod_fcgid: error reading data from FastCGI server, referer: https://XXX/index.php?s=165cbc6730c6e268e8abf34b0f5c5738&script=admin_autoupdate.php&qrystr=s%3D165cbc6730c6e268e8abf34b0f5c5738%26page%3Derror%26errno%3D5 [Wed May 17 16:20:31.484905 2017] [core:error] [pid 2048] [client 95.88.89.239:54941] End of script output before headers: index.php, referer: https://XXX/index.php?s=165cbc6730c6e268e8abf34b0f5c5738&script=admin_autoupdate.php&qrystr=s%3D165cbc6730c6e268e8abf34b0f5c5738%26page%3Derror%26errno%3D5 [Wed May 17 16:20:47.851492 2017] [fcgid:warn] [pid 2046] (104)Connection reset by peer: [client 95.88.89.239:54946] mod_fcgid: error reading data from FastCGI server, referer: https://XXX/index.php?s=165cbc6730c6e268e8abf34b0f5c5738&script=admin_autoupdate.php&qrystr=s%3D165cbc6730c6e268e8abf34b0f5c5738%26page%3Derror%26errno%3D5 [Wed May 17 16:20:47.851703 2017] [core:error] [pid 2046] [client 95.88.89.239:54946] End of script output before headers: index.php, referer: https://XXX/index.php?s=165cbc6730c6e268e8abf34b0f5c5738&script=admin_autoupdate.php&qrystr=s%3D165cbc6730c6e268e8abf34b0f5c5738%26page%3Derror%26errno%3D5 [Wed May 17 16:32:26.619756 2017] [fcgid:warn] [pid 2144] (104)Connection reset by peer: [client 95.88.89.239:55206] mod_fcgid: error reading data from FastCGI server, referer: https://XXX/index.php?s=165cbc6730c6e268e8abf34b0f5c5738&script=admin_autoupdate.php&qrystr=s%3D165cbc6730c6e268e8abf34b0f5c5738%26page%3Derror%26errno%3D5 [Wed May 17 16:32:26.619914 2017] [core:error] [pid 2144] [client 95.88.89.239:55206] End of script output before headers: index.php, referer: https://XXX/index.php?s=165cbc6730c6e268e8abf34b0f5c5738&script=admin_autoupdate.php&qrystr=s%3D165cbc6730c6e268e8abf34b0f5c5738%26page%3Derror%26errno%3D5 [Wed May 17 16:32:46.989698 2017] [fcgid:warn] [pid 2651] [client 95.88.89.239:55237] mod_fcgid: stderr: PHP Warning: curl_exec() has been disabled for security reasons in /var/www/froxlor/lib/ajax.php on line 55, referer: https://XXX/admin_index.php?s=d4a1f3b250a3490ae20fd9585371fc02 web1.log [Wed May 17 16:42:41.775238 2017] [fcgid:warn] [pid 3057] (104)Connection reset by peer: [client 66.249.76.132:52958] mod_fcgid: error reading data from FastCGI server [Wed May 17 16:42:41.775692 2017] [core:error] [pid 3057] [client 66.249.76.132:52958] End of script output before headers: include.php [Wed May 17 16:43:15.916843 2017] [fcgid:warn] [pid 3080] (104)Connection reset by peer: [client 178.154.200.38:38734] mod_fcgid: error reading data from FastCGI server [Wed May 17 16:43:15.917114 2017] [core:error] [pid 3080] [client 178.154.200.38:38734] End of script output before headers: index.php [Wed May 17 16:43:22.559605 2017] [fcgid:warn] [pid 3081] (104)Connection reset by peer: [client 66.249.64.83:48591] mod_fcgid: error reading data from FastCGI server [Wed May 17 16:43:22.559755 2017] [core:error] [pid 3081] [client 66.249.64.83:48591] End of script output before headers: index.php web2.log [Wed May 17 16:53:38.575320 2017] [fcgid:warn] [pid 4053] (104)Connection reset by peer: [client 95.88.89.239:55635] mod_fcgid: error reading data from FastCGI server [Wed May 17 16:53:38.575554 2017] [core:error] [pid 4053] [client 95.88.89.239:55635] End of script output before headers: index.php  
       
      Vielen dank jetzt schon für hilfestellungen
    • By tt33tt
      Seit ich mit http://redmine.froxlor.org/projects/froxlor/wiki/FCGID_-_Handbuch fcgid und suexex eingerichtet habe, funktioniert phpmyadmin nicht mehr. Das äußert sich darin, dass ich beim Öffnen von der phpmyadmin-Seite die php-Datei angezeigt bekomme und im Quellcode sogar die php-Befehle stehen. Das bedeutet, dass keine Interpretation stattfindet.
      Muss ich dafür nun auch einen vhost, einen User etc. anlegen?
      Wenn ich +ExecCGI unter Options hineinschreibe, dann kommt die Fehlermeldung: Either all Options must start with + or -, or no Option may.
       
      Meine /etc/apache2/conf.d/phpmyadmin.conf sieht so aus:
      # phpMyAdmin default Apache configuration Alias /phpmyadmin /usr/share/phpmyadmin <Directory /usr/share/phpmyadmin>     Options FollowSymLinks     DirectoryIndex index.php     <IfModule mod_php5.c>         AddType application/x-httpd-php .php         php_flag magic_quotes_gpc Off         php_flag track_vars On         php_flag register_globals Off         php_admin_flag allow_url_fopen Off         php_value include_path .         php_admin_value upload_tmp_dir /var/lib/phpmyadmin/tmp         php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/phpmyadmin/:/usr/share/php/php-gettext/:/usr/share/javascript/     </IfModule> </Directory> # Authorize for setup <Directory /usr/share/phpmyadmin/setup> <IfModule mod_authn_file.c> AuthType Basic AuthName "phpMyAdmin Setup" AuthUserFile /etc/phpmyadmin/htpasswd.setup </IfModule> Require valid-user </Directory> # Disallow web access to directories that don't need it <Directory /usr/share/phpmyadmin/libraries> Order Deny,Allow Deny from All </Directory> <Directory /usr/share/phpmyadmin/setup/lib> Order Deny,Allow Deny from All </Directory>
    • By tt33tt
      Hallo alle zusammen,
       
      ich habe Wordpress und erhalte dort den Fehler, dass curl deaktiviert ist. In der phpInfo steht dies auch unter disabled functions: disable_functions -> curl_exec,curl_multi_exec
      Auf meinem Webserver habe ich Frolxor mit fcgid und suExec.
      Vermutlich muss ich die "Default Config" ändern, die unter dem Punkt "Voreingestellte PHP-Konfiguration für neue Domains" auf der Seite Einstellungen->fcgid ändern oder?
      Ist das richtig und wo finde ich sie? Ich konnte sie bisher nicht finden.
      Muss ich beide Funktionen curl_exec und curl_multi_exec aktivieren?
    • By tt33tt
      Hallo alle zusammen,
       
      ich versuche gerade herauszufinden, ob ich suPHP, mod_php oder CGI/FastCGI habe.
      Meinen Webserver habe ich entsprechend diese Anleitung angepasst: http://redmine.froxlor.org/projects/froxlor/wiki/FCGID_-_Handbuch
      In Froxlor steht -> Webserver: Apache/2.4.7 (Ubuntu) mod_fcgid/2.3.9
       
      Dann habe ich CGI/FastCGI oder?
      Trotz suExec habe ich kein suPHP aktiviert oder? Sollte ich letzteres noch tun?


×