Jump to content
Froxlor Forum
  • 0
julianlampert

PHP Version Switch

Question

Hi,

 

I've tried to develop a module in which customers can change the PHP configuration for their domain & subdomain. The problem is I am new to froxlor and do not understand the code.

 

My first attempt was: I edited the 'formfields.domain_edit.php' - File for 'customer -> domains' and added the following code:

'section_b' => array(
'title' => $lng['admin']['phpserversettings'],
'image' => 'icons/domain_edit.png',
'fields' => array(
'phpsettingid' => array(
'visible' => (((int)Settings::Get('system.mod_fcgid') == 1 || (int)Settings::Get('phpfpm.enabled') == 1) ? true : false),
'label' => $lng['admin']['phpsettings']['title'],
'type' => 'select',
'select_var' => $phpconfigs
)
)
)

I copied the code from the admin template. But I don't know how where to add the $phpconfigs, I mean in which block of the file 'customer_domains.php' and how to customize it.

 

I tried this snippet:

$phpconfigs = '';
$phpconfigs_result_stmt = Database::query("SELECT * FROM `" . TABLE_PANEL_PHPCONFIGS . "`");

while ($phpconfigs_row = $phpconfigs_result_stmt->fetch(PDO::FETCH_ASSOC)) {
$phpconfigs .= makeoption($phpconfigs_row['description'], $phpconfigs_row['id'], $result['phpsettingid'], true, true);
}

But I don't know how to fill the $result['phpsettingid'] - Value (the $result - Array).

 

Please can anybody give me a clue where I have to add the code snippets and how froxlor edits values in the database.

 

Thank you very much!

 

Regards,

Julian

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

well you have to process the form after the POST, right now, you are only displaying the select-box, the formfields describe the forms, the other snipped just fills the select-box with options.

 

Also, TABLE_PANEL_PHPCONFIGS only holds different php-versions when using FCGID (because you can specify the php-binary there). It won't work for mod_php or php-fpm that way

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By irisdina
      Warning, this is not an official guide!!!
      1.
      sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list
      sudo nano /etc/apt/source.list 1b.  insert (for Debian Stretch)
      1.2B (for Ubuntu Cosmic)
       
      1c. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. 
      sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server
      2. MariaDB install
      Warning use sudo command für this install!
      sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional)
      3. nginx install
      sudo apt install nginx 3a. 
      mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf
      4. PHP install
      sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. 
      sudo service nginx restart sudo service php7.3-fpm restart Froxlor install
      There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master)
      Stable Version
      1. 
      cd /var/www/html/ 1a. 
      sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or
      Git Version (Beta Version)
      sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer  su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory
      composer install --no-dev 1b. 
      sudo chown -R www-data:www-data Froxlor/ Set up Froxlor
      2. Open Your Browser
      2a.
      http://your IP or Hostname/Froxlor
       

      Install Froxlor finish
       3d. Move userdata (Optional) 
      sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. 
      sudo rm /etc/nginx/site-enable/default don't restart nginx!
      Froxlor Settings
      1. Cronjob
      sudo nano /etc/cron.d/froxlor insert 
      # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend
      Settings > Webserver settings > Nginx PHP backend
      from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock
      3. 
      sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port

      2a(1), SSL Port



      Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually
      sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional
      PHP-FPM activate
      1. User/Group add
      sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install 
      sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

      3. Settings > PHP-FPM > Activated:
      Change from NO to YES
      3a. PHP-FPM versions
      Change > php-fpm restart command:
      service php7.3-fpm restart and
      Configuration directory of php-fpm: > to 
      /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

      3c. 
      sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate
      1.
      sudo apt install certbot 1a. 
      sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File
      sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. 
      sudo nano /etc/nginx/acme.conf insert
      location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } }  
      2. Open your  Froxlor Panel
      Settings> SSL > Activated:
      Change from NO to YES
      2a. Settings > SSL > Settings
      Change your path from your certificate / Keyfile
      Path to the SSL certificate
      insert
      /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile
      insert
      /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings
      Activate > Enable Let's Encrypt

      Change Path to the acme.conf snippet to > 
      /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings
      - Enable Let's Encrypt for the froxlor vhost
      - Enable SSL-redirect for the froxlor vhost
      - HTTP Strict Transport Security (HSTS)
      - Include HSTS for any subdomain






      2d. Activated HTTP2 Support on > Settings > Nginx
       
    • By j4mb4l4j4
      Deutsch:
      HI, ich habe mal eine Frage bezüglich des Tausches der PHP Version.
      Aktuell habe ich gem. Tutorial mein Froxlor aufgesetzt ( Apache statt Nginx ).

      Wenn ich jetzt die php-fpm Version von 7.1 auf 7.0 ändern möchte, reicht es dann aus, einfach  Schritt 4 des Tutorials nochmal aufzugreifen und php 7.0 zu installieren
      und dann im Froxlor Panel auf 7.0 umzustellen ? Dann hätte ich 7.1 und 7.0 auf dem Server.

      Ich frage weil ich einen Produktivserver habe und möglichst wenig Ausfall mir erhoffe...
      Grund für meinen Wechsel ist, das Shopware wegen dem Ioncubeloader nicht 7.1 komplett unterstützt sondern nur 7.0...


      Englisch:
      Hi, I've a QUestion about a php-fpm version change.
      I did this Tutorial ( Apache instead of Nginx )
      Now If i want to change the php-fpm version from 7.1 to 7.0 is it just necessary to reproduce step 4 from the tutorial and install 7.0 next to 7.1 ?
      And then change the version in Froxlor System Panel ?
      I've got a live system so I want to do it in best practice.
      Necessary cause shopware is not running fully supported with Ioncubeloader and php 7.1 :-(
       
      Danke schon mal, und frohe Ostern nachträglich !!!!
    • By LukasH
      Einen wunderschönen guten Abend,
      Ich habe ein kleines Problem mit Subdomains auf meinem Webserver. Ich habe für diesen Froxlor mit LetsEncrypt eingestellt und bereits RainLoop als Webmailer eingerichtet. Das hat wunderbar funktioniert über 
      meinedomain.de/webmailordner.
      Nun wollte ich allerdings eine Subdomain anlegen (webmail.meinedomain.de) das will aber nicht funktionieren. Die Subdomain bekommt korrekt ein SSL Zertifikat zugewiesen, allerdings wird die in dem Verzeichnis liegende PHP Datei nicht ausgeführt sondern einfach nur der Inhalt angezeigt. Somit ist das Aufrufen des Webmailers nicht möglich. Rufe ich den Webmailer wieder über "meinedomain.de/webmailordner" auf funktioniert alles ganz normal.
      Ebenfalls wollte ich das Verzeichnis von meinedomain.de ändern, sobald ich das allerdings mache bekomme ich nur noch den Fehler 403 forbidden unter der Domain. Sobald ich den Pfad wieder in den Kundenroot ändere funktioniert es wieder. 
      Allerdings sollen auf den Server doch diverse Domains für verschiedene Dienste umgezogen werden und die aktuelle Domain ist nur für einen Dienst gedacht soll also auf einen Unterordner verweisen, wo ist hier das Problem?
      Vielen Dank für eure Hilfe! In den angehängten Screenshot ist die Konfiguration in Froxlor zu sehen, falls noch etwas benötigt wird reiche ich das natürlich sofort nach. 



    • By UncleSnycs
      Hallo ich hoffe, mir kann jemand helfen. Ich habe eine Subdomain erstellt (phpmyadmin.example.ltd). Dort funktioniert PHP ohne probleme. Auf meiner anderen Subdomain (wi.example.ltd) funktioniert PHP überhaupt nicht und er zeigt mir bei der index.php nur den text an, der in der Datei drin steht. In Der vHost.conf steht, dass php disabled ist. Weiss jemand, wo man das aktivieren kann? Ich finde in der Konfiguration von der Subdomain den Eintrag nicht.
      Vielen Dank schonmal in vorraus.
      Mit freundlichen Grüßen
      UncleSnycs
    • By martinvh
      Hello folks,
      I'm experiencing the following issue: I have create a separate customer account for myself. When I add a subdomain, PHP is disabled in the resulting vHost config. I traced the way down: The customer is PHP enabled, the TLD domain is PHP enabled. I discovered, if I just open and re-save the TLD settings page for the specific domain from the admins account after creating the subdomain in the customer account, the "phpenabled" flag gets updated correctly in the database. Which setting am I missing to realise the behaviour without this workaround?




×
×
  • Create New...