Jump to content
Froxlor Forum
  • 0
IcyMediaT

Question about setting up froxlor on a subdomain

Question

I've installed froxlor about 5 times in the past 36 hours (all on same machine) and still don't quite understand this part.

 

I want to be able to manage my own root domain from froxlor, this is the domain that froxlor is being used on.

 

So i have a domain like so

thisismydomain.com

When I setup froxlor on the first setup screen, if i enter this as my FQDN then i can not add it as a domain in Froxlor so have to manage it outside of Froxlor.

 

I want to manage this domain, which is also the domain Froxlor is installed on from within Froxlor.

 

So i have experiemented with just making up a random subdomain and entering this on the Froxlor setup screen, like this: -

Server name (FQDN, no ip-address): anything.thisismydomain.com

When I do this I can add a customer when i log into Froxlor and then add my actual domain (thisismydomain.com) which is what I was looking to do.

 

My questions are:

 

1) Is this the correct way to setup Froxlor so I can add my own domain in froxlor and have it managed inside froxlor?

2) can i just make up a subdomain, and enter it, and this will work ok? Or do i need to add this to my webserver config files myself somehow also? - i'm using NginX

 

3) I discovered froxlor because I'm working on a server, that someone else setup and they had installed froxlor, so it's all pretty new to me. I'm building a test server to get to grips with it, hence all my recent questions. In the server that is already setup and functioning, there is only one domain visible when you click on domains and it is the root domain, e.g. thisismydomain.com ; there are no other domains in there... how do I achieve this same effect? Whenever I setup froxlor like I have explained above, i get a thisismydomain.com domain entry (after I have added it through froxlor) - but i also get a anything.thisismydomain.com domain entry - which is added when I create the customer - however there is no delete option next to this domain ; and I don't understand how the person that setup the froxlor I'm working with on another server, how they managed to get just the domain listed in the domains entry inside the control panel.

 

One thing i have noticed is that on this, they have used a subdomain it would appear as froxlor is accessed by typing - something.thedomain.com ; and if you go to the domain.com/froxlor nothing is there ; but I'm confused about how they've achieved this also because in the nginx config there are no rewrites to forward traffic from something.thedomain.com to thedomain.com/froxlor - also i've checked the config through the froxlor panel on this server and the 'access froxlor through a hostname option' is not ticked.

 

If you could answer this as detailed as possible, it would be appreciated, as I've been grappling with this question myself for the past few days,

 

Many thanks - and kudos on a great product, and service for the community.

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

1) yes this is the correct way

2) yes, you can use [anythingyoulike].yourdomain.tld it works

3) i think you are talking about the "standard customer subdomain" which is "[loginname].[froxlorhostname], if you do not want these, edit the customer and uncheck "create std subdomain"

Share this post


Link to post
Share on other sites
  • 0

Thanks so much very reassuring to know 1 and 2 are correct ; and 3 is also great, now I know how not to create that customer domain thank you.

 

Do you happen to have any idea why froxlor is accessible through subdomain.domain.com on the server I'm trying to replicate?

 

The sub domain has these entries in the nginx config file ; but i don't see how this is resulting in the traffic at the subdomain address being routed to domain/froxlor ?

can you think of anything that might be causing the redirection?

server {
    listen x.xx.xxx.xxx:80;
    server_name subdomain.domain.com;

    root /var/www;
    index index.htm index.html index.php;

    auth_basic "Login";
    auth_basic_user_file /etc/nginx/subdomain.htpasswd;

    location / {
        try_files $uri $uri/ =404;
    }

    location ~ \.php$ {
        try_files $uri =404;
        fastcgi_split_path_info ^(.+\.php)(/.+)$;
        fastcgi_pass unix:/var/run/php5-fpm.sock;
        fastcgi_index index.php;
        include fastcgi_params;
    }
}

Could it be something to do with .htpasswd ? or can you think of some other place i could look where the redirection might be configured? subdomain.domain.com prompts for a user name and password, and when entered, the froxlor login screen is then displayed but i can't figure out how this is happening

Share this post


Link to post
Share on other sites
  • 0

There is a setting called "Access Froxlor directly via the hostname" in Settings -> System settings

Share this post


Link to post
Share on other sites
  • 0

Hi yes this is not ticked, i've since discovered something though, in the settings --> hostname ; there is an ip address set ;

and when i type that ip address into a browser it goes to subdomain.domain.com/froxlor ; so i think something to do with how it's happening

Share this post


Link to post
Share on other sites
  • 0

In Settiungs -> Systemsettings -> Hostname there is an IP address? That's wrong, there should be a FQDN (the one from the setup) - funny that it is possible to set an ip address there...should not be allowed

Share this post


Link to post
Share on other sites
  • 0

Sorry showing my confusion here. You are right, the hostname is FQDN.

The IP address is in 'what's the ip address of this server'.

 

What is surprising to me, is that when i type that IP address into my browser it goes to the subdomain, which is entered in the hostname setting here, but appends /froxlor to it in the browser window. So i type the IP address listed as the IP address of the server ,in my browser and it loads

subdomain.domain.com/froxlor 

This is the same IP address of the server that is running nginx and that i can remote into it via putty.

 

When i installed from a clean linux install ; if i type my server ip into a browser window i land at domain.com ; not the subdomain i entered into froxlor when i set it up ; and certainly not the subdomain.domain.com/froxlor ; i'm confused here, but i realise this is due to not understanding DNS quite properly and nginx configuration more than anything else. I am trying to replicate the setup on my test server.

Share this post


Link to post
Share on other sites
  • 0

When you enter the IP address in your browser, it will most likely go to the first vhost it will find - usually you do not get redirected to any url except if the vhost has some redirect-stuff in it. Just check your vhost configs

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Jason Szymanski
      Hallo,
       
      ich habe leider ein Problem mit Froxlor.
      Zu meiner Situation: Froxlor läuft auf der Subdomain web01.meinedomain.net
      Jetzt möchte ich die Domain aber auch noch weiter Nutzen und habe mich daher als Kunde angelegt und die Domain meineDomain.net als Domain hinzugefügt.
      Dort kann ich auch weitere Subdomains hinzufügen. Das scheint soweit auch zu klappen ich sehe das er VHosts anlegt und auch die Verzeichnisse im FTP anlegt.
      Wenn ich jetzt allerdings versuche auf meinedomain.net oder eine andere Subdomain unter dieser Domain zuzugreifen leitet er mich auf web01.meinedomain.net
      Ich habe mich schon in den Einstellungen umgeschaut konnte aber keine entsprechende Einstellung finden an der das liegen könnte.
      Wie verhindere ich also das er mich auf Froxlor umleitet?
       
      Mit Freundlichen Grüßen
      Jason Szymanski
    • By rashantha
      Hi Everyone,
      I am new to froxlor moving from Sentora. Setting up on Centos 7. I followed these directions with PHP 7.
      https://www.vultr.com/docs/how-to-install-the-froxlor-server-management-panel-on-centos-7
      I am getting the error below and from googling I reckon it not a password issue. I did the installation twice just to make sure it's not a password issue. It looks more like a connection issue.
      So I checked to make sure it's not a port issue. Any help would be greatly appreciated.

      semanage port -l | grep http_port_t
      http_port_t                    tcp      80, 81, 443, 488, 8008, 8009, 8443, 9000
      pegasus_http_port_t            tcp      5988
       
      Checking MySQL-root access...
      SQLSTATE[HY000] [2002] Permission denied There seems to be a problem with the database-connection. Cannot continue. Please go back and check your credentials.
    • By Maxiffm
      Hallo,
      ich bin schon wieder am verzweifeln, vielleicht kann mir jemand helfen...
      Ich habe eine Domain mit Letsencrypt angelegt und die läuft auch wunderbar.
      Nun will ich dazu eine Wildcard Subdomain OHNE SSL (Letsencrypt) anlegen,
      es wird ein vhost für SSL angelegt und erzeugt beim Apache-Server einen Konfigurationsfehler...
      Läßt sich sowas realisieren oder ist das ein Fehler bei Froxlor ?
      Die Domain mit https://meine-domain.de und http://*.meine-domain.de angelegt, der Ordner
      wo  die -> http://*.meine-domain.de hinverweist wird angelegt, aber die Sub-Domains laufen in den
      Root des Servers, also 404 Not Found.
       
       
       
    • By AreYouLoco?
      Hi,
      I am trying to setup froxlor on my Debian LAMP. I followed the guide from here: https://github.com/Froxlor/Froxlor/wiki/Install-froxlor-on-debian and and here https://github.com/Froxlor/Froxlor/wiki/Install-froxlor-from-tarball.
      I am stuck on page that I need to provide credentials to the database. When I go forward I do get this:

      I fill in my credentials; new password for froxlor database, new password for admin account, my root password that I can use to login locally via:
      mysql -u root -p Please help

       
      EDIT:
      I did some research and I allowed remote root login.
      MariaDB [(none)]> show grants; +------------------------------------------------------------------------------------------------+ | Grants for root@localhost | +------------------------------------------------------------------------------------------------+ | GRANT ALL PRIVILEGES ON *.* TO 'root'@'localhost' IDENTIFIED VIA unix_socket WITH GRANT OPTION | | GRANT PROXY ON ''@'%' TO 'root'@'localhost' WITH GRANT OPTION | +------------------------------------------------------------------------------------------------+  
    • By H4nSolo
      Hallöchen zusammen,
      ich hätte mal eine Frage bezüglich Froxlor und Cloudflare.
       
      Da einige die Froxlor benutzen, bestimmt auch bei cloudflare ihre domain eingetragen haben, stellt sich mir die Frage ob man dies nicht gleich auch mit cloudflare verbinden kann um so seine subdomains / Domains miteinzurichten, ohne sich immer zusätzlich bei cloudflare anzumelden.

      Cloudflare bringt ja von Haus aus eine API mit womit man sich auch über Scripte und einen Authentifikations Key extern anmelden kann.
      Cloudflare API: https://api.cloudflare.com/
       
      Ich für meinen Teil würde es Prima finden wenn zum Beispiel Kunden ihren Login Key eintragen, und damit bequem auch bei erstellung von subdomains gleichzeitig (sofern sie ihre Domain beim Cloudflare registriert haben) alles in einem abwickeltn können.
       
       
      Was haltet ihr von der Idee und könnte man es überhaubt verwirklichen für Froxlor?
       
      lg H4nSolo
×
×
  • Create New...