Jump to content
Froxlor Forum
  • 0
rashantha

SQLSTATE[HY000] [2002] Permission denied

Question

Hi Everyone,

I am new to froxlor moving from Sentora. Setting up on Centos 7. I followed these directions with PHP 7.

https://www.vultr.com/docs/how-to-install-the-froxlor-server-management-panel-on-centos-7

I am getting the error below and from googling I reckon it not a password issue. I did the installation twice just to make sure it's not a password issue. It looks more like a connection issue.

So I checked to make sure it's not a port issue. Any help would be greatly appreciated.


semanage port -l | grep http_port_t
http_port_t                    tcp      80, 81, 443, 488, 8008, 8009, 8443, 9000
pegasus_http_port_t            tcp      5988
 

Checking MySQL-root access...

SQLSTATE[HY000] [2002] Permission denied

There seems to be a problem with the database-connection. Cannot continue. Please go back and check your credentials.

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Success!

I had to remove the DB creation and let the install script do it for me.

I also disabled selinux.

I should create guide.

Share this post


Link to post
Share on other sites
  • 0

Thanks for the fast response.

So I did 

getsebool -a | grep httpd 

and then followed with  setsebool -P httpd_can_network_connect_db 1 after that

I was able to run the install and successfully but then when you click login link it takes you back to the install and not the login.

Do you recommend another Centos 7/PhP install guide?

Share this post


Link to post
Share on other sites
  • 0

Are you sure the setup completed successfully and you READ everything on the last screen CAREFULLY?

Share this post


Link to post
Share on other sites
  • 0

MariaDB [(none)]> show databases;
+--------------------+
| Database           |
+--------------------+
| froxlor            |
| information_schema |
| mysql              |
| performance_schema |
+--------------------+
4 rows in set (0.04 sec)
 

Share this post


Link to post
Share on other sites
  • 0

So I have solved this by creating the file manually 'userdata.inc.php'

I do get a login screen now. But I have a feeling something is wrong. most likely with permissions, but no clue...

Share this post


Link to post
Share on other sites
  • 0

Because as said you did Not read carefully:

9 hours ago, rashantha said:

image.png.0a2968ee95d98d39898a1cffab611824.png

Why do you think there is yellow Text instead of all green? Again: read carefully...

Alternatively, Set correct permissions so that the Webserver User can write to /var/www/html/froxlor

Share this post


Link to post
Share on other sites
  • 0
13 hours ago, d00p said:
 

Because as said you did Not read carefully:

Why do you think there is yellow Text instead of all green? Again: read carefully...

Alternatively, Set correct permissions so that the Webserver User can write to /var/www/html/froxlor

I did run this... so not sure why it couldn't create the file.


chown -R apache:apache /var/www/html/froxlor

d00p - do you see any other issues in that guide - https://www.vultr.com/docs/how-to-install-the-froxlor-server-management-panel-on-centos-7

 

 

Share this post


Link to post
Share on other sites
  • 0

Going to try 1 last time... thinking of SELINUX=disabled but not sure about this? If anyone has installed on CENTOS7 any further input would be appreciated. tia.

 

 

Share this post


Link to post
Share on other sites
  • 0

 

Hey @d00p I have tried several times. I keep getting that the file can't be written

 

looked at user of egrep -i '^user|^group' /etc/httpd/conf/httpd.conf 

tried chown apache: -R froxlor (after cd into correct folder)

also tried sudo chown -R apache:apache /var/www/html/froxlor

still getting below. If I create the file then I get no user. Any other advice?

image.png.07af58b5f85b446e903f41318bc8f777.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By zed
      Hi, after fresh froxlor install on debian9 and php-fpm I have 503 error :
      Service Unavailable The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later. In /var/log/apache2/error.log I found:
      [proxy:error] [pid 997] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /var/lib/apache2/fastcgi/1-froxlor.panel-sub.domain.com-php-fpm.socket (*) failed [proxy_fcgi:error] [pid 997] [client 1.1.1.1:57529] AH01079: failed to make connection to backend: httpd-UDS I have not created any customers or domains yet and I can't access Froxlor panel and phpmyadmin
      File /var/lib/apache2/fastcgi/1-froxlor.panel-sub.domain.com-php-fpm.socket is not available, I created it but still not work.
      What can I do ?
    • By Kyle Willets
      I looked around and like my last question the directory on Centos 7 is different then the configuration in
      RHEL / CentOS (7) »  Webserver (HTTP) »  Apache 2.4
      I see that ofcourse my apache 2 is installed in httpd and I am searching, but no /etc/apache2/conf-enabled/acme.conf. I did see the first command created the var folders fine for customers, but the others all failed: 
      [root@s128426 ~]# nano /etc/httpd/conf/httpd.conf
      [root@s128426 ~]# chown root:0 /etc/apache2/sites-enabled/
      chown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
      [root@s128426 ~]# chmod 0600 /etc/apache2/sites-enabled/
      chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
      [root@s128426 ~]# chown root:0 /etc/apache2/sites-enabled/
      chown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
      [root@s128426 ~]# chmod 0600 /etc/apache2/sites-enabled/
      chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
       
      When I search httpd these directories do not exist within it. Is there a separate install  for apache for Froxlor or something I am missing? I am really thinking about going to debian, but my dedicated host does not offer debian stretch at the moment so went centos being I knew it was the most up to date right now in their list.
       

       
    • By AreYouLoco?
      Hi,
      I am trying to setup froxlor on my Debian LAMP. I followed the guide from here: https://github.com/Froxlor/Froxlor/wiki/Install-froxlor-on-debian and and here https://github.com/Froxlor/Froxlor/wiki/Install-froxlor-from-tarball.
      I am stuck on page that I need to provide credentials to the database. When I go forward I do get this:

      I fill in my credentials; new password for froxlor database, new password for admin account, my root password that I can use to login locally via:
      mysql -u root -p Please help

       
      EDIT:
      I did some research and I allowed remote root login.
      MariaDB [(none)]> show grants; +------------------------------------------------------------------------------------------------+ | Grants for root@localhost | +------------------------------------------------------------------------------------------------+ | GRANT ALL PRIVILEGES ON *.* TO 'root'@'localhost' IDENTIFIED VIA unix_socket WITH GRANT OPTION | | GRANT PROXY ON ''@'%' TO 'root'@'localhost' WITH GRANT OPTION | +------------------------------------------------------------------------------------------------+  
    • By veto
      have now successfully a default froxlor + apache2 + mod_apache + php7  running.
      the problem is now that some php webapps are not supporting php7.
      i read the debian9 can run multiple php version 
      and i installed php 5.6 with
      apt-get install apt-transport-https curl https://packages.sury.org/php/apt.gpg | apt-key add - echo 'deb https://packages.sury.org/php/ stretch main' > /etc/apt/sources.list.d/deb.sury.org.list apt-get update https://pehapkari.cz/blog/2017/03/27/multiple-php-versions-the-easy-way/
      the manual is for nginx.
      i want now to run all virtual host with the default mod_php apache2 setting from froxlor but for some virtualhosts
      use another php handler like  php5.6-cgi or php5.6-fmp.
      there so many different setting possible and with the decaying search quality it difficult to find a staring point
       
       
       
    • By headtrick
      Hello there.
      After updating to PHP 7.1 with FPM my customer sites work perfectly, however I cannot access the Froxlor backend (as well as phpmyadmin) anymore, I get an error 503. Froxlor is supposed to also run with FPM.
      I am running on Debian8, Apache 2.4, PHP 7.1, PHP 7.1-FPM
      The apache error log reads:
      [Tue Jun 06 21:56:28.394119 2017] [proxy:error] [pid 6572] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /run/php/php7.1-fpm.sock (*) failed [Tue Jun 06 21:56:28.394177 2017] [proxy_fcgi:error] [pid 6572] [client x.x.x.x:35356] AH01079: failed to make connection to backend: httpd-UDS php7.1-fpm status seems ok, and the logfile is empty besides from restarts.
      Could it be related to the fact that the customer sites all run with ssl, the froxlor and phpmyadmin not yet?

      Where else can I look? Some help would be appreciated
      Best, Michael


×