Jump to content
Froxlor Forum
  • 1
helgatheviking

just installed froxlor and getting a 404

Question

My main site is WordPress and is installed in /var/www/mysite.com and I just installed froxlor in /var/www/froxlor. And when i went to http://{your-ip-address}/froxlor that trigger's WordPress' 404 page. Do I have to set up a special vhost to access froxlor? Or do I need to add something to the .htaccess to avoid WordPress trying to find a page that matches froxlor? OR, do I need to extract froxlor inside /var/www/mysite? 

 

 

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

I'd guess you already have a special vhost for your wordpress, elseway it would make no sense why you hit its 404 handler...A common default vhost points to /var/www/, that's why we can say: open http://[ip]/froxlor ...

Share this post


Link to post
Share on other sites
  • 0

Yes, I have a custom vhost for WordPress, but even if it were the default vhost that would still happen as www.example.com/froxlor would still look like a "page" to WordPress so WP would try to match it and fail. Does this mean that I need a custom vhost for Froxlor? 

Share this post


Link to post
Share on other sites
  • 0

Froxlor handles its own stuff. You should add a customer and move the wordpress stuff in the customer docroot with its own domain/subdomain.

Share this post


Link to post
Share on other sites
  • 0
On 2/25/2016 at 9:20 AM, d00p said:

Froxlor handles its own stuff. You should add a customer and move the wordpress stuff in the customer docroot with its own domain/subdomain.

 

By own domain/subdomain do you mean have froxlor at froxlor.mysite.com instead of mysite.com/froxlor?

Share this post


Link to post
Share on other sites
  • 0

No, customer was not a typo.

 

Open froxlor, add a customer, move wordpress to the customers docroot, remove any custom vhosts and let froxlors cronjob create them for you.

 

Then you can open wordpress with the standardsubdomain created by froxlor or you add another domain for the customer and use that.

Share this post


Link to post
Share on other sites
  • 0

I'm talking about my own server setup and don't see where any customers figure into the equation, so I'm very confused about your use of the word here. What does adding a customer mean/entail? And I can't open froxlor, that's the point of this thread. 

Share this post


Link to post
Share on other sites
  • 0

1) remove all custom vhosts and let the default point to /var/www/ as intended. that way you can open http://[ip]/froxlor

 

2) you do know what froxlor is for dont you? I'm a bit confused that you don't know what i mean with "customer". That's what froxlor is about, providing an interface for shared-hosting customers (and you as admin of course...)

Share this post


Link to post
Share on other sites
  • 0

Thanks for breaking it down for me. Since a customer is someone who buys things and I thought Froxlor was a server management UI somewhat akin to cpanel, I didn't see the connection. I appreciate the clarification and will try your suggestions a little later on. 

Share this post


Link to post
Share on other sites
  • 0

We are somewhat like cpanel....it's the same thing there....you may want to call it "users" instead of "customers" if it suites you better, but it stays the same somehow. 

Share this post


Link to post
Share on other sites
  • 0
16 minutes ago, Sofia Bovino said:

I am facing the same error, and i tried the solutions which are given above but still facing the same:( anyone for help please

Too less information, what is your EXACT problem, provide steps to reproduce/test, give information about setup, distribution, vhost-content, etc.etc.etc. please

Share this post


Link to post
Share on other sites
  • 0

For future reference. If you have installed froxlor via package manager (for me ubuntu 18.04). The default directory is /var/www/html for apache server. You have to edit default config file and change the webserver default to /var/www

```

nano /etc/apache2/sites-available/000-default.conf

```

Once you have done it restart the apache server and go to http://<IP>/froxlor you should see the installation panel.

Share this post


Link to post
Share on other sites
  • 0
4 minutes ago, Sisir Adhikari said:

For future reference. If you have installed froxlor via package manager (for me ubuntu 18.04). The default directory is /var/www/html for apache server. You have to edit default config file and change the webserver default to /var/www

```

nano /etc/apache2/sites-available/000-default.conf

```

Once you have done it restart the apache server and go to http://<IP>/froxlor you should see the installation panel.

1) old thread

2) this is mentioned in our wiki already

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Henrik
      Hi 
      I have not yet installed Froxlor, but before I do so I would like to know if it is possible to install Froxlor on a server where the Database MySql server is actually located on another server?
      So the webserver is separated from the database server?
      Henrik
    • By Matteo
      I am installing Froxlor 10 on Debian 10 with MySQL and Apache2 on a home web server.
      I get to the installation screen by going to localhost/froxlor and I get
      "Welcome to Froxlor"
      "It seems that Froxlor has not been installed yet."
      "Click on the link below to start the installation."
      I click "Start Install" and get to this page:
      Checking system requirements...
      All requirements are satisfied [green] and this is at the bottom:
      All requirements are satisfied
        Clicking the link to continue takes me to:
      Database connection
      MySQL-Hostname:
      Database name:
      Username for the unprivileged MySQL-account:
      Password for the unprivileged MySQL-account:
      Username for the MySQL-root-account:
      Password for the MySQL-root-account:
       
      Administrator Account
      Administrator Username:
      Administrator Password:
      Administrator-Password (confirm):
      Enable the official newsfeed
      (https://inside.froxlor.org/news/):
       
      Server settings
      Server name (FQDN, no ip-address):
      Server IP:
      Webserver Apache 2.4:
      HTTP username:
      HTTP groupname:
       
      [With all the correct fields and passwords filled in...]
      Clicking the [continue] button takes me to the success screen...:
      Froxlor install - setup
      Checking MySQL-root access... OK Creating backup of old database... OK  Preparing database... OK Creating database and username... OK Testing if database and user have been created correctly... OK Importing data... OK Adjusting settings... OK Inserting new values... OK Creating admin-account... OK Creating configfile... File was saved in /... Froxlor was installed successfully.
        Clicking the login button takes me to this:
      "Welcome to Froxlor"
      "It seems that Froxlor has not been installed yet."
      "Click on the link below to start the installation."
      And the process starts all over again...
      It doesn't matter which browser I use - Chrome, Firefox - the result is the same.
      I am a new Linux user, so some help would be appreciated.
      Thank you.
       
    • By irisdina
      Warning, this is not an official guide!!!
      1.
      sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list
      sudo nano /etc/apt/source.list 1b.  insert (for Debian Stretch)
      1.2B (for Ubuntu Cosmic)
       
      1c. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. 
      sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server
      2. MariaDB install
      Warning use sudo command für this install!
      sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional)
      3. nginx install
      sudo apt install nginx 3a. 
      mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf
      4. PHP install
      sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. 
      sudo service nginx restart sudo service php7.3-fpm restart Froxlor install
      There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master)
      Stable Version
      1. 
      cd /var/www/html/ 1a. 
      sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or
      Git Version (Beta Version)
      sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer  su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory
      composer install --no-dev 1b. 
      sudo chown -R www-data:www-data Froxlor/ Set up Froxlor
      2. Open Your Browser
      2a.
      http://your IP or Hostname/Froxlor
       

      Install Froxlor finish
       3d. Move userdata (Optional) 
      sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. 
      sudo rm /etc/nginx/site-enable/default don't restart nginx!
      Froxlor Settings
      1. Cronjob
      sudo nano /etc/cron.d/froxlor insert 
      # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend
      Settings > Webserver settings > Nginx PHP backend
      from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock
      3. 
      sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port

      2a(1), SSL Port



      Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually
      sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional
      PHP-FPM activate
      1. User/Group add
      sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install 
      sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

      3. Settings > PHP-FPM > Activated:
      Change from NO to YES
      3a. PHP-FPM versions
      Change > php-fpm restart command:
      service php7.3-fpm restart and
      Configuration directory of php-fpm: > to 
      /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

      3c. 
      sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate
      1.
      sudo apt install certbot 1a. 
      sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File
      sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. 
      sudo nano /etc/nginx/acme.conf insert
      location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } }  
      2. Open your  Froxlor Panel
      Settings> SSL > Activated:
      Change from NO to YES
      2a. Settings > SSL > Settings
      Change your path from your certificate / Keyfile
      Path to the SSL certificate
      insert
      /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile
      insert
      /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings
      Activate > Enable Let's Encrypt

      Change Path to the acme.conf snippet to > 
      /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings
      - Enable Let's Encrypt for the froxlor vhost
      - Enable SSL-redirect for the froxlor vhost
      - HTTP Strict Transport Security (HSTS)
      - Include HSTS for any subdomain






      2d. Activated HTTP2 Support on > Settings > Nginx
       
    • By shaaz
      Is that possible to install froxlor in c-panel using one database user password?
      Or how can we skip the values of mysql_unpriv_user and mysql_unpriv_pass while installing?
    • By adamjedgar
      Hi guys,
       
      I have a google cloud compute debian instance
      I have been experimenting with a couple of alternatives to cpanel. Just installed virtualmin and now am looking at froxlor.
       
      I have followed the install outline as documented.
      1. I setup a google cloud launcher LAMP
      2. navigated in browser to <myserveripadress> to ensure apache is working (which it is)
      3. downloaded froxlor to /var/www/ directory
      4. chown froxlor to www-data:www-data (i also checked to ensure my webserver is running as www-data)
       
      Now when i attempt to navigate to http://<mywerveripadress>/froxlor i get the following error in browser 
      "NOTFOUND" the requested URLwas not found on this server.
       
      now when i ssh into server, froxlor is definatelly in /var/www/ directory.
      permissions are  0755 www-data:www-data
       
      i am not sure what i have done wrong?
       
      has anyone with experience in installing this on google cloud got any advice?
×
×
  • Create New...