Jump to content
Froxlor Forum
  • 0
Utini

Die richtigen Mail Einstellungen am Server (FQDN,DNS,Postfix,dovecot...) ?

Question

Hallo zusammen,

?ich bekomme in letzter Zeit komische error E-Mails als Antwort zur?ck und wollte deswegen mal nachfragen ob meine Einstellungen bzgl. dovecot + postfix korrekt sind? Ich kann sowohl E-Mail senden als auch Empfangen wobei ich das Gef?hl habe das teilweise E-Mails bei mir nicht ankommen bzw. beim Empf?nger ankommen. Testmails in die Arbeit bzw. an mich selbst funktionieren.

?Beispiel:

This is the mail system at host mail.s1.my-domainxy.com.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<xxx@gmx.at>: host mx00.emig.gmx.net[212.227.15.9] refused to talk to me:

554-gmx.net (mxgmx010) Nemesis ESMTP Service not available 554-No SMTP

service 554-Bad DNS PTR resource record. 554 For explanation visit

http://postmaster.gmx.com/en/error-messages?ip=xx.xxx.xx.xx.72&c=rdns

------------------------------------------------------------------------------

This is the mail system at host mail.s1.my-domainxy.com.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<xxxmail@gmx.at>: host mx00.emig.gmx.net[212.227.15.9] refused to talk to

me: 554-gmx.net (mxgmx009) Nemesis ESMTP Service not available 554-No SMTP

service 554-Bad DNS PTR resource record. 554 For explanation visit

http://postmaster.gmx.com/en/error-messages?ip=xx.xxx.xx.xx&c=rdns

------------------------------------------------------------------------------

This is the mail system at host mail.s1.my-domainxy.com.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<xxxmail@gmx.at>: host mx01.emig.gmx.net[212.227.17.5] refused to talk to

me: 554-gmx.net (mxgmx113) Nemesis ESMTP Service not available 554-No SMTP

service 554-Bad DNS PTR resource record. 554 For explanation visit

http://postmaster.gmx.com/en/error-messages?ip=xx.xxx.xx.xx.&c=rdns

------------------------------------------------------------------------------

This is the mail system at host mail.s1.my-domainxy.com.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<kontakt@dmoain.de>: host srv.f3g.de[111.111.111.11] said: 450 4.7.1 Client

host rejected: cannot find your hostname, [62.240.105.82] (in reply to RCPT

TO command)

Sowie auch diese Meldung:


This is the mail system at host mail.s1.my-domainxy.com.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<webmaster@my-domainxy.com>: temporary failure. Command output: doveconf: Fatal:
open(/etc/dovecot/dovecot.conf) failed: Permission denied

-----------------------------------------------------------------------------------------

?File permissions (alles CHMOD 640):

ls -al /etc/dovecot/conf.d/
total 184
drwxr-xr-x 2 root root  4096 Dec 29 12:11 .
drwxr-xr-x 5 root root  4096 Jan 12 17:50 ..
-rw-r----- 1 root root  5301 Jan 12 17:51 10-auth.conf
-rw-r--r-- 1 root root  5296 Jun 20  2015 10-auth.conf.frx.bak
-rw-r--r-- 1 root root  1893 Jun 20  2015 10-director.conf
-rw-r--r-- 1 root root  2727 Jun 20  2015 10-logging.conf
-rw-r----- 1 root root 15601 Dec 29 12:09 10-mail.conf
-rw-r--r-- 1 root root 15596 Jun 20  2015 10-mail.conf.frx.bak
-rw-r----- 1 root root  3529 Jan 12 17:50 10-master.conf
-rw-r--r-- 1 root root  3383 Jun 20  2015 10-master.conf.frx.bak
-rw-r--r-- 1 root root  2241 Jan 16 19:37 10-ssl.conf
-rw-r--r-- 1 root root   291 Jun 20  2015 10-tcpwrapper.conf
-rw-r----- 1 root root  1704 Dec 29 12:09 15-lda.conf
-rw-r--r-- 1 root root  1668 Jun 20  2015 15-lda.conf.frx.bak
-rw-r--r-- 1 root root  1137 Jun 20  2015 15-mailboxes.conf
-rw-r----- 1 root root  2441 Dec 29 12:10 20-imap.conf
-rw-r--r-- 1 root root  2425 Jun 20  2015 20-imap.conf.frx.bak
-rw-r----- 1 root root  2398 Dec 29 12:10 20-managesieve.conf
-rw-r--r-- 1 root root  2398 Jun 20  2015 20-managesieve.conf.frx.bak
-rw-r----- 1 root root  4007 Dec 29 12:10 20-pop3.conf
-rw-r--r-- 1 root root  4007 Jun 20  2015 20-pop3.conf.frx.bak
-rw-r--r-- 1 root root   676 Jun 20  2015 90-acl.conf
-rw-r--r-- 1 root root   292 Jun 20  2015 90-plugin.conf
-rw-r--r-- 1 root root  2502 Jun 20  2015 90-quota.conf
-rw-r----- 1 root root  5068 Dec 29 12:11 90-sieve.conf
-rw-r--r-- 1 root root  5062 Jun 20  2015 90-sieve.conf.frx.bak
-rw-r--r-- 1 root root  1829 Jun 20  2015 90-sieve-extprograms.conf
-rw-r--r-- 1 root root   499 Jun 20  2015 auth-checkpassword.conf.ext
-rw-r--r-- 1 root root   489 Jun 20  2015 auth-deny.conf.ext
-rw-r--r-- 1 root root   343 Jun 20  2015 auth-dict.conf.ext
-rw-r--r-- 1 root root   561 Jun 20  2015 auth-master.conf.ext
-rw-r--r-- 1 root root   515 Jun 20  2015 auth-passwdfile.conf.ext
-rw-r--r-- 1 root root   788 Jun 20  2015 auth-sql.conf.ext
-rw-r--r-- 1 root root   611 Jun 20  2015 auth-static.conf.ext
-rw-r--r-- 1 root root  2185 Jun 20  2015 auth-system.conf.ext
-rw-r--r-- 1 root root   330 Jun 20  2015 auth-vpopmail.conf.ext

?/etc/dovecot/dovecot.conf = CHMOD 640

/etc/dovecot/conf.d/10-auth.conf: https://dpaste.de/YY22
/etc/dovecot/conf.d/10-master.conf: https://dpaste.de/7u0e
/etc/dovecot/conf.d/10-ssl.conf: https://dpaste.de/ACVi

/etc/postfix/main.cf: CHMOD 644 https://dpaste.de/wNrQ
/etc/postfix/master.cf: CHMOD 644 https://dpaste.de/81v5

/etc/mailname: s1.my-domainxy.com

Mail relevante DNS Zonen:


*my-domainxy.com - A - Prio 0 - Server-IP
*.s1.my-domainxy.com - A - Prio 0 - Server-IP
my-domainxy.com - A - Prio 0 - Server-IP
mail.my-domainxy.com - A - Prio 0 - Server-IP
s1.my-domainxy.com - A - Prio 0 - Server-IP
www.my-domainxy.com - A - Prio 0 - Server-IP

my-domainxy.com - MX - Prio 10 - mail.my-domainxy.com

Ich denke meine DNS Zonen sind ein bisschen "?berfl??ig konfiguriert"?
Evtl. stimmt was mit den file permissions nicht?

Oder stimmt hier etwas nicht:

append_dot_mydomain = no
biff = no
smtpd_helo_required = yes
smtpd_recipient_restrictions = permit_mynetworks,
    permit_sasl_authenticated,
    reject_invalid_hostname,
    reject_unknown_recipient_domain,
    reject_unauth_destination,
    reject_unauth_pipelining,
    reject_rbl_client sbl.spamhaus.org,
    reject_non_fqdn_recipient,
    permit
smtpd_sender_restrictions = permit_mynetworks,
    reject_sender_login_mismatch,
    permit_sasl_authenticated,
    reject_unknown_helo_hostname,
    reject_unknown_recipient_domain,
    reject_unknown_sender_domain
smtpd_client_restrictions = permit_mynetworks,
    permit_sasl_authenticated,
    reject_unknown_client_hostname,
    reject_rbl_client dnsbl.sorbs.net
smtpd_helo_restrictions = reject_invalid_helo_hostname,
        reject_non_fqdn_helo_hostname,
        reject_unknown_helo_hostname

Oder ist der Fehler hier begraben?

?myhostname = mail.$mydomain
mydomain = s1.domain.com

?

Danke !

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Steht da in der mail: Bad PTR -> dein reverse dns korrekt f?r den fqdn der in der main.cf steht unter mydomain?

Share this post


Link to post
Share on other sites
  • 0

Steht da in der mail: Bad PTR -> dein reverse dns korrekt f?r den fqdn der in der main.cf steht unter mydomain?

Damit meinst du die dns zonen der domain? Die sind wie oben angef?hrt und f?r die "mydomain=" gibts es die passende dns zone (siehe oben) :/

Share this post


Link to post
Share on other sites
  • 0

Das ist die dns zone der domain, ich Rede vom reverse dns, also IP zu domain Aufl?sung.

Share this post


Link to post
Share on other sites
  • 0

Das ist die dns zone der domain, ich Rede vom reverse dns, also IP zu domain Aufl?sung.

 

Also BIND9 ? Oder die hosts datei ? oder hostname / mailname ? Oder bin ich da immer noch falsch? :o

 

In jedem Fall, hier die eintr?ge:

 

/etc/hostname: domain

/etc/mailname: s1.domain.com

 

/etc/hosts:

 

127.0.0.1       localhost
127.0.1.1       sd-xxxxx.dedibox.fr domain
11.111.11.11 s1.domain.com domain.com

 

LG

Share this post


Link to post
Share on other sites
  • 0

Ja, BIND w?re richtig, froxlor legt KEINE rdns Zonen an...und 90% der user verwenden auch externe Nameserver und nicht ihren eignen Server.

Share this post


Link to post
Share on other sites
  • 0

Ja, BIND w?re richtig, froxlor legt KEINE rdns Zonen an...und 90% der user verwenden auch externe Nameserver und nicht ihren eignen Server.

 

Also BIND habe ich gem. froxlor konfigurations template installiert und konfiguriert. Und da gibt es nicht wirklich etwas zu ?ndern?

 

Hilft dieser ouput weiter (auf meinem laptop system ausgef?hrt)?

sneida@_____:~$ host xxx.xx.xxx.xx
xxx.xx.xxx.xx2.in-addr.arpa domain name pointer xxx.xx.xxx.xx.rev.poneytelecom.eu.
sneida@_____:~$ host xxx.xx.xxx.xx
xxx.xx.xxx.xx.in-addr.arpa domain name pointer xxx.xx.xxx.xx.rev.poneytelecom.eu.
sneida@_____:~$ dig xxx.xx.xxx.xx

; <<>> DiG 9.10.3-P3 <<>> xxx.xx.xxx.xx
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 55442
;; flags: qr aa rd ra ad; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1280
;; QUESTION SECTION:
;xxx.xx.xxx.xx.            IN    A

;; ANSWER SECTION:
xxx.xx.xxx.xx       0    IN    A    xxx.xx.xxx.xx

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sat Jan 23 15:10:31 CET 2016
;; MSG SIZE  rcvd: 58

sneida@_____:~$ nslookup xxx.xx.xxx.xx
Server:        127.0.0.1
Address:    127.0.0.1#53

Non-authoritative answer:
xxx.xx.xxx.xx.in-addr.arpa    name = xxx.xx.xxx.xx.rev.poneytelecom.eu.

Authoritative answers can be found from:

sneida@_____:~$ dig +noall +answer -x xxx.xx.xxx.xx
xxx.xx.xxx.xx.in-addr.arpa. 86299 IN    PTR    xxx.xx.xxx.xx.rev.poneytelecom.eu.

Wobei die IP "xxx.xx.xxx.xx" die server ip ist.

 

bzw das hier?

sneida@_____:~$ nslookup domain.com 
Server:        127.0.0.1
Address:    127.0.0.1#53

Non-authoritative answer:
Name:    domain.com
Address: xxx.xx.xxx.xx

sneida@_____:~$ dig +noall +answer -x domain.com 
sneida@_____:~$ dig domain.com

; <<>> DiG 9.10.3-P3 <<>> domain.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41147
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1280
;; QUESTION SECTION:
;domain.com.            IN    A

;; ANSWER SECTION:
domain.com.        1621    IN    A    xxx.xx.xxx.xx

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sat Jan 23 15:14:05 CET 2016
;; MSG SIZE  rcvd: 56

Share this post


Link to post
Share on other sites
  • 0

Ahh ich kann den reverse DNS bei meinem hosting anbieter ?ndern.. und der sollte nun auf "s1.domain.com" eingestellt werden ?

Share this post


Link to post
Share on other sites
  • 0

W?ren damit folgende Einstellungen korrekt (domain.com ist in meinem Fall ein customer + domain im froxlor webpanel, darum s1.domain.com f?r hostname+fqdn?) ?

?reverse dns: s1.domain.com
hostname: s1.domain.com

?

/etc/resolv.conf:

domain domain.com
search domain.com
#nameserver xx.xxx.xx.xx (oder wird dieser Eintrag ben?tigt?)
#nameserver xx.xxx.xx.xx (oder wird dieser Eintrag ben?tigt?)

/etc/hosts:

127.0.0.1       localhost localhost
xx.xxx.xx.xx s1.domain.com

/etc/postfix/main.cf:

mydomain = domain.com
myhostname = s1.domain.com

DNS Record:
s1.domain.com - MX - Prio 10 - xx.xxx.xx.xx

Share this post


Link to post
Share on other sites
  • 0

DNS, main.cnf und hosts passen.

 

An deiner resolv.conf solltest du nicht rumfummeln, wenn du dir nicht sicher bist.

Da kommen die Resolver rein, die du verwenden willst. Entweder die von deinem Provider,

oder z.B. die von Google (8.8.8.8, 8.8.4.4). Ohne die Resolver kann dein Server keine DNS

mehr aufl?sen.

Share this post


Link to post
Share on other sites
  • 0

DNS, main.cnf und hosts passen.

 

An deiner resolv.conf solltest du nicht rumfummeln, wenn du dir nicht sicher bist.

Da kommen die Resolver rein, die du verwenden willst. Entweder die von deinem Provider,

oder z.B. die von Google (8.8.8.8, 8.8.4.4). Ohne die Resolver kann dein Server keine DNS

mehr aufl?sen.

 

Ich musste einiges mehr anpassen. Das installieren/konfigurieren von SPF + OpenDKIM hat ebenfalls geholfen.

 

Bzgl revolv.conf:

nameserver w?rde ich nicht ?ndern aber "domain" und "search" ? Die beiden sind momentan auf "mein-server-provider.com" eingestellt. Ich w?rde hier meine eigene domain hinterlegen?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now





×
×
  • Create New...