Jump to content
Froxlor Forum
  • 0

Awstats Source-Version


franky1973

Question

Vielleicht kann mir hier jemand helfen. Ich versuche auf meinem Webserver (Debian 7) Awstats 7.3 zu verwenden. Nun gibt mir Froxlor aber vor eine Standardinstallation via apt-get (das w?re Awstats 7.0) verwenden zu wollen, die ganz andere Strukturen anlegt und Verweise. Gibt es eine wie auch immer geartete Anleitung, wie ich Awstats aus der Source installieren kann und es dann mit Froxlor verkn?pfe?

 

Vielen Dank schon mal im Voraus

 

Gr??e

 

Franky

Link to post
Share on other sites

13 answers to this question

Recommended Posts

Awstats ist vollkommen losgel?st von Froxlor. Du kannst in den Froxlor-Einstellungen die entscheidenden Pfade alle anpassen. Wie du awstats nun manuell kompilierst und installierst entnimmst du bitte deiner googlesuche ;) Das d?rfte nicht allzuschwer sein

Link to post
Share on other sites

Ok - ich hab mir das Ganze mal genau durchgeschaut und habe es auch zum Laufen gebracht. Musste allerdings 2 Froxlor-Dateien patchen weil es nicht ganz so trivial ist. Ich setze Debian 7 mit lighttpd ein, das soweit noch als Zusatzinformation. Awstats ist jetzt neu unter /usr/local/awstats installiert aus der Source. In den Froxlor-Einstellungen ergeben sich somit folgende Einstellungen f?r die Statistik:

 

Pfad zu AWStats 'awstats_buildstaticpages.pl' -> /usr/local/awstats/tools/

 

Pfad zu AWStats 'awstats.pl' -> /usr/local/awstats/wwwroot/cgi-bin/

 

AWStats Konfigurations-Pfad -> /usr/local/awstats/wwwroot/cgi-bin/

 

Pfad zum AWstats-Icon-Ordner -> /usr/local/awstats/wwwroot/icon/

 

Folgende Patches habe ich gemacht:

 

1. cron_tasks.inc.http.20.lighttpd.php

 

Hier musste ich die zus?tzlich erforderlichen alias-urls und auch die erforderliche script-url eintragen.

Durch die Kapselung durch Bedingungen hier ganze 4 mal.

Leider konnte ich die nur hardcoded machen, da Froxlor f?r diese Werte im Moment noch keine Felder vorsieht.

Im Einzelnen sind dies:

/awstatsclasses sowie /awstatscss und der script-alias /awstats/
 
Somit wird aus
$stats_text.= '  alias.url = ( "/awstats/" => "'.makeCorrectFile($domain['customerroot'] . '/awstats/' . $domain['domain']).'/" )' . "\n";
$stats_text.= '  alias.url += ( "/awstats-icon" => "' . makeCorrectDir(Settings::Get('system.awstats_icons')) . '" )' . "\n";

dann

$stats_text.= '  alias.url = ( "/awstats/" => "'.makeCorrectFile($domain['customerroot'] . '/awstats/' . $domain['domain']).'/" )' . "\n";
$stats_text.= '  alias.url += ( "/awstats-icon" => "' . makeCorrectDir(Settings::Get('system.awstats_icons')) . '" )' . "\n";
$stats_text.= '  alias.url += ( "/awstatsclasses" => "/usr/local/awstats/wwwroot/classes/" )' . "\n";
$stats_text.= '  alias.url += ( "/awstatscss" => "/usr/local/awstats/wwwroot/css/" )' . "\n";
$stats_text.= '  cgi.assign = ( "/awstats/" => "/usr/local/awstats/wwwroot/cgi-bin/" )' . "\n";
 
2. cron_traffic.inc.functions.php
 
Hier muss nur ein ?bergabewert angeh?ngt werden, damit awstats_buildstaticpages.pl die Bilder richtig verlinkt
Zeile 46
aus
safe_exec($awbsp.' -awstatsprog='.escapeshellarg($awprog).' -update -month=' . date('n') . ' -year=' . date('Y') . ' -config=' . $domain . ' -dir='.escapeshellarg($outputdir));

wird

safe_exec($awbsp.' -awstatsprog='.escapeshellarg($awprog).' -update -month=' . date('n') . ' -year=' . date('Y') . ' -config=' . $domain . ' -dir='.escapeshellarg($outputdir) . ' -diricons=/awstats-icon');

Jetzt funktioniert alles wunderbar - die Statistiken werden korrekt erzeugt und angezeigt inkl. aller Grafiken.

 

Das hier nur als Information hoffentlich f?r zuk?nftige Versionen oder Probleml?sung, falls jemand das gleiche Problem hat.

Link to post
Share on other sites

"diricons" Parameter sollte nicht n?tig sein, der kommt aus den settings und wird in die awstats-domain-config geschmissen. Das awstatsclasses und awstatscss selbst auch noch nen alias brauchen kommt mir merkw?rdig vor, hast du da vllt bei der kompilierung/configure f?r alles einzelne pfade spezifiziert?

Link to post
Share on other sites

Ohne den diricons-Parameter hatten bei mir die statischen Awstats-Seiten keinerlei Icons und haben den relativen Pfad /icon f?r alle Grafiken verwendet. Dort fehlte in diesem Fall das /awstats-icon vorn.

 

Zu awstatsclasses und awstatscss:

 

http://www.awstats.org/docs/awstats_setup.html

 

Da lighttpd bekannlich keine httpd.conf hat, habe ich die angezeigten ?nderungen in das Lighttpd-Format ?bersetzt und ?bernommen.

Link to post
Share on other sites

Nur so noch als Anmerkung generell zu Froxlor/Awstats. Im Normalfall sind die Statistiken f?r jeden einsehbar, also nicht passwortgesch?tzt, was nicht unbedingt jeder gut findet. Hier w?re es toll, wenn dies direkt im User-Interface eingestellt werden k?nnte.

Link to post
Share on other sites

Nur so noch als Anmerkung generell zu Froxlor/Awstats. Im Normalfall sind die Statistiken f?r jeden einsehbar, also nicht passwortgesch?tzt,

ist doch gar nicht wahr...es gibt f?r die statistik-ordner per default beim anlegen des Kunden schon nen verzeichnisschutz

Link to post
Share on other sites

Ohne den diricons-Parameter hatten bei mir die statischen Awstats-Seiten keinerlei Icons und haben den relativen Pfad /icon f?r alle Grafiken verwendet. Dort fehlte in diesem Fall das /awstats-icon vorn.

Daf?r gibt es ja die einstellung "pfad zu awstats-icons" so dass unser cron einen entsprechenden alias setzt in der webserver-config

Link to post
Share on other sites

hmm eigenartig - war bei mir nicht so - in /etc/lighttpd/froxlor-htpasswd ist bei mir auch nichts drin und in den einzelnen Domain-Dateien auch nicht. htaccess-Dateien gibt es bei lighty nicht und eine dritte M?glichkeit f?llt mir dazu nicht ein.

 

Hier mal die Umgebungsvariablen:

 

System: Debian 7.8
Kernel-Version: 4.0.0
Webserver: Lighttpd 1.4.35
PHP-Version: 5.6.8
Perl-Version: 5.14.2
MySQL-Server-Version: 5.5.43
Link to post
Share on other sites

Ich habe hier, um den Passwortschutz relativ einfach zu realisieren einen Eintrag in das Feld "Eigene vHost Einstellungen" unter Froxlor f?r die betreffende Domain vorgenommen:

$HTTP["url"] =~ "/awstats/" {
        auth.backend = "htpasswd"
        auth.backend.htpasswd.userfile = "/var/customers/webs/kundendomain/awstats_htpasswd"
        auth.require = ( "" => (
                "method" => "basic",
                "realm" => "Statistik",
                "require" => "user=benutzername"
                )
        )
        setenv.add-environment = ( "REMOTE_USER" => "benutzername" )
}

Die Datei /var/customers/webs/kundendomain/awstats_htpasswd l?sst sich unter Debian recht einfach mit dem Befehl htpasswd anlegen, der im Paket apache2-utils enthalten ist (erfordert keinen Apache - keine Sorge).

Link to post
Share on other sites

Ja ich denke, dass es dort noch etwas hakelig ist. Ich pers?nlich setze lighttpd seit l?ngerer Zeit ein und kann es nur jedem empfehlen. Klein, schnell und f?r High-Traffic Seiten nahezu ideal.

klingt mehr nach der beschreibung von nginx :P

 

Ich habe hier, um den Passwortschutz relativ einfach zu realisieren einen Eintrag in das Feld "Eigene vHost Einstellungen" unter Froxlor f?r die betreffende Domain vorgenommen:

Der Code daf?r is im cronjob drin, k.A. was du da tust, hab jetzt aber gerade keine zeit mir ne lighttdp testmaschine aufzubauen. Ein Manueller Eintrag in die Eigene vHost Einstellungen sollte aber nicht notwendig sein.

 

Die Datei /var/customers/webs/kundendomain/awstats_htpasswd l?sst sich unter Debian recht einfach mit dem Befehl htpasswd anlegen, der im Paket apache2-utils enthalten ist (erfordert keinen Apache - keine Sorge).

Auch das braucht man normal nicht, das macht alles froxlor

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Similar Content

    • By kutte128
      Hallo,
       
      ich habe merkwürdiges Problem bei der awstats Traffic-Generierung: der letzte Tag jedes Monats ist 0 oder wenig drüber.
      Es wird auch nicht auf den nächsten Tag angerechnet, der letzte fehlt einfach.
       
      Logrotate läuft im cron.daily jede Nacht um 03:00h, die Traffic-Generierung standardmäßig um 0:00h.
      Das sollte doch passen oder habe ich irgendwo einen Denkfehler?
      Das logrotate-Script ist aus der "Konfiguration", das cron-Script ist auch original und ein weiteres logrotate-Script was für die apache-logs zuständig sein könnte, läuft auch nicht.
       
      Wenn ich die Statistiken manuell per shell generiere, sind die Daten vollständig
       
      Greetz,
      kutte128
    • By kutte128
      Hallo,
       
      gibt es einen workaround f?r awstats, so dass der Kunde auch die vergangenen Monate ausw?hlen kan?
      Aktuell sieht man ja nur die kompletten Statisken f?r den aktuellen Monat bzw f?r den manuell ?ber staticpages generierten.
       
      Greetz,
      kutte128
    • By behrang
      Hi
      when a customer has many domains he will see awstats for all domains.
      we would like to seperate stats for each domains. The question is: is this maybe possible by preferences already.
      or do we have to change confs manually and is it on the vhost side or within awstats itself.
      thx
    • By mangorausch
      Moinsen. 
       
      Besteht die M?glichkeit, dass "awstats" nicht im Kundenverzeichnis angezeigt werden kann?
      Idealerwei?e soll awstats weiter laufen und funktionieren in diesem Kundenverzeichnis, aber eben nicht angezeigt werden.
       
      Gibt es hierzu eine L?sung oder ist das "unm?glich"?
    • By mark.doe
      Regurlary I am getting this in my email:
       

      Create/Update database for config "/etc/awstats/awstats.customer1office.net.conf" by AWStats version 6.95 (build 1.943) From data in log file "/var/customers/logs/customer1-customer1office.net-access.log"... Phase 1 : First bypass old records, searching new record... Direct access after last parsed record (after line 92287) Error: Couldn't open file "/var/customers/webs/customer1/awstats/customer1office.net/awstats072012.customer1office.net.tmp.7522" for write: Permission denied Setup ('/etc/awstats/awstats.customer1office.net.conf' file, web server or permissions) may be wrong. Check config file, permissions and AWStats documentation (in 'docs' directory). Error: SiteDomain parameter not defined in your config/domain file. You must edit it for using this version of AWStats. Setup ('/etc/awstats/awstats.model.conf' file, web server or permissions) may be wrong. Check config file, permissions and AWStats documentation (in 'docs' directory).
       
      What should be the right permissions?
×
×
  • Create New...