Jump to content
Froxlor Forum

kutte128

Members
  • Content count

    32
  • Joined

  • Last visited

Community Reputation

0 Neutral

About kutte128

  • Rank
    Advanced Froxie
  1. php-fpm crasht regelmäßig

    Ich glaube ich kann jetzt nachvollziehen was der Grund für die Crashes ist. Ein Kunde nutzt eine Wordpress-Seite und wenn der reload/restart Befehl für den PHP-Prozess kommt und wp-cron läuft, wird das Child nicht gekillt und PHP startet nicht mehr. Ich habe ein strace laufen lassen und manuell restarted. Der Prozess läuft unbeirrt weiter, php wirft sein start-stop-daemon: 1 process refused to stop aus und die Seiten sind nicht mehr aufrufbar. Das kann ich jederzeit wiederholen (php5.6 und php7) wenn der wp-cron was längeres zu tun hat oder er diese strace Meldung ausgibt. accept(0, 0x7fffd8a23f30, [112]) = ? ERESTARTSYS (To be restarted if SA_RESTART is set) --- SIGQUIT {si_signo=SIGQUIT, si_code=SI_USER, si_pid=10658, si_uid=0} --- rt_sigreturn({mask=[]}) = -1 EINTR (Interrupted system call) Der Prozess lässt sich nur mit SIGKILL beenden. Jemand eine Idee wo das Problem liegen kann?
  2. Mehrere VHOSTs mit einer IP Adresse

    Das funktioniert "von Haus aus" auch per Domain: Kunde öffnen, Domains -> Einstellungen, auf dass SSL-Symbol der jeweiligen Domain klicken und den Inhalt deiner Zertifikate in die entsprechenden Felder reinkopieren
  3. php-fpm crasht regelmäßig

    Guten Morgen, hab mir das mal in der entsprechenden Zeit mal angeschaut, "leider" kein Crash. Ich hatte auf static mit genau einen Child pro vhost. Auf einem vhost bekam ich nach einer Weile einen bleibenden timeout: DEBUG: pid 31535, fpm_pctl_perform_idle_server_maintenance(), line 362: [pool www] currently 0 active children, 0 spare children Aber der Rest war weiterhin erreichbar. Das selbe Problem hatte ich vorher bei einem gleichen Versuch bei einem anderen vhost, also auch hier random. strace gab auch nichts auffälliges von sich, logs auch nicht. Load, Swap etc auch alles gut Aufgefallen ist mir, dass ich häufiger beim ersten php-fpm restart eine "refused to stop" Meldung erhalte und dann natürlich der Dienst nicht startet. Das passiert wenn er einige Stunden lief. Der Grund ist mir noch ein Rätsel genau wie warum er gerade immer in der Zeit von 2:40 - 3:15 crasht. Außer logrotate um 3:10h, in dem aber kein php mehr ist, passiert da nicht viel
  4. php-fpm crasht regelmäßig

    ah danke, werd ich mir mal anschauen
  5. php-fpm crasht regelmäßig

    Leider nicht, es sind leider verschiedene User und verschiedene Seiten. Meine Idee zum triggern war, dass ich den Server mit 'ab' stresse damit er sich irgendwie verabschiedet, aber davon war er unbeeindruckt.
  6. php-fpm crasht regelmäßig

    Mahlzeit! Ich habe seit ein paar Tagen das Problem, dass sich mein php bei einigen Sites regelmäßig verabschiedet. Aktuell laufen 71 Webpages, davon werden ein paar gut besucht. Ich habe sowohl php 5.6 als auch 7 am laufen. Die Systemauslastung ist sehr niedrig. Es werden keine Fehler geloggt und auch per Stress-Test mit apache bench kann ich keine Probleme finden. In der slowlog taucht auch nichts besonderes auf, auch scheint es keine Probleme mit libraries zu geben. Und es gibt mehr als genug Platz auf der HDD und auch unter /tmp Ursprünglich hatte ich keine max-requests Limitierung, das klappte monatelang ohne Probleme. Jetzt sind noch ein paar kleinere Sites dazu gekommen, ab da stürzte mir php alle paar Stunden ab und blieb auch tot. Ich habe die requests dann auf 500 gesetzt, damit lief er dann 3 Tage bis er wieder komplett hing. Mit 200 läuft er jetzt seit gestern, hing dann heute Nacht um ca 1:00 und ca 3:00. Allerdings nur für ein paar Sekunden und lief danach wieder bis kurz nach 10Uhr - auch nur ein paar Sekunden. Die betroffenen Sites werden Random gewählt. Mal ist es ein OpenCart oder Joomla unter php 5.6, mal ein Shopware unter php7, es können aber auch mehrere betroffen sein. Durchschnittlich werden 25MB pro php Prozess verbraucht. Meine aktuelle conf für php 5.6/php 7: listen = /var/lib/apache2/fastcgi/USER-domain.de-php-fpm.socket listen.owner = USER listen.group = USER listen.mode = 0660 user = USER group = USER pm = ondemand pm.max_children = 30 pm.process_idle_timeout = 10 pm.max_requests = 200 emergency_restart_threshold = 3 emergency_restart_interval = 1m process_control_timeout = 5s System: 8 Kern Intel i7-3770, 16Gb Ram, Gentoo, apache 2.4.27, php 5.6.31, php 7.0.22, mysql 5.6.36 Hat jemand eine Idee wo das Problem liegen oder wie ich es eingrenzen könnte? Gruß, kutte128
  7. Quota voll obwohl noch viel Platz

    Das ist natürlich richtig. Ich hatte früher Web + Mail getrennt und bin davon ausgegangen, dass froxlor mit Webspace + extra Mailkontingent das auch so macht. Thx für die Hilfe!
  8. Quota voll obwohl noch viel Platz

    Hi, ja, das könnte vom Platz her hinkommen Aber wäre es nicht sinnvoll, hier Mail und FTP zu trennen? Der Empfang und Versand von Mails ist ja noch bis zum angegebenen Limit möglich, auch wenn Webapce übervoll ist - was auch gut ist. FTP sollte sich vielleicht ähnlich verhalten. Bei Usern die sehr viele FTP-Daten und gleichzeitig viele IMAP E-Mailadressen nutzen, könnte das zu einem Problem werden. Da ist das Aufschlagen vom Mailkontingent auf den Webspace nur für sehr kurze Zeit eine Lösung
  9. Quota voll obwohl noch viel Platz

    Guten Morgen, die Datenbank ist um die 12Mb. Da muss noch irgend ein anderer Grund sein.
  10. Hi, ich bin über ein ganz merkwürdiges Problem gestolpert: Webspace bekam 1000 zugeordnet und es wurde Ende letzten Jahres ein Joomla installiert. Insgesamt belegt das komplette Home des Users 90Mb. Das Problem ist jetzt, dass im Panel angezeigt wird, dass der Webspace zu 112% belegt ist, Dateien per FTP zu kopieren ist auch nicht möglich weil over quota. Das ist die Ausgabe von repquota: und du -hs: Ich habe auch schon sämtliche Dateien gesucht die dem User gehören, aber es gibt nur die 90Mb. Wo könnte das Problem liegen? Greetz, kutte128
  11. awstats: letzter Tag im Monat 0 Traffic

    Thx, das werd ich mal testen.
  12. Hallo, ich habe merkwürdiges Problem bei der awstats Traffic-Generierung: der letzte Tag jedes Monats ist 0 oder wenig drüber. Es wird auch nicht auf den nächsten Tag angerechnet, der letzte fehlt einfach. Logrotate läuft im cron.daily jede Nacht um 03:00h, die Traffic-Generierung standardmäßig um 0:00h. Das sollte doch passen oder habe ich irgendwo einen Denkfehler? Das logrotate-Script ist aus der "Konfiguration", das cron-Script ist auch original und ein weiteres logrotate-Script was für die apache-logs zuständig sein könnte, läuft auch nicht. Wenn ich die Statistiken manuell per shell generiere, sind die Daten vollständig Greetz, kutte128
  13. Warnung bei Standard FTP-User

    Hi, jupp, ist passiert Viele Gr??e, kutte128
  14. Warnung bei Standard FTP-User

    Guten Morgen, ja, jetzt taucht die Meldung schon vorher direkt beim klick auf Benutzerkonten auf. Auch noch beim Standard-User, aber nicht beim manuellen User
  15. Warnung bei Standard FTP-User

    Hi, die Meldung erscheint, wenn ich als Kunde auf "Benutzerkonten" und dann bei dem Default hinten auf die Optionen klicke
×