Jump to content
Froxlor Forum

franky1973

Members
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

0 Neutral

About franky1973

  • Rank
    Newbie
  • Birthday 11/29/1973

Profile Information

  • Gender
    Not Telling
  • Location
    Berlin
  1. Ja kein Problem - wiegesagt bei mir war es nicht automatisch - ich hab es aber so hingebogen bekommen - alles super - sonst bin ich mit Froxlor sehr zufrieden. Weiter so
  2. Ich habe hier, um den Passwortschutz relativ einfach zu realisieren einen Eintrag in das Feld "Eigene vHost Einstellungen" unter Froxlor f?r die betreffende Domain vorgenommen: $HTTP["url"] =~ "/awstats/" { auth.backend = "htpasswd" auth.backend.htpasswd.userfile = "/var/customers/webs/kundendomain/awstats_htpasswd" auth.require = ( "" => ( "method" => "basic", "realm" => "Statistik", "require" => "user=benutzername" ) ) setenv.add-environment = ( "REMOTE_USER" => "benutzername" ) } Die Datei /var/customers/webs/kundendomain/awstats_htpasswd l?sst sich unter Debian recht einfach mit dem Befehl htpasswd anlegen, der im Paket apache2-utils enthalten ist (erfordert keinen Apache - keine Sorge).
  3. Ja ich denke, dass es dort noch etwas hakelig ist. Ich pers?nlich setze lighttpd seit l?ngerer Zeit ein und kann es nur jedem empfehlen. Klein, schnell und f?r High-Traffic Seiten nahezu ideal.
  4. hmm eigenartig - war bei mir nicht so - in /etc/lighttpd/froxlor-htpasswd ist bei mir auch nichts drin und in den einzelnen Domain-Dateien auch nicht. htaccess-Dateien gibt es bei lighty nicht und eine dritte M?glichkeit f?llt mir dazu nicht ein. Hier mal die Umgebungsvariablen: System: Debian 7.8 Kernel-Version: 4.0.0 Webserver: Lighttpd 1.4.35 PHP-Version: 5.6.8 Perl-Version: 5.14.2 MySQL-Server-Version: 5.5.43
  5. Nur so noch als Anmerkung generell zu Froxlor/Awstats. Im Normalfall sind die Statistiken f?r jeden einsehbar, also nicht passwortgesch?tzt, was nicht unbedingt jeder gut findet. Hier w?re es toll, wenn dies direkt im User-Interface eingestellt werden k?nnte.
  6. Ohne den diricons-Parameter hatten bei mir die statischen Awstats-Seiten keinerlei Icons und haben den relativen Pfad /icon f?r alle Grafiken verwendet. Dort fehlte in diesem Fall das /awstats-icon vorn. Zu awstatsclasses und awstatscss: http://www.awstats.org/docs/awstats_setup.html Da lighttpd bekannlich keine httpd.conf hat, habe ich die angezeigten ?nderungen in das Lighttpd-Format ?bersetzt und ?bernommen.
  7. Ok - ich hab mir das Ganze mal genau durchgeschaut und habe es auch zum Laufen gebracht. Musste allerdings 2 Froxlor-Dateien patchen weil es nicht ganz so trivial ist. Ich setze Debian 7 mit lighttpd ein, das soweit noch als Zusatzinformation. Awstats ist jetzt neu unter /usr/local/awstats installiert aus der Source. In den Froxlor-Einstellungen ergeben sich somit folgende Einstellungen f?r die Statistik: Pfad zu AWStats 'awstats_buildstaticpages.pl' -> /usr/local/awstats/tools/ Pfad zu AWStats 'awstats.pl' -> /usr/local/awstats/wwwroot/cgi-bin/ AWStats Konfigurations-Pfad -> /usr/local/awstats/wwwroot/cgi-bin/ Pfad zum AWstats-Icon-Ordner -> /usr/local/awstats/wwwroot/icon/ Folgende Patches habe ich gemacht: 1. cron_tasks.inc.http.20.lighttpd.php Hier musste ich die zus?tzlich erforderlichen alias-urls und auch die erforderliche script-url eintragen. Durch die Kapselung durch Bedingungen hier ganze 4 mal. Leider konnte ich die nur hardcoded machen, da Froxlor f?r diese Werte im Moment noch keine Felder vorsieht. Im Einzelnen sind dies: /awstatsclasses sowie /awstatscss und der script-alias /awstats/ Somit wird aus $stats_text.= ' alias.url = ( "/awstats/" => "'.makeCorrectFile($domain['customerroot'] . '/awstats/' . $domain['domain']).'/" )' . "\n"; $stats_text.= ' alias.url += ( "/awstats-icon" => "' . makeCorrectDir(Settings::Get('system.awstats_icons')) . '" )' . "\n"; dann $stats_text.= ' alias.url = ( "/awstats/" => "'.makeCorrectFile($domain['customerroot'] . '/awstats/' . $domain['domain']).'/" )' . "\n"; $stats_text.= ' alias.url += ( "/awstats-icon" => "' . makeCorrectDir(Settings::Get('system.awstats_icons')) . '" )' . "\n"; $stats_text.= ' alias.url += ( "/awstatsclasses" => "/usr/local/awstats/wwwroot/classes/" )' . "\n"; $stats_text.= ' alias.url += ( "/awstatscss" => "/usr/local/awstats/wwwroot/css/" )' . "\n"; $stats_text.= ' cgi.assign = ( "/awstats/" => "/usr/local/awstats/wwwroot/cgi-bin/" )' . "\n"; 2. cron_traffic.inc.functions.php Hier muss nur ein ?bergabewert angeh?ngt werden, damit awstats_buildstaticpages.pl die Bilder richtig verlinkt Zeile 46 aus safe_exec($awbsp.' -awstatsprog='.escapeshellarg($awprog).' -update -month=' . date('n') . ' -year=' . date('Y') . ' -config=' . $domain . ' -dir='.escapeshellarg($outputdir)); wird safe_exec($awbsp.' -awstatsprog='.escapeshellarg($awprog).' -update -month=' . date('n') . ' -year=' . date('Y') . ' -config=' . $domain . ' -dir='.escapeshellarg($outputdir) . ' -diricons=/awstats-icon'); Jetzt funktioniert alles wunderbar - die Statistiken werden korrekt erzeugt und angezeigt inkl. aller Grafiken. Das hier nur als Information hoffentlich f?r zuk?nftige Versionen oder Probleml?sung, falls jemand das gleiche Problem hat.
  8. Vielleicht kann mir hier jemand helfen. Ich versuche auf meinem Webserver (Debian 7) Awstats 7.3 zu verwenden. Nun gibt mir Froxlor aber vor eine Standardinstallation via apt-get (das w?re Awstats 7.0) verwenden zu wollen, die ganz andere Strukturen anlegt und Verweise. Gibt es eine wie auch immer geartete Anleitung, wie ich Awstats aus der Source installieren kann und es dann mit Froxlor verkn?pfe? Vielen Dank schon mal im Voraus Gr??e Franky
×
×
  • Create New...