Jump to content
Froxlor Forum
  • 0
mircsicz

PHP-FPM & Nginx: Fehler "502 Bad Gateway"

Question

Hallo zusammen,

 

am Montag hab ich Froxlor von 0.9.32 auf ne GIT Installation umgestellt, also 0.9.33dev3. Mein Server ist ein Wheezy und als Webserver nutze ich Nginx v1.2.1

 

Seitdem hab ich ein paar Probleme, zum einen liefert Contao wei?e inPage iFrame popups, EmonCMS stellt keine Graphen dar und PHPmyadmin bleibt nach der Anmeldung komplett wei?...

 

Aber das wichtigste ist der 502 nach "service php5-fpm restart", der momentane Kompromiss ist ein "chmod 666 /var/run/nginx/*"

 

 

Das log einer Domain sieht wie folgt aus:

2014/12/17 08:23:29 [crit] 23825#0: *18878 connect() to unix:/var/run/nginx/CLIENT-xxx.de-php-fpm.socket failed (13: Permission denied) while connecting to upstream, client: 176.198.171.171, server: xxx.de, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/nginx/CLIENT-xxx.de-php-fpm.socket:", host: "www.xxx.de"

hier die /etc/php5/fpm/php-fpm.conf:

root@websrv:~# grep -v '^;' /etc/php5/fpm/php-fpm.conf

include=/etc/php5-fpm.d/*.conf
include=/etc/php5/fpm/pool.d/*.conf

[global]
pid = /var/run/php5-fpm.pid
error_log = /var/log/php5-fpm.log

NSS hab ich gem?? dieser Doku installiert. Das tut auch wie erwartet:

root@websrv01:/etc/nginx# ll /var/run/nginx/CLIENT-xxx.de-php-fpm.socket
srw-rw-rw- 1 CLIENT CLIENT 0 Dez 17 08:22 /var/run/nginx/CLIENT-xxx.de-php-fpm.socket
root@websrv01:/etc/nginx# ll /var/customers/webs/|grep CLIENT
drwxr-xr-x  6 CLIENT          CLIENT          4,0K Dez 14 11:59 CLIENT

Ich bezweifle zwar das diese config's urs?chlich sein k?nnen, aber der Vollst?ndigkeit halber: /etc/php5-fpm.d/xxx.de.conf und noch /etc/nginx/sites-enabled/22_froxlor_normal_vhost_xxx.de.conf

 

Danke vorab...

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Den nscd hab ich gestern nach dem Einrichten der libnss-msql.cfg erstmal vergessen zu restarten, da hab ich aber beim 'service php5-fpm' restart' gleich bemerkt... Der konnte dann n?mlich die Sockets nicht erstellen! Also noch noch ein 'service nscd restart' & erneutes 'service php5-fpm restart' dann wurden die sockets wieder korrekt erzeugt.

 

Der Zugriff ohne 'chmod 666' oder 'chown www-data:www-data' auf /var/run/nginx/* ging aber erst nach dem ich vorhind zum Beleg der korrekten Gruppenzugeh?rigkeit

groups www-data

ausgef?hrt hab...

 

Ich starte heute Nacht die Maschine noch mal komplett neu um zu pr?fen ob das reboot fest ist... Wenn das passt markier ich den Thread als gel?st!

Share this post


Link to post
Share on other sites
  • 0

Ist eine berechtigungssache. Wie sind die Berechtigungen und besitzer von /var/run/nginx und unter welchem user l?uft der nginx

Share this post


Link to post
Share on other sites
  • 0

Moin moin, 

Ist eine berechtigungssache. Wie sind die Berechtigungen und besitzer von /var/run/nginx und unter welchem user l?uft der nginx

 

die Berechtigungen der Sockets hab ich oben gezeigt, aber das Verzeichnis vergessen, sollte 'eigentlich' passen. Jeder erzeugte Socket wird so wie in der Config definiert mit dem User aus Froxlor erzeugt:

root@websrv:~# ll /var/run/ |grep nginx
drwxrwxr-x 2 www-data   www-data   2,9K Dez 17 09:11 nginx
-rw-r--r-- 1 root       root          6 Dez 17 09:18 nginx.pid
srw-rw-rw- 1 CLIENT CLIENT 0 Dez 17 08:22 /var/run/nginx/CLIENT-xxx.de-php-fpm.socket

Nginx user hab ich vergessen :-( L?uft als www-data. Statt 'chmod 666' funktioniert also auch 'chown www-data:www-data /var/run/nginx/*'

Share this post


Link to post
Share on other sites
  • 0

Naja, der nginx-user selbst muss schon auf /var/run/nginx/ zugreifen k?nnen... Das ist nichts was froxlor regelt

Share this post


Link to post
Share on other sites
  • 0

Das kann er doch mit:

drwxrwxr-x 2 www-data   www-data   2,9K Dez 17 09:11 nginx

Und im Init-Script von php-fpm wird es doch auch gepr?ft:

root@websrv01:/etc/nginx# grep -r '/var/run/nginx' /etc/*|egrep -v 'php5-fpm.d|sites-enabled'
/etc/init.d/php5-fpm:# Check if /var/run/nginx exists and create if not...
/etc/init.d/php5-fpm:if [ ! -d "/var/run/nginx" ]; then
/etc/init.d/php5-fpm:   mkdir /var/run/nginx
/etc/init.d/php5-fpm:   chown www-data:www-data /var/run/nginx

Share this post


Link to post
Share on other sites
  • 0

Na du hast doch grad selbst gesagt, das ein chown ausgereicht hat und es funktioniert. Und wenn das init-script das erledigt weiss ich nicht wo das Problem sein soll....

Share this post


Link to post
Share on other sites
  • 0

Ich mach das chown aber nur auf die Sockets, das Verzeichnis fass ich doch net an...

chown www-data:www-data /var/run/nginx/*

man beachte den Stern am Ende... ;-)

Share this post


Link to post
Share on other sites
  • 0

Dann nutzt du ggfls. nicht die aktuellste libnss-mysql-config in der die gruppe des webserver-users den kunden beigef?gt wird (denn nur so klappt das)

Share this post


Link to post
Share on other sites
  • 0

Die hab ich gestern gem?? der o.g. Doku doch erst erstellt...

root@websrv:~# groups www-data
www-data : www-data froxlorlocal ONE CLIENT NJ MKP WSE NH WS MS JM ML ETC
getpwnam    SELECT username,'x',uid,gid,'MySQL User',homedir,shell \
            FROM ftp_users \
            WHERE username='%1$s' \
            AND login_enabled = 'Y' \
            LIMIT 1
getpwuid    SELECT username,'x',uid,gid,'MySQL User',homedir,shell \
            FROM ftp_users \
            WHERE uid='%1$u' \
            AND login_enabled = 'Y' \
            LIMIT 1
getspnam    SELECT username,password,FLOOR(UNIX_TIMESTAMP()/86400-1),'1','99999','7','-1','-1','0' \
            FROM ftp_users \
            WHERE username='%1$s' \
            AND login_enabled = 'Y' \
            LIMIT 1
getpwent    SELECT username,'x',uid,gid,'MySQL User',homedir,shell \
            FROM ftp_users
getspent    SELECT username,password,FLOOR(UNIX_TIMESTAMP()/86400-1),'1','99999','7','-1','-1','0' \
            FROM ftp_users
getgrnam    SELECT groupname,'x',gid \
            FROM ftp_groups \
            WHERE groupname='%1$s' \
            LIMIT 1
getgrgid    SELECT groupname,'x',gid \
            FROM ftp_groups \
            WHERE gid='%1$u' \
            LIMIT 1
getgrent    SELECT groupname,'x',gid \
            FROM ftp_groups
memsbygid   SELECT members \
            FROM ftp_groups \
            WHERE gid='%1$u'
gidsbymem   SELECT CONCAT_WS(',', gid) as gid \
            FROM ftp_groups \
            WHERE FIND_IN_SET('%1$s', members)

host            127.0.0.1
database        froxlor
username        froxlor
password        froxlor-pwd
port            3306

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Schutzgeist
      Hallo, 
      vielleicht kann mir jemand hier ja einen kleinen Tipp geben.
      Es ist mehr eine nginx-Konfiguration. 
      PHP-404-Rückmeldungen sollen "sauber" an Joomla übergeben werden.
       
      Mein 'Froxlor-Standardvhost sieht wie folgt aus

      Allerdings kann ich über das Joomla eigene REDIRECT Modul keine .php - Erweiterungen intern umleiten. 
      Anstatt  die joomla-eigene 404 Seite zu erhalten, bekomme ich die von nginx, da  die Abfrage hier als erstes ausgeführt wird. 
      Also habe ich meine vhost stümperhaft umgeschrieben, s.d. ein Teil seinen Soll erfüllt. 

      Teilweise kann ich nun die Redirects über Joomla verwalten lassen, aber oft erhalte ich LOOPs, da ich ja immer auf die index.php verweise. 
      So, warum nutze ich nicht die nginx-Weiterleitungen ? 

      Ich nutze ein Multi-Sitemodul  sowie ein Modul, um eine php-Endung  zu simulieren. 
      Beide haben mit meiner und der Standardvhost-Konfiguration leichte Schwierigkeiten. 

       
      Welche Vhost-Anpassungen nutzt ihr bei Eurer Joomla-Webseite ? 
      Der Fehler sitzt vermutlich 30 cm vor meinem Bildschirm. 
      Innerhalb meiner letzten 30 Versuche habe ich wohl  oft alte Cache-Webseiten geladen und ggf. die richtige Konfig übersehen.
       

       
       
       
       
       
    • By irisdina
      Warning, this is not an official guide!!!
      1.
      sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list
      sudo nano /etc/apt/source.list 1b.  insert (for Debian Stretch)
      1.2B (for Ubuntu Cosmic)
       
      1c. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. 
      sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server
      2. MariaDB install
      Warning use sudo command für this install!
      sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional)
      3. nginx install
      sudo apt install nginx 3a. 
      mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf
      4. PHP install
      sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. 
      sudo service nginx restart sudo service php7.3-fpm restart Froxlor install
      There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master)
      Stable Version
      1. 
      cd /var/www/html/ 1a. 
      sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or
      Git Version (Beta Version)
      sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer  su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory
      composer install --no-dev 1b. 
      sudo chown -R www-data:www-data Froxlor/ Set up Froxlor
      2. Open Your Browser
      2a.
      http://your IP or Hostname/Froxlor
       

      Install Froxlor finish
       3d. Move userdata (Optional) 
      sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. 
      sudo rm /etc/nginx/site-enable/default don't restart nginx!
      Froxlor Settings
      1. Cronjob
      sudo nano /etc/cron.d/froxlor insert 
      # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend
      Settings > Webserver settings > Nginx PHP backend
      from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock
      3. 
      sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port

      2a(1), SSL Port



      Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually
      sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional
      PHP-FPM activate
      1. User/Group add
      sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install 
      sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

      3. Settings > PHP-FPM > Activated:
      Change from NO to YES
      3a. PHP-FPM versions
      Change > php-fpm restart command:
      service php7.3-fpm restart and
      Configuration directory of php-fpm: > to 
      /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

      3c. 
      sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate
      1.
      sudo apt install certbot 1a. 
      sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File
      sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. 
      sudo nano /etc/nginx/acme.conf insert
      location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } }  
      2. Open your  Froxlor Panel
      Settings> SSL > Activated:
      Change from NO to YES
      2a. Settings > SSL > Settings
      Change your path from your certificate / Keyfile
      Path to the SSL certificate
      insert
      /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile
      insert
      /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings
      Activate > Enable Let's Encrypt

      Change Path to the acme.conf snippet to > 
      /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings
      - Enable Let's Encrypt for the froxlor vhost
      - Enable SSL-redirect for the froxlor vhost
      - HTTP Strict Transport Security (HSTS)
      - Include HSTS for any subdomain






      2d. Activated HTTP2 Support on > Settings > Nginx
       
×
×
  • Create New...