Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
JND_3004

[solved] FTP Userlogin Probleme (ProFTPd)

Question

Guten Tag,

 

ich m?chte mich mit meinem Testnutzer in FTP einloggen, jedoch kommt immer eine Fehlermeldung:

Antwort:	220 ProFTPD 1.3.4c Server (ProFTPD) [62.75.209.64]
Befehl:	USER JND3004
Antwort:	331 Password required for JND3004
Befehl:	PASS ************
Antwort:	530 Login incorrect.
Fehler:	Kritischer Fehler
Fehler:	Herstellen der Verbindung zum Server fehlgeschlagen

und wenn ich die Konfigurationsanleitung f?r ProFTPd von froxlor befolge, kommt schon beim ersten Befehl eine Fehlermeldung seitens des Servers:

 

Befehl:

apt-get install proftpd-basic proftpd-mod-mysql

Fehlermeldung:

Unpacking proftpd-basic (from .../proftpd-basic_1.3.2c-1ubuntu0.1_amd64.deb) ...                                                                                   
dpkg: error processing /var/cache/apt/archives/proftpd-basic_1.3.2c-1ubuntu0.1_amd64.deb (--unpack):                                                               
 trying to overwrite '/etc/pam.d/proftpd', which is also in package psa-proftpd 1.3.4c-ubuntu10.04.build115130528.15                                               
dpkg-deb: subprocess paste killed by signal (Broken pipe)                                                                                                          
Errors were encountered while processing:                                                                                                                          
 /var/cache/apt/archives/proftpd-basic_1.3.2c-1ubuntu0.1_amd64.deb                                                                                                 
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hoffe man kann mir ggf. weiter Helfen.

Ich verwende ein Linux vServer mit Ubuntu 10.04.1

 

LG, Dittmer

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

L?sche "psa-proftpd" - schau ob sich dann das andere installieren l?sst. Da scheint bei dir was zu blockieren. Und das ein Login nicht funktioniert ist klar, wenn proftpd gar nicht installiert ist

Share this post


Link to post
Share on other sites

L?sche "psa-proftpd" - schau ob sich dann das andere installieren l?sst. Da scheint bei dir was zu blockieren. Und das ein Login nicht funktioniert ist klar, wenn proftpd gar nicht installiert ist

Mein Server kann "psa-proftpd" erst gar nicht finden f?r das deinstallieren. Und mit "das andere installieren" meinst du wohl "Pure FTPd" oder?

 

EDIT: Bei der Suche hat mein Server jetzt nur folgendes mit dem Begriff "psa-proftpd" gefunden:

./cache/apt/archives/psa-proftpd_1.3.4c-ubuntu10.04.build115130528.15_amd64.deb                                                                                    
./cache/apt/archives/psa-proftpd_1.3.4a-ubuntu10.04.build110120606.19_amd64.deb                                                                                    
./lib/dpkg/info/psa-proftpd.conffiles                                                                                                                              
./lib/dpkg/info/psa-proftpd.list                                                                                                                                   
./lib/dpkg/info/psa-proftpd.md5sums

Share this post


Link to post
Share on other sites

psa war doch das Plesk-Prefix? Du m?sstest deinen Server erstmal generell von Plesk-Hinterlassenschaften befreien sonst wird es noch viel mehr und weitaus seltsamere Probleme geben. Am Besten geht man von einem Minimal-Image des Betriebssystems aus.

Share this post


Link to post
Share on other sites

psa war doch das Plesk-Prefix? Du m?sstest deinen Server erstmal generell von Plesk-Hinterlassenschaften befreien sonst wird es noch viel mehr und weitaus seltsamere Probleme geben. Am Besten geht man von einem Minimal-Image des Betriebssystems aus.

Naja, auf meinem Server habe ich Plesk 11.5.30 laufen und m?chte es eigentlich ungern jetzt irgendwie komplett runterschmei?en, da ich auch noch Kunden darauf lassen habe (seit etwa 4 Monaten).

Es muss doch auch so gehen das Plesk und Froxlor gleichzeitig laufen k?nnen oder nicht? ..

 

LG

Share this post


Link to post
Share on other sites

Du weisst schon, dass Plesk und Froxlor das gleiche machen? Wozu willst du denn dann noch froxlor installieren? Ich glaube nicht, dass die beiden sich auf ein und dem selben System gut verstehen werden...

Share this post


Link to post
Share on other sites

Du weisst schon, dass Plesk und Froxlor das gleiche machen? Wozu willst du denn dann noch froxlor installieren? Ich glaube nicht, dass die beiden sich auf ein und dem selben System gut verstehen werden...

Manche Kunden m?chten gerne mit Froxlor arbeiten. Und das Plesk und Froxlor so zu sagen das gleiche machen, wusste ich schon ;)

Share this post


Link to post
Share on other sites

So wird froxlor nicht funktionieren....du musst ja die ganzen Service-Configs entsprechend f?r Froxlor anpassen...da hat Sephi recht, ein "sauberes" System w?re da hilfreicher. Die Kunden und Domains musst du sowieso h?ndisch umziehen...

Share this post


Link to post
Share on other sites

So wird froxlor nicht funktionieren....du musst ja die ganzen Service-Configs entsprechend f?r Froxlor anpassen...da hat Sephi recht, ein "sauberes" System w?re da hilfreicher. Die Kunden und Domains musst du sowieso h?ndisch umziehen...

Also k?nnte ich das ganze mit Froxlor knicken ohne Plesk daf?r deinstallieren zu m?ssen richtig?

Das ich dann meine aktuellen Kunden soweit h?ndisch umziehen lassen m?sste habe ich schon mit gerechnet.

Share this post


Link to post
Share on other sites

ich sage nur das es sicherlich nicht spa?ig ist und ich nicht sicher bin ob du dir da dein plesk nicht kaputt machst mit. mehr nicht.

Share this post


Link to post
Share on other sites

ich sage nur das es sicherlich nicht spa?ig ist und ich nicht sicher bin ob du dir da dein plesk nicht kaputt machst mit. mehr nicht.

hmm, ok. Dann lasse ich es mal dann lieber.

Trotzdem danke f?r die Antworten ;)

 

LG

Share this post


Link to post
Share on other sites

  • Similar Content

    • By Boruch Weisfish
      Hi all,
       
      I am new to Froxlor and so far enjoying it but unsure how to use it and have a few questions.
      I have pointed an A record from my domain provider to the server and am able to access the web panel using the domain but my FTP client (filezilla) can't find it. Does it have a mail server built in or do I have to configure that. Can I use it as a nameserver? What ports does it  need to function (so I can setup my firewall) Thanks in advance for all your help.
    • By Kieron Boswell
      Hi guys, have just got froxlor set-up and looking around it getting it ready to move all my clients into, one or two things I haven't been able to see yet.
      Mail settings, I'm used to being spoon-fed mail settings when I create an account, generally are these fixed so I can make a note? And is there a way to use mail.domain.tld rather than using the primary server domain for example? I'd really like something like that to be the default when I create a new website/email etc if possible. Ftp, is it possible to set ftp.domain.tld as a record that works for FTP automatically when an account is made under a customer? Many thanks, enjoying froxlor so far :-)
    • By Robert08020
      Hallo,
      Wenn ich einen neuen Kunden anlege, Doamin zuweise und FTP einrichte und gehe dann via WinSCP auf den Server, finde ich nichts. Der Ordner /var/customers wurde nicht erstellt.
      Kann mir jemand helfen?
      Mfg Robert08020
    • By Kyle Willets
      =================================================================================================================
       Package                       Arch                   Version                         Repository            Size
      =================================================================================================================
      Reinstalling:
       proftpd                       x86_64                 1.3.5e-4.el7                    epel                 3.7 M
       proftpd-mysql                 x86_64                 1.3.5e-4.el7                    epel                  50 k
      Transaction Summary
      =================================================================================================================
      Reinstall  2 Packages
      Total download size: 3.7 M
      Installed size: 9.7 M
      Is this ok [y/d/N]: y
      Downloading packages:
      (1/2): proftpd-1.3.5e-4.el7.x86_64.rpm                                                    | 3.7 MB  00:00:00
      (2/2): proftpd-mysql-1.3.5e-4.el7.x86_64.rpm                                              |  50 kB  00:00:00
      -----------------------------------------------------------------------------------------------------------------
      Total                                                                            4.0 MB/s | 3.7 MB  00:00:00
      Running transaction check
      Running transaction test
      Transaction test succeeded
      Running transaction
        Installing : proftpd-1.3.5e-4.el7.x86_64                                                                   1/2
        Installing : proftpd-mysql-1.3.5e-4.el7.x86_64                                                             2/2
        Verifying  : proftpd-mysql-1.3.5e-4.el7.x86_64                                                             1/2
        Verifying  : proftpd-1.3.5e-4.el7.x86_64                                                                   2/2
      Installed:
        proftpd.x86_64 0:1.3.5e-4.el7                        proftpd-mysql.x86_64 0:1.3.5e-4.el7
      Complete!
      [root@s128426 ~]# mv "/etc/proftpd/proftpd.conf" "/etc/proftpd/proftpd.conf.frx.bak"
      mv: cannot stat ‘/etc/proftpd/proftpd.conf’: No such file or directory
      [root@s128426 ~]# ^C
      [root@s128426 ~]# cd /etc/proftpd/
      -bash: cd: /etc/proftpd/: No such file or directory
       

      I am unable to setup ProFTP. I am using the latest version of Centos 7 and PHP 7. It says it installed, but yeah as ya can see. With the SSL it says to config something but does nto say what. So was wondering if anyone had any tips on how to get Lets Encypt working properly.
      Thank You.
    • By BigD
      Hi,
      I'm using PureFTP with TLS since years for Froxlor with purchased SSL certificates. Now the certificate expired and I want to use Let's encrypt.
      Here is my suggestion for a more secure PureFTP configuration - in addition to the current parameters from the froxlor setup guide:
      Making TLS mandatory:
      echo "2" > /etc/pure-ftpd/conf/TLS Reduce the Ciphers to the secure ones:
      echo "HIGH:!aNULL:!LOW:!EXP:!RC4:!3DES:!SSLv3:!SSLv2" > /etc/pure-ftpd/conf/TLSCipherSuite Doing this every time the host certificates are updated (or once a night ;-) ):
      cat /etc/ssl/froxlor-custom/{{hostname}}.crt /etc/ssl/froxlor-custom/{{hostname}}_chain.pem /etc/ssl/froxlor-custom/{{hostname}}.key > /etc/ssl/private/pure-ftpd.pem systemctl restart pure-ftpd-mysql Maybe it's an option to make this part of the default configuration and integrate the certificate merging into the froxlor-cron? Any ideas how this could look like on different distributions (Gentoo / RHEL / Ubuntu)?
      Thanks for your feedback
×
×
  • Create New...