Jump to content
Froxlor Forum
  • 0

Fehler nach Upgrade auf 0.10.23.1-1


Go to solution Solved by d00p,

Question

15 answers to this question

Recommended Posts

  • 0
  • Solution

a2dismod php7.0 && a2enmod php7.4 mal probiert?

Ich nehme an bei mod_php steht dein webserver halt noch auf php-7.0

Link to post
Share on other sites
  • 0
On 1/6/2021 at 1:41 PM, systom said:

dann sollte das update aber nicht automatisch angeboten werden für debian stretch. da ist nunmal nur ein altes php vorhanden.

Du kannst auch ganz einfach php7.4 unter Stretch installieren. Dann hast du keine Probleme aktuell mehr.

Link to post
Share on other sites
  • 0

Das ist richtig, allerdings sollten Pakete unter debian die entsprechenden dependencies beachten, darum nehme ich ja debian und nicht Ubuntu. Der Vorteil von debian ist ja, dass ich blind Updates einspielen kann, da die Paketverwaltung sauber ist und alle Abhängigkeiten beachtet. Was hier eben nicht passiert ist.

Link to post
Share on other sites
  • 0
On 1/8/2021 at 7:27 AM, systom said:

Das ist richtig, allerdings sollten Pakete unter debian die entsprechenden dependencies beachten, darum nehme ich ja debian und nicht Ubuntu. Der Vorteil von debian ist ja, dass ich blind Updates einspielen kann, da die Paketverwaltung sauber ist und alle Abhängigkeiten beachtet. Was hier eben nicht passiert ist.

Da gebe ich dir recht ja, war amein Fehler, ich habe die composer Abhängigkeiten aktualisiert und ginge - genau wie du bei Debian - davon aus, dass Composer schon nichts zieht was meine requirements übersteigt - hat es aber leider.

Auf der anderen Seite möchte ich aber auch anhalten seine Systeme aktuell zu halten. Ja debian 9 ist LTS bis 2022, PHP-7.0 aber so gar nicht (keine Sicherheitsupdates mehr seit Januar 2019!!!) Siehe dazu auch: https://www.php.net/supported-versions.php

Link to post
Share on other sites
  • 0

Ok Fehler besprochen.... aber wie kann ich ( unwissender ) den Fehler beheben...

apt-get install  php7.4      bringt kein Erfolg

Errors were encountered while processing:
 afterlogic-lite
E: Sub-process /usr/bin/dpkg returned an error code (1)

Könnt ihr hier weiter helfen..?

Link to post
Share on other sites
  • 0

Leider nix....   Ich habe auf Buster upgedatet, habe nochmals 7.4 installiert, reboot.... NIX

con1.123nic.de   dann seht ihr das selbst...

root@con1:~# php -v
PHP 7.4.15 (cli) (built: Feb 11 2021 21:22:21) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
    with Zend OPcache v7.4.15, Copyright (c), by Zend Technologies
root@con1:~#


root@con1:~# cat /etc/debian_version
10.8
root@con1:~#

 

Link to post
Share on other sites
  • 0

Naja, nur installieren reicht ja nicht - du musst froxlor schon auch sagen was er benutzen soll; bei einem upgrade bleiben gewissen dinge ja erhalten.

Du gibst leider nicht viel Info bzgl des Setups, welcher webserver, wie bindest du php ein? fpm, fcgid oder mod_php? Was genau hast du denn bisher gemacht? So kann man leider nur schwer helfen

Link to post
Share on other sites
  • 0

OK Danke ....

Also ich habe fpm und fcgid  auf NEIN zu stehen, denke also mod_php

Ich habe noch ein zweites system wo alles funktioniert hat mit dem update... nur bei der 1con nicht.

Ich habe von 9 auf 10 upgedatet  hat auch funktioniert.  https://www.prepaid-hoster.de/blog/debian-9-auf-debian-10-updaten/

dann nochmal https://www.itzgeek.com/how-tos/linux/debian/how-to-install-php-7-3-7-2-7-1-on-debian-10-debian-9-debian-8.html

reboot und nix ändert sich...  ( P.S. Danke schonmal für deine Hilfe )

 

 

 

Link to post
Share on other sites
  • 0

root@con1:~# a2dismod php7.0 && a2enmod php7.4
Module php7.0 disabled.
To activate the new configuration, you need to run:
  systemctl restart apache2
Considering dependency mpm_prefork for php7.4:
Considering conflict mpm_event for mpm_prefork:
Considering conflict mpm_worker for mpm_prefork:
Module mpm_prefork already enabled
Considering conflict php5 for php7.4:
Enabling module php7.4.
To activate the new configuration, you need to run:
  systemctl restart apache2
root@con1:~# systemctl restart apache2
root@con1:~#

 

GEILomat   das war die Lösung, oh jeh ich muss echt noch mehr lernen.... Danke für die tolle Hilfe

Bleib gesund  D A N K E S C H Ö N

  • Haha 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...