Jump to content
Froxlor Forum
  • 0

Mailserver - Autokonfiguration greift obwohl diese nicht eingerichtet ist


LukasH
 Share

Question

Einen wunderschönen guten Tag, 

ich habe eine kleine Frage zum Froxlor Mailserver in Verbindung mit Autokonfiguration bzw. Microsoft Outlook.

Und zwar nutze ich für den IMAP Server die Adresse "mail.domainname.tld", hierfür gibt es ein SSL Zertifikat welches auch passt und alles ist gut wenn man Konten manuell damit einrichtet. Wenn ich nun das Konto bei Outlook hinzufüge ohne manuelle Konfiguration nimmt Outlook automatisch imap.domainname.tld, hier gibt es dann natürlich einen Zertifikatsfehler da das Zertifikat ja für mail. ausgestellt ist. 

Ich habe allerdings nie eine Autokonfiguration oder sonst irgend etwas in die Richtung konfiguriert?! Ist das Standardmäßig an? Wenn ja wo finde ich die Config um das anzupassen?

Vielen Dank schon einmal für eure Hilfe!

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

D.h. einfach die Subdomains erstellen, am besten mit LetsEncrypt SSL verschlüsseln, die passenden XML Dateien ablegen und ruhe haben? 

Dann mach ich das mal, vielen Dank! 

Link to comment
Share on other sites

  • 0

dein mailserver hat EINEN hostnamen...ein zertifikat dafür...am einfachsten ist es du erstellst eine http-alias der das abdeckt (mozilla hat da doku, microsoft hat da doku). Siehe erster Link. Du willst ja im grunde den Users sagen: ihr müsst mail.meine-domain.tld als server nutzen...da wo es auch mit zertifikat via SSL abgesichert ist...

Link to comment
Share on other sites

  • 0

Jetzt muss ich doch noch einmal stören...

ich habe nun die Aliase wie folgt angelegt:

Alias "/.well-known/autoconfig/mail/" "/var/www/autoconfig/"
Alias "/.mz-autoconf/" "/var/www/autoconfig/"
Alias "/autodiscover/" "/var/www/autoconfig/"

Diese funktionieren auch:

https://hoerth.eu/autodiscover/autodiscover.xml
https://hoerth.eu/.mz-autoconf/autodiscover.xml
https://hoerth.eu/.well-known/autoconfig/mail/config-v1.1.xml

Dennoch greifen Outlook & Thunderbird im Test auf imap. & smtp. zurück, also nehmen wohl nicht die vorgegebene Konfig ? 

Link to comment
Share on other sites

  • 0

Das wäre doch auch was für die Wunschliste: pro Kundendomain werden die Subdomains im DNS mit angelegt, entsprechende VHosts generiert und mittels eines Alias und bisschen PHP-Magie zentral auf diese GET/POST Anfragen mit XML reagiert. Vermutlich gibt es dann wieder Ausnahmen, die das gern anders hätten, also braucht es pro Domain noch ein Häkchen "ich will autoconfig/autodiscover ja/nein".

Ich bastle gerade an dieser PHP-Magie, werde das dann aber kaum ins froxlor hacken, weil ich da immer die richtigen Stellen so schwer finde und Updates dann so einen manuellen Aufwand bedeuten.

Eine Art feature-crowdfounding wäre gut, ich würde gern was zahlen um sowas später realisiert zu sehen.

Link to comment
Share on other sites

  • 0

Ich dachte schon daran, dass kunde1.tld und kunde2.tld beide mail.hoster.tld als Mailserver nehmen. Dann klappt es doch auch wieder mit dem SSL.  Über welches Zertifikat reden wir eigentlich, über das zur autodiscover-URL (das kann froxlor ja elegant mittels LE erledigen) oder das vom Mailserver?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...