Jump to content
Froxlor Forum
  • 0
Tealk

Neuinstallation auf Deb9

Question

Hallo,

ich befasse mich heute das erste mal mit Froxlor, die Oberfläche gefällt mir echt gut soweit. Nun habe ich die Konfigurationen durch gemacht aber bin auf ein paar Fehler gestoßen.

Hier das System:

  • Debian 9 Stretch
  • Apache/2.4.25
  • PHP 7.2.6-1+0

von den Einstellungen habe ich das "Anpassungen für Apache 2.4 verwenden" aktiviert. Gibt es noch etwas was ich da beachten muss und ich übersehen habe?

Fehlermeldung:

Jun 13 12:36:49 systemd[1]: Starting The Apache HTTP Server...
Jun 13 12:36:49 apachectl[5085]: AH00526: Syntax error on line 11 of /etc/apache2/sites-enabled/28_froxlor_normal_vhost.v220180
Jun 13 12:36:49 apachectl[5085]: Invalid command 'SuexecUserGroup', perhaps misspelled or defined by a module not included in the ser
Jun 13 12:36:49 apachectl[5085]: Action 'start' failed.

 

Share this post


Link to post
Share on other sites

Recommended Posts

  • 1
2 hours ago, Tealk said:

Wenn ich jetzt in den Ordner "/var/lib/apache2/fastcgi" schaue, sind dort nur 3 Dateien die zu einem Kunden gehören, aber nicht die oben angegebene. Bestimmt hab ich noch irgendwo was falsch eingestellt.

 

Und ist es möglich den DocumentRoot auf "/var/www/froxlor/" zu ändern?

beides in Einstellungen -> "Froxlor Vhost Einstellungen", das eine wäre "php-fpm auch für froxlor verwenden. das andere "Froxlor direkt über den hostname erreichbar machen"

Share this post


Link to post
Share on other sites
  • 1
10 minutes ago, Tealk said:

bleibt die erhalten? oder wird die gelöscht wenn froxlor die Dateien neu erstellt?

Müßtest du testen oder halt die Froxlor-generierten Konfiguration in ein extra Verzeichnis legen und dieses in apache2.conf includen.

So hab ich es gemacht:

/etc/apache2/sites-enabled/
000-default.conf
001-froxlor.conf
002-webmail.conf
00x-xxxx.conf

/etc/apache2/sites-froxlor/
10_froxlor_ipandport_1.2.3.4.443.conf
10_froxlor_ipandport_1.2.3.4.80.conf
29_xxxx.conf
35_xxxx.conf

Das Ende meiner /etc/apache2/apache2.conf sieht so aus:

# Include the virtual host configurations:
IncludeOptional sites-enabled/*.conf

# Include the Froxlor host configurations:
Include sites-froxlor/*.conf
Include vhosts_options-froxlor/*.conf

 

Allerdings ist dabei zu beachten, dass der Froxlor-Host nicht von Froxlor generiert wird sondern von Hand angelegt und entsprechende Einstellungen wie FCGI auch von Hand gemacht werden müssen.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, J-B said:

a2enmod suexec

 

Danke, ich merk schon man muss noch ne ganze menge nach installieren.

Bis jetzt startet schon mal mein Apache2, ich meld mich dann wieder wenn was nicht geht ;)

Share this post


Link to post
Share on other sites
  • 0

Libnss....ist alles in den config-templates

Share this post


Link to post
Share on other sites
  • 0

Ich hab grad das Problem das bei der "10_froxlor_ipandport_ip.80" Datei Folgendes drinn steht.

# 10_froxlor_ipandport_ip.80.conf
# Created 13.06.2018 14:40
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

<VirtualHost 185.170.112.156:80>
DocumentRoot "/var/www/"
 ServerName froxlor.domain
  <FilesMatch \.(php)$>
  SetHandler proxy:unix:/var/lib/apache2/fastcgi/1-froxlor.panel-froxlor.domain-php-fpm.socket|fcgi://localhost
  </FilesMatch>
</VirtualHost>

Wenn ich jetzt in den Ordner "/var/lib/apache2/fastcgi" schaue, sind dort nur 3 Dateien die zu einem Kunden gehören, aber nicht die oben angegebene. Bestimmt hab ich noch irgendwo was falsch eingestellt.

 

Und ist es möglich den DocumentRoot auf "/var/www/froxlor/" zu ändern?

Share this post


Link to post
Share on other sites
  • 0

Hallo @d00p

danke schon mal für deine bisherige Hilfe.

Gerade habe ich das merkwürdige Phänomen das ich die php-fpm settings nicht bearbeiten kann. Folgende Meldung bekomme ich:

23000 SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'service php7.2-fpm restart' for key 'reload'

File: /lib/classes/database/class.Database.php:72

Trace:
#0 /lib/classes/database/class.Database.php(72): PDOStatement->execute(Array)
#1 /admin_phpsettings.php(584): Database::pexecute(Object(PDOStatement), Array)
#2 {main}

-------------------------------------------------------------

Froxlor-version: 0.9.39.5
DB-version: 201802130

Ich habe 2 angelegt da ich bei einem den PM auf statisch und bei einem auf dynamisch stellen wollte. Bin mir nicht sicher ob das einen Grund hat warum das Feld keine Duplikate zulässt

 

Außerdem, ich weiß nicht ob ich einfach nur Blind bin, gibt es eine Möglichkeit die access.log zu deaktivieren?

Share this post


Link to post
Share on other sites
  • 0

du kannst keine zwei fpm-configs mit dem selben reload-command anlegen, das macht schlichtweg keinen sinn :)

Share this post


Link to post
Share on other sites
  • 0
57 minutes ago, Tealk said:

Außerdem, ich weiß nicht ob ich einfach nur Blind bin, gibt es eine Möglichkeit die access.log zu deaktivieren?

Nein gibt es nicht

Share this post


Link to post
Share on other sites
  • 0

Gibt es eine best practice für das anlegen von einer phpmyadmin Domain, oder legt man die einfach unter einem Kunden an?

Share this post


Link to post
Share on other sites
  • 0

Jo, entweder in ein Kunden-DocumentRoot rein oder unterhalb von /var/www/froxlor ist so das was ich am meisten gesehen habe (was keine separate manuelle config erfordert)

Share this post


Link to post
Share on other sites
  • 0
54 minutes ago, Tealk said:

Ok danke, bei der letzteren Methode funktioniert nur keine subdomain wenn ich das richtig sehe?

Dann leg doch einfach einen eigenen vhost außerhalb von Froxlor an. Du bist doch der Administrator und kannst somit so allgemeine Dienste kreieren wie du willst.

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Shortie said:

Dann leg doch einfach einen eigenen vhost außerhalb von Froxlor an.

bleibt die erhalten? oder wird die gelöscht wenn froxlor die Dateien neu erstellt?

Share this post


Link to post
Share on other sites
  • 0

Ok von hand habe ich schon mal einen Server eingerichtet, nur da ich viel rum spiele ist es schön ein wi zu haben das eben per 1 klick alle Einstellungen für dich vornimmt.

 

Aber ja die Idee ist echt gut, warum bin ich da net drauf gekommen? xD

 

Ich muss mal schauen ob ich das noch hin bekomme Apache2 und Nginx zusammen zum laufen zu bringen.

Share this post


Link to post
Share on other sites
  • 0
9 minutes ago, Tealk said:

Ok von hand habe ich schon mal einen Server eingerichtet, nur da ich viel rum spiele ist es schön ein wi zu haben das eben per 1 klick alle Einstellungen für dich vornimmt.

Das ist richtig, bei meiner Lösung sind im Problemfall die wichtigen Dienste (froxlor / webmail /...) verfügbar (da ändert sich ja eigentlich nie was) und die Kunden-Websites sogar leichter zu deaktivieren (include auskommentieren) aber trotzdem Einstellungen über das Webinterface machbar.

Share this post


Link to post
Share on other sites
  • 0

Ja danke für die Idee :D

//Edit

Einzig das SSL Zertifikat muss man dann per Hand erstellen, oder gibts da auch schon ne Lösung? ;)

Share this post


Link to post
Share on other sites
  • 0
10 minutes ago, Tealk said:

Ja danke für die Idee :D

//Edit

Einzig das SSL Zertifikat muss man dann per Hand erstellen, oder gibts da auch schon ne Lösung? ;)

Mache ich mittlerweile über das acme.sh Script (https://github.com/Neilpang/acme.sh).
Zuvor hatte ich StartSSL und später ein anderes kostenloses (Symantec), was ich über den Domainprovider bekommen hatte, eingebunden. Das war sowieso von Hand zu machen 1x jährlich.

Share this post


Link to post
Share on other sites
  • 0

Wie umständlich, packs halt innen kunden-account und lass froxlor das LE certificate erstellen...

Share this post


Link to post
Share on other sites
  • 0

Ja ich hab mir nu auch einen eigenen Kunden dafür angelegt und lass die Arbeit Froxlor machen ;)

Sehr schöne Arbeit, großes Lob dafür :)

Share this post


Link to post
Share on other sites
  • 0

Schau Mal in die Entwickler-Konsole vom Browser...mir ist aktuell nichts bekannt warum da was nicht gehen soll.

Share this post


Link to post
Share on other sites
  • 0

Also in der Konsole steht nur "Content Security Policy: Die Einstellungen der Seite haben das Laden einer Ressource auf self blockiert ("script-src"). Source: onfocusin attribute on DIV element."

Ich habe zwar keine CSP eingerichtet aber ich schau mal woher das kommt.

Jedenfalls kommt die Meldung auch wenn die Grafik angezeigt wird, eine andere meldung ist da nicht in der Konsole.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×