Jump to content
Froxlor Forum

Question

Guten morgen liebe Froxlor Gemeinde,

meistens ist ja gar nichts kaputt :) Ich komme nur nicht mehr weiter und finde meinen Fehler.
Ich bekomme einfach die SSL Einstellungen nicht ans laufen und der Apache2 versagt sein Dienst.

Folgendes mache ich und hätte gedacht das läuft:

- Nagel neue Installation von Frocxlor
- SSL Einstellungen aktivieren (mehr nicht - Nur die Option angemacht)
- Apache neugestartet (per Shell)

Apache Dienst wird mit folgenden Status nicht neugestartet:
AH00526: Syntax error on line 5 of /etc/apache2/sites-enabled/03_froxlor_ocsp_cache.conf:
Invalid command 'SSLStaplingCache', perhaps misspelled or defined by a module not included in th...guration

Alle versuche SSL Mods zu aktivieren sind Fehlgeschlagen. Wo ist mein Fehler? Was habe ich vergessen vorher zu aktivieren, entweder per Shell oder Froxlor selbst.

 

Schöne Grüße,

KnowSlayes

Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 0

Server version: Apache/2.4.10 (Debian)
Server built:   Sep 20 2017 04:37:43

Considering dependency setenvif for ssl:
Module setenvif already enabled
Considering dependency mime for ssl:
Module mime already enabled
Considering dependency socache_shmcb for ssl:
Enabling module socache_shmcb.
Enabling module ssl.
See /usr/share/doc/apache2/README.Debian.gz on how to configure SSL and create self-signed certificates.
To activate the new configuration, you need to run:
  service apache2 restart
 

Ich lasse dich auch gerne auf dem kompletten Server drauf. Der ist nagelneu... :) gerade. Ohne eine Einstellung.

Link to post
Share on other sites
  • 0

naja, da steht doch das er mod_ssl erst aktiviert hast...vlltt startest du den apache jetzt einfach mal neu und wirst sehen das es funktioniert :)

Link to post
Share on other sites
  • 0

Ich hatte das selbe Problem. "A2enmod ssl" ausgeführt und siehe da.. mein Fehler SSL noch nicht aktiviert, hätte ich auch selbst drauf kommen können.

Nun, wenn ich versuche Froxlor aufzurufen: "Not Found" (Ohne HTTPS)
Mit HTTPS: "SSL_ERROR_RX_RECORD_TOO_LONG"

Ich vermute mir ist hier ein Fehler unterlaufen.. Nur welcher?

Link to post
Share on other sites
  • 0
1 hour ago, beatkind said:

Ich vermute mir ist hier ein Fehler unterlaufen.. Nur welcher?

falsche config und/order kein Zertifikat hinterlegt - bei ssl muss auch der ssl ip/port vhost ein (möglichst) gültiges zertifikat haben

Link to post
Share on other sites
  • 0
vor 10 Minuten schrieb d00p:

falsche config und/order kein Zertifikat hinterlegt - bei ssl muss auch der ssl ip/port vhost ein (möglichst) gültiges zertifikat haben

Das Froxlor selbst ein LetsEncrypt Zertifikat erstellt, wenn keines Eingetragen, geht / funktioniert nicht?

Im Nachhinein muss es dann manuell eingetragen werden?

Link to post
Share on other sites
  • 0
5 minutes ago, beatkind said:

Das Froxlor selbst ein LetsEncrypt Zertifikat erstellt, wenn keines Eingetragen, geht / funktioniert nicht?

nicht automatisch nö, du musst schon sagen, dass froxlr auch für sich selbst ein LE zertifikat erstellen soll. Einstellungen -> Froxlor Vhost-Einstellungen

Link to post
Share on other sites
  • 0

Dann prüfe doch bitte die erstellen Vhosts in /etc/apache2/sites-enabled und prüfe auch, ob dein SSL IP/Port auch einen Vhost-container erstellt

Link to post
Share on other sites
  • 0
# 10_froxlor_ipandport_*ip*.80.conf
# Created 09.01.2018 12:00
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

<VirtualHost *ip*:80>
DocumentRoot "/var/www/html/froxlor/"
 ServerName *domain*
</VirtualHost>
# 10_froxlor_ipandport_*ip*.443.conf
# Created 09.01.2018 12:00
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

<VirtualHost *ip*:443>
DocumentRoot "/var/www/html/froxlor/"
 ServerName *domain*
</VirtualHost>

 

Ansonten gibt es nur noch die Configs für OCSP Cache und die Customer Ordner, natürlich noch den Default Eintrag des Apaches.

 

Ansonsten würde ich SSL Manuell deaktivieren im Froxlor (denke das geht über Configs?), Einstellungen mit Lets Encrypt nochmal kontrollieren, erneut SSL Aktivieren und Testen.

Sollte das nicht funktionieren einfach ein Lets Encrypt Zert manuell erstellen und nochmal mit SSL probieren?

Link to post
Share on other sites
  • 0

tjoa, ohne vhost-container in der SSL ip/port wird das halt nix. IP/Ports -> die port 443 ip bearbeiten und häkchen bei "Create Vhost-Container" machen (und natürlich bei "ist SSL port")

Link to post
Share on other sites
  • 0

Sorry, aber bist du sicher das du einen server verwalten solltest? Deine bisherigen Aussagen lassen auf fehlende grundlegende Kenntnisse schließen...

Link to post
Share on other sites
  • 0
5 minutes ago, Marc Zweier (KnowSlayes) said:

Tja dümmerchen ich. apache2.crt ist halt nicht apache.crt und SSL will nun mal ein Zertifikat und wenn es erstmal ein Selbst ausgestelltes ist.

genau so ist es :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By logicbloke
      Hello,
      I seem to be getting this error when the cron runs:
      [debug] System certificate file "/etc/ssl/froxlor-custom/xxx.tld.crt" does not seem to exist. Disabling SSL-vhost for "xxx.tld"
      Froxlor VirtualHost is enabled, along with SSL generation but it seems like it's being generated on acme's folder and not copied over to /etc/ssl/froxlor-custom/, anyone has any clues?
       
      Many thanks,
    • By logicbloke
      Hi,
      I'm just wondering what the difference is between the following 2 folders:
      Why is froxlor installing acme.sh cron everytime it runs at 3am everyday especially since the 5-min let's encrypt froxlor cron is already in place? Also, all my db config points to /etc/ssl/froxlor-custom for the domains and all keys/certificates inside that folder have a different md5 from the ones under /root/.acme.sh/, so I'm wondering what's with the mismatch? Are we updating certificates for domains twice?
       
      If anyone can shed some more light on this, it will be very much appreciated.
       
      Many thanks!
    • By Michael Groß
      Hallo zusammen,
      ich kämpfe momentan mit der SSL Konfiguration von meinem Froxlor-Server.
      Bedauerlicherweise befindet sich der Webserver hinter einer Firewall und hat eine private IP Adresse zugewiesen bekommen. 
      Die Firewall leitet entsprechend den Traffic von außerhalb auf den Server weiter (HTTP ist das alles kein Problem).
      Nun habe ich vorhin SSL aktivieren wollen und hierzu kann ich leider keine private IP Adresse eintragen (lässt Froxlor nicht zu).
      Entsprechend habe ich die public IP eingetragen, was aber auch nicht funktioniert, da durch das NAT der Firewall die private IP angesprochen wird - somit funktioniert dies nicht.
      Habt ihr eine Idee, wie man das umbauen kann?
      An sich brauche ich nur die private IP Adresse als SSL Adresse eintragen - vermute aber, dass dadurch Let's Encrypt auch nicht mehr richtig laufen wird.
      Viele Grüße
      Michael
      PS: Ein 1:1 NAT wäre noch eine Möglichkeit, da ich die Public IP aber für diverse Server verwende, fällt das auch raus. Müsste dann eine neue Public IP kaufen, welche ich dann mit einem 1:1 NAT auf den Webserver laufen lasse (wäre noch eine Möglichkeit)
    • By nisamudeen97
      Hi,
      Our froxlor server is behiend NAT and it uses the local IP  192.168.73.40.  We have enabled letsencrypt module in froxlor and tried validating SSL for a domain in the server.  SSL generation is getting failed with 403 error.  See the debug log information.      Replaced domain name and main IP.    Can any one help me regarding the issue.
       
      [information] Updating Let's Encrypt certificates [information] Updating domain-name.com [information] Adding SAN entry: domain-name.com [information] Adding SAN entry: www.domain-name.com [information] letsencrypt-v2 Using 'https://acme-v02.api.letsencrypt.org' to generate certificate [information] letsencrypt-v2 Using existing account key [information] letsencrypt-v2 Starting certificate generation process for domains [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/new-order [information] letsencrypt-v2 Requesting challenge for domain-name.com [information] letsencrypt-v2 Got challenge token for domain-name.com [information] letsencrypt-v2 Token for domain-name.com saved at /var/www/froxlor/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k and should be available at http://domain-name.com/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [information] letsencrypt-v2 Sending request to challenge [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/chall-v3/803008408/k46kFQ [information] letsencrypt-v2 Verification pending, sleeping 1s [information] letsencrypt-v2 Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for domain-name.com: Verification ended with error: {"type":"http-01","status":"invalid","error":{"type":"urn:ietf:params:acme:error:unauthorized","detail":"Invalid response from http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [212.224.xxx.xxx]: \"<!DOCTYPE html>\\n<html lang=\\\"en-CA\\\" class=\\\"html_stretched responsive av-preloader-active av-preloader-enabled av-default-lightbox\"","status":403},"url":"https:\/\/acme-v02.api.letsencrypt.org\/acme\/chall-v3\/803008408\/k46kFQ","token":"vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","validationRecord":[{"url":"http:\/\/www.domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"www.domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"},{"url":"http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"}]} [information] Let's Encrypt certificates have been updated  
    • By peterpan
      Hi,
      I have a domain equipped with a certificate from LE. The cert is valid another 2 months. Now I added a domain as an alias of the existing domain, but the certificate isn't updated to have the new domain as its SAN.
      How do I trigger getting a new and updated certificate? Should I delete the existing one?
      Thanks for helping out.
       
      Peter
×
×
  • Create New...