Jump to content
Froxlor Forum

Question

Maildir wird autom. bei Erstellung von Mailadresse angelegt, aber Pfad ist falsch, siehe

/var/customers/mail/var/customers/mail/[CUSTOMER]/[DOMAIN.TLD]/[MAILBOX]

"var/customers/mail" ist doppelt.

Bitte um Info welcher Prozess dieses Verzeichnis anlegt, bzw. wo der Fehler liegt.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Ich meine mich erinnern zu können das da was mit der Postfix "main.cf" Einstellung "virtual_mailbox_base" war...wie ist da der Wert bei dir? Ich tippe mal auf /var/customers/mails"....ggfls musst du das dort entfernen (also nur auf / setzen)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By irisdina
      Warning, this is not an official guide!!!
      1.
      sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list
      sudo nano /etc/apt/source.list 1b.  insert (for Debian Stretch)
      1.2B (for Ubuntu Cosmic)
       
      1c. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. 
      sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server
      2. MariaDB install
      Warning use sudo command für this install!
      sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional)
      3. nginx install
      sudo apt install nginx 3a. 
      mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf
      4. PHP install
      sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. 
      sudo service nginx restart sudo service php7.3-fpm restart Froxlor install
      There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master)
      Stable Version
      1. 
      cd /var/www/html/ 1a. 
      sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or
      Git Version (Beta Version)
      sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer  su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory
      composer install --no-dev 1b. 
      sudo chown -R www-data:www-data Froxlor/ Set up Froxlor
      2. Open Your Browser
      2a.
      http://your IP or Hostname/Froxlor
       

      Install Froxlor finish
       3d. Move userdata (Optional) 
      sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. 
      sudo rm /etc/nginx/site-enable/default don't restart nginx!
      Froxlor Settings
      1. Cronjob
      sudo nano /etc/cron.d/froxlor insert 
      # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend
      Settings > Webserver settings > Nginx PHP backend
      from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock
      3. 
      sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port

      2a(1), SSL Port



      Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually
      sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional
      PHP-FPM activate
      1. User/Group add
      sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install 
      sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

      3. Settings > PHP-FPM > Activated:
      Change from NO to YES
      3a. PHP-FPM versions
      Change > php-fpm restart command:
      service php7.3-fpm restart and
      Configuration directory of php-fpm: > to 
      /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

      3c. 
      sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate
      1.
      sudo apt install certbot 1a. 
      sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File
      sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. 
      sudo nano /etc/nginx/acme.conf insert
      location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } }  
      2. Open your  Froxlor Panel
      Settings> SSL > Activated:
      Change from NO to YES
      2a. Settings > SSL > Settings
      Change your path from your certificate / Keyfile
      Path to the SSL certificate
      insert
      /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile
      insert
      /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings
      Activate > Enable Let's Encrypt

      Change Path to the acme.conf snippet to > 
      /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings
      - Enable Let's Encrypt for the froxlor vhost
      - Enable SSL-redirect for the froxlor vhost
      - HTTP Strict Transport Security (HSTS)
      - Include HSTS for any subdomain






      2d. Activated HTTP2 Support on > Settings > Nginx
       
    • Guest
      By Guest
      in der config-Datei steht
       
      was für eine valid e-mail Adresse muss das sein ?  diese root@frx.beispiel.de ist ja bisher nicht eingerichtet und packt systemmeldungen in ein verzeichnis

      sollte dort also eine mailadresse rein, die auf einem anderen Server liegt und Mails empfängt, oder sollte/könnte diese root@beispiel.de im froxlor eingerichtet sein ?
    • By Randall Newman
      I have been in the process of installing Froxlor in a Google Cloud Instance. All the errors I have encountered I was able to fix them by searching on the web, but this one I couldn't find a solution for the past two hours. Simply I need help solving this error.😓

    • By jonny87
      Guten Morgen liebe Community,
      ich hab schon gesucht hier, aber nicht wirklich was passendes gefunden, darum mach ich jetzt hier nochmal nen Thread auf. Ich nutz Froxlor nun erfolgreich seit über einem Jahr auf zwei Servern, es funktioniert soweit auch alles mit LetsEncrypt und den Zertifikaten.
      Jetzt hab ich nur folgendes Problem, bzw. ist dies möglich, da ich mehrere Kunden über Froxlor auf zwei Servern verwalte, muss ich natürlich auch E-Mails verwalten, und zwar verschlüsselt. Kann man das über Froxlor machen? Sprich, dass die Kunden ihre Emails über
      imap.kunde1.de & smtp.kunde1.de sowie imap.kunde2.de & smtp.kunde2.de usw. abrufen können. 
      Momentan muss man ja bzw. so hat es mein Admin gemacht, ein Zertifikat für alle hinterlegen, welches auch nicht automatisch per Script geupdatet wird?! -> Ist das so richtig?
      Oder müssen alle Kunden ihre E-Mails per imap.hauptdomain.de abrufen? 
       
       
       
       
       
    • By Patrick Walters
      Hallo,
      ich kenne seit einige Jahren Froxlor und verwende es auch sehr gern. 
       
      Ich habe 2 Probleme und 1 Fragen und hoffe mir kann geholfen werden.
       
      Zur Hintergrund-Information, ich verwende Debian 8 (64bit) und Postfix mit Dovecot.
       
      1. Der Mailversand via Webmailer (Auf gleichen Server) funktioniert, aber in den Mail-Header steht:
      Received: from pexmedia.de (unknown [185.101.92.201]) by pexmedia.de (Postfix) with ESMTPA id 0D8C43C0ECE Der Mailserver sollte eigentlich mail.pexmedia.de sein, der SMTP-Server smtp.pexmedia.de und der IMAP-Server imap.pexmedia.de mit den jeweiliegn Standartports.
      Warum steht vor der Server-IPAdresse unknown? Und wie behebt man es?
       
      2. Die Zugangsdaten für SMTP/IMAP stimmen, jedoch kann kein externes E-Mail Programm die Verbindung erfolgreich herstellen. Kurz gesagt seine Mailkonten kann man nicht mit Mailprogrammen wie Outlook etc. verwenden.
      In /var/log/mail.warn steht:
      Jan 31 04:44:24 mail postfix/smtpd[13385]: warning: unknown[46.44.171.19]: SASL LOGIN authentication failed: UGFzc3dvcmQ6 Jan 31 04:44:25 mail postfix/smtpd[13412]: warning: hostname rt171bb44-46-19.routit.net does not resolve to address 46.44.171.19: Name or service not known Jan 31 04:44:25 mail dovecot: auth: Warning: auth client 0 disconnected with 1 pending requests: Connection reset by peer Beim Versuch mit ein E-Mail Programm die Verbindung aufzubauen. Woran lliegt es?
      Im weiteren steht:
      Jan 31 06:46:17 mail postfix/smtpd[16068]: warning: hostname 201.92.101.185.in-addr.arpa does not resolve to address 185.101.92.201: Name or service not known Mein rDNS Eintrag ist: 201.92.101.185.in-addr.arpa 
      Wie sollte mein rDNS Eintrag denn lauten?
       
      In einer Version von Froxlor die ich mal hatte lief alles reibungslos.
       
      3. Mails von meinem Mailserver kommen bei Google in den Spam-Ordner. Liegt vilt. daran das Google die Mail als nicht verifiziert eingestuft hat. Wie mache ich das am dümmsten? 
       
      Die Configs sind die Standartkonfrigurationen von Froxlor.
       
      Hoffe mir wird geholfen. 
       




×
×
  • Create New...