Jump to content
Froxlor Forum
  • 0
tt33tt

Suexec einrichten: libnss-mysql nicht verfügbar

Question

Hallo alle zusammen,

 

ich will suexec entsprechend der Anleitung http://redmine.froxlor.org/projects/froxlor/wiki/FCGID_-_Handbuch einrichten.

Dort wird gesagt, ich müsse libnss-mysql installieren. In Ubuntu kommt aber die Meldung, dass es das nicht mehr gibt.

Kann ich libnss-mysql durch libnss-mysql-bg ersetzen oder muss dafür das Konfigurationsskript in Froxlor geändert werden (Konfiguration >> Distribution >> Sonstige (System) >> libnss (system login with mysql)?

 

Thx

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

libnss-mysql-bg geht auch, achtung aber ggfls sehen die configs anders aus (anderes format) - weiss ich grad bei ubuntu nciht auswendig

Share this post


Link to post
Share on other sites
  • 0

14.04 (LTS) „Trusty Tahr“

Soweit ich das auf der offiziellen Seite http://libnss-mysql.sourceforge.net/ lesen kann, verweisen die unter Download auch auf libnss-mysql-bg. Wenn ich unter Download auf Debian-Package klicke, dann komme ich auf https://packages.debian.org/unstable/admin/libnss-mysql-bg

Daher kann ich davon ausgehen, dass das der Nachfolger ist oder?

 

//Edit: Wenn ich mir so https://gist.github.com/alpacaaa/3196852 anschaue, dann sehen beide Konfig-Dateien ziemlich gleich aus und heißen sogar gleich.

Share this post


Link to post
Share on other sites
  • 0

Ne, das ist nicht erst seit heute so...in den meisten Fällen sind die Wiki-Einträge viel zu alt. Die ganze Installation und Konfiguration ist ja mittlerweile auch in Froxor's Config-Templates mit drin, das war damals bei diesem Handbuch noch nicht so - das stammt ja zum größten Teil noch aus SysCP Zeiten

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By tt33tt
      Seit ich mit http://redmine.froxlor.org/projects/froxlor/wiki/FCGID_-_Handbuch fcgid und suexex eingerichtet habe, funktioniert phpmyadmin nicht mehr. Das äußert sich darin, dass ich beim Öffnen von der phpmyadmin-Seite die php-Datei angezeigt bekomme und im Quellcode sogar die php-Befehle stehen. Das bedeutet, dass keine Interpretation stattfindet.
      Muss ich dafür nun auch einen vhost, einen User etc. anlegen?
      Wenn ich +ExecCGI unter Options hineinschreibe, dann kommt die Fehlermeldung: Either all Options must start with + or -, or no Option may.
       
      Meine /etc/apache2/conf.d/phpmyadmin.conf sieht so aus:
      # phpMyAdmin default Apache configuration Alias /phpmyadmin /usr/share/phpmyadmin <Directory /usr/share/phpmyadmin>     Options FollowSymLinks     DirectoryIndex index.php     <IfModule mod_php5.c>         AddType application/x-httpd-php .php         php_flag magic_quotes_gpc Off         php_flag track_vars On         php_flag register_globals Off         php_admin_flag allow_url_fopen Off         php_value include_path .         php_admin_value upload_tmp_dir /var/lib/phpmyadmin/tmp         php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/phpmyadmin/:/usr/share/php/php-gettext/:/usr/share/javascript/     </IfModule> </Directory> # Authorize for setup <Directory /usr/share/phpmyadmin/setup> <IfModule mod_authn_file.c> AuthType Basic AuthName "phpMyAdmin Setup" AuthUserFile /etc/phpmyadmin/htpasswd.setup </IfModule> Require valid-user </Directory> # Disallow web access to directories that don't need it <Directory /usr/share/phpmyadmin/libraries> Order Deny,Allow Deny from All </Directory> <Directory /usr/share/phpmyadmin/setup/lib> Order Deny,Allow Deny from All </Directory>
    • By tt33tt
      Hallo alle zusammen,
       
      ich habe Wordpress und erhalte dort den Fehler, dass curl deaktiviert ist. In der phpInfo steht dies auch unter disabled functions: disable_functions -> curl_exec,curl_multi_exec
      Auf meinem Webserver habe ich Frolxor mit fcgid und suExec.
      Vermutlich muss ich die "Default Config" ändern, die unter dem Punkt "Voreingestellte PHP-Konfiguration für neue Domains" auf der Seite Einstellungen->fcgid ändern oder?
      Ist das richtig und wo finde ich sie? Ich konnte sie bisher nicht finden.
      Muss ich beide Funktionen curl_exec und curl_multi_exec aktivieren?
    • By tt33tt
      Hallo alle zusammen,
       
      ich versuche gerade herauszufinden, ob ich suPHP, mod_php oder CGI/FastCGI habe.
      Meinen Webserver habe ich entsprechend diese Anleitung angepasst: http://redmine.froxlor.org/projects/froxlor/wiki/FCGID_-_Handbuch
      In Froxlor steht -> Webserver: Apache/2.4.7 (Ubuntu) mod_fcgid/2.3.9
       
      Dann habe ich CGI/FastCGI oder?
      Trotz suExec habe ich kein suPHP aktiviert oder? Sollte ich letzteres noch tun?
    • By mnt
      Hello,
      i have nginx error:
      2015/06/28 14:02:28 [crit] 81969#0: *8 stat() "/usr/home/customers/webs/test/aaa.bbb.lt/" failed (13: Permission denied), client: 188.69.22.22, server: aaa.bbb.lt, request: "GET / HTTP/1.1", host:
       "aaa.bbb.lt"
      This error exists because /usr/home/customers/webs/test permissions is 0750.
      I figure that this error occurs because my froxlor ftp users not in www group:   #groups www www froxlorlocal   libnss-mysql i think work  good: # getent group ....... froxlorlocal:*:1003:www
      vmail:*:2000
      test::10000:test,www,froxlorlocal
      tnetbalt::10001:tnetbalt,www,froxlorlocal
        why froxlor users (test and tnetbalt) not exists in www group? freebsd 10.1 froxlor 0.9.33.1    
    • By TrustedCreeper
      Hallo und danke schon mal.
       
      Ich habe grade das Problem dass Apache2 nicht mehr starten will. Das ganze hat damit angefangen, dass nur noch "500 Internal Server Error" kam, wenn ich meine Seiten aufgerufen habe. Einige Tage zuvor hatte ich eine neue Domain zu einem Kunden hinzugef?gt und soweit eingerichtet (Subdoimains, Verzeichnis, Email-Adressen), hat alles super funktioniert. Ich hab 2 Kunden in Froxlor, Kenneth und Florian. Nach dem Internal Server Error hab ich einfach mal den kompletten Server neu gestartet. Allerdings ist Apache2 nicht mehr mitgestartet. Nach dem Versuch des manuellen Startens bekomme ich nur folgenden Fehler:
       
      apache2: bad user name Florian Action 'configtest' failed. The Apache error log may have more information. failed! Die neue Domain habe ich aber dem Kunden Kenneth zugewiesen, daher hatte Florian eigentlich nichts damit zu tun (Der Kunde selbst hat auch nichts ge?ndert.).
       
      /var/log/apache2/error.log
      suexec policy violation: see suexec log for more details /var/log/apache2/suexec.log
      invalid target user id: (10000) Die Seite des Kunden Florian hat auch die ganze Zeit noch funktioniert, bis zum "500 Internal Server Error". Wo k?nnte nun also das Problem sein? - Weiter ge?ndert hab ich eigentlich nichts. 
       
      Danke sehr
      ~ TrustedCreeper
×
×
  • Create New...