Jump to content
Froxlor Forum
  • 0
divo

proftpd unter ubuntu startet nicht

Question

Der FTP-Daemon proftpd startet nicht bei ubuntu 14.04.

Folgende Fehlermeldung:  Fatal: unknown configuration directive 'TLSECCertificateFile' on line 7 of '/etc/proftpd/tls.conf'

 

In der Release-Note zu proftpd findet man die Option 'TLSECCertificateFile' erst ab der Version 1.3.5rc4, installiert bei ubuntu 14.04 ist aber 1.3.5rc3.

 

Nach dem man die Optionen 'TLSECCertificateFile' und 'TLSECCertificateKeyFile' löscht startet der ftp-Daemon nun erfolgreich.

 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By DavidCK
      Hi There,
       
      I have a problem with proftpd and folders permissions. I installed wordpress in the domain folder, the installation required sudo chown -R www-data:www-data permission, I assigned this permission via ssh but the problem is when I connect via ftp I can not edit nothing inside my domain folder because my ftp account does not have the permission.
       
      Anyone knows How Can I revert this?
       
      Thanks for your time.
       
      wordpress runs perfect with froxlor!!
    • By v3ng
      Hallo, 
       
      Folgendes Problem, ich wollte gerade meine komplette Owncloud Instanz löschen. FTP meldet jedoch bei einem Ordner ("lib"), dass er keine Rechte hätte. Das Verzeichnis hat genau die selben Rechte sowie Owner, wie andere Verzeichnisse auch, welche ich ohne Probleme löschen kann. 
      Via Shell als selbiger Nutzer funktioniert es ohne Probleme. Nur via FTP klappt es nicht. 
      Genutzt wird ProFTPd. 
       
      Über Hilfe bin ich sehr Dankbar.
       
      Schönes Wochenende!
    • By AndrewL
      I can login to root and other ssh users using SFTP (ProFTPD) without a problem but I can't connect via sftp to any of the froxlor clients that I add via the panel though.
      With some help from here, I did the following:
      Add the following to /etc/proftpd/modules.conf

      LoadModule mod_sftp.c
       
      Add the following to /etc/proftpd/sql.conf
       
      Include /etc/proftpd/sftp.conf
       
      Create file /etc/proftpd/sftp.conf with following content:
      <IfModule mod_sftp.c> SFTPEngine on SFTPLog /var/log/proftpd/sftp.log SFTPHostKey /etc/ssh/sshhostdsakey SFTPHostKey /etc/ssh/sshhostrsakey </IfModule> Restarted proftpd and ssh
      If I try connecting via filezilla to a froxlor client with host sftp://server-ip username say, user1 and the user password, I get the following error:
      Error: Authentication failed. Error: Critical error: Could not connect to server
      Please let me know if there's any info, logs, config, etc you would want me to provide.
    • By JND_3004
      Guten Tag,
       
      ich m?chte mich mit meinem Testnutzer in FTP einloggen, jedoch kommt immer eine Fehlermeldung:
      Antwort: 220 ProFTPD 1.3.4c Server (ProFTPD) [62.75.209.64] Befehl: USER JND3004 Antwort: 331 Password required for JND3004 Befehl: PASS ************ Antwort: 530 Login incorrect. Fehler: Kritischer Fehler Fehler: Herstellen der Verbindung zum Server fehlgeschlagen und wenn ich die Konfigurationsanleitung f?r ProFTPd von froxlor befolge, kommt schon beim ersten Befehl eine Fehlermeldung seitens des Servers:
       
      Befehl:
      apt-get install proftpd-basic proftpd-mod-mysql Fehlermeldung:
      Unpacking proftpd-basic (from .../proftpd-basic_1.3.2c-1ubuntu0.1_amd64.deb) ... dpkg: error processing /var/cache/apt/archives/proftpd-basic_1.3.2c-1ubuntu0.1_amd64.deb (--unpack): trying to overwrite '/etc/pam.d/proftpd', which is also in package psa-proftpd 1.3.4c-ubuntu10.04.build115130528.15 dpkg-deb: subprocess paste killed by signal (Broken pipe) Errors were encountered while processing: /var/cache/apt/archives/proftpd-basic_1.3.2c-1ubuntu0.1_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1) Hoffe man kann mir ggf. weiter Helfen.
      Ich verwende ein Linux vServer mit Ubuntu 10.04.1
       
      LG, Dittmer
×
×
  • Create New...