Jump to content
Froxlor Forum
  • 0
DavidCK

Ftp problem after installing wordpress

Question

Hi There,

 

I have a problem with proftpd and folders permissions. I installed wordpress in the domain folder, the installation required sudo chown -R www-data:www-data permission, I assigned this permission via ssh but the problem is when I connect via ftp I can not edit nothing inside my domain folder because my ftp account does not have the permission.

 

Anyone knows How Can I revert this?

 

Thanks for your time.

 

wordpress runs perfect with froxlor!! :D

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

chown -R [customer]:[customer] /var/customers/webs/[customer]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By UnknownLSL
      Hi guys,
       
      It seems like Wordpress wants to have a loopback configuration for its API.
      "The website wasn't able to finish a loopback request"
      Error: [] cURL error 28: Operation timed out after 10001 milliseconds
      Is it possible to configure that with the current functionality? Following up with the Wordpress support forum, they are not really helpful. They just make it quick with a recommendation to their webhosting sponsors which is very sad, like: "Use one of the webhosters from our list, they will work well."
      Mep.
      Does anybody know how to fix it? I could make it manually with set the customer configuration to "Mail only", but I think that would be a functionality which would affect pretty many users.
       
      Regards and stay healthy,
      UnknownLSL
    • By JavaLink
      Hi
      I try install Froxlor several times bu every time i get error
       SQLSTATE[HY000] [1045] Access denied for user 'myuser'@'localhost' (using password: YES)
      I do these things for create use:
      CREATE USER 'myuser'@'localhost' IDENTIFIED BY 'pP123!@#Hello'; then
      create database froxlor;  
      and then
      GRANT ALL PRIVILEGES ON `froxlor` TO 'myuser'@'localhost';
       
      FLUSH PRIVILEGES;  
      I check connection with a file called con.php contain this ---> and it's OK.
      <?php $servername = "localhost"; $username = "myuser"; $password = "pP123!@#Hello"; // Create connection $conn = new mysqli($servername, $username, $password); // Check connection if ($conn->connect_error) { die("Connection failed: " . $conn->connect_error); } echo "Connected successfully";  
      but after run froxlor to install it and fill all information, i get that error.
      Also i check again with server and find out that the `myuser` user is deleted...What happened? What Froxlor do?
    • By tmuecksch
      Guten Tag,
      ich habe einen Debian 9 Server mit Froxlor und Apache2 am laufen. Wenn ich mit dem Kunden FTP Zugang Dateien hochlade haben diese Ordnungsgemäß das ownership 10000:10000.
      Wenn jedoch in der PHP-Weboberfläche eine Datei hochgeladen wird, wird diese mit dem ownership www-data:www-data hochgeladen. Liegt hier ein Konfigurationsfehler vor oder ist das Verhalten sogar so gewünscht? Ich kann den Fehler leider nicht entdecken. Das Problem ist nur, dass das PHP-Script dann eine Permission Denied Fehlermeldung wirft, wenn versucht wird die Datei zu lesen.
       
      Liebe Grüße
      tmuecksch
    • By divo
      Der FTP-Daemon proftpd startet nicht bei ubuntu 14.04.
      Folgende Fehlermeldung:  Fatal: unknown configuration directive 'TLSECCertificateFile' on line 7 of '/etc/proftpd/tls.conf'
       
      In der Release-Note zu proftpd findet man die Option 'TLSECCertificateFile' erst ab der Version 1.3.5rc4, installiert bei ubuntu 14.04 ist aber 1.3.5rc3.
       
      Nach dem man die Optionen 'TLSECCertificateFile' und 'TLSECCertificateKeyFile' löscht startet der ftp-Daemon nun erfolgreich.
       
    • By v3ng
      Hallo, 
       
      Folgendes Problem, ich wollte gerade meine komplette Owncloud Instanz löschen. FTP meldet jedoch bei einem Ordner ("lib"), dass er keine Rechte hätte. Das Verzeichnis hat genau die selben Rechte sowie Owner, wie andere Verzeichnisse auch, welche ich ohne Probleme löschen kann. 
      Via Shell als selbiger Nutzer funktioniert es ohne Probleme. Nur via FTP klappt es nicht. 
      Genutzt wird ProFTPd. 
       
      Über Hilfe bin ich sehr Dankbar.
       
      Schönes Wochenende!
×
×
  • Create New...