Jump to content
Froxlor Forum
  • 0

froxlor + fcgid + mod_rewrite Probleme


cdn
Go to solution Solved by cdn,

Question

Hallo zusammen,

 

ich habe nun wirklich lange im Internet gesucht konnte das Problem aber nur in Verbindung mit PHP-FPM finden:

 

Bei der Nutzung von Permalinks z.B in einer Wordpress Installation kommt es immer zu einem Umleitungsfehler.

 

mod_rewrite ist aktiviert, in der apache2.conf ist f?r das Kundenverzeichnis ein Allowoverride All gesetzt.

 

Eine L?sung die ich gefunden habe spricht davon alle htaccess Dateien anzupassen und zu erg?nzen.

 

http://forum.froxlor.org/index.php?/topic/917-php-fpm-htaccess-request-exceeded-the-limit-of-10-internal-redirects/

 

Klappt bei der Kombination mit fcgid aber nicht und finde ich auch sehr umst?ndlich dies in jeder Config anzupassen..

 

Dies habe ich auch schon alles gecheckt:

 

https://forum.froxlor.org/index.php/topic/13258-php-fpm-und-mod-rewrite/

 

Jemand eine Idee?

 

Viele Gr??e

 

cdn

Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0

Hallo zusammen,

 

ich habe nun wirklich lange im Internet gesucht konnte das Problem aber nur in Verbindung mit PHP-FPM finden:

 

Bei der Nutzung von Permalinks z.B in einer Wordpress Installation kommt es immer zu einem Umleitungsfehler.

 

mod_rewrite ist aktiviert, in der apache2.conf ist f?r das Kundenverzeichnis ein Allowoverride All gesetzt.

 

Eine L?sung die ich gefunden habe spricht davon alle htaccess Dateien anzupassen und zu erg?nzen.

 

http://forum.froxlor.org/index.php?/topic/917-php-fpm-htaccess-request-exceeded-the-limit-of-10-internal-redirects/

 

Klappt bei der Kombination mit fcgid aber nicht und finde ich auch sehr umst?ndlich dies in jeder Config anzupassen..

 

Dies habe ich auch schon alles gecheckt:

 

https://forum.froxlor.org/index.php/topic/13258-php-fpm-und-mod-rewrite/

 

Jemand eine Idee?

 

Viele Gr??e

 

cdn

 

Vielleicht hilft dir das hier weiter?

https://forum.froxlor.org/index.php/topic/13258-php-fpm-und-mod-rewrite/

 

 

"a2enmod rewrite" ausf?hren

 

 

Apache2.conf "AllowOverride None" zu "All" ab?ndern:

<Directory />
    Options FollowSymLinks
    AllowOverride None
    Require all denied
</Directory>

<Directory /usr/share>
    AllowOverride None
    Require all granted
</Directory>

<Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
</Directory>

<Directory /var/customers/webs/>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>
Link to post
Share on other sites
  • 0

Der Server ist soweit auch neu aufgesetzt und bis auf eine Firewall ist auch nur Froxlor drauf nach Anleitung mit fcgid...

Naja aus den logs kann man wirklich nichts schlussfolgern...

 

access:

[27/Jan/2016:18:20:50 +0100] "GET / HTTP/1.1" 301 438 "http://ADRESSE/wp-admin/options-permalink.php?settings-updated=true" "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0"

error:

[Wed Jan 27 18:21:31.106615 2016] [fcgid:warn] [pid 1797] [client XX.XXX:XXX:XXX:42882] mod_fcgid: stderr: PHP Warning:  curl_exec() has been disabled for security reasons in /var/customers/webs/USER/DOMAIN/wp-content/plugins/wp-piwik/classes/WP_Piwik/Request/Rest.php on line 44

Hab auch schon die Schritte wiederholt und rewrite an und aus gemacht. Leider kein Erfolg -.-

Link to post
Share on other sites
  • 0

Ja! Gibts ein error wegen curl, habe das Plugin jetzt einmal deaktiviert nur das hilft leider auch nicht... Fehlermeldung kommt nicht mehr, aber funktionieren tut es trotzdem nicht.  Apache habe ich auch nochmal neu gestartet.

Link to post
Share on other sites
  • 0

Die Umstellung auf Permalinks. In meinem Falls auf %postname%. Aber das ist egal was ich auswähle. Fehlermeldungen erhalte ich wie schon gesagt gar keine.

 

Was auffällig ist: Auch wenn ich die htaccess Datei komplett leere, dann kommt der gleiche Fehler. AllowOverride ist aber gesetzt in der apache.conf. Evtl liegt es an Berechtigungen bzw. versucht er eine andere .htaccess Datei zu öffnen als die in dem Verzeichnis? Besitzer ist aber der Nutzer selber....

 

 

 

Versuch mal vor der letzten RewriteRule ./index.php [L] folgendes einzufügen:

 

RewriteCond %{REQUEST_URI} !^/php5.fcgi
 
Das ist ein Bekanntes Problem von Wordpress unter php-fpm

 

Habe ich gerade ausprobiert. Das hilft leider nicht -.-

Link to post
Share on other sites
  • 0

dann /var/customers/logs/USER-* ?? Irgendwo steh mit Sicherheit was drin. Ansonsten google auch bitte nach "apache rewrite log", auch da kann man sich diverses ausgeben lassen.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...