Jump to content
Froxlor Forum
  • 0

php-fpm: .htaccess - Request exceeded the limit of 10 internal redirects....


bjo

Question

Hi,

 

I tried to switch from php-fcgi to php-fpm. The most things worked fine, but several wordpress-installations produce internal server errors. In the apache2-errorlog I got "Request exceeded the limit of 10 internal redirects due to probable configuration error. Use'LimitInternalRecursion' to increase the limit if necessary".

The recursion seems to be caused by the rewrite-rules in the .htaccess:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

 

Did any of you got similar problems and found a solution?

Link to post
Share on other sites

1 answer to this question

Recommended Posts

i had a very similar problem with a customers joomla installation and my new server using apache2 + suexec + php5-fpm.

it came down to 1 line which was not matching correctly

you need to debug this properly to get results.

 

RewriteCond %{REQUEST_URI} !^/index\.php

 

change to:

 

RewriteCond %{REQUEST_URI} !^/fastcgiphp/*

 

fixed the problem for me.

 

it seems that the action used in the directoy-options (Action php5-fastcgi /fastcgiphp) is affecting mod_rewrite in a weird way.

i didn't fully understand it myself as i'm no expert to rewrite rules.

 

my apache debug.log if it helps:

[Mon Apr 18 22:20:32 2011] [debug] core.c(3063): [client ***.***.***.***] r->uri = /index.php
[Mon Apr 18 22:20:32 2011] [debug] core.c(3069): [client ***.***.***.***] redirected from r->uri = /fastcgiphp/index.php
[Mon Apr 18 22:20:32 2011] [debug] core.c(3069): [client ***.***.***.***] redirected from r->uri = /index.php
[Mon Apr 18 22:20:32 2011] [debug] core.c(3069): [client ***.***.***.***] redirected from r->uri = /fastcgiphp/index.php
[Mon Apr 18 22:20:32 2011] [debug] core.c(3069): [client ***.***.***.***] redirected from r->uri = /index.php
[Mon Apr 18 22:20:32 2011] [debug] core.c(3069): [client ***.***.***.***] redirected from r->uri = /fastcgiphp/index.php
[Mon Apr 18 22:20:32 2011] [debug] core.c(3069): [client ***.***.***.***] redirected from r->uri = /index.php
[Mon Apr 18 22:20:32 2011] [debug] core.c(3069): [client ***.***.***.***] redirected from r->uri = /fastcgiphp/index.php
[Mon Apr 18 22:20:32 2011] [debug] core.c(3069): [client ***.***.***.***] redirected from r->uri = /index.php
[Mon Apr 18 22:20:32 2011] [debug] core.c(3069): [client ***.***.***.***] redirected from r->uri = /fastcgiphp/index.php
[Mon Apr 18 22:20:32 2011] [debug] core.c(3069): [client ***.***.***.***] redirected from r->uri = /index.php

 

same issue with wordpress and the same solution applies:

 

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_URI} !^/fastcgiphp/*
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . index.php [L]
</IfModule>
# END WordPress

 

*edit* added a wildcard solution that works for all subdirectories.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...