Jump to content
Froxlor Forum
  • 0
caroman

Kleiner Bug im cron-Script

Question

Hallo,

 

heute habe ich die Systemlog gel?scht, vergangene Woche eine subdomain hinzugef?gt, aber eigentlich bekomme ich den Fehler schon l?nger:

 

PHP Notice: Undefined variable: domain in /var/www/froxlor/scripts/jobs/cron_tasks.inc.http.10.apache.php on line 321

 

Keine Ahnung, was ich angestellt habe, um auf diesen Bug zu kommen, den ich per Mail zugesandt bekomme. aber nur einmal nach jeder aktion, z.B, dem Hinzuf?gen einer Subdomain.

 

Ist der Bug bekannt, vielleicht auch, was ich dagegen unternehmen kann? In der Content Suche bin ich leider nicht f?ndig geworden.

 

Im ?brigen l?uft froxlor auf meinem Server super stabil, nur zu empfehlen !!!

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Schon bekannt und in git gefixed. Schau mal einer der letzten commits auf github, da m?sste was sein. Danke trotzdem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By nurtext
      Moin,
      anscheinend schlägt Let's Encrypt bei Subdomains fehl, weil es gerne auch eine weitere "www"-Subdomain an die bestehende hängen würde. Siehe Log:
      root@meine-tolle-domain:/root# /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Updating Let's Encrypt certificates [information] Updating hilfe.meine-tolle-domain.de [information] Adding SAN entry: hilfe.meine-tolle-domain.de [information] Adding SAN entry: www.hilfe.meine-tolle-domain.de [information] letsencrypt Using 'https://acme-v01.api.letsencrypt.org' to generate certificate [information] letsencrypt Creating new account key [information] letsencrypt Starting new account registration [information] letsencrypt Sending registration to letsencrypt server [information] letsencrypt Sending signed request to /acme/new-reg [information] letsencrypt New account registered. [information] letsencrypt Accepting lets encrypt Terms of Service [information] letsencrypt Accepting agreement at URL: https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf [information] letsencrypt Sending signed request to /acme/reg/18369331 [information] letsencrypt Lets encrypt Terms of Service accepted [information] letsencrypt Starting certificate generation process for domains [information] letsencrypt Requesting challenge for hilfe.meine-tolle-domain.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for hilfe.meine-tolle-domain.de [information] letsencrypt Token for hilfe.meine-tolle-domain.de saved at /var/www/froxlor/.well-known/acme-challenge/5lbwRluW103CyNPdbmq7p_kd7p3blY8WGNSV0N0RNBY and should be available at http://hilfe.meine-tolle-domain.de/.well-known/acme-challenge/5lbwRluW103CyNPdbmq7p_kd7p3blY8WGNSV0N0RNBY [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/ZXmZ4SU2Oy0__ipk-ihaPtDq39OyNfBKAEHzfMvmO5U/1478709781 [information] letsencrypt Verification pending, sleeping 1s [information] letsencrypt Verification ended with status: valid [information] letsencrypt Requesting challenge for www.hilfe.meine-tolle-domain.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for www.hilfe.meine-tolle-domain.de [information] letsencrypt Token for www.hilfe.meine-tolle-domain.de saved at /var/www/froxlor/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE and should be available at http://www.hilfe.meine-tolle-domain.de/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE [error] letsencrypt Please check http://www.hilfe.meine-tolle-domain.de/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/www.hilfe.meine-tolle-domain.de\/.well-known\/acme-challenge\/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE): failed to open stream: php_network_getaddresses: getaddrinfo failed: Name or service not known","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":232} [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA/1478709934 [information] letsencrypt Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for hilfe.meine-tolle-domain.de: Verification ended with error: {"identifier":{"type":"dns","value":"www.hilfe.meine-tolle-domain.de"},"status":"invalid","expires":"2017-07-11T15:20:54Z","challenges":[{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:connection","detail":"DNS problem: NXDOMAIN looking up A for www.hilfe.meine-tolle-domain.de","status":400},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709934","token":"eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE","keyAuthorization":"eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE.lzkNGm6yCkkELPqgqQ8h9v-MfPi-5gRkb9yf76fy86s","validationRecord":[{"url":"http:\/\/www.hilfe.meine-tolle-domain.de\/.well-known\/acme-challenge\/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE","hostname":"www.hilfe.meine-tolle-domain.de","port":"80","addressesResolved":[],"addressUsed":"","addressesTried":[]}]},{"type":"tls-sni-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709935","token":"S1kgT_jIG8reMxRvGEf9niDf4WIiPyr5XslKbIFQ6eY"},{"type":"dns-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709936","token":"mp8J-ChoyV2gMPQyuJQoZaRlH2ePfcBYcb0v-cZ1zmU"}],"combinations":[[1],[0],[2]]} [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid root@meine-tolle-domain:/root/ Irgendwie sieht das für mich nicht gewollt aus, oder? 🤔
    • By nisamudeen97
      Hi,
      I am receiving the below alert as mail,  What is this  for  ?  How  can we stop this / fix this.
       
       
      Subject: Cron <root@w03> /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null
      MIME-Version: 1.0
      Content-Type: text/plain; charset=UTF-8
      Content-Transfer-Encoding: 8bit
      X-Cron-Env: <PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin>
      X-Cron-Env: <SHELL=/bin/sh>
      X-Cron-Env: <HOME=/root>
      X-Cron-Env: <LOGNAME=root>
      Message-Id: <20170409220002.09CF0800C2@w03.server.com>
      Date: Mon, 10 Apr 2017 00:00:02 +0200 (CEST)
      sh: 1: /usr/sbin/repquota: not found
       
    • By MrMonkeyMan
      I am new to froxlor and i was wondering how do i create a cronjob for my server
    • By jonnexen
      Hallo,
       
      habe eben eine neue Subdomain anlegen wollen und musste dann feststellen, dass nach 10min immer noch "Neuerstellung der Webserver-Konfiguration" im Panel stand. Ich habe dann also geschaut, warum der Cron nicht l?uft (Dienst war jedoch gestartet). So habe ich auch den Cron neugestartet, geschaut ob in den libnss-configs alles passt und auch ob der Cronjob /etc/cron.d/froxlor passt.
       
      Meiner sah wie folgt aus:
       
      PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
      #
      */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null
      0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null
      5 0 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --used_tickets_reset 1> /dev/null
      7 0 1 * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --ticketarchive 1> /dev/null
      10 0 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --usage_report 1> /dev/null
      0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null
       
      Nun habe ich im Panel unter Konfiguration geschaut und festgestellt, dass dort nur folgendes steht was eingetragen werden soll:
       
      PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
      #
      */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php
       
      Meine Frage: Warum? Ich habe die 0.9.32er Version schon immer auf der Kiste drauf, daher wundert mich das stark...
       
      Der Cron l?uft jetzt allerdings immer noch nicht... Hat jemand einen Ansatz f?r mich? Im Syslog finde ich leider keine Informationen...
       
      Das letzte, was ich gemacht habe war ein apt-get upgrade, davor lief die ganze Sache immer...
       
      EDIT: wenn ich den Cronjob h?ndisch ausf?hre:
      root@www1 /var/customers/webs # php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks
      There is already a Cronjob in progress. Exiting...
      Take a look into the contents of /var/run/froxlor_froxlor_master_cronjob-tasks.lock-* for more information!
       
      Inhalt dieser lock-Datei:
      Setting Lockfile to /var/run/froxlor_froxlor_master_cronjob-tasks.lock-31246
      Setting Froxlor installation path to /var/www/froxlor
      Userdatas included
      Table definitions included



       
    • By Tomasz Czauderna
      Hi
      I have problem with automatic task in cron in exacly i click rebuild config files and nothing is happend.
      My version is 9.32
      Calculating of mailbox-sizes:     25.05.2014 02:00:00 automatic task
      generating of configfiles:     24.05.2014 21:34:00 not working
      archiving old tickets:     22.04.2014 03:00:01 automatic task
      traffic calculation:     25.05.2014 02:00:00 automatic task
      Web- and traffic-reports:     25.05.2014 02:05:00 automatic task
      resetting ticket-counters:     22.04.2014 03:00:01 automatic task
       
      I check all logs and look fine all is good. No errors.
      I change in panel php settings and cron dont change files. And when I add subdomains in customer panel.
       
      I set permision to cron.d and froxlor to 777 and dont worked
      I make migration to fcron(more info) and this start one time and nothing no any errors.
      In older version all was working
      My platform is based on php5.5 but i dont see errors in log.
      when i run from script manual nothing happend
       
       
       




×
×
  • Create New...