Jump to content
Froxlor Forum

Question

I've installed Debian 8.2 amd64 with apache, mysql and php to run as a webserver.

What I want is retrieving the $_SERVER['REMOTE_USER'] when my clients, using Windows XP and Windows 7, visit the intranet installed on the Debian server.

Modules that are enabled in apache:

alias

auth_basic

auth_kerb

authn_core

authn_file

authz_core

authz_host

authz_user

autoindex

cgi

deflate

dir

env

filter

mime

mpm_prefork

negotiation

perl

php5

setenvif

status

 

httpd.conf

DirectoryIndex index.php index.html index.htm KeepAlive on HostnameLookups on <Location /test>
  PerlAuthenHandler "Apache2::AuthenNTLM"
  AuthType ntlm,basic
  AuthName "NTLM Authentication"

  require valid-user

  PerlAddVar ntdomain "MYDOMAIN 10.52.43.220"
  PerlSetVar defaultdomain "MYDOMAIN"

  PerlSetVar splitdomainprefix 1

  PerlSetVar ntlmdebug 0
  PerlSetVar ntlmauthorative off
  PerlSetVar ntlmsemkey 0

  PerlSetVar ntlmsemtimeout 1

</Location>

apache2.conf is a default file without any changes.

 

Because it doesn't work I tried putting an .htaccess in /var/www/test

<Location /test>
AuthType NTLM
NTLMAuth on
NTLMAuthoritative on
NTLMDomain MYDOMAIN
NTLMServer 10.52.43.220
require valid-user
</Location>

But it doesn't work either.

 

/var/log/apache2/error.log displays this:

[Thu Oct 08 11:34:23.786879 2015] [mpm_prefork:notice] [pid 2287]
AH00163: Apache/2.4.10 (Debian) mod_auth_kerb/5.4 mod_perl/2.0.9dev
Perl/v5.20.2 configured -- resuming normal operations [Thu Oct 08 11:34:23.786922 2015] [core:notice] [pid 2287] AH00094: 
Command line: '/usr/sbin/apache2'
[Thu Oct 08 11:35:39.656529 2015] [:error] [pid 2293] [client 10.52.43.14:49784] PHP Notice:  Undefined index: REMOTE_USER in /var/www/html/test/ntlm.php on line 2, referer: http://10.52.43.71/test/

What am I doing wrong and how can I fix it?

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By irisdina
      Warning, this is not an official guide!!!
      1.
      sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list
      sudo nano /etc/apt/source.list 1b.  insert (for Debian Stretch)
      1.2B (for Ubuntu Cosmic)
       
      1c. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. 
      sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server
      2. MariaDB install
      Warning use sudo command für this install!
      sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional)
      3. nginx install
      sudo apt install nginx 3a. 
      mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf
      4. PHP install
      sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. 
      sudo service nginx restart sudo service php7.3-fpm restart Froxlor install
      There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master)
      Stable Version
      1. 
      cd /var/www/html/ 1a. 
      sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or
      Git Version (Beta Version)
      sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer  su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory
      composer install --no-dev 1b. 
      sudo chown -R www-data:www-data Froxlor/ Set up Froxlor
      2. Open Your Browser
      2a.
      http://your IP or Hostname/Froxlor
       

      Install Froxlor finish
       3d. Move userdata (Optional) 
      sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. 
      sudo rm /etc/nginx/site-enable/default don't restart nginx!
      Froxlor Settings
      1. Cronjob
      sudo nano /etc/cron.d/froxlor insert 
      # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend
      Settings > Webserver settings > Nginx PHP backend
      from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock
      3. 
      sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port

      2a(1), SSL Port



      Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually
      sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional
      PHP-FPM activate
      1. User/Group add
      sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install 
      sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

      3. Settings > PHP-FPM > Activated:
      Change from NO to YES
      3a. PHP-FPM versions
      Change > php-fpm restart command:
      service php7.3-fpm restart and
      Configuration directory of php-fpm: > to 
      /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

      3c. 
      sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate
      1.
      sudo apt install certbot 1a. 
      sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File
      sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. 
      sudo nano /etc/nginx/acme.conf insert
      location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } }  
      2. Open your  Froxlor Panel
      Settings> SSL > Activated:
      Change from NO to YES
      2a. Settings > SSL > Settings
      Change your path from your certificate / Keyfile
      Path to the SSL certificate
      insert
      /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile
      insert
      /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings
      Activate > Enable Let's Encrypt

      Change Path to the acme.conf snippet to > 
      /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings
      - Enable Let's Encrypt for the froxlor vhost
      - Enable SSL-redirect for the froxlor vhost
      - HTTP Strict Transport Security (HSTS)
      - Include HSTS for any subdomain






      2d. Activated HTTP2 Support on > Settings > Nginx
       
    • By Christian Vogel
      Ich habe Froxlor installiert und alle Konfigurationen ausgeführt. Dennoch kann ich nicht über Outlook oder Mail auf mein Imap Konto zugreifen. 
      Im syslog sehe ich
      Sep 10 10:11:51 vserver3130 dovecot: imap-login: Aborted login (no auth attempts in 0 secs): user=<>, rip=87.191.51.26, lip=109.73.50.135, session=<uGoEloF1eIxXvzMa>
      postconf -d und dovecot -n hab ich als Textdatei angehängt.
      Habe auch schon etwas bei Google gesucht und hier im Forum die Suchfunktion bemüht - finde aber keine Lösung. Kann mir hier jemand helfen? Werden noch andere Infos benötigt für eine Lösung?
      Danke
      Christian
       
       
      dovecot.txt
      postconf.txt
    • By Keon
      Hallo alle miteinander,
       
      ich bin derweil dabei mir Froxlor auf einem CentOS7 System zum laufen zu bringen. Hier mal kurz ein kleiner Überblick wie ich aktuell stehe:
      SSH Port ändern, sudo User, NTP, EPEL Release, FirewallD für http, https, ssh mit neuem Port frei, fail2ban für SSH Apache, MariaDB, PHPMyAdmin, mod_ssl inkl. config und self signed cert, Froxlor Grundinstallation, Webserver und SSL Einstellungen Admin Menü, (Pfade, reload Script etc.) IP/Port 443 hinzugefügt, Konfiguration -> CentOS -> sonstiges -> cronjob for froxlor Ebenso habe ich - auch wenn unter "Konfiguration" für "CentOS" nicht vorhanden, die acme.conf angelegt  
      Kommen wir zur Frage:
      Wie bekomme ich hin, dass ich folgende Einstellung setzen kann:
       
      Habe ich noch etwas vergessen? Etwas grundlegendes? Bin normalerweise seit Debian Etch bis Jessie gewöhnt - sammle grad die ersten Erfahrungen mit Froxlor & CentOS nach 2 Jahren Pause aus der Informatik.
       
      Beste Grüße
    • By Kyle Willets
      I looked around and like my last question the directory on Centos 7 is different then the configuration in
      RHEL / CentOS (7) »  Webserver (HTTP) »  Apache 2.4
      I see that ofcourse my apache 2 is installed in httpd and I am searching, but no /etc/apache2/conf-enabled/acme.conf. I did see the first command created the var folders fine for customers, but the others all failed: 
      [root@s128426 ~]# nano /etc/httpd/conf/httpd.conf
      [root@s128426 ~]# chown root:0 /etc/apache2/sites-enabled/
      chown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
      [root@s128426 ~]# chmod 0600 /etc/apache2/sites-enabled/
      chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
      [root@s128426 ~]# chown root:0 /etc/apache2/sites-enabled/
      chown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
      [root@s128426 ~]# chmod 0600 /etc/apache2/sites-enabled/
      chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
       
      When I search httpd these directories do not exist within it. Is there a separate install  for apache for Froxlor or something I am missing? I am really thinking about going to debian, but my dedicated host does not offer debian stretch at the moment so went centos being I knew it was the most up to date right now in their list.
       

       
    • By AreYouLoco?
      Hi,
      I am trying to setup froxlor on my Debian LAMP. I followed the guide from here: https://github.com/Froxlor/Froxlor/wiki/Install-froxlor-on-debian and and here https://github.com/Froxlor/Froxlor/wiki/Install-froxlor-from-tarball.
      I am stuck on page that I need to provide credentials to the database. When I go forward I do get this:

      I fill in my credentials; new password for froxlor database, new password for admin account, my root password that I can use to login locally via:
      mysql -u root -p Please help

       
      EDIT:
      I did some research and I allowed remote root login.
      MariaDB [(none)]> show grants; +------------------------------------------------------------------------------------------------+ | Grants for root@localhost | +------------------------------------------------------------------------------------------------+ | GRANT ALL PRIVILEGES ON *.* TO 'root'@'localhost' IDENTIFIED VIA unix_socket WITH GRANT OPTION | | GRANT PROXY ON ''@'%' TO 'root'@'localhost' WITH GRANT OPTION | +------------------------------------------------------------------------------------------------+  




×
×
  • Create New...