Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Vanidor

[solved] 500 Error beim Froxlor Panel

Question

Hallo, ich habe FPM nach der Anleitung installiert. Es l?uft auch alles nur habe ich keinen Zugriff mehr auf das Control Panel von Froxlor. Mich begr??t dort nur eine 500 Error Seite. Ebenfalls wird an anderen Stellen der Quelltext anstelle der Seite angezeigt

 

Im Log steht folgendes:

[Thu Feb 13 16:08:38 2014] [error] [client xx.201.xxx.96] (2)No such file or directory: FastCGI: failed to connect to server "/var/www/php-fpm/froxlor.panel/xxx/503a.fpm.external": connect() failed
[Thu Feb 13 16:08:38 2014] [error] [client xx.201.xxx.96] FastCGI: incomplete headers (0 bytes) received from server "/var/www/php-fpm/froxlor.panel/xxx/503a.fpm.external"

Kann es vielleicht daran liegen, das ich den Harken der bewirkt das der Froxlor Host auch als FPM behandelt wird nicht gesetzt hatte? Wenn ja wie kann ich den nachtr?glich ?ndern?

 

Mit freundlichem Gru?,

 

Vanidor

Share this post


Link to post
Share on other sites

19 answers to this question

Recommended Posts

Wenn der Haken nicht gesetzt w?re, g?be es ja keine FPM config f?r den froxlor-host, ergo w?rdest du den Fehler nicht erhalten. Sind denn alle anderen Seite erreichbar? Wie sieht die entsprechende Vhost-Config aus (10_*.conf in /etc/apache2/sites-enabled). Ebenso br?uchten wir den Inhalt der fpm-config f?r den vhost (in /etc/php5/fpm/pool.d/ oder ?hnlich, je nach konfiguration).

Share this post


Link to post
Share on other sites

Inhalt der 10_froxlor_ipandport_xx.xxx.xx.xxx.xx.conf:

# 10_froxlor_ipandport_xx.xxx.xx.xxx.xx.conf
# Created 13.02.2014 15:59
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

NameVirtualHost xx.xxx.xx.xxx.xx:80
<VirtualHost xx.xxx.xx.xxx.xx:80>
DocumentRoot "/var/www/froxlor/"
 ServerName xx.xxx.net
  FastCgiExternalServer /var/www/php-fpm/froxlor.panel/xx.xxx.net/503a.fpm.external -socket /var/lib/apache2/fastcgi/froxlor.panel-xx.xxx.net-php-fpm.socket -idle-timeout 30
  <Directory "/var/www/froxlor/">
   <FilesMatch "\.(php)$">
     AddHandler php5-fastcgi .php
     Action php5-fastcgi /fastcgiphp
      Options +ExecCGI
    </FilesMatch>
    Order allow,deny
    allow from all
  </Directory>
  Alias /fastcgiphp /var/www/php-fpm/froxlor.panel/xx.xxx.net/503a.fpm.external
</VirtualHost>

Eine Config f?r den entsprechenden V Host existiert nicht in /etc/php5/fpm/pool.d. 

 

Mir ist gerade auch noch aufgefallen, das phpMyAdmin (installiert im Unterverzeichnis einer Domain) als Quelltext angezeigt wird. Andere Dateien sind jedoch noch "normal"

Share this post


Link to post
Share on other sites

Du sagtest es gibt keine erstellten Dateien in /etc/php5/fpm/pool.d/ - was hast du denn bei Froxlor eingestellt, wo die fpm-configs erstellt werden sollen? PHP-FPM muss diese ja inkludieren und per default inkludiert es unter debian den Ordner /etc/php5/fpm/pool.d/. Froxlor's default-Wert f?r diese Einstellung ist "/etc/php-fpm.d/" - sind die Dateien vielleicht dort?

Share this post


Link to post
Share on other sites

kann ja nicht sein, dann w?rde der Vhost nicht so aussehen, der wird ja nur so erstellt, wenn fpm f?r den froxlor-vhost auch aktiviert wurde. Hast du den Cronjob mal manuell abgefeuert und geschaut ob er die config dann erstellt?

Share this post


Link to post
Share on other sites

F?r die Domain und die Standard Subdomain die Froxlor automatisch erstellt f?r diese Domain existieren Config Files. Ich habe auch noch Zugriff auf die Domains jedoch keinen mehr auf das Control Panel, da mir dort nur ein 500 Fehlercode angezeigt wird. 

Share this post


Link to post
Share on other sites

Du wiederholst dich, beantwortest aber nicht die Frage:

 

kann ja nicht sein, dann w?rde der Vhost nicht so aussehen, der wird ja nur so erstellt, wenn fpm f?r den froxlor-vhost auch aktiviert wurde. Hast du den Cronjob mal manuell abgefeuert und geschaut ob er die config dann erstellt?

Share this post


Link to post
Share on other sites

Dann kann ich ohne auf den Server zu gucken nichts weiter sagen, ggfls. was in den Einstellungen nicht ganz stimmig.

Share this post


Link to post
Share on other sites

Sieht danach aus das ich das gleiche Problem habe. Angelegte Kunden-Seiten laufen mit php5-fpm, das Froxlor-Panel nicht.

 

Das im Virtualhost unter FastCgiExternalServer definierte Socket l?uft ins leere, "/etc/php5/fpm/pool.d/" enth?lt keine .conf f?rs Controlpanel, "/etc/php5-fpm/" existiert nicht falls es das geben sollte (habe ich irgendwo hier im Forum gelesen)

 

Habe php5-fpm nach dieser Anleitung installiert: http://redmine.froxlor.org/projects/froxlor/wiki/FPM_-_handbook

Ich habe keine Ahnung was da schief gegengen ist. Aus irgend einen Grund hat der Chronjob die Configuration nur Teilweise angelegt.

 

Froxlor l?uft bei mir unter Debian mit Apache, bzw. lief, denn ich kann froxlor nicht mehr erreichen. Gibt es noch eine Andere L?sung als alles neu zu installieren?

Share this post


Link to post
Share on other sites

"Alles neu installieren" ist NIE die L?sung.
 
Wenn es bei dir kein /etc/php oder /etc/php5/ o.?. (es gibt viele Varianten) gibt, dann hast du aber gewaltig was falsch gemacht, denn dieses Verzeichnis sollte es schon geben, auch ohne Froxlor.
 
Und wie kannst du sagen, dass froxlor die Configs nur Teilweise anlegt, wenn er doch auf Grund des nichtexistenten Verzeichnisses die Pool-Configs garnicht erstellen kann.
 
Um da jetzt etwas effektiver rangehen zu k?nnen:
 
- welche Froxlor version?
- welches Verzeichnis wurde f?r die PHP-FPM Konfigurationen hinterlegt? (Default: /etc/php-fpm.d/, unter Debian ist das definitiv ein anderes Verzeichnis!)
- laufen die Kunden auf FPM aber das Panel nicht, hast du vllt gar nicht eingestellt, dass es das tun soll? (Settings -> FPM -> Enable PHP-FPM for the Froxlor vHost)

- Logs, Vhost-Configs, etc.etc.etc. ein bisschen Info mit der wir arbeiten k?nnen

Share this post


Link to post
Share on other sites

/etc/php-fpm.d/ gibt es nicht, /etc/php5/fpm schon. Auf einer angelegten Kunden-Seite kann ich auch phpinfo() ausf?hren und wird alles ordentlich unter den kunden als User ausgef?hrt.

 

Settings -> FPM -> Enable PHP-FPM ist etwas schwierig da Froxlor nicht mehr l?uft, bin aber der Meinung das ich alle Froxlor-Einstellungen nach FPM-Anleitung gemacht habe. Froxlor Version finde ich nun auch nicht ohne weiteres, habe Froxlor aber erst vor 6 Tagen per apt-get installiert unter Wheezy. Apache MySql, etc. wurden dabei mit installiert.

 

Das Problem scheint mir in der fehlenden .conf Datei in /etc/php5/fpm/pool.d/ zu liegen oder liegt die .conf f?rs Froxlor Panel wo anders? Kann ich irgendwie von ausserhalb (MySQL oder so) Froxlor dazu bewegen diese neu an zu legen? Den Master Chronjob neu starten habe ich schon versucht.

Die .conf's der Kunden in /etc/php5/fpm/pool.d/ sind auf jeden Fall vorhanden und funktionieren.

 

Ein kleiner Ausschnitt aus der Tabelle panel_settings:

63	phpfpm	enabled	1
64	phpfpm	configdir	/etc/php5/fpm/pool.d
65	phpfpm	reload	/etc/init.d/php5-fpm restart
66	phpfpm	pm	static
67	phpfpm	max_children	1
68	phpfpm	start_servers	20
69	phpfpm	min_spare_servers	5
70	phpfpm	max_spare_servers	35
71	phpfpm	max_requests	0
72	phpfpm	tmpdir	/var/customers/tmp/
73	phpfpm	peardir	/usr/share/php/:/usr/share/php5/
74	phpfpm	enabled_ownvhost	0
75	phpfpm	vhost_httpuser	froxlorlocal
76	phpfpm	vhost_httpgroup	froxlorlocal
77	phpfpm	idle_timeout	30
78	phpfpm	aliasconfigdir	/var/www/php-fpm/
79	phpfpm	defaultini	1
80	phpfpm	vhost_defaultini	2
81	phpfpm	fastcgi_ipcdir	/var/lib/apache2/fastcgi/
...
108	system	apacheconf_vhost	/etc/apache2/sites-enabled/
109	system	apacheconf_diroptions	/etc/apache2/sites-enabled/
110	system	apacheconf_htpasswddir	/etc/apache2/htpasswd/
111	system	webalizer_quiet	2
112	system	last_archive_run	000000
113	system	mod_fcgid_configdir	/var/www/php-fcgi-scripts
114	system	mod_fcgid_tmpdir	/var/customers/tmp
...
118	system	default_vhostconf	
...
123	system	httpuser	www-data
124	system	httpgroup	www-data
125	system	webserver	apache2
126	system	mod_fcgid_wrapper	1
127	system	mod_fcgid_starter	0
128	system	mod_fcgid_peardir	/usr/share/php/:/usr/share/php5/
129	system	index_file_extension	html
130	system	mod_fcgid_maxrequests	250
...
133	system	debug_cron	0
134	system	store_index_file_subs	1
135	system	stdsubdomain	
...
163	system	mod_fcgid_ownvhost	0
164	system	mod_fcgid_httpuser	froxlorlocal
165	system	mod_fcgid_httpgroup	froxlorlocal
...
208	panel	version	0.9.31.2

Share this post


Link to post
Share on other sites

/etc/php-fpm.d/ gibt es nicht, /etc/php5/fpm schon.

naja, vorhin hie? es noch, den fpm-config ordner g?be es bei dir nicht...

 

Auf einer angelegten Kunden-Seite kann ich auch phpinfo() ausf?hren und wird alles ordentlich unter den kunden als User ausgef?hrt.

Du hast schlichtweg fpm f?r den froxlor-vhost nicht aktiviert.

 

Settings -> FPM -> Enable PHP-FPM ist etwas schwierig da Froxlor nicht mehr l?uft, bin aber der Meinung das ich alle Froxlor-Einstellungen nach FPM-Anleitung gemacht habe.

Du hast doch die panel_settings grad schon ausgelesen, passe die Einstellungen doch direkt dort an (phpfpm enabled_ownvhost 0 => 1)

 

Froxlor Version finde ich nun auch nicht ohne weiteres, habe Froxlor aber erst vor 6 Tagen per apt-get installiert unter Wheezy.

Du hast sie in der panel_settings doch mit ausgelesen...

 

Das Problem scheint mir in der fehlenden .conf Datei in /etc/php5/fpm/pool.d/ zu liegen oder liegt die .conf f?rs Froxlor Panel wo anders?

Fehlt dort denn NUR die config f?r das Panel? wenn ja -> auch DAS liegt daran, dass du fpm f?rs panel halt nicht aktiviert hast.

 

Kann ich irgendwie von ausserhalb (MySQL oder so) Froxlor dazu bewegen diese neu an zu legen? Den Master Chronjob neu starten habe ich schon versucht.

Cron neustarten? Was soll das bringen? Einfach den Cronjob manuell ausf?hren (nat?rlich nachdem du die Einstellungen angepasst hast):

php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force

Share this post


Link to post
Share on other sites

 

naja, vorhin hie? es noch, den fpm-config ordner g?be es bei dir nicht...

 

 

 

 

Wo denn? Da ist wohl etwas missverstanden worden.

 

 

 

 

Du hast sie in der panel_settings doch mit ausgelesen...

 

 

 

Das stimmt, Danach hatte ich vergessen um den Satz zu entfernen.

 

 

Du hast schlichtweg fpm f?r den froxlor-vhost nicht aktiviert.

 

 

Volltreffer!

Im Controlpanel d?rfte das der Punkt "Default PHP configuration for Froxlor-vHost" sein? Ich kann mich daran erinnern das ich dort ?berlegt hatte, ob ich den ?ndern soll, da dar?ber in FPM-Installationsanleitung nichts erw?hnt wurde, hatte ich mich entschieden erstmal die Finger davon zu lassen.

 

F?r den n?chsten mit dem gleichen Problem, hier die L?sung:

mysql -ufroxlor -pFroxlorMySQLPassword

UPDATE froxlor.panel_settings SET value = 1 WHERE settinggroup='phpfpm' AND varname='enabled_ownvhost';
\q

php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force

Soweit schonmal vielen Dank f?r die Hilfe! Nun habe ich mir nat?rlich nicht die M?he gemacht FPM zu installieren, um mich gleich danach mit einer unverschl?sselten Verbindung in die Verwaltung meines Servers ein zu loggen. Deswegen habe ich eine Datei ge?ndert und eine neu erstellt in /etc/apache2/sites-enabled:

# 10_froxlor_ipandport_--.--.--.--..conf

NameVirtualHost --.--.--.--:80
<VirtualHost --.--.--.--:80>
	ServerName www.domainname.org
	<IfModule mod_rewrite.c>
		RewriteEngine On
		RewriteCond %{HTTPS} off
		RewriteRule (.*) https://domainname.org%{REQUEST_URI}
	</IfModule>
	Redirect / https://www.domainname.org/
</VirtualHost>

# 10_froxlor_ipandport_--.--.--.--.443.conf

NameVirtualHost --.--.--.--:443
<VirtualHost --.--.--.--:443>
DocumentRoot "/var/www/"
 ServerName domainname.org
  FastCgiExternalServer /var/www/php-fpm/froxlor.panel/domainname.org/e302.fpm.external -socket /var/lib/apache2/fastcgi/froxlor.panel-domainname.org-php-fpm.socket -idle-timeout 30
  <Directory "/var/www/">
   <FilesMatch "\.(php)$">
     AddHandler php5-fastcgi .php
     Action php5-fastcgi /fastcgiphp
      Options +ExecCGI
    </FilesMatch>
    Order allow,deny
    allow from all
  </Directory>
  Alias /fastcgiphp /var/www/php-fpm/froxlor.panel/domainname.org/e302.fpm.external
	SSLEngine On
	SSLCertificateFile    /etc/ssl/certs/ssl-cert-snakeoil.pem
	SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key
#	SSLCertificateChainFile /etc/apache2/ssl.crt/server-ca.crt
</VirtualHost>

Ich bin mir dessen bewusst das das nicht der richtige Ort ist f?r diese Anpassung, da Dateien hier von Froxlor ?berschrieben werden. Wie kann ich das ordentlich machen?

Share this post


Link to post
Share on other sites

Im Controlpanel d?rfte das der Punkt "Default PHP configuration for Froxlor-vHost" sein?

Nein, ich hab dir die Option doch genannt. Gemacht hast du allerdings das Richtige (dein SQL)

 

Nun habe ich mir nat?rlich nicht die M?he gemacht FPM zu installieren, um mich gleich danach mit einer unverschl?sselten Verbindung in die Verwaltung meines Servers ein zu loggen.

Was hat die PHP Implementierung mit SSL/nicht-SSL zu tun?

 

 

Ich bin mir dessen bewusst das das nicht der richtige Ort ist f?r diese Anpassung, da Dateien hier von Froxlor ?berschrieben werden. Wie kann ich das ordentlich machen?

Entweder von Froxlor keinen Vhost erstellen lassen und komplett einen manuell erstellen (er darf nur nicht dem Benamungs-Schema von Froxlor entsprechen, sowas wie 001-mein-vhost.conf ist also okay) oder gar nicht, denn Froxlor selbst bietet noch kein SSL f?r seinen eigenen Vhost (steht auf der TODO).

Share this post


Link to post
Share on other sites

  • Similar Content

    • By Schutzgeist
      Hallo, 
      vielleicht kann mir jemand hier ja einen kleinen Tipp geben.
      Es ist mehr eine nginx-Konfiguration. 
      PHP-404-Rückmeldungen sollen "sauber" an Joomla übergeben werden.
       
      Mein 'Froxlor-Standardvhost sieht wie folgt aus

      Allerdings kann ich über das Joomla eigene REDIRECT Modul keine .php - Erweiterungen intern umleiten. 
      Anstatt  die joomla-eigene 404 Seite zu erhalten, bekomme ich die von nginx, da  die Abfrage hier als erstes ausgeführt wird. 
      Also habe ich meine vhost stümperhaft umgeschrieben, s.d. ein Teil seinen Soll erfüllt. 

      Teilweise kann ich nun die Redirects über Joomla verwalten lassen, aber oft erhalte ich LOOPs, da ich ja immer auf die index.php verweise. 
      So, warum nutze ich nicht die nginx-Weiterleitungen ? 

      Ich nutze ein Multi-Sitemodul  sowie ein Modul, um eine php-Endung  zu simulieren. 
      Beide haben mit meiner und der Standardvhost-Konfiguration leichte Schwierigkeiten. 

       
      Welche Vhost-Anpassungen nutzt ihr bei Eurer Joomla-Webseite ? 
      Der Fehler sitzt vermutlich 30 cm vor meinem Bildschirm. 
      Innerhalb meiner letzten 30 Versuche habe ich wohl  oft alte Cache-Webseiten geladen und ggf. die richtige Konfig übersehen.
       

       
       
       
       
       
    • By irisdina
      Warning, this is not an official guide!!!
      1.
      sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list
      sudo nano /etc/apt/source.list 1b.  insert (for Debian Stretch)
      1.2B (for Ubuntu Cosmic)
       
      1c. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. 
      sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server
      2. MariaDB install
      Warning use sudo command für this install!
      sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional)
      3. nginx install
      sudo apt install nginx 3a. 
      mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf
      4. PHP install
      sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. 
      sudo service nginx restart sudo service php7.3-fpm restart Froxlor install
      There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master)
      Stable Version
      1. 
      cd /var/www/html/ 1a. 
      sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or
      Git Version (Beta Version)
      sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer  su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory
      composer install --no-dev 1b. 
      sudo chown -R www-data:www-data Froxlor/ Set up Froxlor
      2. Open Your Browser
      2a.
      http://your IP or Hostname/Froxlor
       

      Install Froxlor finish
       3d. Move userdata (Optional) 
      sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. 
      sudo rm /etc/nginx/site-enable/default don't restart nginx!
      Froxlor Settings
      1. Cronjob
      sudo nano /etc/cron.d/froxlor insert 
      # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend
      Settings > Webserver settings > Nginx PHP backend
      from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock
      3. 
      sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port

      2a(1), SSL Port



      Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually
      sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional
      PHP-FPM activate
      1. User/Group add
      sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install 
      sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

      3. Settings > PHP-FPM > Activated:
      Change from NO to YES
      3a. PHP-FPM versions
      Change > php-fpm restart command:
      service php7.3-fpm restart and
      Configuration directory of php-fpm: > to 
      /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

      3c. 
      sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate
      1.
      sudo apt install certbot 1a. 
      sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File
      sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. 
      sudo nano /etc/nginx/acme.conf insert
      location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } }  
      2. Open your  Froxlor Panel
      Settings> SSL > Activated:
      Change from NO to YES
      2a. Settings > SSL > Settings
      Change your path from your certificate / Keyfile
      Path to the SSL certificate
      insert
      /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile
      insert
      /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings
      Activate > Enable Let's Encrypt

      Change Path to the acme.conf snippet to > 
      /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings
      - Enable Let's Encrypt for the froxlor vhost
      - Enable SSL-redirect for the froxlor vhost
      - HTTP Strict Transport Security (HSTS)
      - Include HSTS for any subdomain






      2d. Activated HTTP2 Support on > Settings > Nginx
       
    • By LostNIL
      Greetings,
      I have Froxlor installed with PHP7.2 and need to install/enable PHP7.2-fpm. I've reviewed the wiki, The Froxlor YouTube video on the subject, and reviewed/completed the instructions within the Panel > Configuration > DB Jessie > Other > FPM and am having difficulties getting the panel to work with FPM. 
      All available instructions are written for PHP5 and when I complete the instructions and substitute PHP7.2, when the panel generates configurations there are syntax errors and the websites go down. 
       
      Does anyone have any pointers or updated instructions on enabling FPM/PHP7+ with Froxlor. 
    • By zed
      Hi, after fresh froxlor install on debian9 and php-fpm I have 503 error :
      Service Unavailable The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later. In /var/log/apache2/error.log I found:
      [proxy:error] [pid 997] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /var/lib/apache2/fastcgi/1-froxlor.panel-sub.domain.com-php-fpm.socket (*) failed [proxy_fcgi:error] [pid 997] [client 1.1.1.1:57529] AH01079: failed to make connection to backend: httpd-UDS I have not created any customers or domains yet and I can't access Froxlor panel and phpmyadmin
      File /var/lib/apache2/fastcgi/1-froxlor.panel-sub.domain.com-php-fpm.socket is not available, I created it but still not work.
      What can I do ?
    • By gunnyst
      Hello again, hope you don't mind me coming up with another issue (including proposal for solution obviously).
      I had another issue using PHP-FPM, where I cannot get my .XML files parsed by the PHP interpreter even though I have this in my .htaccess:
      <FilesMatch "\.(xml)$">   SetHandler php5-fastcgi   Action php5-fastcgi /fastcgiphp   Options +ExecCGI </FilesMatch> It turns out that there is a limit imposed by the security.limit_extensions setting which defaults to .php only. My .XML files are used in order to automatically return the correct autodiscover/autoconfig settings to Outlook/Thunderbird and the like and therefor need to be "dynamic XML files", but I could imagine someone else needing .phps or the like...
      Currently I have gone so far as to add some stuff to /var/www/froxlor/lib/classes/phpinterface/class.phpinterface_fpm.php @ 248:
      if ($this->_domain['domain'] == 'autodiscover.mydomain.tld') {         $fpm_config.= 'security.limit_extensions = .php .xml'."\n"; } But again, this could be a new string-based setting in the new PHP-FPM versions section.
      (Slowly I'll get in touch with the code structure I promise...)
×
×
  • Create New...