Jump to content
Froxlor Forum
  • 0

Fehler beim Speichern von Standard SSL vHost-Einstellungen


Go to solution Solved by d00p,

Question

Hallo,

ich versuche folgende Einstellungen in den Standard (SSL) vHost-Einstellungen (System->Einstellungen->Webserver-Einstellungen) einzutragen:

ServerTokens Prod
ServerSignature Off

Erst einmal die Frage: Ist das der richtige Ort um das global zu machen?

Wenn ja, dann habe ich ein Problem beim Abspeichern wenn das Feld Standard SSL vHost-Einstellungen gefüllt ist. Es erscheint unabhängig vom Inhalt folgende Fehlermeldung:

Quote

Bei dem Speichern des Feldes "system_default_sslvhostconf" trat ein Fehler auf

Falls dies nicht der richtige Ort für eine solche Änderung ist würde mich interessieren ob es innerhalb von Froxlor einen passenden Ort für solche globalen Webserver-Einstellungen gibt.

 

Danke und Gruß,

 

Afox

 

Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 1
  • Solution

das war ne schwere geburt. Das feld wurde tatsächlich nur im Update hinzugefügt und ich hab das total vergessen für neuinstallationen, folgender SQL Befehl sollte das problem lösen:

INSERT INTO `panel_settings` SET `settinggroup` = 'system', `varname` = 'default_sslvhostconf', `value` = '';

 

Link to post
Share on other sites
  • 0
20 minutes ago, Afox said:

Erst einmal die Frage: Ist das der richtige Ort um das global zu machen?

Nein, das gehört in die apache.conf

21 minutes ago, Afox said:

Falls dies nicht der richtige Ort für eine solche Änderung ist würde mich interessieren ob es innerhalb von Froxlor einen passenden Ort für solche globalen Webserver-Einstellungen gibt.

Nein, froxlor ändert nichts an der apache.conf und wird auch nicht. 

21 minutes ago, Afox said:

Bei dem Speichern des Feldes "system_default_sslvhostconf" trat ein Fehler auf

welche froxlor version? Schon mit aktueller git versucht? steht was in den logs?

Link to post
Share on other sites
  • 0

Danke.

8 minutes ago, d00p said:

steht was in den logs?

Leider nein. Habe in den normalen Apache Logs und den Customer Logs geschaut sowie im Froxlor System-Log. Evtl. habe ich einen Ort vergessen.

Bedeutet das dass du es nicht nachstellen konntest? Browser war Firefox falls das eine Rolle spielt.

LG

 

 

Link to post
Share on other sites
  • 0
1 hour ago, Afox said:

Hallo,

ich versuche folgende Einstellungen in den Standard (SSL) vHost-Einstellungen (System->Einstellungen->Webserver-Einstellungen) einzutragen:


ServerTokens Prod
ServerSignature Off

Erst einmal die Frage: Ist das der richtige Ort um das global zu machen?

Unter Debian ist es /etc/apache2/conf-enabled/security.conf

Link to post
Share on other sites
  • 0
31 minutes ago, Afox said:

Bedeutet das dass du es nicht nachstellen konntest?

Na probiers doch im zweifel selbst auf demo.froxlor.org 

Link to post
Share on other sites
  • 0

Danke @Shortie

Habe es jetzt trotzdem in der apache2.conf gemacht. Dürfte keinen Unterschied machen.

4 minutes ago, d00p said:

Na probiers doch im zweifel selbst auf demo.froxlor.org

Habe ich gerade gemacht und genau das gleiche Problem/derselbe Fehler. Ich hatte nur mal "Test" in das Feld "Default SSL vHost-settings" eingetragen.

Link to post
Share on other sites
  • 0
17 minutes ago, Afox said:

Habe ich gerade gemacht und genau das gleiche Problem/derselbe Fehler. Ich hatte nur mal "Test" in das Feld "Default SSL vHost-settings" eingetragen.

Sicher? ich habe gerade exakt das gleiche gemacht...kein Fehler. Egal ob non-ssl oder ssl IP, egal ob chrome oder firefox

Link to post
Share on other sites
  • 0
11 minutes ago, d00p said:

Sicher?

Eigentlich schon. Habe gerade nochmal einen zweiten Client probiert. Selbes Ergebnis unter Firefox. Allerdings sind beides Linux Systeme.

Link to post
Share on other sites
  • 0

Und du hattest auch definitiv das SSL settings Feld gefüllt? Interessanterweise funktioniert es wenn ich das Feld Default vHost-settings befülle. Nur bei den SSL Einstellungen geht es nicht.

Falls wir beide dasselbe gemacht haben und es nur bei mir nicht geht wäre ich daran interessiert es zu debuggen, weiß aber nicht so recht wie wenn nichts in den Logs steht.

Link to post
Share on other sites
  • 0

wie gesagt dann weiß ich auch nicht weiter. Habe schon in die Konsole des Browsers geschaut und dort steht als einziger Fehler:

Quote

Content Security Policy: Die Einstellungen der Seite haben das Laden einer Ressource auf inline blockiert ("script-src").

Dieser ist aber die ganze Zeit vorhanden und beim Absenden kommt kein weiterer Fehler hinzu.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...