Jump to content
Froxlor Forum
  • 0
Afox

Debian 10 (Buster)

Question

hi,

 

wollte mal fragen ob es bereits Planungen zu einem Buster Release gibt, also ob es nach dem Erscheinen am 06.07.2019 mit Froxlor-Paketen zu rechnen ist bzw. wie lange es in etwa dauern wird bis Froxlor kompatibel ist.

 

LG,

 

Afox

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

Wir sind im Release candidate Zyklus. Buster config templates sind bereits eingefügt und müssen noch getestet werden. Es wird aber definitiv keinen stable Release von froxlor zum Release von Buster geben.

Share this post


Link to post
Share on other sites
  • 0

Danke für die Antwort. Ich gehe mal davon aus dass es auch Pakete mit dem stable Release geben wird (so wie bisher nur etwas zeitversetzt). LG

Share this post


Link to post
Share on other sites
  • 0

Gibt es bezüglich Buster schon einen neuen Stand? Welche Version wird damit laufen? Danke

Share this post


Link to post
Share on other sites
  • 0

0.10.0 wird config templates haben, Laufen tut aber auch 0.9.x problemlos...ist ja nur PHP ;) geht nur um die configs

Share this post


Link to post
Share on other sites
  • 0

Kann ich das Distributions Update einfach machen oder muss ich etwas am froxlor 0.9.40.1-1 anpassen?

Share this post


Link to post
Share on other sites
  • 0

An froxlor selbst nicht nein, ggfls halt configs - vorallem mail

Share this post


Link to post
Share on other sites
  • 0

hi nochmal, kommt eigentlich noch ein rc Release vor dem stable Release oder wäre die nächste dann schon die stable Version? Werden noch weitere Pull requests einfließen (z.B. OpenDKIM) oder bleibt der Umfang so wie er aktuell auf github zu sehen ist? VG

Share this post


Link to post
Share on other sites
  • 0

Ein umfangreicher und vorallem nur halbfertiger PR wie Domainkey wird nicht mehr in 0.10.0 einfließen

Share this post


Link to post
Share on other sites
  • 0

Möglich ja, im Moment ist nur leider Zeit der entscheidende Faktor, denn die fehlt mir hoch zehn :)

Share this post


Link to post
Share on other sites
  • 0

Hallo,

verabschiede mich gerade von Strech und stelle um auf Buster. Auf Stretch habe ich das Update auf die letzte Version durchgeführt, ohne Probleme.

Die Froxlor Datenbank habe ich gesichert und auf den BusterServer kopiert.

Die Froxlor Installation auf dem BusterServer iss sauber durchgelaufen, hab die mit der Installation angelegte Datenbank gesichert und dann die Datenbank aus Stretch zurück kopiert.

Auch das zurück kopieren der Datenbank klappte auch ohne Probleme, alles wird angezeigt. Muss danach noch schnell die IP's ändern, alles kein Problem.

Wer ahnt's, es zwickt an einer anderen Stelle: Die User müssten aus der Froxlor Datenbank dem System bekannt gemacht werden, das scheint noch nicht zu klappen:

Wenn ich die webs aus der tgz extrahiere, werden die owner in Zahlen ausgegeben.

Außerdem jammert der Apache herum:  "bad user name ImmoService" könnte sein, dass das mit den ownern zusammenhängt, das Log-File gibt noch nichts sinnvolles her. Da muss ich noch forschen.

Ist bekannt, dass ein einfaches kopieren des customers-Verzeichnis von mit seinen UnterverzeichnissenStretch nach Buster nicht reicht?

Danke für die Antwort schon mal im Voraus !!!! und danke für die super Software in den vergangenen Monaten !!!!!!

Share this post


Link to post
Share on other sites
  • 0

Hattest du denn auf dem alten Server libnss-mysql/libnss-extrausers verwendet? Das wäre die Schnittstelle zwischen Datenbank und System was die User angeht.

Ebenso hast du bei den Datenbanken hoffentlich auch an die mysql-Datenbank gedacht in der sich die ganzen Datenbankbenutzer und Passwörter verstecken, sonst sind zwar die Kundendatenbanken da, aber die Rechte dafür nicht.

Share this post


Link to post
Share on other sites
  • 0

Jup, extrausers kommt zum Einsatz. Hab mal nachgesehen, wie es auf dem BusterServer mit den Datein

/var/lib/extrausers/passwd
/var/lib/extrausers/group
/var/lib/extrausers/shadow


ausssieht. Die waren leer, wie am Anfang, erkllärt alles. Hab dann einen DemoKunden und hierfür eine Domain angelegt, plötzlich waren alle Einträge da, auch nach dem Extrahieren der Customers stimmten die Owner.

Was ich außen vor ließ ist, dass neue Passwörter für MySQL root, MySQL froxlor uns das Admin-Passwort vergeben wurden, das dürfte jedoch nicht ursächlich sein. Natürlich ist klar, dass die Anpassung in den Configurationsdateien erfolgen muss, soweit erforderlich.

Share this post


Link to post
Share on other sites
  • 0

ja dann lief da vllt nur der entsprechende cron nicht, der schreibt dateien ja nur wenn was geändert wurde, also wenn du da eine installation komplett wegziehst macht es durchaus sinn da den cron manuell mit --force --debug auszuführen um alles wieder anzulegen

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...