Jump to content
Froxlor Forum
  • 0
Kieron Boswell

Couple of Mail/FTP questions

Question

Hi guys, have just got froxlor set-up and looking around it getting it ready to move all my clients into, one or two things I haven't been able to see yet.

  • Mail settings, I'm used to being spoon-fed mail settings when I create an account, generally are these fixed so I can make a note? And is there a way to use mail.domain.tld rather than using the primary server domain for example? I'd really like something like that to be the default when I create a new website/email etc if possible.
  • Ftp, is it possible to set ftp.domain.tld as a record that works for FTP automatically when an account is made under a customer?

Many thanks, enjoying froxlor so far :-)

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0
2 minutes ago, Kieron Boswell said:

Mail settings, I'm used to being spoon-fed mail settings when I create an account, generally are these fixed so I can make a note?

what settings do you want to set?

2 minutes ago, Kieron Boswell said:

And is there a way to use mail.domain.tld rather than using the primary server domain for example?

sure, but if you use SSL this will throw a warning that the certificate is not valid for the given domain but basically you can use anything that points to the servers-ip, even the IP itself

3 minutes ago, Kieron Boswell said:

I'd really like something like that to be the default when I create a new website/email etc if possible.

what exactly do you want to make default? dont get what you mean

4 minutes ago, Kieron Boswell said:

Ftp, is it possible to set ftp.domain.tld as a record that works for FTP automatically when an account is made under a customer?

same as mail-domain, you can use anything that points to the server when not using SSL and if the users domain has a wildcard-entry in its dns zone then the customer can use whateverhewants.domain.tld to connect to the ftp server. no need for a specific dns-entry

Share this post


Link to post
Share on other sites
  • 0
27 minutes ago, d00p said:

what settings do you want to set?

7

Sorry if I wasn't clear, I mean when you are finished making an account in other panels I have used, you either see all the required mail settings for adding your account to a client, or you are emailed those settings. Again I'm not comparing Froxlor to anything and saying you should do it like this, but rather asking, where can I find the mail settings, if anywhere? :)

Quote

sure, but if you use SSL this will throw a warning that the certificate is not valid for the given domain but basically you can use anything that points to the servers-ip, even the IP itself

1

Ah, interesting, so to have no errors on mail the only true way is to use the primary domain I access the panel by?

Quote

what exactly do you want to make default? dont get what you mean

1

Here I was asking if by default, mail.domain.tld is a record when the domains are added to Froxlor, so that I can consistently tell clients to use mail.domain, only because its easy to remember.

Quote

same as mail-domain, you can use anything that points to the server when not using SSL and if the users domain has a wildcard-entry in its dns zone then the customer can use whateverhewants.domain.tld to connect to the ftp server. no need for a specific dns-entry

Ok cool, I will try this one now, thanks.

Share this post


Link to post
Share on other sites
  • 1
4 minutes ago, Kieron Boswell said:

the required mail settings for adding your account to a client, or you are emailed those settings.

ah, okay, got it. Yes, you are right, these infos are not being displayed. most people setup up auto-confguration / auto-discover (see https://developer.mozilla.org/de/docs/Mozilla/Thunderbird/Autoconfiguration and/or https://technet.microsoft.com/en-us/library/cc511507.aspx)

7 minutes ago, Kieron Boswell said:

Ah, interesting, so to have no errors on mail the only true way is to use the primary domain I access the panel by?

when SSL is used, if not (port 143 for imap, 110 pop3, 25 smtp) there won't be any warnings of course. Safest way is to use the "mydomain" value from the postfix/main.cf config file as email server

9 minutes ago, Kieron Boswell said:

Here I was asking if by default, mail.domain.tld is a record when the domains are added to Froxlor, so that I can consistently tell clients to use mail.domain, only because its easy to remember.

in case you are using froxlor's DNS (most people dont as they do not maintain their own domain zones) there is an option to automatically add mail-A records to the zone. but as said, if the domain has a wildcard entry pointing to the server's ip, you can use any subdomain imaginable :)

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, d00p said:

ah, okay, got it. Yes, you are right, these infos are not being displayed. most people setup up auto-confguration / auto-discover (see https://developer.mozilla.org/de/docs/Mozilla/Thunderbird/Autoconfiguration and/or https://technet.microsoft.com/en-us/library/cc511507.aspx)

when SSL is used, if not (port 143 for imap, 110 pop3, 25 smtp) there won't be any warnings of course. Safest way is to use the "mydomain" value from the postfix/main.cf config file as email server

in case you are using froxlor's DNS (most people dont as they do not maintain their own domain zones) there is an option to automatically add mail-A records to the zone. but as said, if the domain has a wildcard entry pointing to the server's ip, you can use any subdomain imaginable :)

Thank you d00p, I will have a go at the mail soon. 

Share this post


Link to post
Share on other sites
  • 0
On 2/9/2019 at 9:01 AM, d00p said:

what settings do you want to set?

sure, but if you use SSL this will throw a warning that the certificate is not valid for the given domain but basically you can use anything that points to the servers-ip, even the IP itself

what exactly do you want to make default? dont get what you mean

same as mail-domain, you can use anything that points to the server when not using SSL and if the users domain has a wildcard-entry in its dns zone then the customer can use whateverhewants.domain.tld to connect to the ftp server. no need for a specific dns-entry

Hey again d00p, I had a couple questions, I recently have got mail setup, but not able to connect with anything, SMTP has been configured via Froxlor instructions, same with IMAP/POP3 via Froxlor instructions, the test email works when I use the SMTP test in Froxlor, but in apps/phone/webmail's I just can't connect.

Share this post


Link to post
Share on other sites
  • 0

Server Error Log? Don't just say "it's not working" - that does not really help in finding where the problem may be

Share this post


Link to post
Share on other sites
  • 0
15 minutes ago, d00p said:

Server Error Log? Don't just say "it's not working" - that does not really help in finding where the problem may be

Only thing I can see in Froxlor System log is this; 

    cronjob    maildir /var/customers/mail/myuser/mycustomer/hello/Maildir/ does not exist

Unfortunately, the end clients just say Error connecting, no real error message. 

 

Does Webmail need to be installed? I don't have that yet.

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Kieron Boswell said:

Unfortunately, the end clients just say Error connecting, no real error message. 

SERVER logs, not client.... /var/log/mail.log...

1 minute ago, Kieron Boswell said:

Does Webmail need to be installed? I don't have that yet.

no

2 minutes ago, Kieron Boswell said:

 cronjob    maildir /var/customers/mail/myuser/mycustomer/hello/Maildir/ does not exist

this happens for example if no email has been received by the address yet - when adding a new address, froxlor sends an email to it to create the maildir, maybe that failed? Please ensure that in the settings there is a valid email address and the admin of that customer has a valid email address

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, d00p said:

SERVER logs, not client.... /var/log/mail.log...

no

this happens for example if no email has been received by the address yet - when adding a new address, froxlor sends an email to it to create the maildir, maybe that failed? Please ensure that in the settings there is a valid email address and the admin of that customer has a valid email address

Thank you.

 

Lots of this one!

Feb 10 18:21:25 web01 dovecot: auth-worker(23757): Error: mysql(127.0.0.1): Connect failed to database (froxlor): Access denied for user 'froxlor'@'localhost' (using password: YES) - waiting for 125 seconds before retry

I have obviously missed one password somewhere!

Share this post


Link to post
Share on other sites
  • 0

You may also go through all that again of course but remember to set the mysql password at the top 

Share this post


Link to post
Share on other sites
  • 0
22 minutes ago, d00p said:

You may also go through all that again of course but remember to set the mysql password at the top 

Ok this looks different in log now:

 


Feb 10 18:46:33 web01 dovecot: master: Dovecot v2.2.27 (c0f36b0) starting up for imap, sieve, pop3 (core dumps disabled)
Feb 10 18:47:13 web01 dovecot: imap-login: Aborted login (no auth attempts in 1 secs): user=<>, rip=[IP address], lip=[IP address], session=<CTY5yI2B8qhttDj1>
Feb 10 18:47:18 web01 dovecot: imap-login: Aborted login (no auth attempts in 0 secs): user=<>, rip=[IP address], lip=[IP address], session=<tLGGyI2B9qhttDj1>
Feb 10 18:47:35 web01 postfix/qmgr[1102]: 3C5C52015BF: from=<hello@my.domain>, size=1274, nrcpt=1 (queue active)
Feb 10 18:47:35 web01 dovecot: lda(hello@customer.domain): msgid=<c91463d3618a00cd262c7a98b51de2da@web01.my.domain>: saved mail to INBOX
Feb 10 18:47:35 web01 postfix/pipe[24232]: 3C5C52015BF: to=<hello@customer.domain>, relay=dovecot, delay=494, delays=494/0.06/0/0.08, dsn=2.0.0, status=sent (delivered via dovecot service)
Feb 10 18:47:35 web01 postfix/qmgr[1102]: 3C5C52015BF: removed
Feb 10 18:47:39 web01 postfix/smtpd[24174]: warning: hostname durigq.ga does not resolve to address [IP Address]: Name or service not known
Feb 10 18:47:39 web01 postfix/smtpd[24174]: connect from unknown[IP Address]
Feb 10 18:47:42 web01 postfix/smtpd[24174]: warning: unknown[IP Address]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
Feb 10 18:47:42 web01 postfix/smtpd[24174]: disconnect from unknown[IP Address] ehlo=1 auth=0/1 quit=1 commands=2/3
Feb 10 18:49:20 web01 postfix/smtpd[24174]: warning: unknown[IP Address]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
Feb 10 18:49:20 web01 postfix/smtpd[24174]: disconnect from unknown[IP Address] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4

Better than before!

 

I am guessing now i am just authenticating incorrectly, would you suggest a particular address/port ?

Share this post


Link to post
Share on other sites
  • 0

Many admins set this option to no, it's not too bad. Or you have to explicitly use SSL

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Robert08020
      Hallo,
      Wenn ich einen neuen Kunden anlege, Doamin zuweise und FTP einrichte und gehe dann via WinSCP auf den Server, finde ich nichts. Der Ordner /var/customers wurde nicht erstellt.
      Kann mir jemand helfen?
      Mfg Robert08020
    • By Kyle Willets
      =================================================================================================================
       Package                       Arch                   Version                         Repository            Size
      =================================================================================================================
      Reinstalling:
       proftpd                       x86_64                 1.3.5e-4.el7                    epel                 3.7 M
       proftpd-mysql                 x86_64                 1.3.5e-4.el7                    epel                  50 k
      Transaction Summary
      =================================================================================================================
      Reinstall  2 Packages
      Total download size: 3.7 M
      Installed size: 9.7 M
      Is this ok [y/d/N]: y
      Downloading packages:
      (1/2): proftpd-1.3.5e-4.el7.x86_64.rpm                                                    | 3.7 MB  00:00:00
      (2/2): proftpd-mysql-1.3.5e-4.el7.x86_64.rpm                                              |  50 kB  00:00:00
      -----------------------------------------------------------------------------------------------------------------
      Total                                                                            4.0 MB/s | 3.7 MB  00:00:00
      Running transaction check
      Running transaction test
      Transaction test succeeded
      Running transaction
        Installing : proftpd-1.3.5e-4.el7.x86_64                                                                   1/2
        Installing : proftpd-mysql-1.3.5e-4.el7.x86_64                                                             2/2
        Verifying  : proftpd-mysql-1.3.5e-4.el7.x86_64                                                             1/2
        Verifying  : proftpd-1.3.5e-4.el7.x86_64                                                                   2/2
      Installed:
        proftpd.x86_64 0:1.3.5e-4.el7                        proftpd-mysql.x86_64 0:1.3.5e-4.el7
      Complete!
      [root@s128426 ~]# mv "/etc/proftpd/proftpd.conf" "/etc/proftpd/proftpd.conf.frx.bak"
      mv: cannot stat ‘/etc/proftpd/proftpd.conf’: No such file or directory
      [root@s128426 ~]# ^C
      [root@s128426 ~]# cd /etc/proftpd/
      -bash: cd: /etc/proftpd/: No such file or directory
       

      I am unable to setup ProFTP. I am using the latest version of Centos 7 and PHP 7. It says it installed, but yeah as ya can see. With the SSL it says to config something but does nto say what. So was wondering if anyone had any tips on how to get Lets Encypt working properly.
      Thank You.
    • By BigD
      Hi,
      I'm using PureFTP with TLS since years for Froxlor with purchased SSL certificates. Now the certificate expired and I want to use Let's encrypt.
      Here is my suggestion for a more secure PureFTP configuration - in addition to the current parameters from the froxlor setup guide:
      Making TLS mandatory:
      echo "2" > /etc/pure-ftpd/conf/TLS Reduce the Ciphers to the secure ones:
      echo "HIGH:!aNULL:!LOW:!EXP:!RC4:!3DES:!SSLv3:!SSLv2" > /etc/pure-ftpd/conf/TLSCipherSuite Doing this every time the host certificates are updated (or once a night ;-) ):
      cat /etc/ssl/froxlor-custom/{{hostname}}.crt /etc/ssl/froxlor-custom/{{hostname}}_chain.pem /etc/ssl/froxlor-custom/{{hostname}}.key > /etc/ssl/private/pure-ftpd.pem systemctl restart pure-ftpd-mysql Maybe it's an option to make this part of the default configuration and integrate the certificate merging into the froxlor-cron? Any ideas how this could look like on different distributions (Gentoo / RHEL / Ubuntu)?
      Thanks for your feedback
    • By martinvh
      Hello everybody,
      in the monthly Froxlor usage report I'm getting the message PHP Warning:  stream_socket_enable_crypto(): Peer certificate CN=`<my Froxlor domain>' did not match expected CN=`localhost' in /var/www/froxlor/lib/classes/phpmailer/class.SMTP.php on line 369
      The mail is being sent to the systems root account, which is mapped in /etc/aliases to an existing Froxlor mail account (webmaster@<my Froxlor domain>). Is this related to the Froxlor admin user, whos mail address is the same? Either way, why is the function expecting the local CN instead of the FQDN one? What is the correct setting in this case, or how can I mitigate the warning? The only cause effect I discovered is, that mails cannot be sent to new mail accounts via the alternate mail address, which results in the same error.
      Thanks in advance,
      Martin
    • By Brayan
      Hello,
       
      in old version of Froxlor - have autorespond and  very nice work for vacation messages.
      But in newest version is removed ? Why ?
      I use Postfix/Courier.
      Advice for alternatives ?
      Thanks in advance.
       


×