Jump to content
Froxlor Forum
  • 0
Neutrino

Was bewirkt die EIntellung "Froxlor direkt über den Hostnamen erreichbar machen"?

Question

Einstellungen | Froxlor VirtualHost Einstellungen | Froxlor direkt über den Hostnamen erreichbar machen

Was soll diese Einstellung bewirken?

Ich sehe keine Veränderung?

Bedeutet es, daß man Froxlor auch über eine "Standardsubdomain" erreichen kann?

froxlor-hostnamen-erreichbar.png

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 1

Wie es der Name schon sagt, ist froxlor danach direkt über den eingestellten Hostname erreichbar und du musst nichtmehr den Pfad von Froxlor mit angeben.

 

Quote

Ich sehe keine Veränderung?

Dann lief wohl der Cronjob noch nicht durch

 

Share this post


Link to post
Share on other sites
  • 0
vor 1 Minute schrieb v3ng:

du musst nichtmehr den Pfad von Froxlor mit angeben.

Achso, es soll bewirken, dass man Froxlor unter server.domain.xx erreichbar macht und nicht mehr unter server.domain.xx/froxlor, oder?

Das geht bei mir auch ohne dieser Einstellung, daher die Frage. (Hab den Server nicht selbst installiert)

Kann man sich in Froxlor auch mit einer "Standardsubdomain" einloggen?

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, Neutrino said:

Achso, es soll bewirken, dass man Froxlor unter server.domain.xx erreichbar macht und nicht mehr unter server.domain.xx/froxlor, oder?

Ja

2 minutes ago, Neutrino said:

Das geht bei mir auch ohne dieser Einstellung, daher die Frage. (Hab den Server nicht selbst installiert)

Vllt hat derjenige der es gemacht hat den docroot auf /var/www/froxlor gesetzt oder froxlor direkt nach /var/www entpackt

3 minutes ago, Neutrino said:

Kann man sich in Froxlor auch mit einer "Standardsubdomain" einloggen?

Nein, wozu? Da steckt ja der Login Name sogar drin (webX.system.hostname)

Share this post


Link to post
Share on other sites
  • 0
vor 3 Minuten schrieb d00p:

Vllt hat derjenige der es gemacht hat den docroot auf /var/www/froxlor gesetzt

So ist es.

Das erklärt vermutlich, warum das Let's Encrypt SSL-Zertifikat für den Server nicht funktioniert

 

vor 5 Minuten schrieb d00p:

Da steckt ja der Login Name sogar drin (webX.system.hostname)

Nein, weil ich als Kunden Standard-Subdomain nicht den System-Hostnamen (froxlor.domain.xx) verwende.

Also sind die Standardsubdomains nicht kunde.froxlor.domain.xx sondern kunde.domain.xx

vor 12 Minuten schrieb d00p:

Nein, wozu?

Weil sich der Kunde auch mit kunde.domain.xx/horde ins Webmail einloggt und mit kunde.domain.xx/phpmyadmin ins PhpMyAdmin. Daher wäre es naheligend, wenn sich der Kunde mit kunde.domain.xx ins Froxlor einloggt, wenn der Menüpunkt "Froxlor direkt über den Hostnamen erreichbar machen" angekreuzt ist und wenn nicht, dann mit kunde.domain.xx/froxlor. Ab der da kommt "Error 404 File not found".

 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Neutrino said:

So ist es.

Das erklärt vermutlich, warum das Let's Encrypt SSL-Zertifikat für den Server nicht funktioniert

Hat damit nix zu tun.

1 hour ago, Neutrino said:

Also sind die Standardsubdomains nicht kunde.froxlor.domain.xx sondern kunde.domain.xx

Loginname steckt Trotzdem immer in der Kunden Standard Subdomain

 

1 hour ago, Neutrino said:

Daher wäre es naheligend, wenn sich der Kunde mit kunde.domain.xx ins Froxlor einloggt, wenn der Menüpunkt "Froxlor direkt über den Hostnamen erreichbar machen" angekreuzt ist 

Eh, nein so garnicht...

1 hour ago, Neutrino said:

und wenn nicht, dann mit kunde.domain.xx/froxlor.

Dann bastel dir einen globalen alias wenn du das so möchtest, die meisten wollen das nicht. Es steht dir so gut wie alles frei 

Share this post


Link to post
Share on other sites
  • 0
vor 3 Minuten schrieb d00p:

Hat damit nix zu tun.

Warum seh ich dann in /etc/ssl/froxlor-custom nur die Zertifikate von den Kundendomains aber nicht das Zertifikat des Hauptservers (= jener Server, in dem ich mich als Admin ins Froxlor einlogge)

Share this post


Link to post
Share on other sites
  • 0

lief denn der cronjob? Starte mal manuell mit:

#> php /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug
#> php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...