Jump to content
Froxlor Forum

Neutrino

Members
  • Content Count

    37
  • Joined

  • Last visited

Everything posted by Neutrino

  1. ...damit nicht dauernd der Webserver bei einer Fehlkonfiguration abstürzt und somit die Kundendomains nicht mehr erreichbar sind?
  2. Ich habe mit "IPs und Ports" eine zusätzliche IP-Adresse hinzugefügt, aber ifconfig zeigt mir kein virtuelles Interface an. Was mache ich falsch? Froxlor 0.9.40.1-1 auf Debian 9.8.
  3. Ich will eine Excel Libreoffice-Tabelle machen mit den Attributen der Domains, damit ich alles auf einen Blick kontrollieren kann bzw. nach Attributen sortiert darstellen kann. Dafür sollte ein CSV-Export der Tabelle panel_domains ausreichen. Viellecht wird das mal mit der Froxlor GUI möglich sein?
  4. Hab jetzt. Der Admin kann alles was der Kunde kann außer Redirect-Code ändern - der ist eh auf 301 standardmäßig. Dafür kann der Kunde bei "Webserver SSL-Einstellungen" OCSP stapling nicht editieren und Mailserver-Einstellungen nicht ändern, abgesehen von div. PHP-Einstellungen was ich verstehen kann, daß das der Kunde nicht soll. Also warum soll ich mich als Kunde einloggen um Änderungen an meinen eigenen Domains zu machen? Da verbiete ich es doch lieber weil dann die Bedienung einfacher wird, wenn ich alles als Admin machen kann. Oder sehe ich das falsch?
  5. Würde einstweilen ein CSV-Export der Tabelle panel_domains funktionieren?
  6. Weil ich das als Admin machen will oder sehe ich das falsch? Was kann der Kunde was der Admin nicht kann?
  7. Klar, für meine eigenen Domains. Ich habe die Version 0.9.39.5 installiert. Dachte das ist die aktuelle Version? Jedenfalls danke für den Link. Was für eine Version ist das?
  8. php /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug
  9. Ich sehe im Menü "Domains" den Menüpunkt "Domains importieren", finde aber keinen Menüpunkt die Domainliste zu exportieren. Wie geht das? Danke!
  10. Ja, weil ich zur Zeit mein eigener Kunde bin ;-) Außerdem habe ich dem Kunden verboten an der Domain etwas zu ändern. Wenn der URL nicht mit einem / endet, ist der Redirect falsch Ich habe dort eine Weiterleitung von der nackten Domain zur Domain mit www eingegeben, damit automatisch das www vor der Domain eingefügt wird, wenn man den URL ohne www im Browser eingibt. Wenn die Weiterleitung http://www.domain.tld ist (ohne / am Ende) und man im Browser eingibt http://domain.tld/irgenwas (die Domain ohne www) dann entsteht eine Weiterleitung zu http://www.domain.tldirgendwas. Es fehlt der / nach .tld. Erst wenn als Weiterleitung http://www.domain.tld/ (mit / am Ende) eingegeben wird, dann wird richtigerweise von http://domain.tld/irgendwas zu zu http://www.domain.tld/irgendwas weitergeleitet.
  11. Für den Anfang wäre ein erweiterte Domain-Suche recht gut Z. B. Suche nach "E-Mail-Domain" oder "Nur als E-Mail-Domain verwenden?" bzw. nach den Eigenschaften in den Domaineinstellungen
  12. Ich glaube ich hab schon zu viele Domains da drin - funktioniert eh wie es soll. Sorry für die Falschmeldung ?
  13. Damit ich nicht so lange warten muß, bis der Master-Cronjob ausgeführt wird, klicke ich immer zuerst auf "Configs neu schreiben" und führe dann an der Kommandozeile den Master-Cronjob aus, damit die Konfiguration sofort neu erstellt wird und die Dienste neu gestartet werden. Wie kann ich "Configs neu schreiben": an der Kommandozeile ausführen?
  14. Für mich als Neuling war am Anfang nicht klar, daß man hier auch einen URL für Domainredirect eingeben kann, weil dort steht in kleiner Schrift nur: Schlage vor, daß man den Text erweitert zu "... oder URL für Domainredirect" oder ähnlich. @d00p
  15. Ich habe eine Domain einmal ohne www und einmal mit www zu Froxlor hinzugefügt. Die Domain ohne www hat in den Mailserver-Einstellungen "E-Mail-Domain: Ja" und die Domain mit www hat "E-Mail-Domain: Nein". Eingeloggt als Kunde kann man aber bei "E-Mail-Adresse anlegen" beide Domains aussuchen, einmal mit www und einmal ohne www. Meiner Meinung ist das falsch, weil die Domain mit www die Mailserver-Einstellung "E-Mail-Domain: Nein" hat und deswegen nicht in der Auswahlliste aufscheinen dürfte @d00p
  16. Meanwhile here: https://github.com/Neilpang/acme.sh
  17. Ich hab zwar kein PDNS weil ich Cloudflare benutze aber hätte mich trotzdem interessiert wie die Einträge aussehen. Poste doch einen Screenshot von der Domain und den PDNS-Einstellungen.
  18. Dort (z. B. /var/www/php-fcgi-scripts/kunde1/domain1.xx/php.ini) steht aber: Do not change anything in this file, it will be overwritten by the Froxlor Cronjob! Also wo trägt man den Pfad ein, damit das von Froxlor Cronjob nicht überschrieben wird?
  19. Das würde ich mit Einstellungen | Webserver-Einstellungen | Anzuhängende Pfade bei OpenBasedir machen und dort eintragen: /tmp/:/usr/share/phpmyadmin/ wie geht das "pro config" mit Froxlor bzw. was meinst du mit "pro config"?
  20. Meinst du, es muß bei FCGID Aktiviert: Ja PHP/FPM Aktiviert: Ja stehen? Oder reicht FCGID aus (ohne PHP/FPM)?
  21. Vermutlich hast du die Domain in Froxlor mit Email-Empfang konfiguriert aber keine MX-Records im PDNS gesetzt. Deaktiviere in Froxlor den E-Mail Empfang für die Domain
  22. In my opinion, this is a greater security risk than php access to just /proc/meminfo. Sorry! :-(
  23. Genau das ist der Fehler. Ich brauche das benutzerdefiniert für einen vHost, damit der Webserver dort (und nur dort für den einen vHost) Schreibrechte erhält. Aber wenn jeder vHost dort Schreibrechte hat, ist es ja eigentlich sinnlos, dort sensible Daten zu speichern, oder verstehe ich das falsch? Der Pfad zu open_basedir muß doch absolut sein, oder? Also kann ich einem vHost mit Froxlor keinen benutzerdefinierten open_basedir Pfad angeben, wenn der Pfad innerhalb eines Kunden liegt. Oder muß man das manuell auf der Konsole machen? Danke für die Aufklärung!
×
×
  • Create New...