Jump to content
Froxlor Forum
  • 0
funklaedle

master cronjob

Question

Hallo, ich bekomme alle 5 min folgende Email, was könnte das sein ?

Ich habe den Masterjob schon mit --force laufen lassen, ohne Erfolg.

 

hier die Mail :

Betreff: Cron <root@(none)> /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php

Inhalt:

 

*** Froxlor Master Cronjob ***

Below are possible parameters for this file

--[cronname]		includes the given cron-file
--force			forces re-generating of config-files (webserver, nameserver, etc.)
--debug			output debug information about what is going on to STDOUT.

 

Gruß, Uwe

 

 

 

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

stand tatsächlich in der crontab

# Regular cron jobs for the froxlor package
#
*/5 * * * *<-->root<-->/usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php

vielen Dank und Gruß, Uwe

Share this post


Link to post
Share on other sites
  • 0

Eh ja das hilft dir garnicht, denn der Cronjob macht ohne Parameter mal genau nix - einfach mal als root folgendes ausführen, dann repariert sich das von allein:

php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug

Share this post


Link to post
Share on other sites
  • 0

Hallo, erst mal danke für den Tip, erbrachte aber bei mir leider nicht den gewünschten Effekt.

Ich habe das Script mit --debug ausgeführt. Ausgabe : [notice] Checking system's last guid.  Bekomme besagte Mail aber trotzdem weiter alle 5 min. Aufgaben werden trotzdem ausgeführt falls welche anstehen.

Kann es sein, dass dies nicht auffällt da wohl die allermeisten mails an root nicht weiter leiten ?

Gruß, Uwe

 

 

Share this post


Link to post
Share on other sites
  • 0
On 8/9/2018 at 9:56 AM, funklaedle said:

Kann es sein, dass dies nicht auffällt da wohl die allermeisten mails an root nicht weiter leiten ?

*kopftisch* So sorglos sollte wohl niemand einen Server administrieren.

Für mich sieht es so aus dass etwas in der Datei /etc/cron.d/froxlor nicht stimmt und Parameter wie --tasks o.ä. falsch sind oder fehlen.

Share this post


Link to post
Share on other sites
  • 0

Bitteschön, hier besagte Datei :

# automatically generated cron-configuration by froxlor
# do not manually edit this file as it will be re-generated periodically.
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
#
*/5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null
*/5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt 1> /dev/null
0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null
5 0 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --used_tickets_reset 1> /dev/null
7 0 1 * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --ticketarchive 1> /dev/null
10 0 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --usage_report 1> /dev/null
0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null

Gruß, Uwe

Share this post


Link to post
Share on other sites
  • 0

Und was steht drin? Das von vorher kann's schlecht sein, es sei denn du hast selbst manuell noch einen cronjob angelegt wo der master Cronjob ohne Parameter aufgerufen wird

Share this post


Link to post
Share on other sites
  • 0
14 minutes ago, d00p said:

es sei denn du hast selbst manuell noch einen cronjob angelegt wo der master Cronjob ohne Parameter aufgerufen wird

 

Share this post


Link to post
Share on other sites
  • 0

Sorry für das Ausgraben, aber ich habe mit der aktuellen Froxlor (0.9.40.1) das gleiche Problem.

Die Konfiguration im Panel schläge folgenden Inhalt für die /etc/cron.d/froxlor vor (Debian 9->Sonstiges->Cronjob):

#
# Set PATH, otherwise restart-scripts won't find start-stop-daemon
#
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
#
# Regular cron jobs for the froxlor package
#
# Please check that all following paths are correct
#
*/5 * * * *    root    /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php

 

Das genau führt aber zu dem oben beschriebenen Problem (der Masterjob macht nichts, sondern sagt nur, dass er ohne Parameter gestartet wurde)...

Ich habe jetzt den Inhalt von funklaedle übernommen, aber optimal ist das nicht

Share this post


Link to post
Share on other sites
  • 0

hm, jo möglich das wir es früher anders gemacht haben ja, machste uns auf github nen issue auf dazu? müsste halt nur --force dran (denn beim ersten mal erstellt er dann die entsprechend korrekten einträge aufgrund der einstellungen im panel)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...





×
×
  • Create New...